Mailing List Archive

[PATCH v4 00/15] New event API
This is a tested version of my event handling API proposal. This
series contains a number of uncontroversial stylistic and bugfix
patches, plus these:

02/15 libxenstore: Provide xs_check_watch
12/15 libxl: Use GC_INIT and GC_FREE everywhere
13/15 libxl: make LIBXL_INIT_GC a statement, not an initialiser
14/15 libxl: New API for providing OS events to libxl
15/15 libxl: New event generation API

Changes since v3:

* New patches to use GC_INIT and GC_FREE everywhere so we could
change LIBXL_INIT_GC to properly initialise the new tail queue in
the gc.

* Bugfixes resulting from testing. Domain shutdown/death events work.
Disk eject events work as well as they did beforehand, but it turns
out that our cdrom insert/eject machinery is not currently working
very well. This needs to be addressed separately.

* Added some comments regarding #define OSEVENT_HOOK_INTERN
in libxl_event.c.

Please review. I would like to apply 12/15 in particular ASAP, as it
is textually very intrusive. I think 01-12 ought to be pretty
uncontroversial by now, and I have now tested 02/15 so I think it's
ready to go in.

14 and 15 have the meat.

Ian.

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xensource.com
http://lists.xensource.com/xen-devel
Re: [PATCH v4 00/15] New event API [ In reply to ]
On Mon, 2011-12-05 at 18:10 +0000, Ian Jackson wrote:
[...]
> Please review. I would like to apply 12/15 in particular ASAP, as it
> is textually very intrusive. I think 01-12 ought to be pretty
> uncontroversial by now, and I have now tested 02/15 so I think it's
> ready to go in.

I think I have now acked #1-11 either previously or just now, although
my comment on #12 really is about #7 so having either dismissed or
implemented that suggestion I've effectively acked #1-12.

> 14 and 15 have the meat.

I'll look at these next.

>
> Ian.
>
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@lists.xensource.com
> http://lists.xensource.com/xen-devel



_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xensource.com
http://lists.xensource.com/xen-devel
Re: [PATCH v4 00/15] New event API [ In reply to ]
Ian Campbell writes ("Re: [Xen-devel] [PATCH v4 00/15] New event API"):
> I think I have now acked #1-11 either previously or just now, although
> my comment on #12 really is about #7 so having either dismissed or
> implemented that suggestion I've effectively acked #1-12.

Given the bikeshed nature of your comment on #7 (GC_FREE) I'll wait
and see what develops from my recent posting. I'd rather not go
through and commit another seddery in xen-unstable mainline...

I'll repost 01-06 in their now-hopefully-final form and hopefully
apply them along with some of the rest of the backlog tomorrow.

Ian.

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xensource.com
http://lists.xensource.com/xen-devel
Re: [PATCH v4 00/15] New event API [ In reply to ]
On Thu, 2011-12-08 at 19:25 +0000, Ian Jackson wrote:
> Ian Campbell writes ("Re: [Xen-devel] [PATCH v4 00/15] New event API"):
> > I think I have now acked #1-11 either previously or just now, although
> > my comment on #12 really is about #7 so having either dismissed or
> > implemented that suggestion I've effectively acked #1-12.
>
> Given the bikeshed nature of your comment on #7 (GC_FREE) I'll wait
> and see what develops from my recent posting. I'd rather not go
> through and commit another seddery in xen-unstable mainline...

You replies to #12 & #13 seem reasonable to me so you can consider
#1-#13 acked.

> I'll repost 01-06 in their now-hopefully-final form and hopefully
> apply them along with some of the rest of the backlog tomorrow.
>
> Ian.



_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xensource.com
http://lists.xensource.com/xen-devel