Mailing List Archive

[PATCH] libxc: Refactor x86 specific code into x86 specific files
Move x86 specific code into x86 specific files.
Eliminate arch specific PAGE constants by using common
XC_PAGE_* contants.

Signed-off-by: Christoph Egger <Christoph.Egger@amd.com>

--
---to satisfy European Law for business letters:
Advanced Micro Devices GmbH
Einsteinring 24, 85689 Dornach b. Muenchen
Geschaeftsfuehrer: Alberto Bozzo, Andrew Bowd
Sitz: Dornach, Gemeinde Aschheim, Landkreis Muenchen
Registergericht Muenchen, HRB Nr. 43632
Re: [PATCH] libxc: Refactor x86 specific code into x86 specific files [ In reply to ]
Christoph Egger writes ("[Xen-devel] [PATCH] libxc: Refactor x86 specific code into x86 specific files"):
> Move x86 specific code into x86 specific files.
> Eliminate arch specific PAGE constants by using common
> XC_PAGE_* contants.

I'm not sure I understand the motivation for this.

Ian.

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xensource.com
http://lists.xensource.com/xen-devel
Re: [PATCH] libxc: Refactor x86 specific code into x86 specific files [ In reply to ]
On 11/24/11 17:30, Ian Jackson wrote:
> Christoph Egger writes ("[Xen-devel] [PATCH] libxc: Refactor x86 specific code into x86 specific files"):
>> Move x86 specific code into x86 specific files.
>> Eliminate arch specific PAGE constants by using common
>> XC_PAGE_* contants.
>
> I'm not sure I understand the motivation for this.

Code cleanup, better readability, better code organization.

Christoph

--
---to satisfy European Law for business letters:
Advanced Micro Devices GmbH
Einsteinring 24, 85689 Dornach b. Muenchen
Geschaeftsfuehrer: Alberto Bozzo, Andrew Bowd
Sitz: Dornach, Gemeinde Aschheim, Landkreis Muenchen
Registergericht Muenchen, HRB Nr. 43632


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xensource.com
http://lists.xensource.com/xen-devel
Re: [PATCH] libxc: Refactor x86 specific code into x86 specific files [ In reply to ]
On Thu, 2011-11-24 at 16:56 +0000, Christoph Egger wrote:
> On 11/24/11 17:30, Ian Jackson wrote:
> > Christoph Egger writes ("[Xen-devel] [PATCH] libxc: Refactor x86 specific code into x86 specific files"):
> >> Move x86 specific code into x86 specific files.
> >> Eliminate arch specific PAGE constants by using common
> >> XC_PAGE_* contants.
> >
> > I'm not sure I understand the motivation for this.
>
> Code cleanup, better readability, better code organization.

At the very least each cleanup should be presented individually so we
can judge them on their merits.

The switch to a consistent set of XC_PAGE_* constants doesn't seem like
such a bad idea.

Likewise moving the x86 PT constants out of xg_private.h doesn't seem
unreasonable.

I'm less convinced by the more general movement of interface
definitions/implementations out of #ifdef in the .c and .h files into
foo_x86.[ch]. Seems to me that this just obfuscates the interfaces by
requiring one to go and look in multiple places.

I think what you've done to union cpu_guest_context_any_t and friends is
not an improvement.

The first two hunks of change in xenctrl.h seem like pointless code
motion within the same header.

why have you moved the x86 stuff into x86.h but left the ia64 stuff
ifdef'd in the main headers. For any given construct it should be all or
nothing IMHO.

You haven't made any arrangements to install the new headers.

Ian.


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xensource.com
http://lists.xensource.com/xen-devel