Mailing List Archive

Assertion failed in ospfd 1.2.3
Hello

I try to setup a test software router under Linux (Oracle Linux 6
x86_64) and Quagga 1.2.3. ospfd being started exited a few seconds after
with assertion fault. It seems that is a time of first multicast network
packet received. OSPF configuration is quite simple :

interface eth0
!
interface eth0.3
ip ospf authentication-key ********
!
interface eth1
!
interface eth2
!
interface eth3
!
interface lo
!
router ospf
ospf router-id 172.16.83.71
auto-cost reference-bandwidth 1000
passive-interface eth0
passive-interface eth1
passive-interface eth2
passive-interface eth3
network 172.16.83.71/26 area 172.16.80.0
area 172.16.80.0 authentication
!
line vty

Quagga 1.2.2 at the same computer and configuration works as desired.

I built 1.2.3 RPM using quagga.spec file from tarball with only cosmetic
changes. It is near identical against one from 1.2.2. Building
environment is the same

Here is crashlog:

2018/02/16 18:32:26 OSPF: Assertion `thread->master != ((void *)0) &&
thread != ((void *)0)' failed in file thread.c, line 607, function
thread_add_unuse
2018/02/16 18:32:26 OSPF: Backtrace for 12 stack frames:
2018/02/16 18:32:26 OSPF: [bt 0]
/usr/lib64/quagga/libzebra.so.1(zlog_backtrace+0x35) [0x7fbfd7cb2ea5]
2018/02/16 18:32:26 OSPF: [bt 1]
/usr/lib64/quagga/libzebra.so.1(_zlog_assert_failed+0x67) [0x7fbfd7cb3027]
2018/02/16 18:32:26 OSPF: [bt 2]
/usr/lib64/quagga/libzebra.so.1(+0x27cfe) [0x7fbfd7ca1cfe]
2018/02/16 18:32:26 OSPF: [bt 3]
/usr/lib64/quagga/libzebra.so.1(+0x28389) [0x7fbfd7ca2389]
2018/02/16 18:32:26 OSPF: [bt 4]
/usr/lib64/quagga/libzebra.so.1(funcname_thread_execute+0x4c)
[0x7fbfd7ca30cc]
2018/02/16 18:32:26 OSPF: [bt 5]
/usr/lib64/quagga/libospf.so.0(+0x2f71d) [0x7fbfd7f1d71d]
2018/02/16 18:32:26 OSPF: [bt 6]
/usr/lib64/quagga/libospf.so.0(ospf_read+0x149e) [0x7fbfd7f200be]
2018/02/16 18:32:26 OSPF: [bt 7]
/usr/lib64/quagga/libzebra.so.1(+0x282b2) [0x7fbfd7ca22b2]
2018/02/16 18:32:26 OSPF: [bt 8]
/usr/lib64/quagga/libzebra.so.1(thread_main+0x18) [0x7fbfd7ca3838]
2018/02/16 18:32:26 OSPF: [bt 9] ospfd(main+0x337) [0x401b07]
2018/02/16 18:32:26 OSPF: [bt 10]
/lib64/libc.so.6(__libc_start_main+0xfd) [0x3d4f01ed1d]
2018/02/16 18:32:26 OSPF: [bt 11] ospfd() [0x401669]
2018/02/16 18:32:26 OSPF: Current thread not known/applicable

What can be a troubleshooting procedure?


Regards, Ivan Kuznetsov
SOLVO ltd

_______________________________________________
Quagga-users mailing list
Quagga-users@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-users
Re: Assertion failed in ospfd 1.2.3 [ In reply to ]
Hi

This should suffice. Will investigate this and resolve this

Thanks
Balaji

On Fri, 16 Feb 2018 at 22:04, Ivan Kuznetsov <kia@solvo.ru> wrote:

> Hello
>
> I try to setup a test software router under Linux (Oracle Linux 6
> x86_64) and Quagga 1.2.3. ospfd being started exited a few seconds after
> with assertion fault. It seems that is a time of first multicast network
> packet received. OSPF configuration is quite simple :
>
> interface eth0
> !
> interface eth0.3
> ip ospf authentication-key ********
> !
> interface eth1
> !
> interface eth2
> !
> interface eth3
> !
> interface lo
> !
> router ospf
> ospf router-id 172.16.83.71
> auto-cost reference-bandwidth 1000
> passive-interface eth0
> passive-interface eth1
> passive-interface eth2
> passive-interface eth3
> network 172.16.83.71/26 area 172.16.80.0
> area 172.16.80.0 authentication
> !
> line vty
>
> Quagga 1.2.2 at the same computer and configuration works as desired.
>
> I built 1.2.3 RPM using quagga.spec file from tarball with only cosmetic
> changes. It is near identical against one from 1.2.2. Building
> environment is the same
>
> Here is crashlog:
>
> 2018/02/16 18:32:26 OSPF: Assertion `thread->master != ((void *)0) &&
> thread != ((void *)0)' failed in file thread.c, line 607, function
> thread_add_unuse
> 2018/02/16 18:32:26 OSPF: Backtrace for 12 stack frames:
> 2018/02/16 18:32:26 OSPF: [bt 0]
> /usr/lib64/quagga/libzebra.so.1(zlog_backtrace+0x35) [0x7fbfd7cb2ea5]
> 2018/02/16 18:32:26 OSPF: [bt 1]
> /usr/lib64/quagga/libzebra.so.1(_zlog_assert_failed+0x67) [0x7fbfd7cb3027]
> 2018/02/16 18:32:26 OSPF: [bt 2]
> /usr/lib64/quagga/libzebra.so.1(+0x27cfe) [0x7fbfd7ca1cfe]
> 2018/02/16 18:32:26 OSPF: [bt 3]
> /usr/lib64/quagga/libzebra.so.1(+0x28389) [0x7fbfd7ca2389]
> 2018/02/16 18:32:26 OSPF: [bt 4]
> /usr/lib64/quagga/libzebra.so.1(funcname_thread_execute+0x4c)
> [0x7fbfd7ca30cc]
> 2018/02/16 18:32:26 OSPF: [bt 5]
> /usr/lib64/quagga/libospf.so.0(+0x2f71d) [0x7fbfd7f1d71d]
> 2018/02/16 18:32:26 OSPF: [bt 6]
> /usr/lib64/quagga/libospf.so.0(ospf_read+0x149e) [0x7fbfd7f200be]
> 2018/02/16 18:32:26 OSPF: [bt 7]
> /usr/lib64/quagga/libzebra.so.1(+0x282b2) [0x7fbfd7ca22b2]
> 2018/02/16 18:32:26 OSPF: [bt 8]
> /usr/lib64/quagga/libzebra.so.1(thread_main+0x18) [0x7fbfd7ca3838]
> 2018/02/16 18:32:26 OSPF: [bt 9] ospfd(main+0x337) [0x401b07]
> 2018/02/16 18:32:26 OSPF: [bt 10]
> /lib64/libc.so.6(__libc_start_main+0xfd) [0x3d4f01ed1d]
> 2018/02/16 18:32:26 OSPF: [bt 11] ospfd() [0x401669]
> 2018/02/16 18:32:26 OSPF: Current thread not known/applicable
>
> What can be a troubleshooting procedure?
>
>
> Regards, Ivan Kuznetsov
> SOLVO ltd
>
> _______________________________________________
> Quagga-users mailing list
> Quagga-users@lists.quagga.net
> https://lists.quagga.net/mailman/listinfo/quagga-users
>
Re: Assertion failed in ospfd 1.2.3 [ In reply to ]
On Fri, 16 Feb 2018, Ivan Kuznetsov wrote:

> 2018/02/16 18:32:26 OSPF: Assertion `thread->master != ((void *)0) && thread
> != ((void *)0)' failed in file thread.c, line 607, function thread_add_unuse

> What can be a troubleshooting procedure?

If you 'git revert 5e13840d7f3e7fcdf7e' and then rebuild, does that fix
it?

I.e. backout:

https://gogs.quagga.net/Quagga/quagga/commit/5e13840d7f3e7fcdf7ecff762c019bb56c88965f

regards,
--
Paul Jakma | paul@jakma.org | @pjakma | Key ID: 0xD86BF79464A2FF6A
Fortune:
Deprive a mirror of its silver and even the Czar won't see his face.
_______________________________________________
Quagga-users mailing list
Quagga-users@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-users
Re: Assertion failed in ospfd 1.2.3 [ In reply to ]
Am 2018-02-16 17:51, schrieb Paul Jakma:
> On Fri, 16 Feb 2018, Ivan Kuznetsov wrote:

Hi,

>> 2018/02/16 18:32:26 OSPF: Assertion `thread->master != ((void *)0) &&
>> thread != ((void *)0)' failed in file thread.c, line 607, function
>> thread_add_unuse
>
>> What can be a troubleshooting procedure?
>
> If you 'git revert 5e13840d7f3e7fcdf7e' and then rebuild, does that fix
> it?
>
> I.e. backout:
>
> https://gogs.quagga.net/Quagga/quagga/commit/5e13840d7f3e7fcdf7ecff762c019bb56c88965f

I just built a new RPM based on above ``release'' but the error
unfortunately still occurs:

2018/02/19 07:44:23 OSPF: Assertion `thread->master != ((void *)0) &&
thread != ((void *)0)' failed in file thread.c, line 607, function
thread_add_unuse
2018/02/19 07:44:23 OSPF: Backtrace for 20 stack frames:
2018/02/19 07:44:23 OSPF: [bt 0]
/usr/lib64/quagga/libzebra.so.1(zlog_backtrace+0x37) [0x7fefe278fdb7]
2018/02/19 07:44:23 OSPF: [bt 1]
/usr/lib64/quagga/libzebra.so.1(_zlog_assert_failed+0x5d)
[0x7fefe27906ad]
2018/02/19 07:44:23 OSPF: [bt 2]
/usr/lib64/quagga/libzebra.so.1(+0x28130) [0x7fefe2780130]
2018/02/19 07:44:23 OSPF: [bt 3]
/usr/lib64/quagga/libzebra.so.1(+0x298eb) [0x7fefe27818eb]
2018/02/19 07:44:23 OSPF: [bt 4]
/usr/lib64/quagga/libzebra.so.1(funcname_thread_execute+0x56)
[0x7fefe27819a6]
2018/02/19 07:44:23 OSPF: [bt 5]
/usr/lib64/quagga/libospf.so.0(ospf_if_cleanup+0xe0) [0x7fefe29ef950]
2018/02/19 07:44:23 OSPF: [bt 6]
/usr/lib64/quagga/libospf.so.0(+0x25809) [0x7fefe29f1809]
2018/02/19 07:44:23 OSPF: [bt 7]
/usr/lib64/quagga/libospf.so.0(ospf_ism_event+0x2f) [0x7fefe29f183f]
2018/02/19 07:44:23 OSPF: [bt 8]
/usr/lib64/quagga/libzebra.so.1(+0x2982c) [0x7fefe278182c]
2018/02/19 07:44:23 OSPF: [bt 9]
/usr/lib64/quagga/libzebra.so.1(funcname_thread_execute+0x56)
[0x7fefe27819a6]
2018/02/19 07:44:23 OSPF: [bt 10]
/usr/lib64/quagga/libospf.so.0(ospf_if_down+0x42) [0x7fefe29f0612]
2018/02/19 07:44:23 OSPF: [bt 11]
/usr/lib64/quagga/libospf.so.0(ospf_if_free+0x1e) [0x7fefe29f06ae]
2018/02/19 07:44:23 OSPF: [bt 12]
/usr/lib64/quagga/libospf.so.0(+0x1ef85) [0x7fefe29eaf85]
2018/02/19 07:44:23 OSPF: [bt 13]
/usr/lib64/quagga/libospf.so.0(ospf_terminate+0x49) [0x7fefe29eb689]
2018/02/19 07:44:23 OSPF: [bt 14]
/usr/lib64/quagga/libzebra.so.1(quagga_sigevent_process+0x49)
[0x7fefe279b639]
2018/02/19 07:44:23 OSPF: [bt 15]
/usr/lib64/quagga/libzebra.so.1(+0x28765) [0x7fefe2780765]
2018/02/19 07:44:23 OSPF: [bt 16]
/usr/lib64/quagga/libzebra.so.1(thread_main+0x20) [0x7fefe27819f0]
2018/02/19 07:44:23 OSPF: [bt 17] /usr/sbin/ospfd(main+0x2f3) [0x401a13]
2018/02/19 07:44:23 OSPF: [bt 18]
/lib64/libc.so.6(__libc_start_main+0xf5) [0x7fefdfec0c05]
2018/02/19 07:44:23 OSPF: [bt 19] /usr/sbin/ospfd() [0x401a6a]
2018/02/19 07:44:23 OSPF: Current thread not known/applicable
2018/02/19 07:46:56 OSPF: ASBR[Status:1]: Update
2018/02/19 07:46:56 OSPF: ASBR[Status:2]: Update
2018/02/19 07:46:56 OSPF: ASBR[Status:2]: Already ASBR

Running recent CentOS 7 (3.10.0-693.17.1.el7.x86_64)

Regards

Bernd
_______________________________________________
Quagga-users mailing list
Quagga-users@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-users
Re: Assertion failed in ospfd 1.2.3 [ In reply to ]
Brown paper bag bug, affects bgpd too. See:

https://bugzilla.quagga.net/show_bug.cgi?id=975

I'll spin another release.

On Fri, 16 Feb 2018, Paul Jakma wrote:

> On Fri, 16 Feb 2018, Ivan Kuznetsov wrote:
>
>> 2018/02/16 18:32:26 OSPF: Assertion `thread->master != ((void *)0) &&
>> thread != ((void *)0)' failed in file thread.c, line 607, function
>> thread_add_unuse
>
>> What can be a troubleshooting procedure?
>
> If you 'git revert 5e13840d7f3e7fcdf7e' and then rebuild, does that fix it?
>
> I.e. backout:
>
> https://gogs.quagga.net/Quagga/quagga/commit/5e13840d7f3e7fcdf7ecff762c019bb56c88965f
>
> regards,
>

--
Paul Jakma | paul@jakma.org | @pjakma | Key ID: 0xD86BF79464A2FF6A
Fortune:
Fifth Law of Procrastination:
Procrastination avoids boredom; one never has the feeling that
there is nothing important to do.
_______________________________________________
Quagga-users mailing list
Quagga-users@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-users
Re: Assertion failed in ospfd 1.2.3 [ In reply to ]
On Mon, 19 Feb 2018, Bernd wrote:

> Am 2018-02-16 17:51, schrieb Paul Jakma:
>> On Fri, 16 Feb 2018, Ivan Kuznetsov wrote:
>
> Hi,
>
>>> 2018/02/16 18:32:26 OSPF: Assertion `thread->master != ((void *)0) &&
>>> thread != ((void *)0)' failed in file thread.c, line 607, function
>>> thread_add_unuse
>>
>>> What can be a troubleshooting procedure?
>>
>> If you 'git revert 5e13840d7f3e7fcdf7e' and then rebuild, does that fix
>> it?
>>
>> I.e. backout:
>>
>> https://gogs.quagga.net/Quagga/quagga/commit/5e13840d7f3e7fcdf7ecff762c019bb56c88965f
>
> I just built a new RPM based on above ``release'' but the error
> unfortunately still occurs:

The above commit would have the issue. You'd have to 'git revert' that
ID. Alternatively, better, just drop the fix in:

https://bugzilla.quagga.net/show_bug.cgi?id=975

as a patch to your rpmbuild.

Or wait till later today, and there'll be a 1.2.4 release.

(My bad... ;) ).

Note: this will affect bgpd too, if the 'show ... prefix-count ...'
command is run.

regards,
--
Paul Jakma | paul@jakma.org | @pjakma | Key ID: 0xD86BF79464A2FF6A
Fortune:
Imagination is the one weapon in the war against reality.
-- Jules de Gaultier
_______________________________________________
Quagga-users mailing list
Quagga-users@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-users
Re: Assertion failed in ospfd 1.2.3 [ In reply to ]
Confirm, ospfd works after the patch

Thank you!

19.02.2018 16:37, Paul Jakma ?????:
> On Mon, 19 Feb 2018, Bernd wrote:
>
>> Am 2018-02-16 17:51, schrieb Paul Jakma:
>>>  On Fri, 16 Feb 2018, Ivan Kuznetsov wrote:
>>
>> Hi,
>>
>>>>  2018/02/16 18:32:26 OSPF: Assertion `thread->master != ((void *)0) &&
>>>>  thread != ((void *)0)' failed in file thread.c, line 607, function
>>>>  thread_add_unuse
>>>
>>>>  What can be a troubleshooting procedure?
>>>
>>>  If you 'git revert 5e13840d7f3e7fcdf7e' and then rebuild, does that fix
>>>  it?
>>>
>>>  I.e. backout:
>>>
>>>  https://gogs.quagga.net/Quagga/quagga/commit/5e13840d7f3e7fcdf7ecff762c019bb56c88965f
>>>
>>
>> I just built a new RPM based on above ``release'' but the error
>> unfortunately still occurs:
>
> The above commit would have the issue. You'd have to 'git revert' that
> ID. Alternatively, better, just drop the fix in:
>
>   https://bugzilla.quagga.net/show_bug.cgi?id=975
>
> as a patch to your rpmbuild.

--
Regards, Ivan Kuznetsov
SOLVO ltd
_______________________________________________
Quagga-users mailing list
Quagga-users@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-users