Mailing List Archive

APS/MSP 1+1 questions
Hi,

I config two STM-1s to APS/MSP between two M routers,
one side is M160 (JUNOS 5.5R2.3) and the other side
is a M20 (JUNOS 5.4R2.4) as following.

I have two question on the APS/MSP 1+1 protection,
1. If the working link goes down, system does switch
to protection link automatically, but my routing
protocols (BGP, OSPF, RSVP) also have a up/down
alarm. Does this normal behavior? Is it possible
to prevent routing protocols up/down while switching?
2. When I commit these configurations, a warning message
says: (on M160)
Warning: identical local address is found on
default route instance, intf: so-1/0/2.0,
family type: inet
[edit interfaces so-1/0/2 unit 0 family inet
address 10.10.10.2/30] Warning: identical
local address is found on different interfaces
Simular warning messages also show up on M20 when I commit
his configuration.
Does these messages correct? Or should I modify the config
to prevent such warings? (how to?)

Thanks,
Yu-lin

---------------------------
M160
====
[interfaces]
so-1/0/0 {
description "#### Working-Link to M20 ####";
clocking external;
encapsulation frame-relay;
sonet-options {
path-trace m160-so-1/0/0;
aps {
working-circuit C1;
}
}
unit 0 {
description "### PIPE-0 ###";
point-to-point;
dlci 101;
family inet {
address 10.10.10.2/30;
}
family iso;
family mpls;
}
}
so-1/0/2 {
description "#### Protection-Link to M20 ####";
clocking external;
encapsulation frame-relay;
sonet-options {
path-trace m160-so-1/0/2;
aps {
protect-circuit C1;
}
}
unit 0 {
description "### PIPE-0 ###";
point-to-point;
dlci 101;
family inet {
address 10.10.10.2/30;
}
family iso;
family mpls;
}
}
--------------------------------

M20
===
[interfaces]
so-0/3/0 {
description "#### Working-Link to M160 ####";
dce;
clocking external;
encapsulation frame-relay;
sonet-options {
path-trace m20-so-0/3/0;
aps {
working-circuit C1;
}
}
unit 0 {
description "### PIPE-0 ###";
point-to-point;
dlci 101;
family inet {
address 10.10.10.1/30;
}
family iso;
family mpls;
}
}
so-0/3/1 {
description "#### Protection-Link to M160 ####";
dce;
clocking external;
encapsulation frame-relay;
sonet-options {
path-trace m20-so-0/3/1;
aps {
working-circuit C1;
}
}
unit 0 {
description "### PIPE-0 ###";
point-to-point;
dlci 101;
family inet {
address 10.10.10.1/30;
}
family iso;
family mpls;
}
}
-----------------
AW: APS/MSP 1+1 questions [ In reply to ]
Hi,

to prevent the routing protocols to flap during failover, you should set the
holdtimers on the Sonet Inerfaces to 2000ms.

Regards,

Olaf

-----Urspr?ngliche Nachricht-----
Von: Yu-lin Chang [mailto:ylchang@ascc.net]
Gesendet: Friday, May 23, 2003 10:44 AM
An: juniper@groupstudy.com; juniper-nsp@puck.nether.net
Betreff: [j-nsp] APS/MSP 1+1 questions


Hi,

I config two STM-1s to APS/MSP between two M routers,
one side is M160 (JUNOS 5.5R2.3) and the other side
is a M20 (JUNOS 5.4R2.4) as following.

I have two question on the APS/MSP 1+1 protection,
1. If the working link goes down, system does switch
to protection link automatically, but my routing
protocols (BGP, OSPF, RSVP) also have a up/down
alarm. Does this normal behavior? Is it possible
to prevent routing protocols up/down while switching?
2. When I commit these configurations, a warning message
says: (on M160)
Warning: identical local address is found on
default route instance, intf: so-1/0/2.0,
family type: inet
[edit interfaces so-1/0/2 unit 0 family inet
address 10.10.10.2/30] Warning: identical
local address is found on different interfaces
Simular warning messages also show up on M20 when I commit
his configuration.
Does these messages correct? Or should I modify the config
to prevent such warings? (how to?)

Thanks,
Yu-lin

---------------------------
M160
====
[interfaces]
so-1/0/0 {
description "#### Working-Link to M20 ####";
clocking external;
encapsulation frame-relay;
sonet-options {
path-trace m160-so-1/0/0;
aps {
working-circuit C1;
}
}
unit 0 {
description "### PIPE-0 ###";
point-to-point;
dlci 101;
family inet {
address 10.10.10.2/30;
}
family iso;
family mpls;
}
}
so-1/0/2 {
description "#### Protection-Link to M20 ####";
clocking external;
encapsulation frame-relay;
sonet-options {
path-trace m160-so-1/0/2;
aps {
protect-circuit C1;
}
}
unit 0 {
description "### PIPE-0 ###";
point-to-point;
dlci 101;
family inet {
address 10.10.10.2/30;
}
family iso;
family mpls;
}
}
--------------------------------

M20
===
[interfaces]
so-0/3/0 {
description "#### Working-Link to M160 ####";
dce;
clocking external;
encapsulation frame-relay;
sonet-options {
path-trace m20-so-0/3/0;
aps {
working-circuit C1;
}
}
unit 0 {
description "### PIPE-0 ###";
point-to-point;
dlci 101;
family inet {
address 10.10.10.1/30;
}
family iso;
family mpls;
}
}
so-0/3/1 {
description "#### Protection-Link to M160 ####";
dce;
clocking external;
encapsulation frame-relay;
sonet-options {
path-trace m20-so-0/3/1;
aps {
working-circuit C1;
}
}
unit 0 {
description "### PIPE-0 ###";
point-to-point;
dlci 101;
family inet {
address 10.10.10.1/30;
}
family iso;
family mpls;
}
}
-----------------

_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
http://puck.nether.net/mailman/listinfo/juniper-nsp