Mailing List Archive

Need Help Configuring Cat2924XL
I've got a Cat2924XL with the following relevant config snippets:

rwc-2924xl-131#show vlan
12 DMZ active
100 IP Phones active Fa0/7

interface FastEthernet0/5
switchport voice vlan 100
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 2
switchport voice vlan 100
!
interface FastEthernet0/7
switchport access vlan 100
spanning-tree portfast

interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk

interface VLAN2
ip address 172.16.0.131 255.255.0.0
no ip directed-broadcast
no ip route-cache


So... FE0/7 works fine (as you would expect), but neither 0/5 or 0/6
work ... The phone sees the operational VLAN 100, but never gets an
IP.. What the heck am I doing wrong? Cisco's docs only show the
"switchport voice vlan" option as being relevant. Is there something
I'm missing on the switch config? I've rebooted the phones and switch a
few times.

Thanks for any help,
--
Anthony Mendoza

CONFIDENTIALITY NOTICE: The information contained in this message and
or attachments is intended only for the person or entity to which it
is addressed and may contain confidential and/or privileged material.
Any review, retransmission, dissemination, copying, or other use of
this information by persons or entities other than the intended
recipient is prohibited. If you received this e-mail or its
attachments in error, please contact the sender and delete the
material from any system and destroy any copies.
RE: Need Help Configuring Cat2924XL [ In reply to ]
The voice interfaces should look something like this:
interface FastEthernet0/5
switchport access vlan 416
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 415,416
switchport mode dynamic desirable
switchport voice vlan 415
spanning-tree portfast


Simon

-----Original Message-----
From: cisco-voip-bounces@puck.nether.net
[mailto:cisco-voip-bounces@puck.nether.net] On Behalf Of Anthony Mendoza
Sent: Thursday, July 15, 2004 12:04 PM
To: cisco-voip@puck.nether.net
Subject: [cisco-voip] Need Help Configuring Cat2924XL


I've got a Cat2924XL with the following relevant config snippets:

rwc-2924xl-131#show vlan
12 DMZ active
100 IP Phones active Fa0/7

interface FastEthernet0/5
switchport voice vlan 100
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 2
switchport voice vlan 100
!
interface FastEthernet0/7
switchport access vlan 100
spanning-tree portfast

interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk

interface VLAN2
ip address 172.16.0.131 255.255.0.0
no ip directed-broadcast
no ip route-cache


So... FE0/7 works fine (as you would expect), but neither 0/5 or 0/6 work
... The phone sees the operational VLAN 100, but never gets an IP.. What
the heck am I doing wrong? Cisco's docs only show the "switchport voice
vlan" option as being relevant. Is there something I'm missing on the
switch config? I've rebooted the phones and switch a few times.

Thanks for any help,
--
Anthony Mendoza

CONFIDENTIALITY NOTICE: The information contained in this message and or
attachments is intended only for the person or entity to which it is
addressed and may contain confidential and/or privileged material.
Any review, retransmission, dissemination, copying, or other use of this
information by persons or entities other than the intended recipient is
prohibited. If you received this e-mail or its attachments in error, please
contact the sender and delete the material from any system and destroy any
copies.
_______________________________________________
cisco-voip mailing list
cisco-voip@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-voip
RE: Need Help Configuring Cat2924XL [ In reply to ]
Where's Interface Vlan 100? And where's Vlan2 in your show Vlan? Or is
that a typo and should have been 12?

Scott

-----Original Message-----
From: Anthony Mendoza [mailto:amendoza@Niku.com]
Sent: Thursday, July 15, 2004 12:04 PM
To: cisco-voip@puck.nether.net
Subject: [cisco-voip] Need Help Configuring Cat2924XL


I've got a Cat2924XL with the following relevant config snippets:

rwc-2924xl-131#show vlan
12 DMZ active
100 IP Phones active Fa0/7

interface FastEthernet0/5
switchport voice vlan 100
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 2
switchport voice vlan 100
!
interface FastEthernet0/7
switchport access vlan 100
spanning-tree portfast

interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk

interface VLAN2
ip address 172.16.0.131 255.255.0.0
no ip directed-broadcast
no ip route-cache


So... FE0/7 works fine (as you would expect), but neither 0/5 or 0/6
work ... The phone sees the operational VLAN 100, but never gets an
IP.. What the heck am I doing wrong? Cisco's docs only show the
"switchport voice vlan" option as being relevant. Is there something
I'm missing on the switch config? I've rebooted the phones and switch a

few times.

Thanks for any help,
--
Anthony Mendoza

CONFIDENTIALITY NOTICE: The information contained in this message and
or attachments is intended only for the person or entity to which it
is addressed and may contain confidential and/or privileged material.
Any review, retransmission, dissemination, copying, or other use of
this information by persons or entities other than the intended
recipient is prohibited. If you received this e-mail or its
attachments in error, please contact the sender and delete the
material from any system and destroy any copies.
_______________________________________________
cisco-voip mailing list
cisco-voip@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-voip
Re: Need Help Configuring Cat2924XL [ In reply to ]
My first guess would be to turn trunking on those ports. You have configured voice vlans, not data vlans, so it needs to be set to trunk in order to enable those to work. I've tested with my phone, and not having the trunk statement breaks things pretty quick. It doesn't even try to get an IP address off the data vlan that I've set.

Here's a snippet:

interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 25
switchport mode trunk
switchport voice vlan 625
spanning-tree portfast
end

----- Original Message -----
From: Anthony Mendoza
To: cisco-voip@puck.nether.net
Sent: Thursday, July 15, 2004 3:04 PM
Subject: [cisco-voip] Need Help Configuring Cat2924XL



I've got a Cat2924XL with the following relevant config snippets:

rwc-2924xl-131#show vlan
12 DMZ active
100 IP Phones active Fa0/7

interface FastEthernet0/5
switchport voice vlan 100
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 2
switchport voice vlan 100
!
interface FastEthernet0/7
switchport access vlan 100
spanning-tree portfast

interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk

interface VLAN2
ip address 172.16.0.131 255.255.0.0
no ip directed-broadcast
no ip route-cache


So... FE0/7 works fine (as you would expect), but neither 0/5 or 0/6
work ... The phone sees the operational VLAN 100, but never gets an
IP.. What the heck am I doing wrong? Cisco's docs only show the
"switchport voice vlan" option as being relevant. Is there something
I'm missing on the switch config? I've rebooted the phones and switch a
few times.

Thanks for any help,
--
Anthony Mendoza

CONFIDENTIALITY NOTICE: The information contained in this message and
or attachments is intended only for the person or entity to which it
is addressed and may contain confidential and/or privileged material.
Any review, retransmission, dissemination, copying, or other use of
this information by persons or entities other than the intended
recipient is prohibited. If you received this e-mail or its
attachments in error, please contact the sender and delete the
material from any system and destroy any copies.
_______________________________________________
cisco-voip mailing list
cisco-voip@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-voip
RE: Need Help Configuring Cat2924XL [ In reply to ]
The ports with the voice vlan command need to be in trunking mode. The
switch in the IP Phone is looking for a trunk.

Int fa0/5
Switchport voice vlan 100
Switchport mode trunk
Spanning-tree portfast

Does the 2924xl support voice vlans though? I wasn't aware that it did.

Tm

Tim Medley
Appia Communications


-----Original Message-----
From: cisco-voip-bounces@puck.nether.net
[mailto:cisco-voip-bounces@puck.nether.net] On Behalf Of Anthony Mendoza
Sent: Thursday, July 15, 2004 3:04 PM
To: cisco-voip@puck.nether.net
Subject: [cisco-voip] Need Help Configuring Cat2924XL


I've got a Cat2924XL with the following relevant config snippets:

rwc-2924xl-131#show vlan
12 DMZ active
100 IP Phones active Fa0/7

interface FastEthernet0/5
switchport voice vlan 100
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 2
switchport voice vlan 100
!
interface FastEthernet0/7
switchport access vlan 100
spanning-tree portfast

interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk

interface VLAN2
ip address 172.16.0.131 255.255.0.0
no ip directed-broadcast
no ip route-cache


So... FE0/7 works fine (as you would expect), but neither 0/5 or 0/6
work ... The phone sees the operational VLAN 100, but never gets an
IP.. What the heck am I doing wrong? Cisco's docs only show the
"switchport voice vlan" option as being relevant. Is there something
I'm missing on the switch config? I've rebooted the phones and switch a
few times.

Thanks for any help,
--
Anthony Mendoza

CONFIDENTIALITY NOTICE: The information contained in this message and
or attachments is intended only for the person or entity to which it
is addressed and may contain confidential and/or privileged material.
Any review, retransmission, dissemination, copying, or other use of
this information by persons or entities other than the intended
recipient is prohibited. If you received this e-mail or its
attachments in error, please contact the sender and delete the
material from any system and destroy any copies.
_______________________________________________
cisco-voip mailing list
cisco-voip@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-voip
RE: Need Help Configuring Cat2924XL [ In reply to ]
Do you have to run it as a trunk on the 2924?

Our 3550's look like this:

interface FastEthernet0/2
switchport access vlan 10
switchport mode dynamic desirable
switchport voice vlan 102
mls qos trust cos
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 3
wrr-queue cos-map 3 4
wrr-queue cos-map 4 5 6 7
priority-queue out
spanning-tree portfast

PC's connected to Phones and everything works.

Scott

PS. Simon, are you using CM and what version if so?
I had some problems with phones on the wrong vlan until the firmware
upgraded on the phone. Then they worked just fine.

-----Original Message-----
From: Simon Hamilton-Wilkes [mailto:simon@jettis.com]
Sent: Thursday, July 15, 2004 12:27 PM
To: 'Anthony Mendoza'; cisco-voip@puck.nether.net
Subject: RE: [cisco-voip] Need Help Configuring Cat2924XL

The voice interfaces should look something like this:
interface FastEthernet0/5
switchport access vlan 416
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 415,416
switchport mode dynamic desirable
switchport voice vlan 415
spanning-tree portfast


Simon

-----Original Message-----
From: cisco-voip-bounces@puck.nether.net
[mailto:cisco-voip-bounces@puck.nether.net] On Behalf Of Anthony Mendoza
Sent: Thursday, July 15, 2004 12:04 PM
To: cisco-voip@puck.nether.net
Subject: [cisco-voip] Need Help Configuring Cat2924XL


I've got a Cat2924XL with the following relevant config snippets:

rwc-2924xl-131#show vlan
12 DMZ active
100 IP Phones active Fa0/7

interface FastEthernet0/5
switchport voice vlan 100
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 2
switchport voice vlan 100
!
interface FastEthernet0/7
switchport access vlan 100
spanning-tree portfast

interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk

interface VLAN2
ip address 172.16.0.131 255.255.0.0
no ip directed-broadcast
no ip route-cache


So... FE0/7 works fine (as you would expect), but neither 0/5 or 0/6
work
... The phone sees the operational VLAN 100, but never gets an IP..
What
the heck am I doing wrong? Cisco's docs only show the "switchport voice
vlan" option as being relevant. Is there something I'm missing on the
switch config? I've rebooted the phones and switch a few times.

Thanks for any help,
--
Anthony Mendoza

CONFIDENTIALITY NOTICE: The information contained in this message and or
attachments is intended only for the person or entity to which it is
addressed and may contain confidential and/or privileged material.
Any review, retransmission, dissemination, copying, or other use of this
information by persons or entities other than the intended recipient is
prohibited. If you received this e-mail or its attachments in error,
please
contact the sender and delete the material from any system and destroy
any
copies.
_______________________________________________
cisco-voip mailing list
cisco-voip@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-voip

_______________________________________________
cisco-voip mailing list
cisco-voip@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-voip
Re: Need Help Configuring Cat2924XL [ In reply to ]
Thanks all for your input. On my 2924XL this syntax ultimately worked:

interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,100,1002-1005
switchport mode trunk
switchport voice vlan 100
spanning-tree portfast

Not sure why the Cisco docs didn't show that...

I'm using this rev for those wondering about the 2924xl and voice VLAN
support:

rwc-2924xl-131#sho ver
Cisco Internetwork Operating System Software
IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5)WC10,
RELEASE SOFTWARE (fc1)

--
Anthony Mendoza

On 7/15/2004 12:27 PM, Simon Hamilton-Wilkes wrote:
> The voice interfaces should look something like this:
> interface FastEthernet0/5
> switchport access vlan 416
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 415,416
> switchport mode dynamic desirable
> switchport voice vlan 415
> spanning-tree portfast
>
>
> Simon
>
> -----Original Message-----
> From: cisco-voip-bounces@puck.nether.net
> [mailto:cisco-voip-bounces@puck.nether.net] On Behalf Of Anthony Mendoza
> Sent: Thursday, July 15, 2004 12:04 PM
> To: cisco-voip@puck.nether.net
> Subject: [cisco-voip] Need Help Configuring Cat2924XL
>
>
> I've got a Cat2924XL with the following relevant config snippets:
>
> rwc-2924xl-131#show vlan
> 12 DMZ active
> 100 IP Phones active Fa0/7
>
> interface FastEthernet0/5
> switchport voice vlan 100
> spanning-tree portfast
> !
> interface FastEthernet0/6
> switchport access vlan 2
> switchport voice vlan 100
> !
> interface FastEthernet0/7
> switchport access vlan 100
> spanning-tree portfast
>
> interface FastEthernet0/24
> switchport trunk encapsulation dot1q
> switchport mode trunk
>
> interface VLAN2
> ip address 172.16.0.131 255.255.0.0
> no ip directed-broadcast
> no ip route-cache
>
>
> So... FE0/7 works fine (as you would expect), but neither 0/5 or 0/6 work
> ... The phone sees the operational VLAN 100, but never gets an IP.. What
> the heck am I doing wrong? Cisco's docs only show the "switchport voice
> vlan" option as being relevant. Is there something I'm missing on the
> switch config? I've rebooted the phones and switch a few times.
>
> Thanks for any help,
> --
> Anthony Mendoza
>
> CONFIDENTIALITY NOTICE: The information contained in this message and or
> attachments is intended only for the person or entity to which it is
> addressed and may contain confidential and/or privileged material.
> Any review, retransmission, dissemination, copying, or other use of this
> information by persons or entities other than the intended recipient is
> prohibited. If you received this e-mail or its attachments in error, please
> contact the sender and delete the material from any system and destroy any
> copies.
> _______________________________________________
> cisco-voip mailing list
> cisco-voip@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-voip
>

CONFIDENTIALITY NOTICE: The information contained in this message and
or attachments is intended only for the person or entity to which it
is addressed and may contain confidential and/or privileged material.
Any review, retransmission, dissemination, copying, or other use of
this information by persons or entities other than the intended
recipient is prohibited. If you received this e-mail or its
attachments in error, please contact the sender and delete the
material from any system and destroy any copies.