Mailing List Archive

C2C ASR9K
Greetings
I am trying to configure C2C with BGP as the PE-CE routing protocol and Static as the C to CE routing protocol.
The main issue am running now is the eBGP session (VPNv4) between the CEs , routes are delivered but there is no connectivity and hence the eBGP session is not coming up.
Per my understanding , the BGP should be labelled unicast between the PE (XRV 6.6.2) and the respective CE. Before i changed the BGP session from IPv4 unicast to labeled unicast it was working (CE to CE traffic) , when I moved to the C traffic , I had to change the BGP to labeled unicast.

C1 ? CE2 ? PE3 ? P4 ? P5 ? PE6 ? CE7 ? C8

PE3:
router bgp 100
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
neighbor 10.1.100.6
remote-as 100
update-source Loopback0
address-family vpnv4 unicast

vrf CORE
rd 100:1
address-family ipv4 unicast
allocate-label all
!
neighbor 172.16.23.2
remote-as 10
address-family ipv4 labeled-unicast
route-policy ALLOW in
route-policy ALLOW out

CE2:
router bgp 10
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.1.100.7 remote-as 7
neighbor 10.1.100.7 ebgp-multihop 5
neighbor 172.16.23.3 remote-as 100
!
address-family ipv4
network 10.1.100.2 mask 255.255.255.255
neighbor 172.16.23.3 activate
neighbor 172.16.23.3 send-label
exit-address-family
!
address-family vpnv4
neighbor 10.1.100.7 activate
neighbor 10.1.100.7 send-community extended
exit-address-family
!
address-family ipv4 vrf CUST
redistribute static
exit-address-family

Nothing on the C except for a default route , is there anything I am missing? LDP is functioning well along the path.

Appreciated.


_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: C2C ASR9K [ In reply to ]
Hi Mohammad,

XR requires the PE to have a /32 route towards the directly connected CE. This will enable MPLS on the interface.

PE3:
router static
vrf CORE
address-family ipv4 unicast
172.16.23.2/32 <physical interface towards CE2>

The same thing needs to be done on PE6 towards CE7.

One more thing.

You should specify the update-source on both CE2 and CE7. For instance on CE2:

neighbor 10.1.100.7 update-source lo0

Regards,

Harold



De : cisco-nsp <cisco-nsp-bounces@puck.nether.net> de la part de Mohammad Khalil via cisco-nsp <cisco-nsp@puck.nether.net>
Date : vendredi, 19 janvier 2024 ? 06:00
? : cisco-nsp@puck.nether.net <cisco-nsp@puck.nether.net>
Objet : [c-nsp] C2C ASR9K
Greetings
I am trying to configure C2C with BGP as the PE-CE routing protocol and Static as the C to CE routing protocol.
The main issue am running now is the eBGP session (VPNv4) between the CEs , routes are delivered but there is no connectivity and hence the eBGP session is not coming up.
Per my understanding , the BGP should be labelled unicast between the PE (XRV 6.6.2) and the respective CE. Before i changed the BGP session from IPv4 unicast to labeled unicast it was working (CE to CE traffic) , when I moved to the C traffic , I had to change the BGP to labeled unicast.

C1 ? CE2 ? PE3 ? P4 ? P5 ? PE6 ? CE7 ? C8

PE3:
router bgp 100
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
neighbor 10.1.100.6
remote-as 100
update-source Loopback0
address-family vpnv4 unicast

vrf CORE
rd 100:1
address-family ipv4 unicast
allocate-label all
!
neighbor 172.16.23.2
remote-as 10
address-family ipv4 labeled-unicast
route-policy ALLOW in
route-policy ALLOW out

CE2:
router bgp 10
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.1.100.7 remote-as 7
neighbor 10.1.100.7 ebgp-multihop 5
neighbor 172.16.23.3 remote-as 100
!
address-family ipv4
network 10.1.100.2 mask 255.255.255.255
neighbor 172.16.23.3 activate
neighbor 172.16.23.3 send-label
exit-address-family
!
address-family vpnv4
neighbor 10.1.100.7 activate
neighbor 10.1.100.7 send-community extended
exit-address-family
!
address-family ipv4 vrf CUST
redistribute static
exit-address-family

Nothing on the C except for a default route , is there anything I am missing? LDP is functioning well along the path.

Appreciated.


_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: C2C ASR9K [ In reply to ]
Thanks, Harold, for the great insight , actually I missed configuring the /32 route : ) My bad.
________________________________
From: Harold Ritter (hritter) <hritter@cisco.com>
Sent: Friday, January 19, 2024 6:51 PM
To: Mohammad Khalil <eng_mssk@hotmail.com>; cisco-nsp@puck.nether.net <cisco-nsp@puck.nether.net>
Subject: Re: C2C ASR9K


Hi Mohammad,



XR requires the PE to have a /32 route towards the directly connected CE. This will enable MPLS on the interface.



PE3:

router static

vrf CORE

address-family ipv4 unicast

172.16.23.2/32 <physical interface towards CE2>



The same thing needs to be done on PE6 towards CE7.



One more thing.



You should specify the update-source on both CE2 and CE7. For instance on CE2:



neighbor 10.1.100.7 update-source lo0



Regards,



Harold







De : cisco-nsp <cisco-nsp-bounces@puck.nether.net> de la part de Mohammad Khalil via cisco-nsp <cisco-nsp@puck.nether.net>
Date : vendredi, 19 janvier 2024 ? 06:00
? : cisco-nsp@puck.nether.net <cisco-nsp@puck.nether.net>
Objet : [c-nsp] C2C ASR9K

Greetings
I am trying to configure C2C with BGP as the PE-CE routing protocol and Static as the C to CE routing protocol.
The main issue am running now is the eBGP session (VPNv4) between the CEs , routes are delivered but there is no connectivity and hence the eBGP session is not coming up.
Per my understanding , the BGP should be labelled unicast between the PE (XRV 6.6.2) and the respective CE. Before i changed the BGP session from IPv4 unicast to labeled unicast it was working (CE to CE traffic) , when I moved to the C traffic , I had to change the BGP to labeled unicast.

C1 ? CE2 ? PE3 ? P4 ? P5 ? PE6 ? CE7 ? C8

PE3:
router bgp 100
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
neighbor 10.1.100.6
remote-as 100
update-source Loopback0
address-family vpnv4 unicast

vrf CORE
rd 100:1
address-family ipv4 unicast
allocate-label all
!
neighbor 172.16.23.2
remote-as 10
address-family ipv4 labeled-unicast
route-policy ALLOW in
route-policy ALLOW out

CE2:
router bgp 10
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.1.100.7 remote-as 7
neighbor 10.1.100.7 ebgp-multihop 5
neighbor 172.16.23.3 remote-as 100
!
address-family ipv4
network 10.1.100.2 mask 255.255.255.255
neighbor 172.16.23.3 activate
neighbor 172.16.23.3 send-label
exit-address-family
!
address-family vpnv4
neighbor 10.1.100.7 activate
neighbor 10.1.100.7 send-community extended
exit-address-family
!
address-family ipv4 vrf CUST
redistribute static
exit-address-family

Nothing on the C except for a default route , is there anything I am missing? LDP is functioning well along the path.

Appreciated.


_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/