Mailing List Archive

MPLS xconnect with a WS-C3850 switch?
I have an interesting one that I'm trying to figure out. I have TAC case
open, but they've been slow to respond to say the least. Wondering if
anyone else has ever run into this. I have a simple MPLS xconnect between
2 ASR-920 routers running EIGRP. When I insert the 3850 in between them,
the xconnect comes up, but doesn't actually pass data. The 3850 has MPLS
enabled and sees the routes, etc. but doesn't seem to actually be passing
the traffic.

Feed --- 920_1 ----- 3850 ------ 920_2 ----- destination

920_1# sh mpls l2transport vc

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ----------
----------
Te0/0/1 Ethernet:1 10.10.0.6 10 UP


If I pull the 3850 out of the mix and connect the ASR920 routers together,
the xconnect comes up and passes traffic as I would expect. All of the
routes look fine, the 2 ASRs can ping each other, etc. But when I look at
the traffic counters, I see both sides transmitting, but never receiving
packets. According to the docs, the 3850 does support MPLS, and I do have
(or at least should have) the appropriate license. It seems like I'm
missing something, but I can't seem to figure out what that is.


Important parts of the config

920_1 (other side is the same, with different IPs).
interface TenGigabitEthernet0/0/0
description Uplink to 3850
mtu 9198
ip address 10.10.0.2 255.255.255.252
mpls ip
interface TenGigabitEthernet0/0/1
description Text Crossconnect
service instance 1 ethernet
encapsulation untagged
xconnect 10.10.0.6 10 encapsulation mpls

3850
ip routing
mpls label protocol ldp
system mtu 9198
interface TenGigabitEthernet1/0/1
description Asr920_1
no switchport
ip address 10.10.0.1 255.255.255.252
mpls ip
mpls label protocol ldp
interface TenGigabitEthernet1/0/2
description Asr920_2
no switchport
ip address 10.10.0.5 255.255.255.252
mpls ip
mpls label protocol ldp
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: MPLS xconnect with a WS-C3850 switch? [ In reply to ]
I'm doing this now between ASR920's, works fine.

Here's an example of what I'm doing:

ASR-920-1
interface GigabitEthernet0/0/22
description xxxxxxxxxx
mtu 9000
no ip address
load-interval 30
carrier-delay msec 0
negotiation auto
!
service instance 3936 ethernet
description xxxxxxxxxxxxxxxxxxxxxx
encapsulation dot1q 3936
rewrite ingress tag pop 1 symmetric
xconnect x.x.x.x 3936 encapsulation mpls (loopback IP of ASR2)
mtu 1600
!


ASR-920-2

interface GigabitEthernet0/0/13
description xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
mtu 9000
no ip address
load-interval 30
carrier-delay msec 0
negotiation auto
cdp enable
!
service instance 3936 ethernet
description xxxxxxxxxxxxxxxxxxxx
encapsulation dot1q 3936
rewrite ingress tag pop 1 symmetric
xconnect x.x.x.x 3936 encapsulation mpls (loopback IP of ASR1)
mtu 1600
!

Scott

On Thu, Nov 7, 2019 at 8:12 AM Shawn L <shawn@rmrf.us> wrote:

> I have an interesting one that I'm trying to figure out. I have TAC case
> open, but they've been slow to respond to say the least. Wondering if
> anyone else has ever run into this. I have a simple MPLS xconnect between
> 2 ASR-920 routers running EIGRP. When I insert the 3850 in between them,
> the xconnect comes up, but doesn't actually pass data. The 3850 has MPLS
> enabled and sees the routes, etc. but doesn't seem to actually be passing
> the traffic.
>
> Feed --- 920_1 ----- 3850 ------ 920_2 ----- destination
>
> 920_1# sh mpls l2transport vc
>
> Local intf Local circuit Dest address VC ID Status
> ------------- -------------------------- --------------- ----------
> ----------
> Te0/0/1 Ethernet:1 10.10.0.6 10 UP
>
>
> If I pull the 3850 out of the mix and connect the ASR920 routers together,
> the xconnect comes up and passes traffic as I would expect. All of the
> routes look fine, the 2 ASRs can ping each other, etc. But when I look at
> the traffic counters, I see both sides transmitting, but never receiving
> packets. According to the docs, the 3850 does support MPLS, and I do have
> (or at least should have) the appropriate license. It seems like I'm
> missing something, but I can't seem to figure out what that is.
>
>
> Important parts of the config
>
> 920_1 (other side is the same, with different IPs).
> interface TenGigabitEthernet0/0/0
> description Uplink to 3850
> mtu 9198
> ip address 10.10.0.2 255.255.255.252
> mpls ip
> interface TenGigabitEthernet0/0/1
> description Text Crossconnect
> service instance 1 ethernet
> encapsulation untagged
> xconnect 10.10.0.6 10 encapsulation mpls
>
> 3850
> ip routing
> mpls label protocol ldp
> system mtu 9198
> interface TenGigabitEthernet1/0/1
> description Asr920_1
> no switchport
> ip address 10.10.0.1 255.255.255.252
> mpls ip
> mpls label protocol ldp
> interface TenGigabitEthernet1/0/2
> description Asr920_2
> no switchport
> ip address 10.10.0.5 255.255.255.252
> mpls ip
> mpls label protocol ldp
> _______________________________________________
> cisco-nsp mailing list cisco-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: MPLS xconnect with a WS-C3850 switch? [ In reply to ]
A-ha. Gave both routers loopback ip addresses and configured the xconnect
to use them, and it came right up.

It's interesting that it wouldn't work with addresses on the physical
interfaces. In any event, it's working now. Thanks!

Shawn

On Thu, Nov 7, 2019 at 10:49 AM Scott Miller <fordlove@gmail.com> wrote:

> I'm doing this now between ASR920's, works fine.
>
> Here's an example of what I'm doing:
>
> ASR-920-1
> interface GigabitEthernet0/0/22
> description xxxxxxxxxx
> mtu 9000
> no ip address
> load-interval 30
> carrier-delay msec 0
> negotiation auto
> !
> service instance 3936 ethernet
> description xxxxxxxxxxxxxxxxxxxxxx
> encapsulation dot1q 3936
> rewrite ingress tag pop 1 symmetric
> xconnect x.x.x.x 3936 encapsulation mpls (loopback IP of ASR2)
> mtu 1600
> !
>
>
> ASR-920-2
>
> interface GigabitEthernet0/0/13
> description xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
> mtu 9000
> no ip address
> load-interval 30
> carrier-delay msec 0
> negotiation auto
> cdp enable
> !
> service instance 3936 ethernet
> description xxxxxxxxxxxxxxxxxxxx
> encapsulation dot1q 3936
> rewrite ingress tag pop 1 symmetric
> xconnect x.x.x.x 3936 encapsulation mpls (loopback IP of ASR1)
> mtu 1600
> !
>
> Scott
>
> On Thu, Nov 7, 2019 at 8:12 AM Shawn L <shawn@rmrf.us> wrote:
>
>> I have an interesting one that I'm trying to figure out. I have TAC case
>> open, but they've been slow to respond to say the least. Wondering if
>> anyone else has ever run into this. I have a simple MPLS xconnect between
>> 2 ASR-920 routers running EIGRP. When I insert the 3850 in between them,
>> the xconnect comes up, but doesn't actually pass data. The 3850 has MPLS
>> enabled and sees the routes, etc. but doesn't seem to actually be passing
>> the traffic.
>>
>> Feed --- 920_1 ----- 3850 ------ 920_2 ----- destination
>>
>> 920_1# sh mpls l2transport vc
>>
>> Local intf Local circuit Dest address VC ID
>> Status
>> ------------- -------------------------- --------------- ----------
>> ----------
>> Te0/0/1 Ethernet:1 10.10.0.6 10 UP
>>
>>
>> If I pull the 3850 out of the mix and connect the ASR920 routers together,
>> the xconnect comes up and passes traffic as I would expect. All of the
>> routes look fine, the 2 ASRs can ping each other, etc. But when I look at
>> the traffic counters, I see both sides transmitting, but never receiving
>> packets. According to the docs, the 3850 does support MPLS, and I do have
>> (or at least should have) the appropriate license. It seems like I'm
>> missing something, but I can't seem to figure out what that is.
>>
>>
>> Important parts of the config
>>
>> 920_1 (other side is the same, with different IPs).
>> interface TenGigabitEthernet0/0/0
>> description Uplink to 3850
>> mtu 9198
>> ip address 10.10.0.2 255.255.255.252
>> mpls ip
>> interface TenGigabitEthernet0/0/1
>> description Text Crossconnect
>> service instance 1 ethernet
>> encapsulation untagged
>> xconnect 10.10.0.6 10 encapsulation mpls
>>
>> 3850
>> ip routing
>> mpls label protocol ldp
>> system mtu 9198
>> interface TenGigabitEthernet1/0/1
>> description Asr920_1
>> no switchport
>> ip address 10.10.0.1 255.255.255.252
>> mpls ip
>> mpls label protocol ldp
>> interface TenGigabitEthernet1/0/2
>> description Asr920_2
>> no switchport
>> ip address 10.10.0.5 255.255.255.252
>> mpls ip
>> mpls label protocol ldp
>> _______________________________________________
>> cisco-nsp mailing list cisco-nsp@puck.nether.net
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>
>
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: MPLS xconnect with a WS-C3850 switch? [ In reply to ]
On 7/Nov/19 18:37, Shawn L wrote:
> A-ha. Gave both routers loopback ip addresses and configured the xconnect
> to use them, and it came right up.
>
> It's interesting that it wouldn't work with addresses on the physical
> interfaces. In any event, it's working now. Thanks!

I'm surprised an Enterprise Catalyst switch can run MPLS :-).

But more importantly, I don't remember ever setting up pw's on physical
interface IP addresses... always toward the Loopback.

Mark.
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: MPLS xconnect with a WS-C3850 switch? [ In reply to ]
Doesn't necessarily need to be the loopback, but whatever IP is configured
as the MPLS LDP ROUTER-ID.

It's just that most of us use the loopback for the MPLS LDP ROUTER-ID.



On Thu, Nov 7, 2019 at 2:50 PM Mark Tinka <mark.tinka@seacom.mu> wrote:

>
>
> On 7/Nov/19 18:37, Shawn L wrote:
> > A-ha. Gave both routers loopback ip addresses and configured the
> xconnect
> > to use them, and it came right up.
> >
> > It's interesting that it wouldn't work with addresses on the physical
> > interfaces. In any event, it's working now. Thanks!
>
> I'm surprised an Enterprise Catalyst switch can run MPLS :-).
>
> But more importantly, I don't remember ever setting up pw's on physical
> interface IP addresses... always toward the Loopback.
>
> Mark.
> _______________________________________________
> cisco-nsp mailing list cisco-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: MPLS xconnect with a WS-C3850 switch? [ In reply to ]
On Fri, Nov 8, 2019, at 05:55, Scott Miller wrote:

> It's just that most of us use the loopback for the MPLS LDP ROUTER-ID.

A Loopback being the established BCP since it never goes down.

--
R.-A. Feurdean
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: MPLS xconnect with a WS-C3850 switch? [ In reply to ]
On 8/Nov/19 06:55, Scott Miller wrote:
> Doesn't necessarily need to be the loopback, but whatever IP is
> configured as the MPLS LDP ROUTER-ID.
>
> It's just that most of us use the loopback for the MPLS LDP ROUTER-ID.

The pedantry is accurate, but I'd rather not waste time about real life :-).

Mark.
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: MPLS xconnect with a WS-C3850 switch? [ In reply to ]
On 8/Nov/19 08:33, Radu-Adrian FEURDEAN wrote:

> A Loopback being the established BCP since it never goes down.

This.

But even more importantly, it abstracts the underlying transport
infrastructure. It doesn't matter which link carries the traffic, it
will always get to the router.

Mark.

_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/