Mailing List Archive

Call rejeciton from Cisco
Hello. I am using an AS5400 to generate a PRI that is then going to a CiscoIAD. So on the AS5400 side I have. The IAD only has 8 analog voice ports, so I am using the last 8 channels of the PRI for voice ports, and the first 16 channels as a T1 for internet service.

controller T1 1/0:24
framing esf
channel-group 0 timeslots 1-16 speed 64
loopback network ignore
pri-group timeslots 17-24

interface Serial1/0:24:0
ip address 216.24.28.249 255.255.255.252
encapsulation ppp
no cdp enable
!
interface Serial1/0:24:23
no ip address
isdn switch-type primary-ni
isdn protocol-emulate network
no isdn outgoing ie redirecting-number
no isdn incoming alerting add-PI
no cdp enable


On the IAD I have....

controller T1 1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-16 speed 64
pri-group timeslots 17-24 nfas_d primary nfas_int 1 nfas_group 1

interface Serial1/0:0
ip address 216.24.28.250 255.255.255.252
encapsulation ppp
!
interface Serial1/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable

dial-peer voice 1 pots
description route calls to ISDN
destination-pattern .T
port 1/0:23

The PRI and TEI's seem to be up. The AS5400 has intermachine trunks connecting it to the telco system and routes incoming and outgoing phone calls all day long, but when I try to make an outgoing call from the Cisco IAD I see the IAD 2400 appear to do the call setup and send the call out 1/0:23, but eventually I get a reject with a cause code of "0x0", which isn't very helpful. I'm not even sure if the error message is coming from the far end (the AS5400) or the near end (the IAD2400).

Error output below with the reject highlighted in red. It would seem that the called is being rejected for "Invalid information element contents." I'm having a hard time determining which elements it considers invalid, though. We've never generated our own PRI out to a client box before, so any information anyone has would be greatly appreciated. Also, if anyone has a config example of both ends of such an arrangement I would love to see it.

022127: 1w0d: ISDN Se1/0:24:23 Q931: RX <- SETUP pd = 8 callref = 0x002C
Bearer Capability i = 0x9090A2
Standard = CCITT
Transer Capability = 3.1kHz Audio
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xE1818397
Preferred, Interface 1, Channel 23
Progress Ind i = 0x8183 - Origination address is non-ISDN
Calling Party Number i = 0x2183, '5025673005'
Plan:ISDN, Type:National
Called Party Number i = 0x80, '75023871095'
Plan:Unknown, Type:Unknown
022128: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x64FBB518), ticks (30000), event (0x1250)
022129: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: source = 0x20A, event = 0x241, call id = 0x0, int id = 0x0
022130: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: call_id 0x2F62 cr 0x802C state 0 event 0x5 ces 1
022131: 1w0d: ISDN Se1/0:24:23 Q931d: L3_ProcessEvent: callref = 0x802C SETUP:U0_Setup(nlcb)
022132: 1w0d: ISDN Se1/0:24:23 Q931d: L3_state_change: callref 0x802C old NULL_STATE, new CALL_PRESENT
022133: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: source = 0x400, event = 0x340, call id = 0x2F62, int id = 0x0
022134: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: call_id 0x2F62 cr 0x802C state 6 event 0x82 ces 1
022135: 1w0d: ISDN Se1/0:24:23 Q931d: L3_ProcessEvent: callref = 0x802C CC_SETUP_REJ_REQ:U6_SetupRejReq(nlcb)
022136: 1w0d: ISDN Se1/0:24:23 Q931d: L3_state_change: callref 0x802C old CALL_PRESENT, new NULL_STATE
022137: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x65F432AC), ticks (1000), event (0x1240)
022138: 1w0d: ISDN Se1/0:24:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x802C
Cause i = 0x82E418 - Invalid information element contents
022139: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x64FBB518), ticks (30000), event (0x1250)
AMSS1#
Re: Call rejeciton from Cisco [ In reply to ]
On a related note, I am aware that part of the problem might be that the called party number might be listed as plan unknown and type unknown. I've been trying to figure out a way on the IAD 2400 to set this to national and isdn for all outgoing calls, but the only way I can find to do that is with translation rules, and those all seem to assume that the first thing you want to do is search and replace part of the dialed number. I really don't care what the dialed number is. Is there some way to match just on the plan and type, or some way to set those values other than a translation rule?
----- Original Message -----
From: Joseph Mays
To: cisco-nas@puck.nether.net ; cisco-nsp@puck.nether.net
Sent: Tuesday, May 15, 2012 1:42 PM
Subject: Call rejeciton from Cisco


Hello. I am using an AS5400 to generate a PRI that is then going to a CiscoIAD. So on the AS5400 side I have. The IAD only has 8 analog voice ports, so I am using the last 8 channels of the PRI for voice ports, and the first 16 channels as a T1 for internet service.

controller T1 1/0:24
framing esf
channel-group 0 timeslots 1-16 speed 64
loopback network ignore
pri-group timeslots 17-24

interface Serial1/0:24:0
ip address 216.24.28.249 255.255.255.252
encapsulation ppp
no cdp enable
!
interface Serial1/0:24:23
no ip address
isdn switch-type primary-ni
isdn protocol-emulate network
no isdn outgoing ie redirecting-number
no isdn incoming alerting add-PI
no cdp enable


On the IAD I have....

controller T1 1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-16 speed 64
pri-group timeslots 17-24 nfas_d primary nfas_int 1 nfas_group 1

interface Serial1/0:0
ip address 216.24.28.250 255.255.255.252
encapsulation ppp
!
interface Serial1/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable

dial-peer voice 1 pots
description route calls to ISDN
destination-pattern .T
port 1/0:23

The PRI and TEI's seem to be up. The AS5400 has intermachine trunks connecting it to the telco system and routes incoming and outgoing phone calls all day long, but when I try to make an outgoing call from the Cisco IAD I see the IAD 2400 appear to do the call setup and send the call out 1/0:23, but eventually I get a reject with a cause code of "0x0", which isn't very helpful. I'm not even sure if the error message is coming from the far end (the AS5400) or the near end (the IAD2400).

Error output below with the reject highlighted in red. It would seem that the called is being rejected for "Invalid information element contents." I'm having a hard time determining which elements it considers invalid, though. We've never generated our own PRI out to a client box before, so any information anyone has would be greatly appreciated. Also, if anyone has a config example of both ends of such an arrangement I would love to see it.

022127: 1w0d: ISDN Se1/0:24:23 Q931: RX <- SETUP pd = 8 callref = 0x002C
Bearer Capability i = 0x9090A2
Standard = CCITT
Transer Capability = 3.1kHz Audio
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xE1818397
Preferred, Interface 1, Channel 23
Progress Ind i = 0x8183 - Origination address is non-ISDN
Calling Party Number i = 0x2183, '5025673005'
Plan:ISDN, Type:National
Called Party Number i = 0x80, '75023871095'
Plan:Unknown, Type:Unknown
022128: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x64FBB518), ticks (30000), event (0x1250)
022129: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: source = 0x20A, event = 0x241, call id = 0x0, int id = 0x0
022130: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: call_id 0x2F62 cr 0x802C state 0 event 0x5 ces 1
022131: 1w0d: ISDN Se1/0:24:23 Q931d: L3_ProcessEvent: callref = 0x802C SETUP:U0_Setup(nlcb)
022132: 1w0d: ISDN Se1/0:24:23 Q931d: L3_state_change: callref 0x802C old NULL_STATE, new CALL_PRESENT
022133: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: source = 0x400, event = 0x340, call id = 0x2F62, int id = 0x0
022134: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: call_id 0x2F62 cr 0x802C state 6 event 0x82 ces 1
022135: 1w0d: ISDN Se1/0:24:23 Q931d: L3_ProcessEvent: callref = 0x802C CC_SETUP_REJ_REQ:U6_SetupRejReq(nlcb)
022136: 1w0d: ISDN Se1/0:24:23 Q931d: L3_state_change: callref 0x802C old CALL_PRESENT, new NULL_STATE
022137: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x65F432AC), ticks (1000), event (0x1240)
022138: 1w0d: ISDN Se1/0:24:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x802C
Cause i = 0x82E418 - Invalid information element contents
022139: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x64FBB518), ticks (30000), event (0x1250)
AMSS1#
Re: Call rejeciton from Cisco [ In reply to ]
Disregard. I figured out how to get it to set the plan and type, but it's still having the same problem.

027789: 1w0d: ISDN Se1/0:24:23 Q931: RX <- SETUP pd = 8 callref = 0x002D
Bearer Capability i = 0x9090A2
Standard = CCITT
Transer Capability = 3.1kHz Audio
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xE1818397
Preferred, Interface 1, Channel 23
Progress Ind i = 0x8183 - Origination address is non-ISDN
Calling Party Number i = 0x2183, '5025673005'
Plan:ISDN, Type:National
Called Party Number i = 0xA1, '5023871095'
Plan:ISDN, Type:National
027790: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x64FBB518), ticks (30000), event (0x1250)
027791: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: source = 0x20A, event = 0x241, call id = 0x0, int id = 0x0
027792: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: call_id 0x300E cr 0x802D state 0 event 0x5 ces 1
027793: 1w0d: ISDN Se1/0:24:23 Q931d: L3_ProcessEvent: callref = 0x802D SETUP:U0_Setup(nlcb)
027794: 1w0d: ISDN Se1/0:24:23 Q931d: L3_state_change: callref 0x802D old NULL_STATE, new CALL_PRESENT
027795: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: source = 0x400, event = 0x340, call id = 0x300E, int id = 0x0
027796: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: call_id 0x300E cr 0x802D state 6 event 0x82 ces 1
027797: 1w0d: ISDN Se1/0:24:23 Q931d: L3_ProcessEvent: callref = 0x802D CC_SETUP_REJ_REQ:U6_SetupRejReq(nlcb)
027798: 1w0d: ISDN Se1/0:24:23 Q931d: L3_state_change: callref 0x802D old CALL_PRESENT, new NULL_STATE
027799: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x65F432AC), ticks (1000), event (0x1240)
027800: 1w0d: ISDN Se1/0:24:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x802D
Cause i = 0x82E418 - Invalid information element contents

----- Original Message -----
From: Joseph Mays
To: cisco-nas@puck.nether.net ; cisco-nsp@puck.nether.net
Sent: Tuesday, May 15, 2012 2:08 PM
Subject: Re: Call rejeciton from Cisco


On a related note, I am aware that part of the problem might be that the called party number might be listed as plan unknown and type unknown. I've been trying to figure out a way on the IAD 2400 to set this to national and isdn for all outgoing calls, but the only way I can find to do that is with translation rules, and those all seem to assume that the first thing you want to do is search and replace part of the dialed number. I really don't care what the dialed number is. Is there some way to match just on the plan and type, or some way to set those values other than a translation rule?
----- Original Message -----
From: Joseph Mays
To: cisco-nas@puck.nether.net ; cisco-nsp@puck.nether.net
Sent: Tuesday, May 15, 2012 1:42 PM
Subject: Call rejeciton from Cisco


Hello. I am using an AS5400 to generate a PRI that is then going to a CiscoIAD. So on the AS5400 side I have. The IAD only has 8 analog voice ports, so I am using the last 8 channels of the PRI for voice ports, and the first 16 channels as a T1 for internet service.

controller T1 1/0:24
framing esf
channel-group 0 timeslots 1-16 speed 64
loopback network ignore
pri-group timeslots 17-24

interface Serial1/0:24:0
ip address 216.24.28.249 255.255.255.252
encapsulation ppp
no cdp enable
!
interface Serial1/0:24:23
no ip address
isdn switch-type primary-ni
isdn protocol-emulate network
no isdn outgoing ie redirecting-number
no isdn incoming alerting add-PI
no cdp enable


On the IAD I have....

controller T1 1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-16 speed 64
pri-group timeslots 17-24 nfas_d primary nfas_int 1 nfas_group 1

interface Serial1/0:0
ip address 216.24.28.250 255.255.255.252
encapsulation ppp
!
interface Serial1/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable

dial-peer voice 1 pots
description route calls to ISDN
destination-pattern .T
port 1/0:23

The PRI and TEI's seem to be up. The AS5400 has intermachine trunks connecting it to the telco system and routes incoming and outgoing phone calls all day long, but when I try to make an outgoing call from the Cisco IAD I see the IAD 2400 appear to do the call setup and send the call out 1/0:23, but eventually I get a reject with a cause code of "0x0", which isn't very helpful. I'm not even sure if the error message is coming from the far end (the AS5400) or the near end (the IAD2400).

Error output below with the reject highlighted in red. It would seem that the called is being rejected for "Invalid information element contents." I'm having a hard time determining which elements it considers invalid, though. We've never generated our own PRI out to a client box before, so any information anyone has would be greatly appreciated. Also, if anyone has a config example of both ends of such an arrangement I would love to see it.

022127: 1w0d: ISDN Se1/0:24:23 Q931: RX <- SETUP pd = 8 callref = 0x002C
Bearer Capability i = 0x9090A2
Standard = CCITT
Transer Capability = 3.1kHz Audio
Transfer Mode = Circuit
Transfer Rate = 64 kbit/s
Channel ID i = 0xE1818397
Preferred, Interface 1, Channel 23
Progress Ind i = 0x8183 - Origination address is non-ISDN
Calling Party Number i = 0x2183, '5025673005'
Plan:ISDN, Type:National
Called Party Number i = 0x80, '75023871095'
Plan:Unknown, Type:Unknown
022128: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x64FBB518), ticks (30000), event (0x1250)
022129: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: source = 0x20A, event = 0x241, call id = 0x0, int id = 0x0
022130: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: call_id 0x2F62 cr 0x802C state 0 event 0x5 ces 1
022131: 1w0d: ISDN Se1/0:24:23 Q931d: L3_ProcessEvent: callref = 0x802C SETUP:U0_Setup(nlcb)
022132: 1w0d: ISDN Se1/0:24:23 Q931d: L3_state_change: callref 0x802C old NULL_STATE, new CALL_PRESENT
022133: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: source = 0x400, event = 0x340, call id = 0x2F62, int id = 0x0
022134: 1w0d: ISDN Se1/0:24:23 Q931d: L3_Go: call_id 0x2F62 cr 0x802C state 6 event 0x82 ces 1
022135: 1w0d: ISDN Se1/0:24:23 Q931d: L3_ProcessEvent: callref = 0x802C CC_SETUP_REJ_REQ:U6_SetupRejReq(nlcb)
022136: 1w0d: ISDN Se1/0:24:23 Q931d: L3_state_change: callref 0x802C old CALL_PRESENT, new NULL_STATE
022137: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x65F432AC), ticks (1000), event (0x1240)
022138: 1w0d: ISDN Se1/0:24:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x802C
Cause i = 0x82E418 - Invalid information element contents
022139: 1w0d: ISDN Se1/0:24:23 LIFd: LIF_StartTimer: timer (0x64FBB518), ticks (30000), event (0x1250)
AMSS1#