Mailing List Archive

Cisco 7206VXR running out of steam at 20mb throughput
We have a Cisco 7206VXR router which is connected to interoute on one side and a 3com 3300 with various VOIP Gateways (Cisco 53xx and 54xx) and HTTP servers on the other, however its performance is not quite what we expected, it seems to suffer from high CPU once throughout hits approx 20mb upwards, til it gets to around 30mb when CPU is 90% and it becomes unuseable.

According to our Cisco dealer this unit should be good for 100mb plus throughput no problems, so they are puzzled by the problem, they have sold us some more ram we are now upto 1gb but it has made no difference.

I have tried introducing an access list firstly to rule out ICMP flood / attack and then I blocked http as well to rule out code red.

I have also followed the Cisco guide to troubleshooting high CPU issue, and enabled CEF and tried to make the config as simple as possible. I also used IP accounting to identify that the traffic is as I expect (not DOS)

It seems the VOIP traffic maybe causing the problem, and a few people have commented that the small packet size causes issues - this accounts for 90% of the traffic going through this router.

Can anyone point me the right direction regarding what to try on this?

Version:- "disk2:c7200-is-mz.123-9.bin"
Here is the config:-

Current configuration : 2319 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 ****
!
username ***
username ***
no aaa new-model
ip subnet-zero
!
!
ip cef
!

!
interface FastEthernet0/0
ip address 212.*** 255.255.255.252
duplex full
no cdp enable
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface FastEthernet1/0
ip address 84.*** 255.255.255.224 secondary
ip address 212.*** 255.255.255.224 secondary
ip address 89.*** 255.255.255.224 secondary
ip address 212.*** 255.255.255.224
duplex half
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 212.***

no ip http server
!
!
access-list 101 deny icmp any any
access-list 101 permit ip any any
access-list 102 deny icmp any any
access-list 102 deny tcp any any eq www
access-list 102 deny tcp any any eq 443
access-list 102 permit ip any any
!
snmp-server community ***
snmp-server enable traps tty
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
transport preferred all
transport output all
stopbits 1
line aux 0
transport preferred all
transport output all
stopbits 1
line vty 0 4
password ***
login
transport preferred all
transport input all
transport output all
line vty 5 10
password ***
login
transport preferred all
transport input all
transport output all
!
!
end

I'm at a loss as to what to try next, so any pointers would be much appreciated!

Thanks

Wayne




________________________________________________
Message sent using UebiMiau 2.7.9-pjm-patch
Re: Cisco 7206VXR running out of steam at 20mb throughput [ In reply to ]
Let's see a 'show proc cpu | excl %0.00__%0.00__%0.00' when your CPU
is running hot. As well, let's see show int f0/0 and show int f1/0

That aside, a couple things:

- Either force the connection between the 3Com and F1/0 to 100/full
or connect the 3Com to a Gig interface and let it auto-sense speed
and duplex. I see you have the FastE forced to half duplex which
isn't going to help your throughput. You will notice collisions and
dropped packets in show int as a result. I'm not sure if that's
going to increase CPU utilization though.

- Can you separate your traffic into VLANs? A bunch of secondaries
on an interface are an old practice and should be avoided, IMO.

- ip route-cache same-interface used to be helpful for situations
like yours, but it's been years since I used it and it was with fast
switching at the time, not CEF switching, so I'm not sure if it's
needed seeing as how you are running CEF.

On 17-May-07, at 8:37 AM, Wayne @ CTL wrote:

> We have a Cisco 7206VXR router which is connected to interoute on
> one side and a 3com 3300 with various VOIP Gateways (Cisco 53xx and
> 54xx) and HTTP servers on the other, however its performance is not
> quite what we expected, it seems to suffer from high CPU once
> throughout hits approx 20mb upwards, til it gets to around 30mb
> when CPU is 90% and it becomes unuseable.
>
> According to our Cisco dealer this unit should be good for 100mb
> plus throughput no problems, so they are puzzled by the problem,
> they have sold us some more ram we are now upto 1gb but it has made
> no difference.
>
> I have tried introducing an access list firstly to rule out ICMP
> flood / attack and then I blocked http as well to rule out code red.
>
> I have also followed the Cisco guide to troubleshooting high CPU
> issue, and enabled CEF and tried to make the config as simple as
> possible. I also used IP accounting to identify that the traffic is
> as I expect (not DOS)
>
> It seems the VOIP traffic maybe causing the problem, and a few
> people have commented that the small packet size causes issues -
> this accounts for 90% of the traffic going through this router.
>
> Can anyone point me the right direction regarding what to try on this?
>
> Version:- "disk2:c7200-is-mz.123-9.bin"
> Here is the config:-
>
> Current configuration : 2319 bytes
> !
> version 12.3
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname Router
> !
> boot-start-marker
> boot-end-marker
> !
> enable secret 5 ****
> !
> username ***
> username ***
> no aaa new-model
> ip subnet-zero
> !
> !
> ip cef
> !
>
> !
> interface FastEthernet0/0
> ip address 212.*** 255.255.255.252
> duplex full
> no cdp enable
> !
> interface GigabitEthernet0/1
> no ip address
> shutdown
> duplex auto
> speed auto
> media-type rj45
> no negotiation auto
> !
> interface GigabitEthernet0/2
> no ip address
> shutdown
> duplex auto
> speed auto
> media-type rj45
> no negotiation auto
> !
> interface GigabitEthernet0/3
> no ip address
> shutdown
> duplex auto
> speed auto
> media-type rj45
> no negotiation auto
> !
> interface FastEthernet1/0
> ip address 84.*** 255.255.255.224 secondary
> ip address 212.*** 255.255.255.224 secondary
> ip address 89.*** 255.255.255.224 secondary
> ip address 212.*** 255.255.255.224
> duplex half
> no cdp enable
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 212.***
>
> no ip http server
> !
> !
> access-list 101 deny icmp any any
> access-list 101 permit ip any any
> access-list 102 deny icmp any any
> access-list 102 deny tcp any any eq www
> access-list 102 deny tcp any any eq 443
> access-list 102 permit ip any any
> !
> snmp-server community ***
> snmp-server enable traps tty
> !
> !
> !
> !
> !
> gatekeeper
> shutdown
> !
> !
> line con 0
> transport preferred all
> transport output all
> stopbits 1
> line aux 0
> transport preferred all
> transport output all
> stopbits 1
> line vty 0 4
> password ***
> login
> transport preferred all
> transport input all
> transport output all
> line vty 5 10
> password ***
> login
> transport preferred all
> transport input all
> transport output all
> !
> !
> end
>
> I'm at a loss as to what to try next, so any pointers would be much
> appreciated!
>
> Thanks
>
> Wayne
>
>
>
>
>
> ________________________________________________
> Message sent using UebiMiau 2.7.9-pjm-patch
> _______________________________________________
> cisco-bba mailing list
> cisco-bba@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-bba

_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
Re: Cisco 7206VXR running out of steam at 20mb throughput [ In reply to ]
Please post a copy of "sh proc cpu | exc 0.00.*0.00"

Regards,

Frank

_____

From: cisco-bba-bounces@puck.nether.net
[mailto:cisco-bba-bounces@puck.nether.net] On Behalf Of Wayne @ CTL
Sent: Thursday, May 17, 2007 7:37 AM
To: cisco-bba@puck.nether.net
Subject: [cisco-bba] Cisco 7206VXR running out of steam at 20mb throughput



We have a Cisco 7206VXR router which is connected to interoute on one side
and a 3com 3300 with various VOIP Gateways (Cisco 53xx and 54xx) and HTTP
servers on the other, however its performance is not quite what we expected,
it seems to suffer from high CPU once throughout hits approx 20mb upwards,
til it gets to around 30mb when CPU is 90% and it becomes unuseable.

According to our Cisco dealer this unit should be good for 100mb plus
throughput no problems, so they are puzzled by the problem, they have sold
us some more ram we are now upto 1gb but it has made no difference.

I have tried introducing an access list firstly to rule out ICMP flood /
attack and then I blocked http as well to rule out code red.

I have also followed the Cisco guide to troubleshooting high CPU issue, and
enabled CEF and tried to make the config as simple as possible. I also used
IP accounting to identify that the traffic is as I expect (not DOS)

It seems the VOIP traffic maybe causing the problem, and a few people have
commented that the small packet size causes issues - this accounts for 90%
of the traffic going through this router.

Can anyone point me the right direction regarding what to try on this?

Version:- "disk2:c7200-is-mz.123-9.bin"
Here is the config:-

Current configuration : 2319 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 ****
!
username ***
username ***
no aaa new-model
ip subnet-zero
!
!
ip cef
!

!
interface FastEthernet0/0
ip address 212.*** 255.255.255.252
duplex full
no cdp enable
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface FastEthernet1/0
ip address 84.*** 255.255.255.224 secondary
ip address 212.*** 255.255.255.224 secondary
ip address 89.*** 255.255.255.224 secondary
ip address 212.*** 255.255.255.224
duplex half
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 212.***

no ip http server
!
!
access-list 101 deny icmp any any
access-list 101 permit ip any any
access-list 102 deny icmp any any
access-list 102 deny tcp any any eq www
access-list 102 deny tcp any any eq 443
access-list 102 permit ip any any
!
snmp-server community ***
snmp-server enable traps tty
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
transport preferred all
transport output all
stopbits 1
line aux 0
transport preferred all
transport output all
stopbits 1
line vty 0 4
password ***
login
transport preferred all
transport input all
transport output all
line vty 5 10
password ***
login
transport preferred all
transport input all
transport output all
!
!
end

I'm at a loss as to what to try next, so any pointers would be much
appreciated!

Thanks

Wayne






________________________________________________
Message sent using UebiMiau 2.7.9-pjm-patch
Re: Cisco 7206VXR running out of steam at 20mb throughput [ In reply to ]
Sorry, I meant "show proc cpu sorted | excl 0.00%__0.00%__0.00%" or
"show proc cpu | excl 0.00%__0.00%__0.00%"

On 17-May-07, at 10:39 AM, Jason Lixfeld wrote:

> Let's see a 'show proc cpu | excl %0.00__%0.00__%0.00' when your CPU
> is running hot. As well, let's see show int f0/0 and show int f1/0
>
> That aside, a couple things:
>
> - Either force the connection between the 3Com and F1/0 to 100/full
> or connect the 3Com to a Gig interface and let it auto-sense speed
> and duplex. I see you have the FastE forced to half duplex which
> isn't going to help your throughput. You will notice collisions and
> dropped packets in show int as a result. I'm not sure if that's
> going to increase CPU utilization though.
>
> - Can you separate your traffic into VLANs? A bunch of secondaries
> on an interface are an old practice and should be avoided, IMO.
>
> - ip route-cache same-interface used to be helpful for situations
> like yours, but it's been years since I used it and it was with fast
> switching at the time, not CEF switching, so I'm not sure if it's
> needed seeing as how you are running CEF.
>
> On 17-May-07, at 8:37 AM, Wayne @ CTL wrote:
>
>> We have a Cisco 7206VXR router which is connected to interoute on
>> one side and a 3com 3300 with various VOIP Gateways (Cisco 53xx and
>> 54xx) and HTTP servers on the other, however its performance is not
>> quite what we expected, it seems to suffer from high CPU once
>> throughout hits approx 20mb upwards, til it gets to around 30mb
>> when CPU is 90% and it becomes unuseable.
>>
>> According to our Cisco dealer this unit should be good for 100mb
>> plus throughput no problems, so they are puzzled by the problem,
>> they have sold us some more ram we are now upto 1gb but it has made
>> no difference.
>>
>> I have tried introducing an access list firstly to rule out ICMP
>> flood / attack and then I blocked http as well to rule out code red.
>>
>> I have also followed the Cisco guide to troubleshooting high CPU
>> issue, and enabled CEF and tried to make the config as simple as
>> possible. I also used IP accounting to identify that the traffic is
>> as I expect (not DOS)
>>
>> It seems the VOIP traffic maybe causing the problem, and a few
>> people have commented that the small packet size causes issues -
>> this accounts for 90% of the traffic going through this router.
>>
>> Can anyone point me the right direction regarding what to try on
>> this?
>>
>> Version:- "disk2:c7200-is-mz.123-9.bin"
>> Here is the config:-
>>
>> Current configuration : 2319 bytes
>> !
>> version 12.3
>> service timestamps debug datetime msec
>> service timestamps log datetime msec
>> no service password-encryption
>> !
>> hostname Router
>> !
>> boot-start-marker
>> boot-end-marker
>> !
>> enable secret 5 ****
>> !
>> username ***
>> username ***
>> no aaa new-model
>> ip subnet-zero
>> !
>> !
>> ip cef
>> !
>>
>> !
>> interface FastEthernet0/0
>> ip address 212.*** 255.255.255.252
>> duplex full
>> no cdp enable
>> !
>> interface GigabitEthernet0/1
>> no ip address
>> shutdown
>> duplex auto
>> speed auto
>> media-type rj45
>> no negotiation auto
>> !
>> interface GigabitEthernet0/2
>> no ip address
>> shutdown
>> duplex auto
>> speed auto
>> media-type rj45
>> no negotiation auto
>> !
>> interface GigabitEthernet0/3
>> no ip address
>> shutdown
>> duplex auto
>> speed auto
>> media-type rj45
>> no negotiation auto
>> !
>> interface FastEthernet1/0
>> ip address 84.*** 255.255.255.224 secondary
>> ip address 212.*** 255.255.255.224 secondary
>> ip address 89.*** 255.255.255.224 secondary
>> ip address 212.*** 255.255.255.224
>> duplex half
>> no cdp enable
>> !
>> ip classless
>> ip route 0.0.0.0 0.0.0.0 212.***
>>
>> no ip http server
>> !
>> !
>> access-list 101 deny icmp any any
>> access-list 101 permit ip any any
>> access-list 102 deny icmp any any
>> access-list 102 deny tcp any any eq www
>> access-list 102 deny tcp any any eq 443
>> access-list 102 permit ip any any
>> !
>> snmp-server community ***
>> snmp-server enable traps tty
>> !
>> !
>> !
>> !
>> !
>> gatekeeper
>> shutdown
>> !
>> !
>> line con 0
>> transport preferred all
>> transport output all
>> stopbits 1
>> line aux 0
>> transport preferred all
>> transport output all
>> stopbits 1
>> line vty 0 4
>> password ***
>> login
>> transport preferred all
>> transport input all
>> transport output all
>> line vty 5 10
>> password ***
>> login
>> transport preferred all
>> transport input all
>> transport output all
>> !
>> !
>> end
>>
>> I'm at a loss as to what to try next, so any pointers would be much
>> appreciated!
>>
>> Thanks
>>
>> Wayne
>>
>>
>>
>>
>>
>> ________________________________________________
>> Message sent using UebiMiau 2.7.9-pjm-patch
>> _______________________________________________
>> cisco-bba mailing list
>> cisco-bba@puck.nether.net
>> https://puck.nether.net/mailman/listinfo/cisco-bba
>
> _______________________________________________
> cisco-bba mailing list
> cisco-bba@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-bba

_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
Re: Cisco 7206VXR running out of steam at 20mb throughput [ In reply to ]
Hi Frank, Jason, thanks for your replies.
The half duplex was set for another test I have reset it to full-duplex.
Not sure about the implications of Vlan the subnets, and I tried ip
route-cache same-interface, it had no effect but I guess it may take time if
its a cache.

Here are the results of the show procs and i/f:-

Router#sh proc cpu | exc 0.00.*0.00
CPU utilization for five seconds: 62%/62%; one minute: 61%; five minutes:
60%
PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
29 337020 111884 3012 0.00% 0.03% 0.01% 0 Net
Background

32 1613052 468318 3444 0.07% 0.20% 0.17% 0 Per-Second
Jobs

123 824 120 6866 0.00% 0.02% 0.06% 0 Exec

Router#show int f0/0
FastEthernet0/0 is up, line protocol is up
Hardware is DEC21140A, address is 0050.2aca.2400 (bia 0050.2aca.2400)
Internet address is 212***/30
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 63/255, rxload 64/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters 04:14:20
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 25472000 bits/sec, 40880 packets/sec
5 minute output rate 24730000 bits/sec, 38624 packets/sec
614086423 packets input, 1854036321 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
370 input errors, 0 CRC, 0 frame, 0 overrun, 370 ignored
0 watchdog
0 input packets with dribble condition detected
568907290 packets output, 2654008434 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out


Router#show int f1/0
FastEthernet1/0 is up, line protocol is up
Hardware is DEC21140, address is 0050.2aca.241c (bia 0050.2aca.241c)
Internet address is 212.***/27
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 253/255, txload 65/255, rxload 63/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters 04:15:01
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 56560
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 24802000 bits/sec, 38766 packets/sec
5 minute output rate 25523000 bits/sec, 40978 packets/sec
571887898 packets input, 2950256234 bytes
Received 60253 broadcasts, 0 runts, 673 giants, 0 throttles
9379444 input errors, 9379388 CRC, 0 frame, 0 overrun, 56 ignored
0 watchdog
4631020 input packets with dribble condition detected
617023050 packets output, 2136329926 bytes, 0 underruns
0 output errors, 9521056 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Thanks,

Wayne


----- Original Message -----
From: Frank Bulk
To: 'Wayne @ CTL' ; cisco-bba@puck.nether.net
Sent: Thursday, May 17, 2007 4:27 PM
Subject: RE: [cisco-bba] Cisco 7206VXR running out of steam at 20mb
throughput


Please post a copy of "sh proc cpu | exc 0.00.*0.00"

Regards,

Frank

_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
Re: Cisco 7206VXR running out of steam at 20mb throughput [ In reply to ]
Router#show proc cpu | excl %0.00__%0.00__%0.00
CPU utilization for five seconds: 61%/61%; one minute: 60%; five minutes:
60%
PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
1 0 2 0 0.00% 0.00% 0.00% 0 Chunk Manager

2 128 93543 1 0.00% 0.00% 0.00% 0 Load Meter

3 184 22624 8 0.00% 0.00% 0.00% 0 CEF process

4 0 1 0 0.00% 0.00% 0.00% 0 EDDRI_MAIN

5 64576 47518 1358 0.00% 0.00% 0.00% 0 Check heaps

6 8 65 123 0.00% 0.00% 0.00% 0 Pool Manager

7 0 1 0 0.00% 0.00% 0.00% 0
AAA_SERVER_DEADT

8 0 2 0 0.00% 0.00% 0.00% 0 Timers

9 0 2 0 0.00% 0.00% 0.00% 0 Serial
Backgroun

10 0 2 0 0.00% 0.00% 0.00% 0 ATM Idle
Timer

11 0 2 0 0.00% 0.00% 0.00% 0 ATM AutoVC
Perio

12 0 2 0 0.00% 0.00% 0.00% 0 ATM VC Auto
Crea

13 0 2 0 0.00% 0.00% 0.00% 0 AAA
high-capacit

14 228924 466778 490 0.00% 0.00% 0.00% 0 EnvMon

15 0 1 0 0.00% 0.00% 0.00% 0 OIR Handler

16 0 7796 0 0.00% 0.00% 0.00% 0 IPC Dynamic
Cach

17 0 1 0 0.00% 0.00% 0.00% 0 IPC Zone
Manager

18 3260 466598 6 0.00% 0.00% 0.00% 0 IPC Periodic
Tim

19 1648 466598 3 0.00% 0.00% 0.00% 0 IPC Deferred
Por

20 0 1 0 0.00% 0.00% 0.00% 0 IPC Seat
Manager

21 103268 589059 175 0.00% 0.00% 0.00% 0 ARP Input

22 496 111233 4 0.00% 0.00% 0.00% 0 HC Counter
Timer

23 0 2 0 0.00% 0.00% 0.00% 0 DDR Timers

24 0 2 0 0.00% 0.00% 0.00% 0 Entity MIB
API

25 0 1 0 0.00% 0.00% 0.00% 0 SERIAL
A'detect

26 2584 466599 5 0.00% 0.00% 0.00% 0 GraphIt

27 0 2 0 0.00% 0.00% 0.00% 0 Dialer event

28 0 1 0 0.00% 0.00% 0.00% 0 Critical
Bkgnd

29 337060 111894 3012 0.00% 0.03% 0.02% 0 Net
Background

30 0 87 0 0.00% 0.00% 0.00% 0 Logger

31 4748 466595 10 0.00% 0.00% 0.00% 0 TTY
Background

32 1613244 468366 3444 0.15% 0.15% 0.15% 0 Per-Second
Jobs

33 0 1 0 0.00% 0.00% 0.00% 0 Inode Table
Dest

34 0 1 0 0.00% 0.00% 0.00% 0 CSP Timer

35 0 1 0 0.00% 0.00% 0.00% 0 SONET alarm
time

36 0 1 0 0.00% 0.00% 0.00% 0 POS APS Event
Pr

37 0 2 0 0.00% 0.00% 0.00% 0 VNM DSPRM
MAIN

38 0 1 0 0.00% 0.00% 0.00% 0 CES Line
Conditi

39 4 2 2000 0.00% 0.00% 0.00% 0 Flash MIB
Update

40 0 2 0 0.00% 0.00% 0.00% 0 ATM OAM Input

41 0 2 0 0.00% 0.00% 0.00% 0 ATM OAM TIMER

42 0 15 0 0.00% 0.00% 0.00% 0 TurboACL

43 0 2 0 0.00% 0.00% 0.00% 0 AAA Server

44 0 1 0 0.00% 0.00% 0.00% 0 AAA ACCT Proc

45 0 1 0 0.00% 0.00% 0.00% 0 ACCT Periodic
Pr

46 0 2 0 0.00% 0.00% 0.00% 0 AAA
Dictionary R

47 124724 639639 194 0.00% 0.01% 0.00% 0 IP Input

48 0 1 0 0.00% 0.00% 0.00% 0 ICMP event
handl

49 1468 53542 27 0.00% 0.00% 0.00% 0 CDP Protocol

50 0 1 0 0.00% 0.00% 0.00% 0 SSS Manager

51 52 62357 0 0.00% 0.00% 0.00% 0 SSS Test
Client

52 0 1 0 0.00% 0.00% 0.00% 0 SSS Feature
Mana

53 208 1826961 0 0.00% 0.00% 0.00% 0 SSS Feature
Time

54 0 3 0 0.00% 0.00% 0.00% 0 PPP Hooks

55 0 1 0 0.00% 0.00% 0.00% 0 X.25 Encaps
Mana

56 0 1 0 0.00% 0.00% 0.00% 0 VPDN call
manage

57 1120 7809 143 0.00% 0.00% 0.00% 0 IP Background

58 104 7800 13 0.00% 0.00% 0.00% 0 IP RIB Update

59 0 3 0 0.00% 0.00% 0.00% 0 SNMP Timers

60 0 2 0 0.00% 0.00% 0.00% 0 PPP IP Route

61 0 2 0 0.00% 0.00% 0.00% 0 PPP IPCP

62 480 7801 61 0.00% 0.00% 0.00% 0 Adj Manager

63 12 532 22 0.00% 0.00% 0.00% 0 CEF Scanner

64 320 24624 12 0.00% 0.00% 0.00% 0 TCP Timer

65 8 39 205 0.00% 0.00% 0.00% 0 TCP Protocols

66 0 1 0 0.00% 0.00% 0.00% 0 Socket Timers

67 0 1561 0 0.00% 0.00% 0.00% 0 HTTP CORE

68 0 1 0 0.00% 0.00% 0.00% 0 RARP Input

69 7896 32776 240 0.00% 0.00% 0.00% 0 DHCPD Receive

70 136 7794 17 0.00% 0.00% 0.00% 0 IP Cache Ager

71 0 1 0 0.00% 0.00% 0.00% 0 COPS

72 0 2 0 0.00% 0.00% 0.00% 0 PPP SSS

73 0 2 0 0.00% 0.00% 0.00% 0 PPP Bind

74 0 1 0 0.00% 0.00% 0.00% 0 PAD InCall

75 0 2 0 0.00% 0.00% 0.00% 0 X.25
Background

76 0 2 0 0.00% 0.00% 0.00% 0 Dialer
Forwarder

77 4240 466609 9 0.00% 0.00% 0.00% 0 RUDPV1 Main
Proc

78 0 1 0 0.00% 0.00% 0.00% 0 bsm_timers

79 1960 466600 4 0.00% 0.00% 0.00% 0 bsm_xmt_proc

80 0 2 0 0.00% 0.00% 0.00% 0 RLM groups
Proce

81 0 3 0 0.00% 0.00% 0.00% 0 gk process

82 0 1 0 0.00% 0.00% 0.00% 0 Border
Element p

83 4 18710 0 0.00% 0.00% 0.00% 0
CRM_CALL_UPDATE_

84 0 2 0 0.00% 0.00% 0.00% 0 LOCAL AAA

85 0 2 0 0.00% 0.00% 0.00% 0 ENABLE AAA

86 0 2 0 0.00% 0.00% 0.00% 0 LINE AAA

87 0 2 0 0.00% 0.00% 0.00% 0 TPLUS

88 1696 3220 526 0.00% 0.00% 0.00% 2 Virtual Exec

89 0 2 0 0.00% 0.00% 0.00% 0 ASNL

90 0 2 0 0.00% 0.00% 0.00% 0 VSP_MGR

91 0 1 0 0.00% 0.00% 0.00% 0 VoIP AAA

92 4 1 4000 0.00% 0.00% 0.00% 0
QOS_MODULE_MAIN

93 0 1 0 0.00% 0.00% 0.00% 0
RPMS_PROC_MAIN

94 0 1 0 0.00% 0.00% 0.00% 0 CCVPM_HTSP

95 0 1 0 0.00% 0.00% 0.00% 0 CCVPM_R2

96 0 1 0 0.00% 0.00% 0.00% 0 CCSWVOICE

97 0 1 0 0.00% 0.00% 0.00% 0 sssapp

98 0 1 0 0.00% 0.00% 0.00% 0 http client
proc

99 848 7807 108 0.00% 0.00% 0.00% 0 IP SNMP

100 0 2 0 0.00% 0.00% 0.00% 0 Proxy Session
Ap

101 36 46771 0 0.00% 0.00% 0.00% 0 RMON Recycle
Pro

102 0 2 0 0.00% 0.00% 0.00% 0 RMON Deferred
Se

103 0 1 0 0.00% 0.00% 0.00% 0 SYSMGT Events

104 0 2 0 0.00% 0.00% 0.00% 0 AAA SEND STOP
EV

105 0 1 0 0.00% 0.00% 0.00% 0 Syslog Traps

106 0 1 0 0.00% 0.00% 0.00% 0 RMON Packets

107 15908 116340240 0 0.00% 0.00% 0.00% 0 SAA Event
Proces

108 0 1 0 0.00% 0.00% 0.00% 0 VPDN Scal

109 2940 466065 6 0.00% 0.00% 0.00% 0 trunk
conditioni

110 0 1 0 0.00% 0.00% 0.00% 0 trunk
conditioni

111 896 7808 114 0.00% 0.00% 0.00% 0 PDU
DISPATCHER

112 27112 476235 56 0.00% 0.00% 0.00% 0 Net Input

113 28 93544 0 0.00% 0.00% 0.00% 0 Compute load
avg

114 100024 7927 12618 0.00% 0.00% 0.00% 0 Per-minute
Jobs

115 0 3899 0 0.00% 0.00% 0.00% 0 CC-API_VCM

116 11504 4659663 2 0.00% 0.00% 0.00% 0 CCPROXY_CT

117 0 1 0 0.00% 0.00% 0.00% 0 xcpa-driver

118 16 3898 4 0.00% 0.00% 0.00% 0 DHCPD Timer

119 244 132488 1 0.00% 0.00% 0.00% 0 DHCPD
Database

120 664 7807 85 0.00% 0.00% 0.00% 0 SNMP ENGINE

121 0 1 0 0.00% 0.00% 0.00% 0 SNMP
ConfCopyPro

122 0 1 0 0.00% 0.00% 0.00% 0 SNMP Traps

123 824 120 6866 0.00% 0.00% 0.05% 0 Exec

124 212 34987 6 0.23% 0.09% 0.02% 3 Virtual Exec

_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
Re: Cisco 7206VXR running out of steam at 20mb throughput [ In reply to ]
Something seems to be amiss. How can your CPU utilization be at 62%
with no processes registering high CPU usage. You've got lots of
packets hitting your FE interfaces, so I would think there would be
an IP Input process or something to justify the usage.

In any event... Clear the counters on your FastEthernet interfaces.
Make sure everything is 100/full (on the router and the switch) and
let's see what sort of errors (if any) show up on the interfaces
after that.

You may also want to move FE0/0 to GE0/1 and move FE1/0 to GE0/2 or
some variation of that. The onboard GEs will be able to push far
more packets than your FE PAs can. If your issues are stemming from
your FEs processing more PPS than they can handle (or getting close
to hitting that ceiling), the move to the GEs will mitigate that and
give you a better baseline.

On 17-May-07, at 1:19 PM, Wayne @ CTL wrote:

> Hi Frank, Jason, thanks for your replies.
> The half duplex was set for another test I have reset it to full-
> duplex.
> Not sure about the implications of Vlan the subnets, and I tried ip
> route-cache same-interface, it had no effect but I guess it may
> take time if
> its a cache.
>
> Here are the results of the show procs and i/f:-
>
> Router#sh proc cpu | exc 0.00.*0.00
> CPU utilization for five seconds: 62%/62%; one minute: 61%; five
> minutes:
> 60%
> PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
> 29 337020 111884 3012 0.00% 0.03% 0.01% 0 Net
> Background
>
> 32 1613052 468318 3444 0.07% 0.20% 0.17% 0 Per-
> Second
> Jobs
>
> 123 824 120 6866 0.00% 0.02% 0.06% 0 Exec
>
> Router#show int f0/0
> FastEthernet0/0 is up, line protocol is up
> Hardware is DEC21140A, address is 0050.2aca.2400 (bia 0050.2aca.
> 2400)
> Internet address is 212***/30
> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> reliability 255/255, txload 63/255, rxload 64/255
> Encapsulation ARPA, loopback not set
> Keepalive set (10 sec)
> Full-duplex, 100Mb/s, 100BaseTX/FX
> ARP type: ARPA, ARP Timeout 04:00:00
> Last input 00:00:00, output 00:00:00, output hang never
> Last clearing of "show interface" counters 04:14:20
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output
> drops: 0
> Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 25472000 bits/sec, 40880 packets/sec
> 5 minute output rate 24730000 bits/sec, 38624 packets/sec
> 614086423 packets input, 1854036321 bytes
> Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
> 370 input errors, 0 CRC, 0 frame, 0 overrun, 370 ignored
> 0 watchdog
> 0 input packets with dribble condition detected
> 568907290 packets output, 2654008434 bytes, 0 underruns
> 0 output errors, 0 collisions, 0 interface resets
> 0 babbles, 0 late collision, 0 deferred
> 0 lost carrier, 0 no carrier
> 0 output buffer failures, 0 output buffers swapped out
>
>
> Router#show int f1/0
> FastEthernet1/0 is up, line protocol is up
> Hardware is DEC21140, address is 0050.2aca.241c (bia 0050.2aca.241c)
> Internet address is 212.***/27
> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> reliability 253/255, txload 65/255, rxload 63/255
> Encapsulation ARPA, loopback not set
> Keepalive set (10 sec)
> Full-duplex, 100Mb/s, 100BaseTX/FX
> ARP type: ARPA, ARP Timeout 04:00:00
> Last input 00:00:00, output 00:00:00, output hang never
> Last clearing of "show interface" counters 04:15:01
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output
> drops: 56560
> Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 24802000 bits/sec, 38766 packets/sec
> 5 minute output rate 25523000 bits/sec, 40978 packets/sec
> 571887898 packets input, 2950256234 bytes
> Received 60253 broadcasts, 0 runts, 673 giants, 0 throttles
> 9379444 input errors, 9379388 CRC, 0 frame, 0 overrun, 56 ignored
> 0 watchdog
> 4631020 input packets with dribble condition detected
> 617023050 packets output, 2136329926 bytes, 0 underruns
> 0 output errors, 9521056 collisions, 1 interface resets
> 0 babbles, 0 late collision, 0 deferred
> 0 lost carrier, 0 no carrier
> 0 output buffer failures, 0 output buffers swapped out
>
> Thanks,
>
> Wayne
>
>
> ----- Original Message -----
> From: Frank Bulk
> To: 'Wayne @ CTL' ; cisco-bba@puck.nether.net
> Sent: Thursday, May 17, 2007 4:27 PM
> Subject: RE: [cisco-bba] Cisco 7206VXR running out of steam at 20mb
> throughput
>
>
> Please post a copy of "sh proc cpu | exc 0.00.*0.00"
>
> Regards,
>
> Frank
>
> _______________________________________________
> cisco-bba mailing list
> cisco-bba@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-bba

_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
Re: Cisco 7206VXR running out of steam at 20mbthroughput [ In reply to ]
You have to remember what the value actually means:

62%/62%

Means 62% of the work is been packet switch

And the left minus the right is the amount that is been process switched.

Explaining the low process usage. You want this as much as possible.


Vince

-----Original Message-----
From: cisco-bba-bounces@puck.nether.net
[mailto:cisco-bba-bounces@puck.nether.net] On Behalf Of Jason Lixfeld
Sent: Thursday, May 17, 2007 1:35 PM
To: cisco-bba@puck.nether.net
Subject: Re: [cisco-bba] Cisco 7206VXR running out of steam at
20mbthroughput

Something seems to be amiss. How can your CPU utilization be at 62% with no
processes registering high CPU usage. You've got lots of packets hitting
your FE interfaces, so I would think there would be an IP Input process or
something to justify the usage.

In any event... Clear the counters on your FastEthernet interfaces.
Make sure everything is 100/full (on the router and the switch) and let's
see what sort of errors (if any) show up on the interfaces after that.

You may also want to move FE0/0 to GE0/1 and move FE1/0 to GE0/2 or some
variation of that. The onboard GEs will be able to push far more packets
than your FE PAs can. If your issues are stemming from your FEs processing
more PPS than they can handle (or getting close to hitting that ceiling),
the move to the GEs will mitigate that and give you a better baseline.

On 17-May-07, at 1:19 PM, Wayne @ CTL wrote:

> Hi Frank, Jason, thanks for your replies.
> The half duplex was set for another test I have reset it to full-
> duplex.
> Not sure about the implications of Vlan the subnets, and I tried ip
> route-cache same-interface, it had no effect but I guess it may take
> time if its a cache.
>
> Here are the results of the show procs and i/f:-
>
> Router#sh proc cpu | exc 0.00.*0.00
> CPU utilization for five seconds: 62%/62%; one minute: 61%; five
> minutes:
> 60%
> PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
> 29 337020 111884 3012 0.00% 0.03% 0.01% 0 Net
> Background
>
> 32 1613052 468318 3444 0.07% 0.20% 0.17% 0 Per-
> Second
> Jobs
>
> 123 824 120 6866 0.00% 0.02% 0.06% 0 Exec
>
> Router#show int f0/0
> FastEthernet0/0 is up, line protocol is up
> Hardware is DEC21140A, address is 0050.2aca.2400 (bia 0050.2aca.
> 2400)
> Internet address is 212***/30
> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> reliability 255/255, txload 63/255, rxload 64/255
> Encapsulation ARPA, loopback not set
> Keepalive set (10 sec)
> Full-duplex, 100Mb/s, 100BaseTX/FX
> ARP type: ARPA, ARP Timeout 04:00:00
> Last input 00:00:00, output 00:00:00, output hang never
> Last clearing of "show interface" counters 04:14:20
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output
> drops: 0
> Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 25472000 bits/sec, 40880 packets/sec
> 5 minute output rate 24730000 bits/sec, 38624 packets/sec
> 614086423 packets input, 1854036321 bytes
> Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
> 370 input errors, 0 CRC, 0 frame, 0 overrun, 370 ignored
> 0 watchdog
> 0 input packets with dribble condition detected
> 568907290 packets output, 2654008434 bytes, 0 underruns
> 0 output errors, 0 collisions, 0 interface resets
> 0 babbles, 0 late collision, 0 deferred
> 0 lost carrier, 0 no carrier
> 0 output buffer failures, 0 output buffers swapped out
>
>
> Router#show int f1/0
> FastEthernet1/0 is up, line protocol is up
> Hardware is DEC21140, address is 0050.2aca.241c (bia 0050.2aca.241c)
> Internet address is 212.***/27
> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> reliability 253/255, txload 65/255, rxload 63/255
> Encapsulation ARPA, loopback not set
> Keepalive set (10 sec)
> Full-duplex, 100Mb/s, 100BaseTX/FX
> ARP type: ARPA, ARP Timeout 04:00:00
> Last input 00:00:00, output 00:00:00, output hang never
> Last clearing of "show interface" counters 04:15:01
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output
> drops: 56560
> Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 24802000 bits/sec, 38766 packets/sec
> 5 minute output rate 25523000 bits/sec, 40978 packets/sec
> 571887898 packets input, 2950256234 bytes
> Received 60253 broadcasts, 0 runts, 673 giants, 0 throttles
> 9379444 input errors, 9379388 CRC, 0 frame, 0 overrun, 56 ignored
> 0 watchdog
> 4631020 input packets with dribble condition detected
> 617023050 packets output, 2136329926 bytes, 0 underruns
> 0 output errors, 9521056 collisions, 1 interface resets
> 0 babbles, 0 late collision, 0 deferred
> 0 lost carrier, 0 no carrier
> 0 output buffer failures, 0 output buffers swapped out
>
> Thanks,
>
> Wayne
>
>
> ----- Original Message -----
> From: Frank Bulk
> To: 'Wayne @ CTL' ; cisco-bba@puck.nether.net
> Sent: Thursday, May 17, 2007 4:27 PM
> Subject: RE: [cisco-bba] Cisco 7206VXR running out of steam at 20mb
> throughput
>
>
> Please post a copy of "sh proc cpu | exc 0.00.*0.00"
>
> Regards,
>
> Frank
>
> _______________________________________________
> cisco-bba mailing list
> cisco-bba@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-bba

_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
Re: Cisco 7206VXR running out of steam at 20mbthroughput [ In reply to ]
Wayne,

which NPE do you use?

I see that you're switching many very small packets through the box (~
80 byte/pkt average), which could explain the high usage with a moderate
bandwidth.
In an IMIX environment, you'd be able to switch approximately 5-8 times
as much (as the avg. packet size is much higher)..

I guess you need a faster NPE..

oli


Wayne @ CTL <> wrote on Thursday, May 17, 2007 7:20 PM:

> Hi Frank, Jason, thanks for your replies.
> The half duplex was set for another test I have reset it to
> full-duplex. Not sure about the implications of Vlan the subnets, and
> I tried ip route-cache same-interface, it had no effect but I guess
> it may take time if its a cache.
>
> Here are the results of the show procs and i/f:-
>
> Router#sh proc cpu | exc 0.00.*0.00
> CPU utilization for five seconds: 62%/62%; one minute: 61%; five
> minutes: 60%
> PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
> 29 337020 111884 3012 0.00% 0.03% 0.01% 0 Net
> Background
>
> 32 1613052 468318 3444 0.07% 0.20% 0.17% 0
> Per-Second Jobs
>
> 123 824 120 6866 0.00% 0.02% 0.06% 0 Exec
>
> Router#show int f0/0
> FastEthernet0/0 is up, line protocol is up
> Hardware is DEC21140A, address is 0050.2aca.2400 (bia
> 0050.2aca.2400) Internet address is 212***/30
> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> reliability 255/255, txload 63/255, rxload 64/255
> Encapsulation ARPA, loopback not set
> Keepalive set (10 sec)
> Full-duplex, 100Mb/s, 100BaseTX/FX
> ARP type: ARPA, ARP Timeout 04:00:00
> Last input 00:00:00, output 00:00:00, output hang never
> Last clearing of "show interface" counters 04:14:20
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
> 0 Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 25472000 bits/sec, 40880 packets/sec
> 5 minute output rate 24730000 bits/sec, 38624 packets/sec
> 614086423 packets input, 1854036321 bytes
> Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
> 370 input errors, 0 CRC, 0 frame, 0 overrun, 370 ignored
> 0 watchdog
> 0 input packets with dribble condition detected
> 568907290 packets output, 2654008434 bytes, 0 underruns
> 0 output errors, 0 collisions, 0 interface resets
> 0 babbles, 0 late collision, 0 deferred
> 0 lost carrier, 0 no carrier
> 0 output buffer failures, 0 output buffers swapped out
>
>
> Router#show int f1/0
> FastEthernet1/0 is up, line protocol is up
> Hardware is DEC21140, address is 0050.2aca.241c (bia 0050.2aca.241c)
> Internet address is 212.***/27
> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> reliability 253/255, txload 65/255, rxload 63/255
> Encapsulation ARPA, loopback not set
> Keepalive set (10 sec)
> Full-duplex, 100Mb/s, 100BaseTX/FX
> ARP type: ARPA, ARP Timeout 04:00:00
> Last input 00:00:00, output 00:00:00, output hang never
> Last clearing of "show interface" counters 04:15:01
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
> 56560 Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 24802000 bits/sec, 38766 packets/sec
> 5 minute output rate 25523000 bits/sec, 40978 packets/sec
> 571887898 packets input, 2950256234 bytes
> Received 60253 broadcasts, 0 runts, 673 giants, 0 throttles
> 9379444 input errors, 9379388 CRC, 0 frame, 0 overrun, 56 ignored
> 0 watchdog
> 4631020 input packets with dribble condition detected
> 617023050 packets output, 2136329926 bytes, 0 underruns
> 0 output errors, 9521056 collisions, 1 interface resets
> 0 babbles, 0 late collision, 0 deferred
> 0 lost carrier, 0 no carrier
> 0 output buffer failures, 0 output buffers swapped out
>
> Thanks,
>
> Wayne
>
>
> ----- Original Message -----
> From: Frank Bulk
> To: 'Wayne @ CTL' ; cisco-bba@puck.nether.net
> Sent: Thursday, May 17, 2007 4:27 PM
> Subject: RE: [cisco-bba] Cisco 7206VXR running out of steam at 20mb
> throughput
>
>
> Please post a copy of "sh proc cpu | exc 0.00.*0.00"
>
> Regards,
>
> Frank
>
> _______________________________________________
> cisco-bba mailing list
> cisco-bba@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-bba
_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
Re: Cisco 7206VXR running out of steam at 20mbthroughput [ In reply to ]
Hi Oli,
The CPU is :-
7206VXR (NPE-G1) processor (revision A) with 983040K/65536K bytes of memory.

I'm quite surprised that it can't cope, - can you advise a piece of kit that
will do the job? Do you think swapping the card for a G2 would give us the
50-100mb we require bearing in mind the small packet size? Or are we better
off with a different product?

Many thanks,

Wayne


----- Original Message -----
From: "Oliver Boehmer (oboehmer)" <oboehmer@cisco.com>
To: "Wayne @ CTL" <Wayne@squeezemail.co.uk>; <cisco-bba@puck.nether.net>
Sent: Friday, May 18, 2007 6:49 AM
Subject: RE: [cisco-bba] Cisco 7206VXR running out of steam at
20mbthroughput


Wayne,

which NPE do you use?

I see that you're switching many very small packets through the box (~
80 byte/pkt average), which could explain the high usage with a moderate
bandwidth.
In an IMIX environment, you'd be able to switch approximately 5-8 times
as much (as the avg. packet size is much higher)..

I guess you need a faster NPE..

oli


Wayne @ CTL <> wrote on Thursday, May 17, 2007 7:20 PM:

> Hi Frank, Jason, thanks for your replies.
> The half duplex was set for another test I have reset it to
> full-duplex. Not sure about the implications of Vlan the subnets, and
> I tried ip route-cache same-interface, it had no effect but I guess
> it may take time if its a cache.
>
> Here are the results of the show procs and i/f:-
>
> Router#sh proc cpu | exc 0.00.*0.00
> CPU utilization for five seconds: 62%/62%; one minute: 61%; five
> minutes: 60%
> PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
> 29 337020 111884 3012 0.00% 0.03% 0.01% 0 Net
> Background
>
> 32 1613052 468318 3444 0.07% 0.20% 0.17% 0
> Per-Second Jobs
>
> 123 824 120 6866 0.00% 0.02% 0.06% 0 Exec
>
> Router#show int f0/0
> FastEthernet0/0 is up, line protocol is up
> Hardware is DEC21140A, address is 0050.2aca.2400 (bia
> 0050.2aca.2400) Internet address is 212***/30
> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> reliability 255/255, txload 63/255, rxload 64/255
> Encapsulation ARPA, loopback not set
> Keepalive set (10 sec)
> Full-duplex, 100Mb/s, 100BaseTX/FX
> ARP type: ARPA, ARP Timeout 04:00:00
> Last input 00:00:00, output 00:00:00, output hang never
> Last clearing of "show interface" counters 04:14:20
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
> 0 Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 25472000 bits/sec, 40880 packets/sec
> 5 minute output rate 24730000 bits/sec, 38624 packets/sec
> 614086423 packets input, 1854036321 bytes
> Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
> 370 input errors, 0 CRC, 0 frame, 0 overrun, 370 ignored
> 0 watchdog
> 0 input packets with dribble condition detected
> 568907290 packets output, 2654008434 bytes, 0 underruns
> 0 output errors, 0 collisions, 0 interface resets
> 0 babbles, 0 late collision, 0 deferred
> 0 lost carrier, 0 no carrier
> 0 output buffer failures, 0 output buffers swapped out
>
>
> Router#show int f1/0
> FastEthernet1/0 is up, line protocol is up
> Hardware is DEC21140, address is 0050.2aca.241c (bia 0050.2aca.241c)
> Internet address is 212.***/27
> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
> reliability 253/255, txload 65/255, rxload 63/255
> Encapsulation ARPA, loopback not set
> Keepalive set (10 sec)
> Full-duplex, 100Mb/s, 100BaseTX/FX
> ARP type: ARPA, ARP Timeout 04:00:00
> Last input 00:00:00, output 00:00:00, output hang never
> Last clearing of "show interface" counters 04:15:01
> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
> 56560 Queueing strategy: fifo
> Output queue: 0/40 (size/max)
> 5 minute input rate 24802000 bits/sec, 38766 packets/sec
> 5 minute output rate 25523000 bits/sec, 40978 packets/sec
> 571887898 packets input, 2950256234 bytes
> Received 60253 broadcasts, 0 runts, 673 giants, 0 throttles
> 9379444 input errors, 9379388 CRC, 0 frame, 0 overrun, 56 ignored
> 0 watchdog
> 4631020 input packets with dribble condition detected
> 617023050 packets output, 2136329926 bytes, 0 underruns
> 0 output errors, 9521056 collisions, 1 interface resets
> 0 babbles, 0 late collision, 0 deferred
> 0 lost carrier, 0 no carrier
> 0 output buffer failures, 0 output buffers swapped out
>
> Thanks,
>
> Wayne
>
>
> ----- Original Message -----
> From: Frank Bulk
> To: 'Wayne @ CTL' ; cisco-bba@puck.nether.net
> Sent: Thursday, May 17, 2007 4:27 PM
> Subject: RE: [cisco-bba] Cisco 7206VXR running out of steam at 20mb
> throughput
>
>
> Please post a copy of "sh proc cpu | exc 0.00.*0.00"
>
> Regards,
>
> Frank
>
> _______________________________________________
> cisco-bba mailing list
> cisco-bba@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-bba

_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
Re: Cisco 7206VXR running out of steam at 20mbthroughput [ In reply to ]
Oh, this is very strange, a NPE-G1 should cope with this load. Something
else is going on. "show align" shows anything? Any log messages?
Please unicast a show tech (will try to look at it soon)..

oli

Wayne @ CTL <mailto:Wayne@squeezemail.co.uk> wrote on Friday, May 18,
2007 9:52 AM:

> Hi Oli,
> The CPU is :-
> 7206VXR (NPE-G1) processor (revision A) with 983040K/65536K bytes of
> memory.
>
> I'm quite surprised that it can't cope, - can you advise a piece of
> kit that
> will do the job? Do you think swapping the card for a G2 would give
> us the 50-100mb we require bearing in mind the small packet size? Or
> are we better
> off with a different product?
>
> Many thanks,
>
> Wayne
>
>
> ----- Original Message -----
> From: "Oliver Boehmer (oboehmer)" <oboehmer@cisco.com>
> To: "Wayne @ CTL" <Wayne@squeezemail.co.uk>;
> <cisco-bba@puck.nether.net>
> Sent: Friday, May 18, 2007 6:49 AM
> Subject: RE: [cisco-bba] Cisco 7206VXR running out of steam at
> 20mbthroughput
>
>
> Wayne,
>
> which NPE do you use?
>
> I see that you're switching many very small packets through the box (~
> 80 byte/pkt average), which could explain the high usage with a
> moderate
> bandwidth.
> In an IMIX environment, you'd be able to switch approximately 5-8
> times
> as much (as the avg. packet size is much higher)..
>
> I guess you need a faster NPE..
>
> oli
>
>
> Wayne @ CTL <> wrote on Thursday, May 17, 2007 7:20 PM:
>
>> Hi Frank, Jason, thanks for your replies.
>> The half duplex was set for another test I have reset it to
>> full-duplex. Not sure about the implications of Vlan the subnets, and
>> I tried ip route-cache same-interface, it had no effect but I guess
>> it may take time if its a cache.
>>
>> Here are the results of the show procs and i/f:-
>>
>> Router#sh proc cpu | exc 0.00.*0.00
>> CPU utilization for five seconds: 62%/62%; one minute: 61%; five
>> minutes: 60% PID Runtime(ms) Invoked uSecs 5Sec 1Min
>> 5Min TTY Process 29 337020 111884 3012 0.00% 0.03%
>> 0.01% 0 Net Background
>>
>> 32 1613052 468318 3444 0.07% 0.20% 0.17% 0
>> Per-Second Jobs
>>
>> 123 824 120 6866 0.00% 0.02% 0.06% 0 Exec
>>
>> Router#show int f0/0
>> FastEthernet0/0 is up, line protocol is up
>> Hardware is DEC21140A, address is 0050.2aca.2400 (bia
>> 0050.2aca.2400) Internet address is 212***/30
>> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
>> reliability 255/255, txload 63/255, rxload 64/255
>> Encapsulation ARPA, loopback not set
>> Keepalive set (10 sec)
>> Full-duplex, 100Mb/s, 100BaseTX/FX
>> ARP type: ARPA, ARP Timeout 04:00:00
>> Last input 00:00:00, output 00:00:00, output hang never
>> Last clearing of "show interface" counters 04:14:20
>> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output
>> drops: 0 Queueing strategy: fifo Output queue: 0/40 (size/max)
>> 5 minute input rate 25472000 bits/sec, 40880 packets/sec
>> 5 minute output rate 24730000 bits/sec, 38624 packets/sec
>> 614086423 packets input, 1854036321 bytes
>> Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
>> 370 input errors, 0 CRC, 0 frame, 0 overrun, 370 ignored 0
>> watchdog 0 input packets with dribble condition detected
>> 568907290 packets output, 2654008434 bytes, 0 underruns
>> 0 output errors, 0 collisions, 0 interface resets
>> 0 babbles, 0 late collision, 0 deferred
>> 0 lost carrier, 0 no carrier
>> 0 output buffer failures, 0 output buffers swapped out
>>
>>
>> Router#show int f1/0
>> FastEthernet1/0 is up, line protocol is up
>> Hardware is DEC21140, address is 0050.2aca.241c (bia
>> 0050.2aca.241c) Internet address is 212.***/27
>> MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
>> reliability 253/255, txload 65/255, rxload 63/255
>> Encapsulation ARPA, loopback not set
>> Keepalive set (10 sec)
>> Full-duplex, 100Mb/s, 100BaseTX/FX
>> ARP type: ARPA, ARP Timeout 04:00:00
>> Last input 00:00:00, output 00:00:00, output hang never
>> Last clearing of "show interface" counters 04:15:01
>> Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
>> 56560 Queueing strategy: fifo
>> Output queue: 0/40 (size/max)
>> 5 minute input rate 24802000 bits/sec, 38766 packets/sec
>> 5 minute output rate 25523000 bits/sec, 40978 packets/sec
>> 571887898 packets input, 2950256234 bytes
>> Received 60253 broadcasts, 0 runts, 673 giants, 0 throttles
>> 9379444 input errors, 9379388 CRC, 0 frame, 0 overrun, 56
>> ignored 0 watchdog 4631020 input packets with dribble
>> condition detected 617023050 packets output, 2136329926 bytes,
>> 0 underruns 0 output errors, 9521056 collisions, 1 interface
>> resets 0 babbles, 0 late collision, 0 deferred
>> 0 lost carrier, 0 no carrier
>> 0 output buffer failures, 0 output buffers swapped out
>>
>> Thanks,
>>
>> Wayne
>>
>>
>> ----- Original Message -----
>> From: Frank Bulk
>> To: 'Wayne @ CTL' ; cisco-bba@puck.nether.net
>> Sent: Thursday, May 17, 2007 4:27 PM
>> Subject: RE: [cisco-bba] Cisco 7206VXR running out of steam at 20mb
>> throughput
>>
>>
>> Please post a copy of "sh proc cpu | exc 0.00.*0.00"
>>
>> Regards,
>>
>> Frank
>>
>> _______________________________________________
>> cisco-bba mailing list
>> cisco-bba@puck.nether.net
>> https://puck.nether.net/mailman/listinfo/cisco-bba
_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba