Mailing List Archive

[Zope-PTK] Comments on the new docs... :)
----------
class IndexableContent:
"""
Interface for indexing by PortalCatalog.

PortalContent implements this interface. The existing portions of
this interface are firm.

TODO: Add 'Subject', a list of strings, which will be
keyword-indexed by the PortalCatalog.
"""
--------

Care to make it soemthing other than Subject? Subject seems to be
something that individual products may very well want to have. For
example a mail item woudl defintiely want to have Subject available, as
would custome nes items and announcements (eg. I am working on an
announcement object that also posts to a specified newsgroup, where I
would definitely need to have Subject). Perhaps "keywords" or something
like that?

Bill

--
In flying I have learned that carelessness and overconfidence are
usually far more dangerous than deliberately accepted risks.
-- Wilbur Wright in a letter to his father, September 1900
Re: [Zope-PTK] Comments on the new docs... :) [ In reply to ]
On Fri, Feb 18, 2000 at 03:21:26PM -0700, Bill Anderson wrote:
>
> TODO: Add 'Subject', a list of strings, which will be
> keyword-indexed by the PortalCatalog.
>
> Care to make it soemthing other than Subject? Subject seems to be
> something that individual products may very well want to have. For

Yes. Topic? Better yet, Topics, since it's a list. At least
that's what I use in Hack&Roll News (I made it a multiple
selection based on a folder property ``site_topics'').

[]s,
|alo
+----
--
I am Lalo of deB-org. You will be freed.
Resistance is futile.

http://www.webcom.com/lalo mailto:lalo@webcom.com
pgp key in the web page

Debian GNU/Linux --- http://www.debian.org
Brazil of Darkness -- http://zope.gf.com.br/BroDar
Re: [Zope-PTK] Comments on the new docs... :) [ In reply to ]
Lalo Martins wrote:
>
> On Fri, Feb 18, 2000 at 03:21:26PM -0700, Bill Anderson wrote:
> >
> > TODO: Add 'Subject', a list of strings, which will be
> > keyword-indexed by the PortalCatalog.
> >
> > Care to make it soemthing other than Subject? Subject seems to be
> > something that individual products may very well want to have. For
>
> Yes. Topic? Better yet, Topics, since it's a list. At least
> that's what I use in Hack&Roll News (I made it a multiple
> selection based on a folder property ``site_topics'').


This is going to get tough, I guess ;)

Tpoics would not be good for those working on implementing news sites,
help systems, or Banner Advertising Systems for example (or a
Portal-Based KnowledgeKit). Seems to me it shouldn't be a common type of
word. Maybe something like:

Key_Words
Index_Topics
Index_Strings

may be best, since most people would tend to use single words, like
'Topics' as opposed to 'Key_Topics'.


--
In flying I have learned that carelessness and overconfidence are
usually far more dangerous than deliberately accepted risks.
-- Wilbur Wright in a letter to his father, September 1900
Re: [Zope-PTK] Comments on the new docs... :) [ In reply to ]
Mike Pelletier wrote:
>
> On Fri, 18 Feb 2000, Bill Anderson wrote:
>
> > Care to make it soemthing other than Subject? Subject seems to be
> > something that individual products may very well want to have. For
> > example a mail item woudl defintiely want to have Subject available, as
> > would custome nes items and announcements (eg. I am working on an
> > announcement object that also posts to a specified newsgroup, where I
> > would definitely need to have Subject). Perhaps "keywords" or something
> > like that?
>
> It's called Subject because a goal of the PTK is to have all it's
> objects conform to the Dublin Core, in as much as is useful. You still
> have 'subject' (distinct from 'Subject') available to you. It would also
> seem reasonable in this case for the Subject method of a discussion item
> to return the discussion subject as it's 0th element. I suppose what I'm
> saying is, it's okay for products to use these Dublic Core names. In
> fact, it's encouraged, as long as they are publishing the same general
> metadata in the same format.

Ok, I guess my biggest concern is that subclassing from the base classes
would cause problems with making my own method/variable of the same
name. Like how subclassing CatalogAware means I can't define a 'summary'
field.

--
In flying I have learned that carelessness and overconfidence are
usually far more dangerous than deliberately accepted risks.
-- Wilbur Wright in a letter to his father, September 1900