Mailing List Archive

[Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN
What was the reason to split these? Why can't we just have a consistent
CONFIG_XEN (provided in arch/*/Kconfig), and derive all
architecture-specific information from other CONFIG_* values? Main
reason for the question is the (apparently) inconsistent use of one or
the other in various places.

Thanks, Jan

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
RE: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
CONFIG_XEN should be used whenever the change applies
to Xen for all architectures. CONFIG_X86_XEN should be used
in generic code when a change applies only to x86.
(There was a recent example of this... I can dig it up
if you wish.) If the code is clearly x86-specific
(e.g. in arch/i386 or include/asm-x86), I agree the
_X86_ part is superfluous.

> -----Original Message-----
> From: xen-merge-bounces@lists.xensource.com
> [mailto:xen-merge-bounces@lists.xensource.com] On Behalf Of
> Jan Beulich
> Sent: Wednesday, December 21, 2005 9:15 AM
> To: xen-merge@lists.xensource.com
> Subject: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN
>
> What was the reason to split these? Why can't we just have a
> consistent
> CONFIG_XEN (provided in arch/*/Kconfig), and derive all
> architecture-specific information from other CONFIG_* values? Main
> reason for the question is the (apparently) inconsistent use of one or
> the other in various places.
>
> Thanks, Jan
>
> _______________________________________________
> Xen-merge mailing list
> Xen-merge@lists.xensource.com
> http://lists.xensource.com/xen-merge
>

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
RE: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
>CONFIG_XEN should be used whenever the change applies
>to Xen for all architectures. CONFIG_X86_XEN should be used
>in generic code when a change applies only to x86.
>(There was a recent example of this... I can dig it up
>if you wish.)

It'd be interesting, if it doesn't take you too much time. I'd have
wanted to rather make this a conditional like

#if defined(CONFIG_XEN) && defined(CONFIG_X86)

as I expect this to be rare.

>If the code is clearly x86-specific
>(e.g. in arch/i386 or include/asm-x86), I agree the
>_X86_ part is superfluous.

Sure. But I'd like this to be consistent, which is why, for now, I used
CONFIG_X86_XEN everywhere.

Jan

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
RE: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
> It'd be interesting, if it doesn't take you too much time. I'd have
> wanted to rather make this a conditional like

Looks like my memory was faulty... I was just
recalling the attached message. The double
conditional is probably a better choice for
common files.

Dan

P.S. James -- It looks like the xen-merge archives
have had the same problem as xen-ia64-devel archives.
(I had to dig up this message from my personal
email archives.)

> -----Original Message-----
> From: Magenheimer, Dan (HP Labs Fort Collins)
> Sent: Friday, August 12, 2005 10:57 AM
> To: 'Vincent Hanquez'
> Cc: xen-merge@lists.xensource.com
> Subject: RE: [Xen-merge] CONFIG_XEN (and more?)
>
> > CONFIG_XEN is suppose to be ARCH-agnostic
> > CONFIG_X86_XEN is for i386-xen
>
> Perfect! Thanks!
>
> Perhaps the CONFIG_X86_XEN designation should start appearing
> in the -sparse trees?. I'm hoping to start merging Xen/ia64
> changes into the -sparse trees at some point and it
> doesn't require any patches outside of arch/ia64, asm-ia64,
> and of course the xen common directories (drivers/xen, etc).
>
> If the Xen/x86-required changes to linux common files
> (include/linux/highmem.h for example) are ifdef'd,
> then other architectures can use the same mkbuildtree.
>
> Dan
>

> -----Original Message-----
> From: Jan Beulich [mailto:JBeulich@novell.com]
> Sent: Wednesday, December 21, 2005 10:20 AM
> To: Magenheimer, Dan (HP Labs Fort Collins)
> Cc: xen-merge@lists.xensource.com
> Subject: RE: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN
>
> >CONFIG_XEN should be used whenever the change applies
> >to Xen for all architectures. CONFIG_X86_XEN should be used
> >in generic code when a change applies only to x86.
> >(There was a recent example of this... I can dig it up
> >if you wish.)
>
> It'd be interesting, if it doesn't take you too much time. I'd have
> wanted to rather make this a conditional like
>
> #if defined(CONFIG_XEN) && defined(CONFIG_X86)
>
> as I expect this to be rare.
>
> >If the code is clearly x86-specific
> >(e.g. in arch/i386 or include/asm-x86), I agree the
> >_X86_ part is superfluous.
>
> Sure. But I'd like this to be consistent, which is why, for
> now, I used
> CONFIG_X86_XEN everywhere.
>
> Jan
>

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
Re: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
Magenheimer, Dan (HP Labs Fort Collins) wrote:
> P.S. James -- It looks like the xen-merge archives
> have had the same problem as xen-ia64-devel archives.
> (I had to dig up this message from my personal
> email archives.)

Thanks, fixed.

James

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
Re: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
Lets not forget CONFIG_PPC_XEN :)


On Dec 21, 2005, at 12:19 PM, Jan Beulich wrote:

>> CONFIG_XEN should be used whenever the change applies
>> to Xen for all architectures. CONFIG_X86_XEN should be used
>> in generic code when a change applies only to x86.
>> (There was a recent example of this... I can dig it up
>> if you wish.)
>
> It'd be interesting, if it doesn't take you too much time. I'd have
> wanted to rather make this a conditional like
>
> #if defined(CONFIG_XEN) && defined(CONFIG_X86)
>
> as I expect this to be rare.
>
>> If the code is clearly x86-specific
>> (e.g. in arch/i386 or include/asm-x86), I agree the
>> _X86_ part is superfluous.
>
> Sure. But I'd like this to be consistent, which is why, for now, I
> used
> CONFIG_X86_XEN everywhere.
>
> Jan
>
> _______________________________________________
> Xen-merge mailing list
> Xen-merge@lists.xensource.com
> http://lists.xensource.com/xen-merge
>

-JX
--
"I got an idea, an idea so smart my head would explode if I even
began to know what I was talking about." -- Peter Griffin (Family
Guy)




_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
Re: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
* Jimi Xenidis (jimix@watson.ibm.com) wrote:
> Lets not forget CONFIG_PPC_XEN :)

After upstream dir rename shouldn't that be CONFIG_POWERPC_XEN? ;-) j/k

Are there good examples where CONFIG_XEN isn't sufficient? It'd be nice
to eliminate the extra if possible.

thanks,
-chris

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
Re: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
On Dec 22, 2005, at 11:29 AM, Chris Wright wrote:

> * Jimi Xenidis (jimix@watson.ibm.com) wrote:
>> Lets not forget CONFIG_PPC_XEN :)
>
> After upstream dir rename shouldn't that be CONFIG_POWERPC_XEN? ;-)
> j/k
Working that as we speak.

Feels like the last 2 months have just been a merge-a-thon for me :)

-JX
--
"I got an idea, an idea so smart my head would explode if I even
began to know what I was talking about." -- Peter Griffin (Family
Guy)




_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
RE: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
Agree, but s/2/20/. :-( Buy you a beer at the summit? :-}

> -----Original Message-----
> From: xen-merge-bounces@lists.xensource.com
> [mailto:xen-merge-bounces@lists.xensource.com] On Behalf Of
> Jimi Xenidis
> Sent: Thursday, December 22, 2005 10:28 AM
> To: Chris Wright
> Cc: xen-merge@lists.xensource.com; Jan Beulich
> Subject: Re: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN
>
>
> On Dec 22, 2005, at 11:29 AM, Chris Wright wrote:
>
> > * Jimi Xenidis (jimix@watson.ibm.com) wrote:
> >> Lets not forget CONFIG_PPC_XEN :)
> >
> > After upstream dir rename shouldn't that be
> CONFIG_POWERPC_XEN? ;-)
> > j/k
> Working that as we speak.
>
> Feels like the last 2 months have just been a merge-a-thon for me :)
>
> -JX
> --
> "I got an idea, an idea so smart my head would explode if I even
> began to know what I was talking about." -- Peter Griffin (Family
> Guy)
>
>
>
>
> _______________________________________________
> Xen-merge mailing list
> Xen-merge@lists.xensource.com
> http://lists.xensource.com/xen-merge
>

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
Re: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
On Wed, Dec 21, 2005 at 05:14:43PM +0100, Jan Beulich wrote:
> What was the reason to split these? Why can't we just have a consistent
> CONFIG_XEN (provided in arch/*/Kconfig), and derive all
> architecture-specific information from other CONFIG_* values? Main
> reason for the question is the (apparently) inconsistent use of one or
> the other in various places.

I introduce CONFIG_X86_XEN as a mirror to CONFIG_XEN_X86 that we had in
the previous architecture. ditto for CONFIG_X86_64_XEN

CONFIG_XEN should be use when there's no reason to use a specific
architecture version (which is almost everytimes).

But the option should stay, CONFIG_X86_XEN is actually a subarch config
name, and even if x86_64 doesn't have subarch, it's nice to have a
consistant naming scheme.

Cheers,
--
Vincent Hanquez

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge
Re: [Xen-merge] CONFIG_XEN vs. CONFIG_X86{,_64}_XEN [ In reply to ]
>>> Vincent Hanquez <vincent.hanquez@cl.cam.ac.uk> 23.12.05 13:28:44
>>>
>On Wed, Dec 21, 2005 at 05:14:43PM +0100, Jan Beulich wrote:
>> What was the reason to split these? Why can't we just have a
consistent
>> CONFIG_XEN (provided in arch/*/Kconfig), and derive all
>> architecture-specific information from other CONFIG_* values? Main
>> reason for the question is the (apparently) inconsistent use of one
or
>> the other in various places.
>
>I introduce CONFIG_X86_XEN as a mirror to CONFIG_XEN_X86 that we had
in
>the previous architecture. ditto for CONFIG_X86_64_XEN
>
>CONFIG_XEN should be use when there's no reason to use a specific
>architecture version (which is almost everytimes).
>
>But the option should stay, CONFIG_X86_XEN is actually a subarch
config
>name, and even if x86_64 doesn't have subarch, it's nice to have a
>consistant naming scheme.

I don't fully agree here. Xen only uses the sub-arch functionality, it
shouldn't really be considered a subarch. And, as somebody else also
said before, the option is just redundant, unless there was a
significant number of instances where CONFIG_X86_XEN (or
CONFIG_X86_64_XEN) must be used, but CONFIG_XEN cannot.

Jan

_______________________________________________
Xen-merge mailing list
Xen-merge@lists.xensource.com
http://lists.xensource.com/xen-merge