Mailing List Archive

IO::Stream? It's not a stream.
According to Tim Bunce:
> From: Chip Salzenberg <chs@nando.net>
> > According to John Macdonald:
> > > On the naming issue, I'd be inclined to use either Stream or
> > > DataStream as the top level ...
> >
> > However, sockets aren't all streams -- neither are pipes, for
> > that matter, since they preserve write() boundaries on some
> > systems. So I'd not use "Stream" as a top-level name.
>
> I think that's being rather pedantic about the definition of a Stream.

I'm making a distinction that will come naturally to anyone who (e.g.)
has ever programmed with sockets: SOCK_STREAM is one type of socket,
and SOCK_DGRAM is another.

> Anyway, I thought from recent messages we were converging towards
> IO::Stream
> as a base class name.

I'd prefer IO::Handle, myself. But I'm prepared to be ignored.
--
Chip Salzenberg, aka <chs@nando.net>
"Hey, it's the Miss Alternate Universe Pageant!"
-- Crow T. Robot, MST3K: "Stranded In Space"
Re: IO::Stream? It's not a stream. [ In reply to ]
Chip says:
> According to Tim Bunce:
> > From: Chip Salzenberg <chs@nando.net>
> > > According to John Macdonald:
> > > > On the naming issue, I'd be inclined to use either Stream or
> > > > DataStream as the top level ...
> > >
> > > However, sockets aren't all streams -- neither are pipes, for
> > > that matter, since they preserve write() boundaries on some
> > > systems. So I'd not use "Stream" as a top-level name.
> >
> > I think that's being rather pedantic about the definition of a Stream.
>
> I'm making a distinction that will come naturally to anyone who (e.g.)
> has ever programmed with sockets: SOCK_STREAM is one type of socket,
> and SOCK_DGRAM is another.
>
> > Anyway, I thought from recent messages we were converging towards
> > IO::Stream
> > as a base class name.

I think that was me, but I wasn't really serious. The discussion went from
FileHandle to File to Stream to IO, the final rationale being that there were
forms of IO that were not strictly streams. This prompted me to say that if
it was stream IO one could always have "an IO::Stream class :-)" --- like C++.
Sorry if the attempt at humour was a bit obscure.

> I'd prefer IO::Handle, myself. But I'm prepared to be ignored.

C++ has the answer again. It should be IO::S :-)))). Oh alright -- how about
and IO::State?
Re: IO::Stream? It's not a stream. [ In reply to ]
> From: Raphael Manfredi <ram@hptnos02.grenoble.hp.com>
>
> Quoting Chip Salzenberg:
> :> Anyway, I thought from recent messages we were converging towards
> :> IO::Stream
> :> as a base class name.
> :
> :I'd prefer IO::Handle, myself. But I'm prepared to be ignored.
>
> I agree.
>
> IO::Stream conveys a "stream" connotation that may not exist with
> non-stream I/O types that are "record" or "packet" oriented.

Heck, I'm happy with IO::Handle.

Let's have a bout of violent agreement here ;-)

Tim.
Re: IO::Stream? It's not a stream. [ In reply to ]
On Thu, 26 Oct 1995, Tim Bunce wrote:

> > From: Raphael Manfredi <ram@hptnos02.grenoble.hp.com>
> >
> > Quoting Chip Salzenberg:
> > :> Anyway, I thought from recent messages we were converging towards
> > :> IO::Stream
> > :> as a base class name.
> > :
> > :I'd prefer IO::Handle, myself. But I'm prepared to be ignored.
> >
> > I agree.
> >
> > IO::Stream conveys a "stream" connotation that may not exist with
> > non-stream I/O types that are "record" or "packet" oriented.
>
> Heck, I'm happy with IO::Handle.
>
> Let's have a bout of violent agreement here ;-)

Sounds dandy! :-)

> Tim.

--
Kenneth Albanowski (kjahds@kjahds.com, CIS: 70705,126)