Mailing List Archive

802.3ad between M5 & Cisco cat3750
Hello,

Anyone have an example of the Cat side of a 802.3ad link between a M5
and cat3550/3750? I have found plenty examples of the Juniper side
(pretty simple) but I can't seem to get the link to come up. All the
cisco examples include LACP which juniper doesn't support until JUNOS
6.1 (we're at 5.7R1.2)?

I thought it would be as simple as:

Juniper:

ge-0/0/0 {
description "gigE#1 to 3750";
gigether-options {
802.3ad ae0;
}
}

ae0 {
vlan-tagging;
aggregated-ether-options {
minimum-links 1;
}
unit 0 {
vlan-id 100;
family inet {
address 10.10.10.1/24;
}
}
}


Cisco:

interface GigabitEthernet1/0/27
description ge-0/0/0 on Juniper
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group 1 mode on


Thanks,
Jason
802.3ad between M5 & Cisco cat3750 [ In reply to ]
On Sun, Jan 25, 2004 at 03:15:17PM -0500, Robert J. Adams wrote:
> Hello,

hello,

>
> Anyone have an example of the Cat side of a 802.3ad link between a M5
> and cat3550/3750? I have found plenty examples of the Juniper side
> (pretty simple) but I can't seem to get the link to come up. All the
> cisco examples include LACP which juniper doesn't support until JUNOS
> 6.1 (we're at 5.7R1.2)?
>
> I thought it would be as simple as:
>
> Juniper:
>
> ge-0/0/0 {
> description "gigE#1 to 3750";
> gigether-options {
> 802.3ad ae0;
> }
> }
>
> ae0 {
> vlan-tagging;
> aggregated-ether-options {
> minimum-links 1;
> }
> unit 0 {
> vlan-id 100;
> family inet {
> address 10.10.10.1/24;
> }
> }
> }
>
>
> Cisco:
>
> interface GigabitEthernet1/0/27
> description ge-0/0/0 on Juniper
> switchport access vlan 100
> switchport trunk encapsulation dot1q
> switchport mode trunk
> no ip address
> channel-group 1 mode on

with this configuration in the cisco side is ok for me (802.1q +
802.3ad) :

interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
channel-protocol lacp

>
>
> Thanks,
> Jason
>
> _______________________________________________
> juniper-nsp mailing list juniper-nsp@puck.nether.net
> http://puck.nether.net/mailman/listinfo/juniper-nsp

--
Philippe
802.3ad between M5 & Cisco cat3750 [ In reply to ]
> with this configuration in the cisco side is ok for me (802.1q +
> 802.3ad) :
>
> interface Port-channel1
> switchport
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport nonegotiate
> !
> interface GigabitEthernet1/1
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport nonegotiate
> channel-group 1 mode active
> channel-protocol lacp

Hello,

What version of JUNOS are you running? We're not using 802.1q for
anything besides this (I guess you -have- to use 802.1q tags when doing
802.3ad on a juniper) ..

-j
802.3ad between M5 & Cisco cat3750 [ In reply to ]
* radams@siscom.net (Robert J. Adams) [Mon 26 Jan 2004, 02:34 CET]:
> What version of JUNOS are you running? We're not using 802.1q for
> anything besides this (I guess you -have- to use 802.1q tags when doing
> 802.3ad on a juniper) ..

Correct, an aggregated link must have "vlan-tagging" enabled.

FWIW, on a Foundry switch the configuration is as simple as "trunk
server e 1 to 2" to configure an aggregated link.


-- Niels.

--
802.3ad between M5 & Cisco cat3750 [ In reply to ]
Did you try changing the native vlan on the cisco side? If memory serves me
right Cisco leaves vlan 1 untagged yet Juniper tags the default vlan. Not
sure this applies to .3ad's but thought it was worth mentioning.

-Scotty

----- Original Message -----
From: "Niels Bakker" <niels=juniper-nsp@bakker.net>
To: <juniper-nsp@puck.nether.net>
Sent: Monday, January 26, 2004 5:48 AM
Subject: Re: [j-nsp] 802.3ad between M5 & Cisco cat3750


> * radams@siscom.net (Robert J. Adams) [Mon 26 Jan 2004, 02:34 CET]:
> > What version of JUNOS are you running? We're not using 802.1q for
> > anything besides this (I guess you -have- to use 802.1q tags when doing
> > 802.3ad on a juniper) ..
>
> Correct, an aggregated link must have "vlan-tagging" enabled.
>
> FWIW, on a Foundry switch the configuration is as simple as "trunk
> server e 1 to 2" to configure an aggregated link.
>
>
> -- Niels.
>
> --
> _______________________________________________
> juniper-nsp mailing list juniper-nsp@puck.nether.net
> http://puck.nether.net/mailman/listinfo/juniper-nsp
>
>
802.3ad between M5 & Cisco cat3750 [ In reply to ]
>>Correct, an aggregated link must have "vlan-tagging" enabled.
>>
>>FWIW, on a Foundry switch the configuration is as simple as "trunk
>>server e 1 to 2" to configure an aggregated link.

* radams@siscom.net (Robert J. Adams (jason)) [Mon 26 Jan 2004, 22:41 CET]:
> So you didn't have to configure tagged vlans on the Foundry? What do you
> have the vlan id set to on the juniper?

Well, of course you have to do that too. The vlan-id's on the Juniper
match the configuration of the switch. In this particular case:

!
vlan 110 by port
tagged ethe 1 to 2
!
vlan 130 by port
tagged ethe 1 to 2
!

... and configure the appropriate units on interface ae0 on the Juniper.


-- Niels.

--
802.3ad between M5 & Cisco cat3750 [ In reply to ]
> Correct, an aggregated link must have "vlan-tagging" enabled.
>
> FWIW, on a Foundry switch the configuration is as simple as "trunk
> server e 1 to 2" to configure an aggregated link.

So you didn't have to configure tagged vlans on the Foundry? What do you
have the vlan id set to on the juniper?

-j
802.3ad between M5 & Cisco cat3750 [ In reply to ]
On 07:13 Mon 26 Jan , Scotty wrote:
> Did you try changing the native vlan on the cisco side? If memory serves me
> right Cisco leaves vlan 1 untagged yet Juniper tags the default vlan. Not
> sure this applies to .3ad's but thought it was worth mentioning.

just to confirm; yes it does ...

-Daniel.


>
> -Scotty
>
> ----- Original Message -----
> From: "Niels Bakker" <niels=juniper-nsp@bakker.net>
> To: <juniper-nsp@puck.nether.net>
> Sent: Monday, January 26, 2004 5:48 AM
> Subject: Re: [j-nsp] 802.3ad between M5 & Cisco cat3750
>
>
> > * radams@siscom.net (Robert J. Adams) [Mon 26 Jan 2004, 02:34 CET]:
> > > What version of JUNOS are you running? We're not using 802.1q for
> > > anything besides this (I guess you -have- to use 802.1q tags when doing
> > > 802.3ad on a juniper) ..
> >
> > Correct, an aggregated link must have "vlan-tagging" enabled.
> >
> > FWIW, on a Foundry switch the configuration is as simple as "trunk
> > server e 1 to 2" to configure an aggregated link.
> >
> >
> > -- Niels.
> >
> > --
> > _______________________________________________
> > juniper-nsp mailing list juniper-nsp@puck.nether.net
> > http://puck.nether.net/mailman/listinfo/juniper-nsp
> >
> >
>
> _______________________________________________
> juniper-nsp mailing list juniper-nsp@puck.nether.net
> http://puck.nether.net/mailman/listinfo/juniper-nsp