Mailing List Archive

[nsp] Cisco 802 ISDN config
below is the runing config for a cisco 802 ISDN router. We trying to establish
a dialup connection to a cisco AS5300 to establish a 128k link (both channels).

The following error is reported from the show log;
ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 255 changed to down.

Not sure what I am missing here or what I have futsed in the config. Feel free
to tear it apart.

Thank

Dave

----------------------------

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CPE1
!
logging buffered 4096 debugging
enable secret 5 *********************
enable password 7 *******************
!
ip subnet-zero
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool ClientLAN
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
!
no ip domain-lookup
isdn switch-type basic-dms100
!
!
!
interface Ethernet0
description LAN
ip address 192.168.0.1 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface BRI0
description Connection to ISP
no ip address
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-dms100
isdn spid1 9054280817 00
isdn spid2 9054283995 00
!
interface Dialer1
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
no ip split-horizon
dialer in-band
dialer idle-timeout 7200
dialer string 9054358193
dialer hold-queue 10
dialer load-threshold 1 either
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname ***********
ppp chap password 7 ********************
ppp pap sent-username ********** password 7 ******************
ppp multilink
!
ip nat inside source list 101 interface Dialer1 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 60 0
password 7 ********************
login
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
password 7 *******************
login
!
end

Dave
RE: [nsp] Cisco 802 ISDN config [ In reply to ]
Dave, what does your show isdn status say?



Rick Cheung
NPI IT Wan Team, CCNP


-----Original Message-----
From: Dave [Hawk-Systems] [mailto:dave@hawk-systems.com]
Sent: Friday, September 20, 2002 3:31 PM
To: cisco-nsp@puck.nether.net
Subject: [nsp] Cisco 802 ISDN config


below is the runing config for a cisco 802 ISDN router. We trying to
establish
a dialup connection to a cisco AS5300 to establish a 128k link (both
channels).

The following error is reported from the show log;
ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 255 changed to down.

Not sure what I am missing here or what I have futsed in the config. Feel
free
to tear it apart.

Thank

Dave

----------------------------

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CPE1
!
logging buffered 4096 debugging
enable secret 5 *********************
enable password 7 *******************
!
ip subnet-zero
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool ClientLAN
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
!
no ip domain-lookup
isdn switch-type basic-dms100
!
!
!
interface Ethernet0
description LAN
ip address 192.168.0.1 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface BRI0
description Connection to ISP
no ip address
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-dms100
isdn spid1 9054280817 00
isdn spid2 9054283995 00
!
interface Dialer1
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
no ip split-horizon
dialer in-band
dialer idle-timeout 7200
dialer string 9054358193
dialer hold-queue 10
dialer load-threshold 1 either
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname ***********
ppp chap password 7 ********************
ppp pap sent-username ********** password 7 ******************
ppp multilink
!
ip nat inside source list 101 interface Dialer1 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 60 0
password 7 ********************
login
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
password 7 *******************
login
!
end

Dave

_______________________________________________
cisco-nsp mailing list real_name)s@puck.nether.net
http://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
RE: [nsp] Cisco 802 ISDN config [ In reply to ]
> Dave, what does your show isdn status say?

Checked this, made some minor mods to the config and checked the spids, am
still not getting successful calls and am also getting this error occasionally;
//
00:15:24: %PQICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?
//


here is the result of the sh isdn stat and debug output of attempted call

### Result of sh isdn stat;
Global ISDN Switchtype = basic-dms100
ISDN BRI0 interface
dsl 0, interface ISDN Switchtype = basic-dms100
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 122, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
TEI = 123, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
Spid Status:
TEI 122, ces = 1, state = 5(init)
spid1 configured, no LDN, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 70, tid = 0
TEI 123, ces = 2, state = 5(init)
spid2 configured, no LDN, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 71, tid = 0
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dls 0 CCBs = 0
Total Allocated ISDN CCBs = 0


### Result of ping with debugging on;
00:16:11: Dialer1: ip (s=192.168.0.1, d=206.47.131.10), 100 bytes, outgoing
interesting (ip Permit)
00:16:11: BRI0: rotor dialout [priority]
00:16:11: BRI0: Dialing cause ip (s=192.168.0.1, d=206.47.131.10)
00:16:11: BRI0: Attempting to dial 9054358277
00:16:11: ISDN BRI0: TX -> SETUP pd = 8 callref = 0x0B
00:16:11: Bearer Capability i = 0x8890
00:16:11: Channel ID i = 0x83
00:16:11: Called Party Number i = 0x80, '9054358277'
00:16:47244681216: ISDN BR0: RX <- CA::_PROC .pd = 8 callref = 0x8B
00:16:47251435588: Channel ID i = 0x89
00:16:47244681216: Locking Shift to Codeset 5
00:16:47251435372: Codeset 5 IE 0x2A i = 0x80880A, '9054358277',
0x80010A800114800114800114
00:16:52348074545: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x8B
00:16:51546402884: Cause i = 0xE281 - Unallocated/unassigned number
00:16:51539648512: Signal i = 0x03 - Network congestion tone on
00:16:12: ISDN BRI0: TX -> RELEASE pd = 8 callref = 0x0B
00:16:12: BRI0: wait for isdn carrier timeout, call id=0x800B
00:16:12: : Dialing failed, 0 packets unqueued and discarded
00:16:12: BR0:1 LCP: State is Closed
00:16:12: BR0:1 PPP: Phase os DOWM
00:16:12: BRI0:1: disconnecting call
00:16:51539648512: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x8B
00:16:51546402884: Signal i = 0x3F - Tones off

repeats...


is the receiving line not accepting the digital call or not correctly configured
for it? It is a valid number used for analog dialup conenctions, and is a Cisco
AS5300 with PRIs in each port. This line

00:16:51546402884: Cause i = 0xE281 - Unallocated/unassigned number

leads me to believe that there is something wrong, perhaps in routing the call
to the box? no idea. Anyone have a clue?

copy of config below.

thanks

Dave

>>----------------------------
>>
>>version 12.0
>>no service pad
>>service timestamps debug uptime
>>service timestamps log uptime
>>service password-encryption
>>!
>>hostname CPE1
>>!
>>logging buffered 4096 debugging
>>enable secret 5 *********************
>>enable password 7 *******************
>>!
>>ip subnet-zero
>>ip dhcp excluded-address 192.168.0.1
>>!
>>ip dhcp pool ClientLAN
>> network 192.168.0.0 255.255.255.0
>> default-router 192.168.0.1
>>!
>>no ip domain-lookup
>>isdn switch-type basic-dms100
>>!
>>!
>>!
>>interface Ethernet0
>> description LAN
>> ip address 192.168.0.1 255.255.255.0
>> no ip directed-broadcast
>> ip nat inside
>>!
>>interface BRI0
>> description Connection to ISP
>> no ip address
>> no ip directed-broadcast
>> ip nat outside
>> encapsulation ppp
>> dialer rotary-group 1
>> isdn switch-type basic-dms100
>> isdn spid1 905428081700
>> isdn spid2 905428399500
>>!
>>interface Dialer1
>> ip address negotiated
>> no ip directed-broadcast
>> ip nat outside
>> encapsulation ppp
>> no ip split-horizon
>> dialer in-band
>> dialer idle-timeout 7200
>> dialer string 9054358277
>> dialer hold-queue 10
>> dialer load-threshold 1 either
>> dialer-group 1
>> ppp authentication chap pap callin
>> ppp chap hostname ***********
>> ppp chap password 7 ********************
>> ppp pap sent-username ********** password 7 ******************
>> ppp multilink
>>!
>>ip nat inside source list 101 interface Dialer1 overload
>>no ip http server
>>ip classless
>>ip route 0.0.0.0 0.0.0.0 Dialer1
>>!
>>access-list 1 permit 192.168.1.0 0.0.0.255
>>access-list 101 permit ip 192.168.0.0 0.0.0.255 any
>>dialer-list 1 protocol ip permit
>>!
>>line con 0
>> exec-timeout 60 0
>> password 7 ********************
>> login
>> transport input none
>> stopbits 1
>>line vty 0 4
>> exec-timeout 0 0
>> password 7 *******************
>> login
>>!
>>end