Mailing List Archive

client-initiated l2tp tunnel
hi,

we are trying to setup an l2tp tunnel up from an cisco 837 adsl router to an lns.

we are able to establish the tunnel, the session however will not get established. i've attached the c837's config (you'll see very basic - still testing).

we've tried using chap/pap with local auth and radius - the problem seems to be with the ppp auth. could anyone advise of any known problems when using this feature? google and cco has limited information.

thanks in advance

-jaco

--
Current configuration : 1904 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname dsl-ce
!
memory-size iomem 5
enable secret 5 $1$x7yn$hE1YnaYv2nQ2mnT2x2fk6.
!
no aaa new-model
ip subnet-zero
ip telnet source-interface Ethernet0
no ip domain lookup
!
!
ip cef
ip cef accounting per-prefix
ip audit notify log
ip audit po max-events 100
l2tp-class l2tpclass1
!
pseudowire-class pwclass1
encapsulation l2tpv2
ip local interface ATM0.1
!
no ftp-server write-enable
!
interface Loopback1
no ip address
!
interface Ethernet0
ip address 172.20.8.17 255.255.255.248
no cdp enable
hold-queue 100 out
!
interface ATM0
no ip address
load-interval 30
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Virtual-PPP1
ip unnumbered Ethernet0
no cdp enable
ppp authentication chap
ppp chap hostname clns1-rba
ppp chap password 7 131112011F050A2D
pseudowire 10.10.208.137 10 pw-class pwclass1
!
interface Dialer0
ip address negotiated
no ip redirects
encapsulation ppp
ip route-cache flow
load-interval 30
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username bje@chiefjanitor.com password 0 mypassword
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 192.168.198.0 255.255.255.0 Virtual-PPP1
!
no ip http server
no ip http secure-server
!
!
line con 0
exec-timeout 120 0
no modem enable
stopbits 1
line aux 0
line vty 0 4
exec-timeout 120 0
password 7 0507070D
login local
length 0
!
scheduler max-task-time 5000
!
end
--


--
bje@serendipity.org.za
the faculty of making fortunate discoveries
Re: client-initiated l2tp tunnel [ In reply to ]
I remember that it was a problem in the first releases when the feature
was introduced with auth direction. The workaround was to force the
whished direction with "ppp direction".

You can check it with "debug ppp authentication".


FĂ©lix



Jaco Engelbrecht wrote:
> hi,
>
> we are trying to setup an l2tp tunnel up from an cisco 837 adsl router to an lns.
>
> we are able to establish the tunnel, the session however will not get established. i've attached the c837's config (you'll see very basic - still testing).
>
> we've tried using chap/pap with local auth and radius - the problem seems to be with the ppp auth. could anyone advise of any known problems when using this feature? google and cco has limited information.
>
> thanks in advance
>
> -jaco
>
> --
> Current configuration : 1904 bytes
> !
> version 12.3
> no service pad
> service timestamps debug datetime msec
> service timestamps log datetime msec
> service password-encryption
> !
> hostname dsl-ce
> !
> memory-size iomem 5
> enable secret 5 $1$x7yn$hE1YnaYv2nQ2mnT2x2fk6.
> !
> no aaa new-model
> ip subnet-zero
> ip telnet source-interface Ethernet0
> no ip domain lookup
> !
> !
> ip cef
> ip cef accounting per-prefix
> ip audit notify log
> ip audit po max-events 100
> l2tp-class l2tpclass1
> !
> pseudowire-class pwclass1
> encapsulation l2tpv2
> ip local interface ATM0.1
> !
> no ftp-server write-enable
> !
> interface Loopback1
> no ip address
> !
> interface Ethernet0
> ip address 172.20.8.17 255.255.255.248
> no cdp enable
> hold-queue 100 out
> !
> interface ATM0
> no ip address
> load-interval 30
> no atm ilmi-keepalive
> dsl operating-mode auto
> !
> interface ATM0.1 point-to-point
> pvc 8/35
> pppoe-client dial-pool-number 1
> !
> !
> interface FastEthernet1
> no ip address
> duplex auto
> speed auto
> !
> interface FastEthernet2
> no ip address
> duplex auto
> speed auto
> !
> interface FastEthernet3
> no ip address
> duplex auto
> speed auto
> !
> interface FastEthernet4
> no ip address
> duplex auto
> speed auto
> !
> interface Virtual-PPP1
> ip unnumbered Ethernet0
> no cdp enable
> ppp authentication chap
> ppp chap hostname clns1-rba
> ppp chap password 7 131112011F050A2D
> pseudowire 10.10.208.137 10 pw-class pwclass1
> !
> interface Dialer0
> ip address negotiated
> no ip redirects
> encapsulation ppp
> ip route-cache flow
> load-interval 30
> dialer pool 1
> dialer-group 1
> ppp authentication pap callin
> ppp pap sent-username bje@chiefjanitor.com password 0 mypassword
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer0
> ip route 192.168.198.0 255.255.255.0 Virtual-PPP1
> !
> no ip http server
> no ip http secure-server
> !
> !
> line con 0
> exec-timeout 120 0
> no modem enable
> stopbits 1
> line aux 0
> line vty 0 4
> exec-timeout 120 0
> password 7 0507070D
> login local
> length 0
> !
> scheduler max-task-time 5000
> !
> end
> --
>
>
Re: client-initiated l2tp tunnel [ In reply to ]
hi!

On Tue 2005-02-08 (16:22), F?lix Izquierdo wrote:
> I remember that it was a problem in the first releases when the feature
> was introduced with auth direction. The workaround was to force the
> whished direction with "ppp direction".

excellent, busy trying this :) i'm sure this is going to do the trick.

what ios version are you currently using on the c837s? are you using l2tp v2 or v3?

later
jaco

--
bje@serendipity.org.za
the faculty of making fortunate discoveries
Re: client-initiated l2tp tunnel [ In reply to ]
Jaco Engelbrecht wrote:

> hi!
>
> On Tue 2005-02-08 (16:22), F?lix Izquierdo wrote:
>
>>I remember that it was a problem in the first releases when the feature
>>was introduced with auth direction. The workaround was to force the
>>whished direction with "ppp direction".
>
>
> excellent, busy trying this :) i'm sure this is going to do the trick.
>
> what ios version are you currently using on the c837s? are you using l2tp v2 or v3?
>

Last rebuilds of 12.3(11)T ( 12.3(11)T2 and 12.3(11)T3 ). The default
direction for virtual-ppp interfaces is "dedicated line", then, if you
don't change the direction and you want only callout auth, don't
configure any "ppp authentication... callin" command, because the
"callin" option will be ingnored.

I'm using l2tp v2.
Re: client-initiated l2tp tunnel [ In reply to ]
hi,

i've changed the ios on my cisco 837 to ios 12.3.11T, the l2tp session is coming up now but now drops after a minute:

<snip>
*Mar 1 15:00:11.675: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Virtual-PPP1, changed state to up
*Mar 1 15:01:02.887: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed
state to down
*Mar 1 15:01:02.895: Vp1 PPP: Sending Acct Event[Down] id[174]
*Mar 1 15:01:02.895: Vp1 IPCP: Remove link info for cef entry
192.168.208.137
*Mar 1 15:01:02.895: Vp1 IPCP: State is Closed
*Mar 1 15:01:02.899: Vp1 PPP: Phase is TERMINATING
*Mar 1 15:01:02.899: Vp1 LCP: State is Closed
*Mar 1 15:01:02.899: Vp1 PPP: Phase is DOWN
*Mar 1 15:01:02.915: Vp1 IPCP: Remove route to 192.168.208.137
*Mar 1 15:01:02.915: Vp1 IPCP: Remove default route thru 192.168.208.137
*Mar 1 15:01:03.891: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Virtual-PPP1, changed state to down
*Mar 1 15:01:13.023: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed
state to up
*Mar 1 15:01:13.027: Vp1 PPP: Using default call direction
*Mar 1 15:01:13.027: Vp1 PPP: Treating connection as a dedicated line
*Mar 1 15:01:13.031: Vp1 PPP: Phase is ESTABLISHING, Active Open
*Mar 1 15:01:13.031: Vp1 PPP: Authorization required
*Mar 1 15:01:13.031: Vp1 LCP: O CONFREQ [Closed] id 203 len 10
*Mar 1 15:01:13.031: Vp1 LCP: MagicNumber 0x13274C7F
(0x050613274C7F)
*Mar 1 15:01:13.079: Vp1 LCP: I CONFREQ [REQsent] id 1 len 14
*Mar 1 15:01:13.079: Vp1 LCP: AuthProto PAP (0x0304C023)
*Mar 1 15:01:13.079: Vp1 LCP: MagicNumber 0x29111891
(0x050629111891)
*Mar 1 15:01:13.079: Vp1 LCP: O CONFACK [REQsent] id 1 len 14
*Mar 1 15:01:13.083: Vp1 LCP: AuthProto PAP (0x0304C023)
*Mar 1 15:01:13.083: Vp1 LCP: MagicNumber 0x29111891
(0x050629111891)
*Mar 1 15:01:13.083: Vp1 LCP: I CONFACK [ACKsent] id 203 len 10
*Mar 1 15:01:13.083: Vp1 LCP: MagicNumber 0x13274C7F
(0x050613274C7F)
*Mar 1 15:01:13.083: Vp1 LCP: State is Open
*Mar 1 15:01:13.083: Vp1 PPP: No authorization without authentication
*Mar 1 15:01:13.083: Vp1 PPP: Phase is AUTHENTICATING, by the peer
*Mar 1 15:01:13.083: Vp1 PAP: Using hostname from interface PAP
*Mar 1 15:01:13.087: Vp1 PAP: Using password from interface PAP
*Mar 1 15:01:13.087: Vp1 PAP: O AUTH-REQ id 15 len 39 from
"bje@serendipity@static.ip"
*Mar 1 15:01:13.247: Vp1 PAP: I AUTH-ACK id 15 len 5
*Mar 1 15:01:13.247: Vp1 PPP: Phase is FORWARDING, Attempting Forward
*Mar 1 15:01:13.251: Vp1 PPP: Queue IPCP code[1] id[1]
*Mar 1 15:01:13.251: Vp1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar 1 15:01:13.251: Vp1 PPP: Phase is UP
*Mar 1 15:01:13.255: Vp1 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar 1 15:01:13.255: Vp1 IPCP: Address 196.14.112.159
(0x0306C40E709F)
*Mar 1 15:01:13.255: Vp1 PPP: Process pending ncp packets
*Mar 1 15:01:13.255: Vp1 IPCP: Redirect packet to Vp1
*Mar 1 15:01:13.255: Vp1 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar 1 15:01:13.255: Vp1 IPCP: Address 192.168.208.137
(0x0306C41AD089)
*Mar 1 15:01:13.255: Vp1 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar 1 15:01:13.259: Vp1 IPCP: Address 192.168.208.137
(0x0306C41AD089)
*Mar 1 15:01:13.299: Vp1 IPCP: I CONFNAK [ACKsent] id 1 len 10
*Mar 1 15:01:13.307: Vp1 IPCP: Address 172.16
(0x0306C4277EF7)
*Mar 1 15:01:13.307: Vp1 IPCP: O CONFREQ [ACKsent] id 2 len 4
*Mar 1 15:01:13.351: Vp1 IPCP: I CONFACK [ACKsent] id 2 len 4
*Mar 1 15:01:13.351: Vp1 IPCP: State is Open
*Mar 1 15:01:13.363: Vp1 IPCP: Add link info for cef entry
192.168.208.137
*Mar 1 15:01:13.363: Vp1 IPCP: Install route to 192.168.208.137
*Mar 1 15:01:14.251: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Virtual-PPP1, changed state to up
</snip>

we also using pap and auth'ing against a radius server. here is some vpdn debugging output:

<snip>
dsl-ce#sho debug
VPN:
L2X protocol events debugging is on
L2X control packets debugging is on
L2X protocol errors debugging is on
PPP:
PPP authentication debugging is on
PPP protocol negotiation debugging is on
dsl-ce#
*Mar 1 15:04:10.559: uid:2 Tnl/Sn 1054/206 L2TP: Parse AVP 0, len 8,
flag 0x8000 (M)
*Mar 1 15:04:10.559: uid:2 Tnl/Sn 1054/206 L2TP: Parse CDN
*Mar 1 15:04:10.559: uid:2 Tnl/Sn 1054/206 L2TP: Parse AVP 14, len 8,
flag 0x8000 (M)
*Mar 1 15:04:10.563: uid:2 Tnl/Sn 1054/206 L2TP: Assigned Call ID 4801
*Mar 1 15:04:10.563: uid:2 Tnl/Sn 1054/206 L2TP: Parse AVP 1, len 38,
flag 0x8000 (M)
*Mar 1 15:04:10.563: uid:2 Tnl/Sn 1054/206 L2TP: Result code(2): 2:
Call disconnected, refer to error msg
*Mar 1 15:04:10.563: Error code(6): Vendor specific
*Mar 1 15:04:10.563: Optional msg: Locally generated disconnect
*Mar 1 15:04:10.563: uid:2 Tnl/Sn 1054/206 L2TP: Parse AVP 46, len 11,
flag 0x0
*Mar 1 15:04:10.567: uid:2 Tnl/Sn 1054/206 L2TP: disconnected, code 3,
direction local for CP 0x0
*Mar 1 15:04:10.567: uid:2 Tnl/Sn 1054/206 L2TP: Parse Cisco AVP 104,
len 11, flag 0x0
*Mar 1 15:04:10.567: uid:2 Tnl/Sn 1054/206 L2TP: PPP Disconnect Cause
Code (Cisco) Already rcvd IETF version, ignoring
*Mar 1 15:04:10.567: uid:2 Tnl/Sn 1054/206 L2TP: No missing AVPs in CDN
*Mar 1 15:04:10.567: uid:2 Tnl/Sn 1054/206 L2TP: I CDN, flg TLS, ver 2,
len 88, tnl 1054, lsid 206, rsid 4801, ns 2, nr 4
contiguous pak, size 88
C8 02 00 58 04 1E 00 CE 00 02 00 04 80 08 00 00
00 00 00 0E 80 08 00 00 00 0E 12 C1 80 26 00 00
00 01 00 02 00 06 4C 6F 63 61 6C 6C 79 20 67 65
6E 65 72 61 74 65 64 20 64 69 73 63 6F 6E 6E 65
63 74 00 0B 00 00 00 2E ...
*Mar 1 15:04:10.571: uid:2 Tnl/Sn 1054/206 L2TP: O ZLB ctrl ack, flg
TLS, ver 2, len 12, tnl 44599, lsid 206, rsid 4801, ns 4, nr 3
C8 02 00 0C AE 37 00 00 00 04 00 03
*Mar 1 15:04:10.579: uid:2 Tnl/Sn 1054/206 L2TP: I CDN from clns1-rba
tnl 44599, cl 4801
*Mar 1 15:04:10.579: uid:2 Tnl/Sn 1054/206 L2TP: disconnect (L2X) IETF:
18/host-request Ascend: 66/VPDN Local PPP Disconnect
*Mar 1 15:04:10.579: uid:2 Tnl/Sn 1054/206 L2TP: Destroying session
*Mar 1 15:04:10.579: L2X: Sending L2TUN message <Disconnect>
*Mar 1 15:04:10.579: uid:2 Tnl/Sn 1054/206 L2TP: Session state change
from established to idle
*Mar 1 15:04:10.579: Tnl 1054 L2TP: Tunnel state change from
established to no-sessions-left
*Mar 1 15:04:10.579: Tnl 1054 L2TP: No more sessions in tunnel,
shutdown (likely) in 15 seconds
*Mar 1 15:04:10.583: L2X: Session not up, discarded data packet at
process level
*Mar 1 15:04:10.583: L2X: l2tun session [2174859524], event [server
terminate], old state [open], new state [wait-free]
*Mar 1 15:04:10.583: L2X: l2tun session [2174859524], event [client
free], old state [wait-free], new state [terminal]
*Mar 1 15:04:10.599: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed
state to down
*Mar 1 15:04:10.603: Vp1 PPP: Sending Acct Event[Down] id[17A]
*Mar 1 15:04:10.603: Vp1 IPCP: Remove link info for cef entry
192.168.208.137
*Mar 1 15:04:10.603: Vp1 IPCP: State is Closed
*Mar 1 15:04:10.607: Vp1 PPP: Phase is TERMINATING
*Mar 1 15:04:10.607: Vp1 LCP: State is Closed
*Mar 1 15:04:10.607: Vp1 PPP: Phase is DOWN
*Mar 1 15:04:10.615: Vp1 IPCP: Remove route to 192.168.208.137
*Mar 1 15:04:10.615: Vp1 IPCP: Remove default route thru 192.168.208.137
*Mar 1 15:04:11.599: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Virtual-PPP1, changed state to down
*Mar 1 15:04:13.559: Tnl 1054 L2TP: O ZLB ctrl ack, flg TLS, ver 2,
len 12, tnl 44599, ns 4, nr 3
C8 02 00 0C AE 37 00 00 00 04 00 03
*Mar 1 15:04:20.559: Tnl 1054 L2TP: Parse AVP 0, len 8, flag 0x8000
(M)
*Mar 1 15:04:20.559: Tnl 1054 L2TP: Parse StopCCN
*Mar 1 15:04:20.559: Tnl 1054 L2TP: Parse AVP 9, len 8, flag 0x8000
(M)
*Mar 1 15:04:20.559: Tnl 1054 L2TP: Assigned Tunnel ID 44599
*Mar 1 15:04:20.563: Tnl 1054 L2TP: Parse AVP 1, len 10, flag 0x8000
(M)
*Mar 1 15:04:20.563: L2X: Result code(1): 1: Request to clear control
connection
*Mar 1 15:04:20.563: Error code(0): No error
*Mar 1 15:04:20.563: Tnl 1054 L2TP: No missing AVPs in StopCCN
*Mar 1 15:04:20.563: Tnl 1054 L2TP: I StopCCN, flg TLS, ver 2, len 38,
tnl 1054, ns 3, nr 4
contiguous pak, size 38
C8 02 00 26 04 1E 00 00 00 03 00 04 80 08 00 00
00 00 00 04 80 08 00 00 00 09 AE 37 80 0A 00 00
00 01 00 01 00 00
*Mar 1 15:04:20.571: Tnl 1054 L2TP: O ZLB ctrl ack, flg TLS, ver 2,
len 12, tnl 44599, ns 4, nr 4
C8 02 00 0C AE 37 00 00 00 04 00 04
*Mar 1 15:04:20.571: Tnl 1054 L2TP: I StopCCN from clns1-rba tnl 44599
*Mar 1 15:04:20.571: Tnl 1054 L2TP: Tunnel state change from
no-sessions-left to shutting-down
*Mar 1 15:04:20.571: Tnl 1054 L2TP: Shutdown tunnel
*Mar 1 15:04:20.571: Tnl 1054 L2TP: Tunnel state change from
shutting-down to idle
*Mar 1 15:04:20.595: L2X: l2tun session [2174859524], event [client
request], old state [open], new state [open]
*Mar 1 15:04:20.599: L2X: L2TP: Received L2TUN message <Connect>
*Mar 1 15:04:20.599: Tnl/Sn 23325/207 L2TP: Session state change from
idle to wait-for-tunnel
*Mar 1 15:04:20.599: uid:2 Tnl/Sn 23325/207 L2TP: Create session
*Mar 1 15:04:20.603: Tnl 23325 L2TP: SM State idle
*Mar 1 15:04:20.603: Tnl 23325 L2TP: O SCCRQ
*Mar 1 15:04:20.603: Tnl 23325 L2TP: O SCCRQ, flg TLS, ver 2, len 115,
tnl 0, ns 0, nr 0
C8 02 00 73 00 00 00 00 00 00 00 00 80 08 00 00
00 00 00 01 80 08 00 00 00 02 01 00 00 08 00 00
00 06 11 30 80 0C 00 00 00 07 64 73 6C 2D 63 65
00 19 00 00 00 08 43 69 73 63 6F 20 53 79 73 74
65 6D 73 2C 20 49 6E ...
*Mar 1 15:04:20.607: Tnl 23325 L2TP: Control channel retransmit delay
set to 1 seconds
*Mar 1 15:04:20.607: Tnl 23325 L2TP: Tunnel state change from idle to
wait-ctl-reply
*Mar 1 15:04:20.607: Tnl 23325 L2TP: SM State wait-ctl-reply
*Mar 1 15:04:20.647: Tnl 23325 L2TP: Parse AVP 0, len 8, flag 0x8000
(M)
*Mar 1 15:04:20.647: Tnl 23325 L2TP: Parse SCCRP
*Mar 1 15:04:20.647: Tnl 23325 L2TP: Parse AVP 2, len 8, flag 0x8000
(M)
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Protocol Ver 256
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Parse AVP 3, len 10, flag 0x8000
(M)
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Framing Cap 0x0
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Parse AVP 4, len 10, flag 0x8000
(M)
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Bearer Cap 0x0
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Parse AVP 6, len 8, flag 0x0
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Firmware Ver 0x1120
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Parse AVP 7, len 15, flag 0x8000
(M)
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Hostname clns1-rba
*Mar 1 15:04:20.655: Tnl 23325 L2TP: Parse AVP 8, len 25, flag 0x0
*Mar 1 15:04:20.659: Tnl 23325 L2TP: Vendor Name Cisco Systems, Inc.
*Mar 1 15:04:20.659: Tnl 23325 L2TP: Parse AVP 9, len 8, flag 0x8000
(M)
*Mar 1 15:04:20.659: Tnl 23325 L2TP: Assigned Tunnel ID 61497
*Mar 1 15:04:20.663: Tnl 23325 L2TP: Parse AVP 10, len 8, flag 0x8000
(M)
*Mar 1 15:04:20.663: Tnl 23325 L2TP: Rx Window Size 800
*Mar 1 15:04:20.663: Tnl 23325 L2TP: No missing AVPs in SCCRP
*Mar 1 15:04:20.663: Tnl 23325 L2TP: I SCCRP, flg TLS, ver 2, len 112,
tnl 23325, ns 0, nr 1
contiguous pak, size 112
C8 02 00 70 5B 1D 00 00 00 00 00 01 80 08 00 00
00 00 00 02 80 08 00 00 00 02 01 00 80 0A 00 00
00 03 00 00 00 00 80 0A 00 00 00 04 00 00 00 00
00 08 00 00 00 06 11 20 80 0F 00 00 00 07 63 6C
6E 73 31 2D 72 62 61 00 ...
*Mar 1 15:04:20.667: Tnl 23325 L2TP: I SCCRP from clns1-rba
*Mar 1 15:04:20.667: Tnl 23325 L2TP: Tunnel state change from
wait-ctl-reply to established
*Mar 1 15:04:20.667: Tnl 23325 L2TP: O SCCCN to clns1-rba tnlid 61497
*Mar 1 15:04:20.671: Tnl 23325 L2TP: O SCCCN, flg TLS, ver 2, len 20,
tnl 61497, ns 1, nr 1
C8 02 00 14 F0 39 00 00 00 01 00 01 80 08 00 00
00 00 00 03
*Mar 1 15:04:20.671: Tnl 23325 L2TP: Control channel retransmit delay
set to 1 seconds
*Mar 1 15:04:20.675: Tnl 23325 L2TP: SM State established
*Mar 1 15:04:20.675: uid:2 Tnl/Sn 23325/207 L2TP: O ICRQ to clns1-rba
61497/0
*Mar 1 15:04:20.675: uid:2 Tnl/Sn 23325/207 L2TP: O ICRQ, flg TLS, ver
2, len 48, tnl 61497, lsid 207, rsid 0, ns 2, nr 1
C8 02 00 30 F0 39 00 00 00 02 00 01 80 08 00 00
00 00 00 0A 80 0A 00 00 00 0F 63 F6 84 AD 80 08
00 00 00 0E 00 CF 80 0A 00 00 00 12 00 00 00 00
*Mar 1 15:04:20.679: uid:2 Tnl/Sn 23325/207 L2TP: Session state change
from wait-for-tunnel to wait-reply
*Mar 1 15:04:20.715: uid:2 Tnl/Sn 23325/207 L2TP: Parse AVP 0, len 8,
flag 0x8000 (M)
*Mar 1 15:04:20.715: uid:2 Tnl/Sn 23325/207 L2TP: Parse ICRP
*Mar 1 15:04:20.719: uid:2 Tnl/Sn 23325/207 L2TP: Parse AVP 14, len 8,
flag 0x8000 (M)
*Mar 1 15:04:20.719: uid:2 Tnl/Sn 23325/207 L2TP: Assigned Call ID 4804
*Mar 1 15:04:20.719: uid:2 Tnl/Sn 23325/207 L2TP: No missing AVPs in
ICRP
*Mar 1 15:04:20.719: uid:2 Tnl/Sn 23325/207 L2TP: I ICRP, flg TLS, ver
2, len 28, tnl 23325, lsid 207, rsid 0, ns 1, nr 3
contiguous pak, size 28
C8 02 00 1C 5B 1D 00 CF 00 01 00 03 80 08 00 00
00 00 00 0B 80 08 00 00 00 0E 12 C4
*Mar 1 15:04:20.723: uid:2 Tnl/Sn 23325/207 L2TP: Session state change
from wait-reply to established
*Mar 1 15:04:20.723: L2X: Sending L2TUN message <Connect OK>
*Mar 1 15:04:20.723: uid:2 Tnl/Sn 23325/207 L2TP: O ICCN to clns1-rba
61497/4804
*Mar 1 15:04:20.723: uid:2 Tnl/Sn 23325/207 L2TP: O ICCN, flg TLS, ver
2, len 40, tnl 61497, lsid 207, rsid 4804, ns 3, nr 2
C8 02 00 28 F0 39 12 C4 00 03 00 02 80 08 00 00
00 00 00 0C 80 0A 00 00 00 18 00 00 00 00 80 0A
00 00 00 13 00 00 00 01
*Mar 1 15:04:20.727: Tnl 23325 L2TP: Control channel retransmit delay
set to 1 seconds
*Mar 1 15:04:20.727: L2X: l2tun session [2174859524], event [server
response], old state [open], new state [open]
*Mar 1 15:04:20.731: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed
state to up
*Mar 1 15:04:20.731: Vp1 PPP: Using default call direction
*Mar 1 15:04:20.731: Vp1 PPP: Treating connection as a dedicated line
*Mar 1 15:04:20.731: Vp1 PPP: Phase is ESTABLISHING, Active Open
*Mar 1 15:04:20.731: Vp1 PPP: Authorization required
*Mar 1 15:04:20.731: Vp1 LCP: O CONFREQ [Closed] id 206 len 10
*Mar 1 15:04:20.739: Vp1 LCP: MagicNumber 0x132A29BB
(0x0506132A29BB)
*Mar 1 15:04:21.727: Tnl 23325 L2TP: Control channel retransmit delay
set to 1 seconds
*Mar 1 15:04:22.739: Vp1 LCP: TIMEout: State REQsent
*Mar 1 15:04:22.739: Vp1 LCP: O CONFREQ [REQsent] id 207 len 10
*Mar 1 15:04:22.739: Vp1 LCP: MagicNumber 0x132A29BB
(0x0506132A29BB)
*Mar 1 15:04:22.779: Vp1 LCP: I CONFREQ [REQsent] id 1 len 14
*Mar 1 15:04:22.779: Vp1 LCP: AuthProto PAP (0x0304C023)
*Mar 1 15:04:22.779: Vp1 LCP: MagicNumber 0x2913FDA3
(0x05062913FDA3)
*Mar 1 15:04:22.779: Vp1 LCP: O CONFACK [REQsent] id 1 len 14
*Mar 1 15:04:22.779: Vp1 LCP: AuthProto PAP (0x0304C023)
*Mar 1 15:04:22.779: Vp1 LCP: MagicNumber 0x2913FDA3
(0x05062913FDA3)
*Mar 1 15:04:22.779: Vp1 LCP: I CONFACK [ACKsent] id 207 len 10
*Mar 1 15:04:22.779: Vp1 LCP: MagicNumber 0x132A29BB
(0x0506132A29BB)
*Mar 1 15:04:22.779: Vp1 LCP: State is Open
*Mar 1 15:04:22.779: Vp1 PPP: No authorization without authentication
*Mar 1 15:04:22.779: Vp1 PPP: Phase is AUTHENTICATING, by the peer
*Mar 1 15:04:22.779: Vp1 PAP: Using hostname from interface PAP
*Mar 1 15:04:22.779: Vp1 PAP: Using password from interface PAP
*Mar 1 15:04:22.783: Vp1 PAP: O AUTH-REQ id 18 len 39 from
"bje@serendipity@static.ip"
*Mar 1 15:04:22.951: Vp1 PAP: I AUTH-ACK id 18 len 5
*Mar 1 15:04:22.951: Vp1 PPP: Phase is FORWARDING, Attempting Forward
*Mar 1 15:04:22.955: Vp1 PPP: Queue IPCP code[1] id[1]
*Mar 1 15:04:22.955: Vp1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar 1 15:04:22.955: Vp1 PPP: Phase is UP
*Mar 1 15:04:22.955: Vp1 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar 1 15:04:22.963: Vp1 IPCP: Address 196.14.112.159
(0x0306C40E709F)
*Mar 1 15:04:22.963: Vp1 PPP: Process pending ncp packets
*Mar 1 15:04:22.963: Vp1 IPCP: Redirect packet to Vp1
*Mar 1 15:04:22.963: Vp1 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar 1 15:04:22.963: Vp1 IPCP: Address 192.168.208.137
(0x0306C41AD089)
*Mar 1 15:04:22.963: Vp1 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar 1 15:04:22.963: Vp1 IPCP: Address 192.168.208.137
(0x0306C41AD089)
*Mar 1 15:04:23.011: Vp1 IPCP: I CONFNAK [ACKsent] id 1 len 10
*Mar 1 15:04:23.011: Vp1 IPCP: Address 172.16
(0x0306C4277EF7)
*Mar 1 15:04:23.011: Vp1 IPCP: O CONFREQ [ACKsent] id 2 len 4
*Mar 1 15:04:23.051: Vp1 IPCP: I CONFACK [ACKsent] id 2 len 4
*Mar 1 15:04:23.051: Vp1 IPCP: State is Open
*Mar 1 15:04:23.055: Vp1 IPCP: Add link info for cef entry
192.168.208.137
*Mar 1 15:04:23.055: Vp1 IPCP: Install route to 192.168.208.137
*Mar 1 15:04:23.959: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Virtual-PPP1, changed state to up
*Mar 1 15:04:23.963: L2X: Attempted multiple encap passes, dropping
*Mar 1 15:04:34.227: L2X: Attempted multiple encap passes, dropping
dsl-ce#
</snip>

the lns router shows that is does connect:

<snip>
clns1-rba#sho vpdn tunnel

L2TP Tunnel Information Total tunnels 17 sessions 27

LocID RemID Remote Name State Remote Address Port Sessions VPDN
Group
12859 45596 dsl-ce est 196.14.112.159 1701 1 4
clns1-rba#sho vpdn session

L2TP Session Information Total tunnels 18 sessions 27

LocID RemID TunID Intf Username State Last Chg
Uniq ID
4808 209 21308 Vi362.1 bje@serendipity@stati est 00:00:25 104

</snip>

this is the latest config being used:

ce:

<snip>
l2tp-class l2tpclass1
!
pseudowire-class pwclass1
encapsulation l2tpv2
ip local interface ATM0.1
!
interface Virtual-PPP1
ip address negotiated
no cdp enable
ppp pap sent-username bje@serendipity@static.ip password 7 <removed>
pseudowire 192.168.208.137 10 pw-class pwclass1
!
</snip>

lns:

<snip>
vpdn-group 4
! Default L2TP VPDN group
description ADSL L2TP Tunnels
accept-dialin
protocol l2tp
virtual-template 4
no l2tp tunnel authentication
!
interface Virtual-Template4
ip unnumbered FastEthernet0
ip verify unicast reverse-path
no logging event link-status
peer default ip address pool default
ppp authentication pap staticip
ppp authorization staticip
ppp accounting staticip
!
</snip>


... any ideas?

regards
jaco

--
bje@serendipity.org.za
the faculty of making fortunate discoveries