Mailing List Archive

DSL resiliency over two 7200's
Hi,



Has anyone an opinion on the best way to handle the following scenario?



Two 7204VXR's (NPE-G1) terminating L2TP tunnels from Telco: Current
config below. Second box similar.



Telco suggesting we share inbound DSL sessions over Gig0/1 is shared
over two boxes. These ports are connected to 2 x 6500 GigE ports owned
by telco. Internally we have BVI1 hooked up to redundant L2 switches. We
had HSRP configured internally so this won't work.



If we loose primary box, it would require manual intervention from telco
to transfer traffic to second box.



Any thoughts appreciated.



vpdn enable

no vpdn history failure cause normal

vpdn history failure table-size 50

vpdn ip udp ignore checksum

!

vpdn-group 1

description VPDN-GROUP-1

accept-dialin

protocol l2tp

virtual-template 1

terminate-from hostname telco.domain

source-ip y.y.y.x

lcp renegotiation on-mismatch

l2tp tunnel password password1

!

virtual-template 1 pre-clone 8000

!

!

interface Loopback0

description VPDN Tunnel Endpoint1

ip address x.x.x.y 255.255.255.255

!

!

interface GigabitEthernet0/1

description GigabitEthernet To Telco_Box_1

ip address v.v.v.w 255.255.255.248

standby 222 ip v.v.v.y

standby 222 priority 150

standby 222 preempt

!

!

interface BVI1

description Bridge-group for L2 to Router1-2

ip address a.a.a.b 255.255.255.0

standby 1 ip a.a.a.c

standby 1 priority 150

standby 1 preempt

standby 1 track GigabitEthernet0/1 70

!

router bgp 1234

no synchronization

bgp log-neighbor-changes

network v.v.v.0

network y.y.y.0

network b.b.b.0 mask 255.255.240.0

neighbor v.v.v.a remote-as 5678

neighbor v.v.v.a description Telco_Box_1

no auto-summary
Re: DSL resiliency over two 7200's [ In reply to ]
If the telco uses RADIUS to initiate the L2TP tunnel to your LNS, and the
LAC supports the cisco VPDN standard then they can specify more then one
IP for the end of the L2TP tunnel. It can be done as a round-robin or
failover.

K

On Mon, 5 Dec 2005, Mark Tohill wrote:

> Hi,
>
>
>
> Has anyone an opinion on the best way to handle the following scenario?
>
>
>
> Two 7204VXR's (NPE-G1) terminating L2TP tunnels from Telco: Current
> config below. Second box similar.
>
>
>
> Telco suggesting we share inbound DSL sessions over Gig0/1 is shared
> over two boxes. These ports are connected to 2 x 6500 GigE ports owned
> by telco. Internally we have BVI1 hooked up to redundant L2 switches. We
> had HSRP configured internally so this won't work.
>
>
>
> If we loose primary box, it would require manual intervention from telco
> to transfer traffic to second box.
>
>
>
> Any thoughts appreciated.
>
>
>
> vpdn enable
>
> no vpdn history failure cause normal
>
> vpdn history failure table-size 50
>
> vpdn ip udp ignore checksum
>
> !
>
> vpdn-group 1
>
> description VPDN-GROUP-1
>
> accept-dialin
>
> protocol l2tp
>
> virtual-template 1
>
> terminate-from hostname telco.domain
>
> source-ip y.y.y.x
>
> lcp renegotiation on-mismatch
>
> l2tp tunnel password password1
>
> !
>
> virtual-template 1 pre-clone 8000
>
> !
>
> !
>
> interface Loopback0
>
> description VPDN Tunnel Endpoint1
>
> ip address x.x.x.y 255.255.255.255
>
> !
>
> !
>
> interface GigabitEthernet0/1
>
> description GigabitEthernet To Telco_Box_1
>
> ip address v.v.v.w 255.255.255.248
>
> standby 222 ip v.v.v.y
>
> standby 222 priority 150
>
> standby 222 preempt
>
> !
>
> !
>
> interface BVI1
>
> description Bridge-group for L2 to Router1-2
>
> ip address a.a.a.b 255.255.255.0
>
> standby 1 ip a.a.a.c
>
> standby 1 priority 150
>
> standby 1 preempt
>
> standby 1 track GigabitEthernet0/1 70
>
> !
>
> router bgp 1234
>
> no synchronization
>
> bgp log-neighbor-changes
>
> network v.v.v.0
>
> network y.y.y.0
>
> network b.b.b.0 mask 255.255.240.0
>
> neighbor v.v.v.a remote-as 5678
>
> neighbor v.v.v.a description Telco_Box_1
>
> no auto-summary
>
>
>
>

_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
RE: DSL resiliency over two 7200's [ In reply to ]
Krzysztof,

Thanks for that.

I researched this and hope the Telco can implement it ok.

Has anyone any thoughts on IP Address pool management, routing and any
other issues introduced when load-sharing across multiple LNS's?

Thanks
Mark

-----Original Message-----
From: Krzysztof Adamski [mailto:k@adamski.org]
Sent: 05 December 2005 16:09
To: Mark Tohill
Cc: cisco-bba@puck.nether.net
Subject: Re: [cisco-bba] DSL resiliency over two 7200's


If the telco uses RADIUS to initiate the L2TP tunnel to your LNS, and
the
LAC supports the cisco VPDN standard then they can specify more then one
IP for the end of the L2TP tunnel. It can be done as a round-robin or
failover.

K

On Mon, 5 Dec 2005, Mark Tohill wrote:

> Hi,
>
>
>
> Has anyone an opinion on the best way to handle the following
scenario?
>
>
>
> Two 7204VXR's (NPE-G1) terminating L2TP tunnels from Telco: Current
> config below. Second box similar.
>
>
>
> Telco suggesting we share inbound DSL sessions over Gig0/1 is shared
> over two boxes. These ports are connected to 2 x 6500 GigE ports
owned
> by telco. Internally we have BVI1 hooked up to redundant L2 switches.
We
> had HSRP configured internally so this won't work.
>
>
>
> If we loose primary box, it would require manual intervention from
telco
> to transfer traffic to second box.
>
>
>
> Any thoughts appreciated.
>
>
>
> vpdn enable
>
> no vpdn history failure cause normal
>
> vpdn history failure table-size 50
>
> vpdn ip udp ignore checksum
>
> !
>
> vpdn-group 1
>
> description VPDN-GROUP-1
>
> accept-dialin
>
> protocol l2tp
>
> virtual-template 1
>
> terminate-from hostname telco.domain
>
> source-ip y.y.y.x
>
> lcp renegotiation on-mismatch
>
> l2tp tunnel password password1
>
> !
>
> virtual-template 1 pre-clone 8000
>
> !
>
> !
>
> interface Loopback0
>
> description VPDN Tunnel Endpoint1
>
> ip address x.x.x.y 255.255.255.255
>
> !
>
> !
>
> interface GigabitEthernet0/1
>
> description GigabitEthernet To Telco_Box_1
>
> ip address v.v.v.w 255.255.255.248
>
> standby 222 ip v.v.v.y
>
> standby 222 priority 150
>
> standby 222 preempt
>
> !
>
> !
>
> interface BVI1
>
> description Bridge-group for L2 to Router1-2
>
> ip address a.a.a.b 255.255.255.0
>
> standby 1 ip a.a.a.c
>
> standby 1 priority 150
>
> standby 1 preempt
>
> standby 1 track GigabitEthernet0/1 70
>
> !
>
> router bgp 1234
>
> no synchronization
>
> bgp log-neighbor-changes
>
> network v.v.v.0
>
> network y.y.y.0
>
> network b.b.b.0 mask 255.255.240.0
>
> neighbor v.v.v.a remote-as 5678
>
> neighbor v.v.v.a description Telco_Box_1
>
> no auto-summary
>
>
>
>


_______________________________________________
cisco-bba mailing list
cisco-bba@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba