Mailing List Archive

[OSSTEST PATCH 1/3] sg-report-flight: Rename "sub" to more descriptive "relevant_flights"
No functional change. We're going to add another WITH...

Signed-off-by: Ian Jackson <iwj@xenproject.org>
---
sg-report-flight | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/sg-report-flight b/sg-report-flight
index fd266586..40a3cc92 100755
--- a/sg-report-flight
+++ b/sg-report-flight
@@ -316,7 +316,8 @@ END
# best option.

my $flightsq= <<END;
- WITH sub AS (
+ WITH
+ relevant_flights AS (
SELECT DISTINCT flight, blessing
FROM flights
$runvars_joins
@@ -328,7 +329,7 @@ $runvars_conds
LIMIT 1000
)
SELECT flight, jobs.status
- FROM sub
+ FROM relevant_flights
$flightsq_jobs_join
WHERE (1=1)
$flightsq_jobcond
--
2.20.1