Mailing List Archive

Extreme 200-series switches
Hi,

These switches are Broadcom FASTPATH based, like Ubiquiti EdgeMAX
switches, however using the edgemax config doesn't quite work. One thing
is you need to use quit instead of exit in clogin - it seems to be
detected as an Extreme switch, but it's not really. If I change this
code (line 841 of clogin r3943 from Debian stretch backports 3.9-1~bpo9+1)

if { [string compare "extreme" "$platform"] } {
send -h "exit\r"
} else {
send -h "quit\r"
}

to send -h "quit\r" then it quits ok, although it then doesn't detect
end of run. I don't really understand the Extreme platform detection,
particularly since ExtremeXOS uses xlogin anyway. Any thoughts on how to
get this model to work?

Thanks,

--
James Andrewartha
Network & Projects Engineer
Christ Church Grammar School
Claremont, Western Australia
Ph. (08) 9442 1757
Mob. 0424 160 877

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Extreme 200-series switches [ In reply to ]
Fri, Mar 01, 2019 at 06:29:23PM +0800, James Andrewartha:
> Hi,
>
> These switches are Broadcom FASTPATH based, like Ubiquiti EdgeMAX
> switches, however using the edgemax config doesn't quite work. One thing
> is you need to use quit instead of exit in clogin - it seems to be
> detected as an Extreme switch, but it's not really. If I change this
> code (line 841 of clogin r3943 from Debian stretch backports 3.9-1~bpo9+1)
>
> if { [string compare "extreme" "$platform"] } {
> send -h "exit\r"
> } else {
> send -h "quit\r"
> }
>
> to send -h "quit\r" then it quits ok, although it then doesn't detect
> end of run. I don't really understand the Extreme platform detection,
> particularly since ExtremeXOS uses xlogin anyway. Any thoughts on how to
> get this model to work?

I can't seem to find an example of the config, just commands. it does
not seem to be like an edgemax, but i could be wrong. Perhaps show us
the equivalent of show config and a login/logout sequence. it seem to
have netconf support too.

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Extreme 200-series switches [ In reply to ]
On 13/03/19 04:42, heasley wrote:
> Fri, Mar 01, 2019 at 06:29:23PM +0800, James Andrewartha:
>> These switches are Broadcom FASTPATH based, like Ubiquiti EdgeMAX
>> switches, however using the edgemax config doesn't quite work. One thing
>> is you need to use quit instead of exit in clogin - it seems to be
>> detected as an Extreme switch, but it's not really. If I change this
>> code (line 841 of clogin r3943 from Debian stretch backports 3.9-1~bpo9+1)
>>
>> if { [string compare "extreme" "$platform"] } {
>> send -h "exit\r"
>> } else {
>> send -h "quit\r"
>> }
>>
>> to send -h "quit\r" then it quits ok, although it then doesn't detect
>> end of run. I don't really understand the Extreme platform detection,
>> particularly since ExtremeXOS uses xlogin anyway. Any thoughts on how to
>> get this model to work?
>
> I can't seem to find an example of the config, just commands. it does
> not seem to be like an edgemax, but i could be wrong. Perhaps show us
> the equivalent of show config and a login/logout sequence. it seem to
> have netconf support too.

Here you go (with a bit of line-wrapping unfortunately). As mentioned,
you have to use quit to disconnect. exit will leave enable but won't
disconnect.

aludra:~# ssh admin@10.40.21.117
admin@10.40.21.117's password:

(dinnovation7) >en

(dinnovation7) #

(dinnovation7) #show version

Switch: 1

System Description............................. Extreme 210-Series 12GE
PoE+, 2 1GbE SFP ports, 1 Fixed AC PSU, L2 Switching, 1.2.3.5, Linux
3.6.5, U-Boot 2012.10-00003-g56c397c (Mar 28 2017 - 15:11:08)
Machine Type................................... Extreme 210-Series 12GE
PoE+, 2 1GbE SFP ports, 1 Fixed AC PSU, L2 Switching
Machine Model.................................. 210-12p-GE2
Serial Number.................................. 1834N-41130
Part Number.................................... 800852-00-07
Maintenance Level.............................. 3
Manufacturer................................... 0xbc00
Burned In MAC Address.......................... 00:04:96:B0:43:20
Software Version............................... 1.2.3.5
Operating System............................... Linux 3.6.5
Network Processing Device...................... BCM53344_A0
Additional Packages............................ FASTPATH QOS
FASTPATH IPv6 Management
FASTPATH Routing
FASTPATH OpEN API

show hardware is the same as show version.

(dinnovation7) #show bootvar

Image Descriptions

active :
backup :


Images currently available on Flash

---- ------------ ------------ ----------------- -----------------
unit active backup current-active next-active
---- ------------ ------------ ----------------- -----------------

1 1.2.3.5 1.2.3.5 1.2.3.5 1.2.3.5

(dinnovation7) #show environment

Temp (C)....................................... 27
Temperature traps range: 0 to 45 degrees (Celsius)

Temperature Sensors:
Unit Sensor Description Temp (C) State Max_Temp (C)
---- ------ ---------------- ---------- --------------
--------------
1 1 LM75 27 Normal 29

Fans:
Unit Fan Description Type Speed Duty level State
---- --- -------------- --------- ------------- ------------- --------------
1 1 Fan-1 Fixed Not Supported Not Supported Operational

Power Modules:
Unit Power supply Description Type State
---- ------------ ---------------- ---------- --------------
1 1 PS-1 Fixed Operational

Disk usage information:
Unit Total space (KB) Free space (KB) Used space (KB)
Utilization (%)
---- ---------------- --------------- ---------------
---------------
1 27,584 25,804 1,780 6


(dinnovation7) #show running-config

!Current Configuration:
!
!System Description "Extreme 210-Series 12GE PoE+, 2 1GbE SFP ports, 1
Fixed AC PSU, L2 Switching, 1.2.3.5, Linux 3.6.5, U-Boot
2012.10-00003-g56c397c (Mar 28 2017 - 15:11:08)"
!System Software Version "1.2.3.5"
!System Up Time "1 days 8 hrs 59 mins 14 secs"
!Additional Packages FASTPATH QOS,FASTPATH IPv6 Management,FASTPATH
Routing
!Current SNTP Synchronized Time: Mar 15 05:50:00 2019 UTC
!
hostname "dinnovation7"
network protocol none
network parms 10.40.21.117 255.255.0.0 10.40.0.1
vlan database
vlan 20,45
vlan name 20 "Staff"
vlan name 45 "NVX"
set igmp 1
set igmp fast-leave 1
exit

ip ssh server enable
no ip telnet server enable
configure
sntp client mode unicast
sntp server "time.contoso.com"
clock timezone 8 minutes 0 zone "AWST"
ip domain name "contoso.com"
ip name server 10.43.0.3 10.43.0.4
logging email
logging email from-addr dinnovation7@contoso.com
logging email message-type urgent to-addr example@contoso.com
mail-server "mail.contoso.com"
security none
username admin
password admin
exit
username "admin" password hashgoeshere level 15 encrypted
line console
exit

line telnet
exit

line ssh
exit

snmp-server sysname "dinnovation7"
snmp-server location "Contoso/D/D232"
snmp-server contact "James Andrewartha <example@contoso.com>"
!
snmp-server user "snmpuser" DefaultRead auth-md5-key hashgoeshere
priv-des-key hashgoeshere
set igmp
set igmp querier

interface 0/1
set igmp
set igmp fast-leave
switchport mode trunk
lldp transmit-tlv port-desc
lldp transmit-tlv sys-name
lldp transmit-tlv sys-desc
lldp transmit-tlv sys-cap
lldp transmit-mgmt
exit

interface 0/2
set igmp
set igmp fast-leave
exit

interface 0/3
set igmp
set igmp fast-leave
switchport mode access
switchport access vlan 45
switchport trunk native vlan 45
no poe
exit

interface 0/4
set igmp
set igmp fast-leave
exit
interface 0/5
set igmp
set igmp fast-leave
switchport mode access
switchport access vlan 45
switchport trunk native vlan 45
no poe
exit

interface 0/6
set igmp
set igmp fast-leave
exit

interface 0/7
set igmp
set igmp fast-leave
exit

interface 0/8
set igmp
set igmp fast-leave
exit

interface 0/9
set igmp
set igmp fast-leave
switchport mode access
switchport access vlan 20
switchport trunk native vlan 20
exit

interface 0/10
set igmp
set igmp fast-leave
exit

interface 0/11
set igmp
set igmp fast-leave
exit

interface 0/12
set igmp
set igmp fast-leave
exit

interface 0/13
set igmp
set igmp fast-leave
exit

interface 0/14
set igmp
set igmp fast-leave
exit

exit

(dinnovation7) #exit

(dinnovation7) >exit
^
% Invalid input detected at '^' marker.

(dinnovation7) >quitConnection to 10.40.21.117 closed.



--
James Andrewartha
Network & Projects Engineer
Christ Church Grammar School
Claremont, Western Australia
Ph. (08) 9442 1757
Mob. 0424 160 877

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Extreme 200-series switches [ In reply to ]
Fri, Mar 15, 2019 at 02:01:43PM +0800, James Andrewartha:
> On 13/03/19 04:42, heasley wrote:
> > Fri, Mar 01, 2019 at 06:29:23PM +0800, James Andrewartha:
> >> These switches are Broadcom FASTPATH based, like Ubiquiti EdgeMAX
> >> switches, however using the edgemax config doesn't quite work. One thing
> >> is you need to use quit instead of exit in clogin - it seems to be
> >> detected as an Extreme switch, but it's not really. If I change this
> >> code (line 841 of clogin r3943 from Debian stretch backports 3.9-1~bpo9+1)
> >>
> >> if { [string compare "extreme" "$platform"] } {
> >> send -h "exit\r"
> >> } else {
> >> send -h "quit\r"
> >> }
> >>
> >> to send -h "quit\r" then it quits ok, although it then doesn't detect
> >> end of run. I don't really understand the Extreme platform detection,
> >> particularly since ExtremeXOS uses xlogin anyway. Any thoughts on how to
> >> get this model to work?
> >
> > I can't seem to find an example of the config, just commands. it does
> > not seem to be like an edgemax, but i could be wrong. Perhaps show us
> > the equivalent of show config and a login/logout sequence. it seem to
> > have netconf support too.
>
> Here you go (with a bit of line-wrapping unfortunately). As mentioned,
> you have to use quit to disconnect. exit will leave enable but won't
> disconnect.
>
> aludra:~# ssh admin@10.40.21.117
> admin@10.40.21.117's password:
...

Perhaps this

Index: bin/clogin.in
===================================================================
--- bin/clogin.in (revision 3966)
+++ bin/clogin.in (working copy)
@@ -452,6 +452,12 @@
send -h "quit\r"
exp_continue;
}
+ -re "^\% Invalid input detected at " {
+ # Broadcom Fastpath based
+ # Extreme 200 series
+ send -h "quit\r"
+ exp_continue;
+ }
"The system has unsaved changes" { # Force10 SFTOS
if {$do_saveconfig} {
catch {send "y\r"}

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Extreme 200-series switches [ In reply to ]
Hi,

On 25/03/19 00:38, heasley wrote:
> Perhaps this
>
> Index: bin/clogin.in
> ===================================================================
> --- bin/clogin.in (revision 3966)
> +++ bin/clogin.in (working copy)
> @@ -452,6 +452,12 @@
> send -h "quit\r"
> exp_continue;
> }
> + -re "^\% Invalid input detected at " {
> + # Broadcom Fastpath based
> + # Extreme 200 series
> + send -h "quit\r"
> + exp_continue;
> + }
> "The system has unsaved changes" { # Force10 SFTOS
> if {$do_saveconfig} {
> catch {send "y\r"}
>

That works a treat, thanks. I haven't yet tested it when there's an
unsaved config change though. Also I'll need to filter out these
changing parts, where in the code is this done in 3.x?

!
- !Temp (C)....................................... 26
+ !Temp (C)....................................... 27
!Temperature traps range: 0 to 45
!Fans:
!Unit Fan Description Type Speed Duty
!---- --- -------------- --------- ------------- -------------
!1 1 Fan-1 Fixed Not
!Power Modules:
!Unit Power supply Description Type State
!---- ------------ ---------------- ---------- --------------
!1 1 PS-1 Fixed Operational
!Disk usage information:
!Unit Total space (KB) Free space
!---- ---------------- --------------- ---------------
---------------
- !1 27,584 25,828 1,756
6
+ !1 27,584 25,784 1,800
6
!

--
James Andrewartha
Network & Projects Engineer
Christ Church Grammar School
Claremont, Western Australia
Ph. (08) 9442 1757
Mob. 0424 160 877

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Extreme 200-series switches [ In reply to ]
heya,
while i don't have extreme devices, the code seems to live in lib/exos.pm.in.

i would guess temperature & diskspace and such could perhaps be gated with the FILTER_OSC setting (see man rancid.conf), fortigate.pm.in has some examples which can get you started.

rancid.pm.in has some helper functions if you want to parse storage usage to human readable form or % space remaining, this can also reduce the amount of diffs you receive for minor changes in free space.


// nick

> -----Original Message-----
> From: Rancid-discuss [mailto:rancid-discuss-bounces@shrubbery.net] On
> Behalf Of James Andrewartha
> Sent: Monday, March 25, 2019 08:12
> To: heasley <heas@shrubbery.net>
> Cc: rancid-discuss@shrubbery.net
> Subject: Re: [rancid] Extreme 200-series switches
>
> Hi,
>
> On 25/03/19 00:38, heasley wrote:
> > Perhaps this
> >
> > Index: bin/clogin.in
> >
> ==========================================================
> =========
> > --- bin/clogin.in(revision 3966)
> > +++ bin/clogin.in(working copy)
> > @@ -452,6 +452,12 @@
> > send -h "quit\r"
> > exp_continue;
> > }
> > +-re "^\% Invalid input detected at "{
> > + # Broadcom Fastpath based
> > + # Extreme 200 series
> > + send -h "quit\r"
> > + exp_continue;
> > +}
> > "The system has unsaved changes"{ # Force10 SFTOS
> > if {$do_saveconfig} {
> > catch {send "y\r"}
> >
>
> That works a treat, thanks. I haven't yet tested it when there's an
> unsaved config change though. Also I'll need to filter out these
> changing parts, where in the code is this done in 3.x?
>
> !
> - !Temp (C)....................................... 26
> + !Temp (C)....................................... 27
> !Temperature traps range: 0 to 45
> !Fans:
> !Unit Fan Description Type Speed Duty
> !---- --- -------------- --------- ------------- -------------
> !1 1 Fan-1 Fixed Not
> !Power Modules:
> !Unit Power supply Description Type State
> !---- ------------ ---------------- ---------- --------------
> !1 1 PS-1 Fixed Operational
> !Disk usage information:
> !Unit Total space (KB) Free space
> !---- ---------------- --------------- ---------------
> ---------------
> - !1 27,584 25,828 1,756
> 6
> + !1 27,584 25,784 1,800
> 6
> !
>
> --
> James Andrewartha
> Network & Projects Engineer
> Christ Church Grammar School
> Claremont, Western Australia
> Ph. (08) 9442 1757
> Mob. 0424 160 877
>
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss@shrubbery.net
> http://www.shrubbery.net/mailman/listinfo/rancid-discuss

________________________________

Volg Aquafin op Facebook<https://www.facebook.com/AquafinNV> | Twitter<https://twitter.com/aquafinnv> | YouTube<http://www.youtube.com/channel/UCk_4P5BJ-MtEEDCkCsR_KqQ?feature=mhee> | LinkedIN<http://www.linkedin.com/company/aquafin/products> | Instagram<https://www.instagram.com/aquafin_nv/>

In het kader van de uitoefening van onze taken verzamelen we bij Aquafin persoonsgegevens. Hoe we omgaan met deze gegevens en wat de rechten van de betrokkenen zijn, kan je nalezen in onze privacy policy<https://www.aquafin.be/nl-be/privacy-policy>.

P Denk aan het milieu. Druk deze mail niet onnodig af.

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss