Mailing List Archive

Rancid and Netgear switches
For a client I suddenly am getting a pile of Netgear switches.

I had previously patched the Dell routines to work with DLink and am starting to do the same for Netgear (it supports a show running_config), but I did not see either much discussion (some in 2008) or any built in support (at least under the name netgear). I know they are not the biggest name in enterprise gear, but they are getting a larger presence all the time.

Is there something out of the box that might work, or is manually fixing up routines the right path?

At the moment I'm continuing to patch the dllogin (etc) so I localize all my patches, if there's a better spot...?

Linwood

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Rancid and Netgear switches [ In reply to ]
If you post a snippet of config, somebody might recognise what ODM makes
the switches.

alexd

On 16/05/18 14:25, on@LEFerguson.com wrote:
> For a client I suddenly am getting a pile of Netgear switches.
>
> I had previously patched the Dell routines to work with DLink and am starting to do the same for Netgear (it supports a show running_config), but I did not see either much discussion (some in 2008) or any built in support (at least under the name netgear). I know they are not the biggest name in enterprise gear, but they are getting a larger presence all the time.
>
> Is there something out of the box that might work, or is manually fixing up routines the right path?
>
> At the moment I'm continuing to patch the dllogin (etc) so I localize all my patches, if there's a better spot...?
>
> Linwood
>
> _______________________________________________
> Rancid-discuss mailing list
> Rancid-discuss@shrubbery.net
> http://www.shrubbery.net/mailman/listinfo/rancid-discuss
>

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Rancid and Netgear switches [ In reply to ]
> If you post a snippet of config, somebody might recognise what ODM makes the switches.

Sure, thanks. The login is

User:
Password:

The not-enabled prompt is the model in parenthesis

(M4100-26G) >

The enable prompt (no password required, at least as we are set up):

(M4100-26G) #

A "terminal length 0" will disable paging or the prompt looks like " --More-- or (q)uit".

The config is exceptionally cisco-like, here's one redacted a bit:

!Current Configuration:
!
!System Description "M4100-26G ProSafe 24-port Gigabit L2+ Intelligent Edge Managed Switch, 10.0.2.26, B1.0.1.1"
!System Software Version "10.0.2.26"
!System Up Time "0 days 15 hrs 57 mins 20 secs"
!Additional Packages QOS,IPv6 Management,Routing
!Current SNTP Synchronized Time: SNTP Client Mode Is Disabled
!
vlan database
vlan 150,153,158,161,163,169-172,192,300,2135,4080-4081
vlan name 150 "stuff"
vlan name 153 "more stuff"
....

no vlan routing 1
vlan routing 192 1
exit

network mgmt_vlan 192
configure
no sntp client mode
sntp server "192.168.1.129"
clock summer-time recurring USA offset 1
time-range
ip name server 192.168.0.1
no ip routing
ip default-gateway 192.168.1.129
username "admin" password stuff level 15 encrypted
line console
serial timeout 15
exit

line telnet
exit

line ssh
exit

snmp-server sysname "something"
snmp-server location "somewhere"
!
snmp-server community "something"
snmp-server community ipaddr 192.168.1.143 something
snmp-server community ipmask 255.255.255.255 something
no snmp-server community public
no snmp-server community private

interface 0/1
description 'Local switch access'
switchport mode access
switchport access vlan 192
switchport trunk allowed vlan 192
vlan participation auto 1
vlan tagging 192
lldp notification
exit

interface 0/2
description 'something'
switchport mode access
switchport access vlan 192
switchport trunk allowed vlan 192
vlan participation auto 1
lldp notification
exit

interface 0/3
description 'something'
switchport mode access
switchport access vlan 192
switchport trunk allowed vlan 192
vlan participation auto 1
lldp notification
exit

.......


interface vlan 192
routing
ip address 192.168.1.210 255.255.255.128
exit

ip management vlan 192
exit

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Rancid and Netgear switches [ In reply to ]
On 16/05/18 14:50, on@LEFerguson.com wrote:
>> If you post a snippet of config, somebody might recognise what ODM makes the switches.
> Sure, thanks. The login is
>
> User:
> Password:
>
> The not-enabled prompt is the model in parenthesis
>
> (M4100-26G) >
>
> The enable prompt (no password required, at least as we are set up):
>
> (M4100-26G) #
>
> A "terminal length 0" will disable paging or the prompt looks like " --More-- or (q)uit".
>
> The config is exceptionally cisco-like, here's one redacted a bit:
>
> !Current Configuration:
> !
> !System Description "M4100-26G ProSafe 24-port Gigabit L2+ Intelligent Edge Managed Switch, 10.0.2.26, B1.0.1.1"
> !System Software Version "10.0.2.26"
> !System Up Time "0 days 15 hrs 57 mins 20 secs"
> !Additional Packages QOS,IPv6 Management,Routing
> !Current SNTP Synchronized Time: SNTP Client Mode Is Disabled
>

Looks a lot like a Ubiquiti EdgeMAX so presumably Ubiquiti and Netgear
are buying the design from the same place.
You're in luck:
#  edgemax.pm - Ubiquity ("UBNT") EdgeMAX switch rancid procedures



alexd

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Rancid and Netgear switches [ In reply to ]
> Looks a lot like a Ubiquiti EdgeMAX so presumably Ubiquiti and Netgear are buying the design from the same place.
> You're in luck:
> # edgemax.pm - Ubiquity ("UBNT") EdgeMAX switch rancid procedures
>

Real close but it uses exit not logout. exit won't actually log off, it just loops forever. Doing a site turn-up now so cannot experiment much more until later today or evening. Not sure if that part is in clogin or the module edgemax.

Thanks, getting closer.

Linwood
_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Rancid and Netgear switches [ In reply to ]
Wed, May 16, 2018 at 05:08:04PM +0000, on@LEFerguson.com:
> > Looks a lot like a Ubiquiti EdgeMAX so presumably Ubiquiti and Netgear are buying the design from the same place.
> > You're in luck:
> > # edgemax.pm - Ubiquity ("UBNT") EdgeMAX switch rancid procedures
> >
>
> Real close but it uses exit not logout. exit won't actually log off, it just loops forever. Doing a site turn-up now so cannot experiment much more until later today or evening. Not sure if that part is in clogin or the module edgemax.
>
> Thanks, getting closer.
>
> Linwood

i'd added this for f5 v13, perhaps something similar would work for ulogin.

Index: bin/clogin.in
===================================================================
--- bin/clogin.in (revision 3786)
+++ bin/clogin.in (working copy)
@@ -440,6 +440,11 @@
send -h "exit\r"
exp_continue;
}
+ -re "^\[^\n\r *]*Use .quit. to end" {
+ # the F5 >=11 uses quit
+ send -h "quit\r"
+ exp_continue;
+ }
"The system has unsaved changes" { # Force10 SFTOS
if {$do_saveconfig} {
catch {send "y\r"}

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss
Re: Rancid and Netgear switches [ In reply to ]
Thanks. I ended up patching the dllogin.pm and dllogin scripts, mostly to localize my changes.

The issue I found that made me do it a bit differently is that it appears these switches are instantly disconnecting, without echoing the logout command or showing a prompt, so I just treat eof as OK if the command completes OK.

I think I have it running, I just did a show config, hopefully everything is really in there.

Appreciate the pointers.

Linwood


-----Original Message-----
From: heasley [mailto:heas@shrubbery.net]
Sent: Wednesday, May 16, 2018 9:14 PM
To: on@LEFerguson.com
Cc: Alex DEKKER <rancid@ale.cx>; rancid-discuss@shrubbery.net
Subject: Re: [rancid] Rancid and Netgear switches

Wed, May 16, 2018 at 05:08:04PM +0000, on@LEFerguson.com:
> > Looks a lot like a Ubiquiti EdgeMAX so presumably Ubiquiti and Netgear are buying the design from the same place.
> > You're in luck:
> > # edgemax.pm - Ubiquity ("UBNT") EdgeMAX switch rancid procedures
> >
>
> Real close but it uses exit not logout. exit won't actually log off, it just loops forever. Doing a site turn-up now so cannot experiment much more until later today or evening. Not sure if that part is in clogin or the module edgemax.
>
> Thanks, getting closer.
>
> Linwood

i'd added this for f5 v13, perhaps something similar would work for ulogin.

Index: bin/clogin.in
===================================================================
--- bin/clogin.in (revision 3786)
+++ bin/clogin.in (working copy)
@@ -440,6 +440,11 @@
send -h "exit\r"
exp_continue;
}
+ -re "^\[^\n\r *]*Use .quit. to end" {
+ # the F5 >=11 uses quit
+ send -h "quit\r"
+ exp_continue;
+ }
"The system has unsaved changes" { # Force10 SFTOS
if {$do_saveconfig} {
catch {send "y\r"}

_______________________________________________
Rancid-discuss mailing list
Rancid-discuss@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/rancid-discuss