Mailing List Archive

ospfd problems
Since I'm trying to get the ospfd ptp working as per the RFC, I
thought I'd better work on the most recent code. Previously I'd
been developing from the CVS snapshot of 2003/08/08.

However, with the config files and ./configure options I was
using then, I can't get OSPF to work with ethernet links
configured "point-to-point" at all -- let alone be able to
test my changes :-(

If I ./configure it without --enable-user=root, then it defaults
to user & group 'quagga', which exists, but when I execute zebra -d,
I get the error message "bind: Address already in use"

On the other hand if I ./configure it with --enable-user=root
--enable-group=root then it runs fine, but OSPF isn't enabled on
the interfaces I've configured as point-to-point :-(

I'm trying to run ospf over ethernet connections that I've
configured as 'point-to-point', by:

# ip addr add aa.bb.cc.dd/32 peer pp.qq.rr.ss/32 dev ethn

With the snapshot taken on 2003-08-08 this works without problem.

With the snapshot taken yesterday (2003-10-16) I cannot get it to
work.

With both codebases, it happily talks over "normal" ethernet
links, but over the point-to-point ones it doesn't even send
hello packets. When I telnet to the ospf daemon and issue the
show ip ospf interface command, it claims that the (point-to-point)
interface is up, but that "OSPF not enabled on this interface".

See the attached "session" for details...

Any ideas on

a) Why I'm getting the bind problem if I don't set the user to root
b) Why it's not working over the ptp link?

Or am I going to have to revert to an older snapshot?

Many thanks

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

# ./configure --disable-ripd --disable-ripngd --disable-bgpd
--enable-nssa --enable-opaque-lsa --enable-ospf-te
...
zebra configuration
-------------------
quagga version : 0.96.4
host operationg system : linux-gnu
source code location : .
compiler : gcc
compiler flags : -g -O2 -Wall
linker flags : -lm -lcrypt
state file directory : /var/run
user to run as : quagga
group to run as : quagga
group for vty sockets :

# make
...

# make install
...

# zebra -d
bind: Address already in use

# cat /etc/passwd
root:x:0:0:root:/root:/bin/bash
...
quagga:x:500:500::/home/quagga:/bin/bash

# make distclean
...

# ./configure --disable-ripd --disable-ripngd --disable-bgpd
--enable-nssa --enable-opaque-lsa --enable-ospf-te
--enable-user=root --enable-group=root
...
zebra configuration
-------------------
quagga version : 0.96.4
host operationg system : linux-gnu
source code location : .
compiler : gcc
compiler flags : -g -O2 -Wall
linker flags : -lm -lcrypt
state file directory : /var/run
user to run as : root
group to run as : root
group for vty sockets :

# make
...

# make install
...

# zebra -d

# ospfd -d

# telnet localhost 2604
ospfd> enable
ospfd# show running-config
Current configuration:
!
hostname ospfd
password zebra
enable password zebra
log stdout
!
!
!
interface dummy0
!
interface eth0
!
interface eth1
!
interface eth2
!
interface eth3
ip ospf network point-to-point
!
interface eth4
!
interface eth5
!
interface lo
!
router ospf
ospf router-id 10.11.28.54
redistribute connected
passive-interface eth0
network 10.11.28.0/24 area 0.0.0.0
network 10.11.32.0/24 area 0.0.0.0
network 10.11.37.54/32 area 0.0.0.0
!
line vty
!
end
ospfd# show ip ospf interface
dummy0 is down
OSPF not enabled on this interface
eth0 is up
OSPF not enabled on this interface
eth1 is up
Internet Address 10.11.28.54/24, Area 0.0.0.0
Router ID 10.11.28.54, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 10.11.28.54, Interface Address 10.11.28.54
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:09
Neighbor Count is 0, Adjacent neighbor count is 0
eth2 is down
OSPF not enabled on this interface
eth3 is up
OSPF not enabled on this interface
eth4 is up
Internet Address 10.11.32.54/24, Area 0.0.0.0
Router ID 10.11.28.54, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 10.11.28.54, Interface Address 10.11.32.54
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:09
Neighbor Count is 0, Adjacent neighbor count is 0
eth5 is down
OSPF not enabled on this interface
lo is up
OSPF not enabled on this interface
ospfd> quit

# ip addr show
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
3: eth1: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 100
link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
inet 10.11.28.54/24 brd 10.11.28.255 scope global eth1
4: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 100
link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
5: eth3: <BROADCAST,MULTICAST,PROMISC,UP> mtu 1500 qdisc pfifo_fast qlen 100
link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
inet 10.11.37.54 peer 10.11.37.64/32 scope global eth3
6: eth4: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 100
link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
inet 10.11.32.54/24 brd 10.11.32.255 scope global eth4
7: eth5: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 100
link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
8: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 100
link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
inet aa.bb.cc.dd/24 brd aa.bb.cc.255 scope global eth0
9: dummy0: <BROADCAST> mtu 1500 qdisc noop
link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

# cat /usr/local/etc/zebra.conf
! zebra configuration file

hostname xxx
password zebra
enable password zebra

! Interfaces
interface lo

interface eth2
shutdown
interface eth5
shutdown
interface dummy0
shutdown
log stdout

# cat /usr/local/etc/ospfd.conf
! OSPFd configuration file

hostname ospfd
password zebra
enable password zebra
!
interface eth0

interface eth3
ip ospf network point-to-point

router ospf
passive-interface eth0
router-id 10.11.28.54
redistribute connected
network 10.11.28.0/24 area 0
network 10.11.32.0/24 area 0
network 10.11.37.54/32 area 0

log stdout

#

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

<M>
--