Mailing List Archive

Why ospf hello packet without Designated Router and Backup Designated Router?
Hi all,
I want to know why ospf hello packet without Designated Router and Backup
Designated Router?

ospf.conf has any setting?

This is our setting

==================================
password zebra
!
access-list vty permit 127.0.0.0/8
access-list vty deny any
!
line vty
access-class vty
!
!
interface br0
ip ospf cost 1
ip ospf priority 1
!
interface usb0
ip ospf cost 10
ip ospf priority 1
!
interface gretunnel
ip ospf cost 10
ip ospf priority 1
!
router ospf
network 192.168.15.0/24 area 0
network 192.168.4.56/30 area 0
network 192.168.3.0/24 area 0
redistribute connected
redistribute kernel
!
log syslog
==================================

Thanks
Re: Why ospf hello packet without Designated Router and Backup Designated Router? [ In reply to ]
On Thu, 23 Mar 2017, ??? wrote:

> Hi all,
> I want to know why ospf hello packet without Designated Router and Backup
> Designated Router?

These are elected on broadcast links, after the exchange of a few
packets. What is the issue you're seeing?

If adjacencies are not forming, double-check your network configuration
- firewalling particularly. If you've written or modified the network
driver, check multicast is working correctly up to user-space.

regards,
--
Paul Jakma | paul@jakma.org | @pjakma | Key ID: 0xD86BF79464A2FF6A
Fortune:
Why are there always boycotts? Shouldn't there be girlcotts too?
-- argon on #Linux
Re: Why ospf hello packet without Designated Router and Backup Designated Router? [ In reply to ]
Hi Pual,
The interface is gre tunnel, I print inet_ntoa (DR (oi)), but I saw 0.0.0.0.

=============================================================
gretunnel is up
ifindex 13, MTU 1476 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP>
Internet Address 192.168.3.1/24, Area 0.0.0.0
MTU mismatch detection:enabled
Router ID 192.168.4.54, Network Type POINTOPOINT, Cost: 10
Transmit Delay is 1 sec, State Point-To-Point, Priority 1
No designated router on this network
No backup designated router on this network
Multicast group memberships: OSPFAllRouters
Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
Hello due in 2.224s
Neighbor Count is 1, Adjacent neighbor count is 1
==============================================================

If the network type is POINTOPOINT to cause Designated Router is 0.0.0.0?
How can I do to let it can work and packet with Designated Router IP.

Thanks

2017-03-23 17:34 GMT+08:00 Paul Jakma <paul@jakma.org>:

> On Thu, 23 Mar 2017, ??? wrote:
>
> Hi all,
>> I want to know why ospf hello packet without Designated Router and Backup
>> Designated Router?
>>
>
> These are elected on broadcast links, after the exchange of a few packets.
> What is the issue you're seeing?
>
> If adjacencies are not forming, double-check your network configuration -
> firewalling particularly. If you've written or modified the network driver,
> check multicast is working correctly up to user-space.
>
> regards,
> --
> Paul Jakma | paul@jakma.org | @pjakma | Key ID: 0xD86BF79464A2FF6A
> Fortune:
> Why are there always boycotts? Shouldn't there be girlcotts too?
> -- argon on #Linux
Re: Why ospf hello packet without Designated Router and Backup Designated Router? [ In reply to ]
On Thu, Mar 23, 2017 at 07:06:11PM +0800, ??? wrote:
> Hi Pual,
> The interface is gre tunnel, I print inet_ntoa (DR (oi)), but I saw 0.0.0.0.
>
> =============================================================
> gretunnel is up
> ifindex 13, MTU 1476 bytes, BW 0 Kbit <UP,POINTOPOINT,RUNNING,NOARP>
> Internet Address 192.168.3.1/24, Area 0.0.0.0
> MTU mismatch detection:enabled
> Router ID 192.168.4.54, Network Type POINTOPOINT, Cost: 10
> Transmit Delay is 1 sec, State Point-To-Point, Priority 1
> No designated router on this network
> No backup designated router on this network
> Multicast group memberships: OSPFAllRouters
> Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
> Hello due in 2.224s
> Neighbor Count is 1, Adjacent neighbor count is 1
> ==============================================================
>
> If the network type is POINTOPOINT to cause Designated Router is 0.0.0.0?
> How can I do to let it can work and packet with Designated Router IP.

By default linux gre tunnels don't do multicast.

Something like this could make it do so:

ip link set gretunnel multicast on

Would have to do that on both ends. To make it permanent would require
puttings something in the network interface config to do that.

--
Len Sorensen

_______________________________________________
Quagga-dev mailing list
Quagga-dev@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-dev
Re: Why ospf hello packet without Designated Router and Backup Designated Router? [ In reply to ]
There are no DR/BDR election on non-broadcast media (i.e. point to
point in this case).
Tracing it to be 0.0.0.0 is just an artefact from when the interface
data structure was initialized (XCALLOC).
If you want (B)DR to be elected, you need to change the network type of
the interface .


Best,
Olivier


On Thu, 2017-03-23 at 09:24 -0400, Lennart Sorensen wrote:
> On Thu, Mar 23, 2017 at 07:06:11PM +0800, ??? wrote:
> > Hi Pual,
> > The interface is gre tunnel, I print inet_ntoa (DR (oi)), but I saw
> > 0.0.0.0.
> >
> > =============================================================
> > gretunnel is up
> >   ifindex 13, MTU 1476 bytes, BW 0 Kbit
> > <UP,POINTOPOINT,RUNNING,NOARP>
> >   Internet Address 192.168.3.1/24, Area 0.0.0.0
> >   MTU mismatch detection:enabled
> >   Router ID 192.168.4.54, Network Type POINTOPOINT, Cost: 10
> >   Transmit Delay is 1 sec, State Point-To-Point, Priority 1
> >   No designated router on this network
> >   No backup designated router on this network
> >   Multicast group memberships: OSPFAllRouters
> >   Timer intervals configured, Hello 10s, Dead 40s, Wait 40s,
> > Retransmit 5
> >     Hello due in 2.224s
> >   Neighbor Count is 1, Adjacent neighbor count is 1
> > ==============================================================
> >
> > If the network type is POINTOPOINT to cause Designated Router is
> > 0.0.0.0?
> > How can I do to let it can work and packet with Designated Router
> > IP.
>
> By default linux gre tunnels don't do multicast.
>
> Something like this could make it do so:
>
> ip link set gretunnel multicast on
>
> Would have to do that on both ends.  To make it permanent would
> require
> puttings something in the network interface config to do that.
>
Re: Why ospf hello packet without Designated Router and Backup Designated Router? [ In reply to ]
On Thu, 23 Mar 2017, Lennart Sorensen wrote:

> By default linux gre tunnels don't do multicast.
>
> Something like this could make it do so:
>
> ip link set gretunnel multicast on
>
> Would have to do that on both ends. To make it permanent would require
> puttings something in the network interface config to do that.

Sounds like a patch for ospfd.texi begging to be written there, on the
gotcha above.

regards,
--
Paul Jakma | paul@jakma.org | @pjakma | Key ID: 0xD86BF79464A2FF6A
Fortune:
A boss with no humor is like a job that's no fun.

_______________________________________________
Quagga-dev mailing list
Quagga-dev@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-dev