Mailing List Archive

solaris x86 perl progress!
dear porters,

thanks for the responses to my email of last week. i took all
the advice i gleaned from your messages, and tried the following:
1. downloaded & installed perl5.001m
2. eliminated the ucb library from the library search
(that was one of my choices to try to fix the
problem i'm having, not the perl default for solaris)
(incidentally, I have a book on solaris admin that
suggests using the ucb library first or only!!??)
3. fixed the duplicate "SP" def by placing an
#undef SP
in the file pp.h at line 15. this is a much nicer fix
than the laborious substitution of another variable,
and works fine, as far as i can tell.

the resulting status is
A. perl passed all of its installation tests, except one
rand() test-- this is the test that failed in
5.001, also, but is probably non-fatal to
most applications. also, it can be "fixed"
by specifying a 15 bit rand() result.
B. the crazy behavior on the set_cpu script persists.
C. the segmentation fault when I tried to execute
one of my other basis scripts has been
replaced by a message that seems
appropriate under the circumstances.

so item (B) is the main remaining foible that I know of.

i'd appreciate your next iteration of ideas on how to debug or
what to try...

bill mead

ps- as far as i'm concerned, i'd prefer it if you made perl5.001m into perl5.002,
since it is better than 5.001 in every way that I can see at this point. i would have wasted
somewhat less time if i'd simply started from 5.001m-- although some of the "wasted"
time was due to confusion created by the complicated installation and the large
number of options.