Mailing List Archive

wrong IP in traceroutes
Hello

Sometimes we get the wrong IP back in traceroutes. Here is an example:

gigabit@kviknet01:~$ mtr -n -r -c3 185.24.168.181
Start: 2021-05-15T14:58:20+0000
HOST: kviknet01.ring.nlnog.net Loss% Snt Last Avg Best Wrst StDev
1.|-- 212.237.176.65 0.0% 3 0.2 0.2 0.2 0.2 0.0
2.|-- 185.107.12.27 0.0% 3 0.5 0.5 0.4 0.5 0.0
3.|-- 45.145.95.250 0.0% 3 0.3 0.3 0.3 0.3 0.0
4.|-- 10.10.123.7 0.0% 3 10.1 12.6 10.1 16.5 3.4
(more hops)

Hop #3 should have been 185.24.168.29. Instead we get 45.145.95.250 which
is unfortunate because that address belongs to a customer and it is not
even within the IP ranges allocated to us. The customer owns his own
address space directly with RIPE.

The interface is this:

admin@gc-edge1# show interfaces ps44
description "Kviknet peering BGP";
anchor-point {
lt-0/0/0;
}
vlan-tagging;
unit 0 {
encapsulation ethernet-vpls;
}
unit 40 {
alias kviknet;
vlan-id 40;
family inet {
address 185.24.168.29/30;
}
family inet6 {
address 2a00:7660:100:26::2/126;
}
}

The IP address from the traceroute is this one:

admin@gc-edge1# show interfaces ps3
anchor-point {
lt-0/0/0;
}
unit 0 {
encapsulation ethernet-ccc;
}
unit 1 {
family inet {
address 45.145.95.250/29;
}
family inet6 {
address 2a00:7660:100:1::2/125;
}
}

The traffic did obviously not go via ps3 as that connects directly to a
single homed customer.

Is this a bug? Can I do something to get a better choice for IP address in
traceroutes? It appears to be linked to the fact this goes via a "ps"
interface.

Thanks,

Baldur
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp