Mailing List Archive

l2circuit between QFX-5110 & MX204 - one way traffic
Hi,

Not sure if I'm "doing the dumb" or Junos bug or limitation of the QFX /
Trident 2+ chip-set.

Trying to do a basic l2circuit as follows

VLAN Tagged Interface > MX204 l2circuit / ldp > QFX-5110 / ldp > QFX-5110
l2circuit / ldp > VLAN Tagged Interface

What I am seeing is traffic going Test Device > QFX-5110 > QFX-5110 > MX204
> Test Device arrives fine.

Return path from Test Device > MX204 > QFX-5110 > QFX-5110 > Test Device is
broken.


Config is as follows

*MX204 Port facing test device on VLAN tag 123*

liam@WN-MX204-1# show interfaces xe-0/1/3
description "WN-PVE-1 C0/F3 enp6s0f1";
flexible-vlan-tagging;
mtu 9216;
encapsulation flexible-ethernet-services;
unit 123 {
encapsulation vlan-ccc;
vlan-id 123;
family ccc;
}

MPLS port facing intermediate / transit QFX (MS)

liam@WN-MX204-1# show interfaces xe-0/1/1
description "OTN MS";
mtu 9216;
unit 0 {
family inet {
address 172.16.130.2/30;
}
family mpls;
}

liam@WN-MX204-1# show interfaces lo0
unit 0 {
family inet {
address 127.0.0.1/32;
address 192.168.68.3/32;
}
}

liam@WN-MX204-1# show protocols l2circuit
neighbor 192.168.68.5 {
interface xe-0/1/3.123 {
virtual-circuit-id 123;
control-word;
encapsulation-type ethernet-vlan;
ignore-mtu-mismatch;
pseudowire-status-tlv;
}
}

liam@WN-MX204-1# show protocols ldp
interface xe-0/1/1.0;
interface lo0.0;

liam@WN-MX204-1# show protocols mpls
path-mtu {
rsvp mtu-signaling;
}
ipv6-tunneling;
icmp-tunneling;
optimize-timer 60;
label-switched-path wn-mx-to-na-qfx-test {
from 192.168.68.3;
to 192.168.68.5;
adaptive;
fast-reroute;
primary anypath;
}
path anypath;
interface xe-0/1/1.0;

liam@WN-MX204-1# show protocols ospf
traffic-engineering;
area 0.0.0.0 {
interface lo0.0 {
passive;
}
interface fxp0.0 {
disable;
}
interface xe-0/1/0.549 {
interface-type p2p;
}
interface xe-0/1/1.0 {
interface-type p2p;
}
}


*Intermediate / transit QFX*, MPLS interface facing MX204

liam@MS-QFX5110-1# show interfaces xe-0/0/1
description "OTN MS-WN";
mtu 9216;
unit 0 {
family inet {
address 172.16.130.1/30;
}
family mpls;
}

Interface facing destination QFX

liam@MS-QFX5110-1# show interfaces xe-0/0/0
description "OTN MS-NA";
mtu 9216;
unit 0 {
family inet {
address 172.16.130.5/30;
}
family mpls;
}

liam@MS-QFX5110-1# show interfaces lo0
unit 0 {
family inet {
address 127.0.0.1/32;
address 192.168.68.6/32;
}
}

liam@MS-QFX5110-1# show protocols ldp
interface xe-0/0/0.0;
interface xe-0/0/1.0;
interface lo0.0;

liam@MS-QFX5110-1# show protocols mpls
path-mtu {
rsvp mtu-signaling;
}
ipv6-tunneling;
icmp-tunneling;
optimize-timer 60;
path anypath;
interface xe-0/0/0.0;
interface xe-0/0/1.0;

liam@MS-QFX5110-1# show protocols ospf
traffic-engineering;
area 0.0.0.0 {
interface lo0.0 {
passive;
}
interface vme.0 {
disable;
}
interface xe-0/0/0.0 {
interface-type p2p;
}
interface xe-0/0/1.0 {
interface-type p2p;
}
}


*Destination QFX / other end of l2circuit*, interfacing test equipment on
vlan 123

liam@NA-QFX5110-1# show interfaces xe-0/0/9
description "Temp Link to Arista";
flexible-vlan-tagging;
mtu 9216;
encapsulation flexible-ethernet-services;
unit 123 {
encapsulation vlan-ccc;
vlan-id 123;
family ccc;
}

Interface facing intermediate / transit QFX

liam@NA-QFX5110-1# show interfaces xe-0/0/1
description "OTN NA-MS";
mtu 9216;
unit 0 {
family inet {
address 172.16.130.6/30;
}
family mpls;
}

liam@NA-QFX5110-1# show interfaces lo0
unit 0 {
family inet {
address 127.0.0.1/32;
address 192.168.68.5/32;
}
}

liam@NA-QFX5110-1# show protocols l2circuit
neighbor 192.168.68.3 {
interface xe-0/0/9.123 {
virtual-circuit-id 123;
control-word;
encapsulation-type ethernet-vlan;
ignore-mtu-mismatch;
pseudowire-status-tlv;
}
}

liam@NA-QFX5110-1# show protocols ldp
interface xe-0/0/1.0;
interface lo0.0;

liam@NA-QFX5110-1# show protocols mpls
path-mtu {
rsvp mtu-signaling;
}
ipv6-tunneling;
icmp-tunneling;
optimize-timer 60;
label-switched-path na-qfx-to-wn-mx-test {
from 192.168.68.5;
to 192.168.68.3;
adaptive;
fast-reroute;
primary anypath;
}
path anypath;
interface xe-0/0/1.0;

liam@NA-QFX5110-1# show protocols ospf
traffic-engineering;
area 0.0.0.0 {
interface lo0.0 {
passive;
}
interface vme.0 {
disable;
}
interface xe-0/0/0.554 {
interface-type p2p;
}
interface xe-0/0/1.0 {
interface-type p2p;
}
}


L2 Circuit is up on the QFX

liam@NA-QFX5110-1> show l2circuit connections
Layer-2 Circuit Connections:

Legend for connection status (St)
EI -- encapsulation invalid NP -- interface h/w not present
MM -- mtu mismatch Dn -- down
EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
CM -- control-word mismatch Up -- operational
VM -- vlan id mismatch CF -- Call admission control failure
OL -- no outgoing label IB -- TDM incompatible bitrate
NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
BK -- Backup Connection ST -- Standby Connection
CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
LD -- local site signaled down RS -- remote site standby
RD -- remote site signaled down HS -- Hot-standby Connection
XX -- unknown

Legend for interface status
Up -- operational
Dn -- down
Neighbor: 192.168.68.3
Interface Type St Time last up # Up trans
xe-0/0/9.123(vc 123) rmt Up Jul 18 21:05:02 2019 1
Remote PE: 192.168.68.3, Negotiated control-word: Yes (Null)
Incoming label: 73, Outgoing label: 95
Negotiated PW status TLV: Yes
local PW status code: 0x00000000, Neighbor PW status code: 0x00000000
Local interface: xe-0/0/9.123, Status: Up, Encapsulation: VLAN
Flow Label Transmit: No, Flow Label Receive: No

L2 Circuit is up on the MX

liam@WN-MX204-1> show l2circuit connections
Layer-2 Circuit Connections:

Legend for connection status (St)
EI -- encapsulation invalid NP -- interface h/w not present
MM -- mtu mismatch Dn -- down
EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
CM -- control-word mismatch Up -- operational
VM -- vlan id mismatch CF -- Call admission control failure
OL -- no outgoing label IB -- TDM incompatible bitrate
NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
BK -- Backup Connection ST -- Standby Connection
CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
LD -- local site signaled down RS -- remote site standby
RD -- remote site signaled down HS -- Hot-standby Connection
XX -- unknown

Legend for interface status
Up -- operational
Dn -- down
Neighbor: 192.168.68.5
Interface Type St Time last up # Up trans
xe-0/1/3.123(vc 123) rmt Up Jul 19 01:03:21 2019 1
Remote PE: 192.168.68.5, Negotiated control-word: Yes (Null)
Incoming label: 95, Outgoing label: 73
Negotiated PW status TLV: Yes
local PW status code: 0x00000000, Neighbor PW status code: 0x00000000
Local interface: xe-0/1/3.123, Status: Up, Encapsulation: VLAN
Flow Label Transmit: No, Flow Label Receive: No


On the* MX end test equipment *I can see the MAC address learned from the *QFX
end test equipment*, however on the *QFX end test equipment* I cannot see
the MAC address of the* MX end test equipment*.

The MX's and QFX's are running Junos: 18.4R1-S3.1

Not sure if I just have this configured wrong, or a QFX chippie limitation
or a Junos bug.

Any help / pointers would be appreciated :)


--
Kind Regards


Liam Farr

Maxum Data
+64-9-950-5302
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
Re: l2circuit between QFX-5110 & MX204 - one way traffic [ In reply to ]
Try below on QFX5110 terminating l2circuit. Last I remember the
flexible-vlan-tagging + flexible-ethernet-services behaves oddly on the
QFX5110.

delete interfaces xe-0/0/9 flexible-vlan-tagging
set interfaces xe-0/0/9 vlan-tagging
set interfaces xe-0/0/9 encapsulation vlan-ccc

Heng Chai, Tan

On 18-07-19 9:48 PM, Liam Farr wrote:
> Hi,
>
> Not sure if I'm "doing the dumb" or Junos bug or limitation of the QFX /
> Trident 2+ chip-set.
>
> Trying to do a basic l2circuit as follows
>
> VLAN Tagged Interface > MX204 l2circuit / ldp > QFX-5110 / ldp > QFX-5110
> l2circuit / ldp > VLAN Tagged Interface
>
> What I am seeing is traffic going Test Device > QFX-5110 > QFX-5110 > MX204
>> Test Device arrives fine.
> Return path from Test Device > MX204 > QFX-5110 > QFX-5110 > Test Device is
> broken.
>
>
> Config is as follows
>
> *MX204 Port facing test device on VLAN tag 123*
>
> liam@WN-MX204-1# show interfaces xe-0/1/3
> description "WN-PVE-1 C0/F3 enp6s0f1";
> flexible-vlan-tagging;
> mtu 9216;
> encapsulation flexible-ethernet-services;
> unit 123 {
> encapsulation vlan-ccc;
> vlan-id 123;
> family ccc;
> }
>
> MPLS port facing intermediate / transit QFX (MS)
>
> liam@WN-MX204-1# show interfaces xe-0/1/1
> description "OTN MS";
> mtu 9216;
> unit 0 {
> family inet {
> address 172.16.130.2/30;
> }
> family mpls;
> }
>
> liam@WN-MX204-1# show interfaces lo0
> unit 0 {
> family inet {
> address 127.0.0.1/32;
> address 192.168.68.3/32;
> }
> }
>
> liam@WN-MX204-1# show protocols l2circuit
> neighbor 192.168.68.5 {
> interface xe-0/1/3.123 {
> virtual-circuit-id 123;
> control-word;
> encapsulation-type ethernet-vlan;
> ignore-mtu-mismatch;
> pseudowire-status-tlv;
> }
> }
>
> liam@WN-MX204-1# show protocols ldp
> interface xe-0/1/1.0;
> interface lo0.0;
>
> liam@WN-MX204-1# show protocols mpls
> path-mtu {
> rsvp mtu-signaling;
> }
> ipv6-tunneling;
> icmp-tunneling;
> optimize-timer 60;
> label-switched-path wn-mx-to-na-qfx-test {
> from 192.168.68.3;
> to 192.168.68.5;
> adaptive;
> fast-reroute;
> primary anypath;
> }
> path anypath;
> interface xe-0/1/1.0;
>
> liam@WN-MX204-1# show protocols ospf
> traffic-engineering;
> area 0.0.0.0 {
> interface lo0.0 {
> passive;
> }
> interface fxp0.0 {
> disable;
> }
> interface xe-0/1/0.549 {
> interface-type p2p;
> }
> interface xe-0/1/1.0 {
> interface-type p2p;
> }
> }
>
>
> *Intermediate / transit QFX*, MPLS interface facing MX204
>
> liam@MS-QFX5110-1# show interfaces xe-0/0/1
> description "OTN MS-WN";
> mtu 9216;
> unit 0 {
> family inet {
> address 172.16.130.1/30;
> }
> family mpls;
> }
>
> Interface facing destination QFX
>
> liam@MS-QFX5110-1# show interfaces xe-0/0/0
> description "OTN MS-NA";
> mtu 9216;
> unit 0 {
> family inet {
> address 172.16.130.5/30;
> }
> family mpls;
> }
>
> liam@MS-QFX5110-1# show interfaces lo0
> unit 0 {
> family inet {
> address 127.0.0.1/32;
> address 192.168.68.6/32;
> }
> }
>
> liam@MS-QFX5110-1# show protocols ldp
> interface xe-0/0/0.0;
> interface xe-0/0/1.0;
> interface lo0.0;
>
> liam@MS-QFX5110-1# show protocols mpls
> path-mtu {
> rsvp mtu-signaling;
> }
> ipv6-tunneling;
> icmp-tunneling;
> optimize-timer 60;
> path anypath;
> interface xe-0/0/0.0;
> interface xe-0/0/1.0;
>
> liam@MS-QFX5110-1# show protocols ospf
> traffic-engineering;
> area 0.0.0.0 {
> interface lo0.0 {
> passive;
> }
> interface vme.0 {
> disable;
> }
> interface xe-0/0/0.0 {
> interface-type p2p;
> }
> interface xe-0/0/1.0 {
> interface-type p2p;
> }
> }
>
>
> *Destination QFX / other end of l2circuit*, interfacing test equipment on
> vlan 123
>
> liam@NA-QFX5110-1# show interfaces xe-0/0/9
> description "Temp Link to Arista";
> flexible-vlan-tagging;
> mtu 9216;
> encapsulation flexible-ethernet-services;
> unit 123 {
> encapsulation vlan-ccc;
> vlan-id 123;
> family ccc;
> }
>
> Interface facing intermediate / transit QFX
>
> liam@NA-QFX5110-1# show interfaces xe-0/0/1
> description "OTN NA-MS";
> mtu 9216;
> unit 0 {
> family inet {
> address 172.16.130.6/30;
> }
> family mpls;
> }
>
> liam@NA-QFX5110-1# show interfaces lo0
> unit 0 {
> family inet {
> address 127.0.0.1/32;
> address 192.168.68.5/32;
> }
> }
>
> liam@NA-QFX5110-1# show protocols l2circuit
> neighbor 192.168.68.3 {
> interface xe-0/0/9.123 {
> virtual-circuit-id 123;
> control-word;
> encapsulation-type ethernet-vlan;
> ignore-mtu-mismatch;
> pseudowire-status-tlv;
> }
> }
>
> liam@NA-QFX5110-1# show protocols ldp
> interface xe-0/0/1.0;
> interface lo0.0;
>
> liam@NA-QFX5110-1# show protocols mpls
> path-mtu {
> rsvp mtu-signaling;
> }
> ipv6-tunneling;
> icmp-tunneling;
> optimize-timer 60;
> label-switched-path na-qfx-to-wn-mx-test {
> from 192.168.68.5;
> to 192.168.68.3;
> adaptive;
> fast-reroute;
> primary anypath;
> }
> path anypath;
> interface xe-0/0/1.0;
>
> liam@NA-QFX5110-1# show protocols ospf
> traffic-engineering;
> area 0.0.0.0 {
> interface lo0.0 {
> passive;
> }
> interface vme.0 {
> disable;
> }
> interface xe-0/0/0.554 {
> interface-type p2p;
> }
> interface xe-0/0/1.0 {
> interface-type p2p;
> }
> }
>
>
> L2 Circuit is up on the QFX
>
> liam@NA-QFX5110-1> show l2circuit connections
> Layer-2 Circuit Connections:
>
> Legend for connection status (St)
> EI -- encapsulation invalid NP -- interface h/w not present
> MM -- mtu mismatch Dn -- down
> EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
> CM -- control-word mismatch Up -- operational
> VM -- vlan id mismatch CF -- Call admission control failure
> OL -- no outgoing label IB -- TDM incompatible bitrate
> NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
> BK -- Backup Connection ST -- Standby Connection
> CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
> LD -- local site signaled down RS -- remote site standby
> RD -- remote site signaled down HS -- Hot-standby Connection
> XX -- unknown
>
> Legend for interface status
> Up -- operational
> Dn -- down
> Neighbor: 192.168.68.3
> Interface Type St Time last up # Up trans
> xe-0/0/9.123(vc 123) rmt Up Jul 18 21:05:02 2019 1
> Remote PE: 192.168.68.3, Negotiated control-word: Yes (Null)
> Incoming label: 73, Outgoing label: 95
> Negotiated PW status TLV: Yes
> local PW status code: 0x00000000, Neighbor PW status code: 0x00000000
> Local interface: xe-0/0/9.123, Status: Up, Encapsulation: VLAN
> Flow Label Transmit: No, Flow Label Receive: No
>
> L2 Circuit is up on the MX
>
> liam@WN-MX204-1> show l2circuit connections
> Layer-2 Circuit Connections:
>
> Legend for connection status (St)
> EI -- encapsulation invalid NP -- interface h/w not present
> MM -- mtu mismatch Dn -- down
> EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
> CM -- control-word mismatch Up -- operational
> VM -- vlan id mismatch CF -- Call admission control failure
> OL -- no outgoing label IB -- TDM incompatible bitrate
> NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
> BK -- Backup Connection ST -- Standby Connection
> CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
> LD -- local site signaled down RS -- remote site standby
> RD -- remote site signaled down HS -- Hot-standby Connection
> XX -- unknown
>
> Legend for interface status
> Up -- operational
> Dn -- down
> Neighbor: 192.168.68.5
> Interface Type St Time last up # Up trans
> xe-0/1/3.123(vc 123) rmt Up Jul 19 01:03:21 2019 1
> Remote PE: 192.168.68.5, Negotiated control-word: Yes (Null)
> Incoming label: 95, Outgoing label: 73
> Negotiated PW status TLV: Yes
> local PW status code: 0x00000000, Neighbor PW status code: 0x00000000
> Local interface: xe-0/1/3.123, Status: Up, Encapsulation: VLAN
> Flow Label Transmit: No, Flow Label Receive: No
>
>
> On the* MX end test equipment *I can see the MAC address learned from the *QFX
> end test equipment*, however on the *QFX end test equipment* I cannot see
> the MAC address of the* MX end test equipment*.
>
> The MX's and QFX's are running Junos: 18.4R1-S3.1
>
> Not sure if I just have this configured wrong, or a QFX chippie limitation
> or a Junos bug.
>
> Any help / pointers would be appreciated :)
>
>

_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
Re: l2circuit between QFX-5110 & MX204 - one way traffic [ In reply to ]
I’m only aware of that being an issue when vlan bridge encapsulation is enabled on the PHY:

https://www.juniper.net/documentation/en_US/junos/topics/reference/general/mpls-limitations-qfx-series.html

(There may, of course, be other cases too that are documented elsewhere)

In any event, this worked for me from a QFX to an ACX:

set interfaces xe-0/0/2 flexible-vlan-tagging
set interfaces xe-0/0/2 encapsulation flexible-ethernet-services
set interfaces xe-0/0/2 unit 11 encapsulation vlan-ccc
set interfaces xe-0/0/2 unit 11 vlan-id 11
set protocols l2circuit neighbor 10.15.48.100 interface xe-0/0/2.11 virtual-circuit-id 1
set protocols l2circuit neighbor 10.15.48.100 interface xe-0/0/2.11 description foo
set protocols l2circuit neighbor 10.15.48.100 interface xe-0/0/2.11 encapsulation-type interworking

(I don’t recall if interworking is actually required here. That could be a relic from a different test, likely port based to VLAN based)

> On Jul 18, 2019, at 10:02 AM, Heng Chai, Tan <hc.tan@sg.gs> wrote:
>
> Try below on QFX5110 terminating l2circuit. Last I remember the flexible-vlan-tagging + flexible-ethernet-services behaves oddly on the QFX5110.
>
> delete interfaces xe-0/0/9 flexible-vlan-tagging
> set interfaces xe-0/0/9 vlan-tagging
> set interfaces xe-0/0/9 encapsulation vlan-ccc
>
> Heng Chai, Tan
>
> On 18-07-19 9:48 PM, Liam Farr wrote:
>> Hi,
>>
>> Not sure if I'm "doing the dumb" or Junos bug or limitation of the QFX /
>> Trident 2+ chip-set.
>>
>> Trying to do a basic l2circuit as follows
>>
>> VLAN Tagged Interface > MX204 l2circuit / ldp > QFX-5110 / ldp > QFX-5110
>> l2circuit / ldp > VLAN Tagged Interface
>>
>> What I am seeing is traffic going Test Device > QFX-5110 > QFX-5110 > MX204
>>> Test Device arrives fine.
>> Return path from Test Device > MX204 > QFX-5110 > QFX-5110 > Test Device is
>> broken.
>>
>>
>> Config is as follows
>>
>> *MX204 Port facing test device on VLAN tag 123*
>>
>> liam@WN-MX204-1# show interfaces xe-0/1/3
>> description "WN-PVE-1 C0/F3 enp6s0f1";
>> flexible-vlan-tagging;
>> mtu 9216;
>> encapsulation flexible-ethernet-services;
>> unit 123 {
>> encapsulation vlan-ccc;
>> vlan-id 123;
>> family ccc;
>> }
>>
>> MPLS port facing intermediate / transit QFX (MS)
>>
>> liam@WN-MX204-1# show interfaces xe-0/1/1
>> description "OTN MS";
>> mtu 9216;
>> unit 0 {
>> family inet {
>> address 172.16.130.2/30;
>> }
>> family mpls;
>> }
>>
>> liam@WN-MX204-1# show interfaces lo0
>> unit 0 {
>> family inet {
>> address 127.0.0.1/32;
>> address 192.168.68.3/32;
>> }
>> }
>>
>> liam@WN-MX204-1# show protocols l2circuit
>> neighbor 192.168.68.5 {
>> interface xe-0/1/3.123 {
>> virtual-circuit-id 123;
>> control-word;
>> encapsulation-type ethernet-vlan;
>> ignore-mtu-mismatch;
>> pseudowire-status-tlv;
>> }
>> }
>>
>> liam@WN-MX204-1# show protocols ldp
>> interface xe-0/1/1.0;
>> interface lo0.0;
>>
>> liam@WN-MX204-1# show protocols mpls
>> path-mtu {
>> rsvp mtu-signaling;
>> }
>> ipv6-tunneling;
>> icmp-tunneling;
>> optimize-timer 60;
>> label-switched-path wn-mx-to-na-qfx-test {
>> from 192.168.68.3;
>> to 192.168.68.5;
>> adaptive;
>> fast-reroute;
>> primary anypath;
>> }
>> path anypath;
>> interface xe-0/1/1.0;
>>
>> liam@WN-MX204-1# show protocols ospf
>> traffic-engineering;
>> area 0.0.0.0 {
>> interface lo0.0 {
>> passive;
>> }
>> interface fxp0.0 {
>> disable;
>> }
>> interface xe-0/1/0.549 {
>> interface-type p2p;
>> }
>> interface xe-0/1/1.0 {
>> interface-type p2p;
>> }
>> }
>>
>>
>> *Intermediate / transit QFX*, MPLS interface facing MX204
>>
>> liam@MS-QFX5110-1# show interfaces xe-0/0/1
>> description "OTN MS-WN";
>> mtu 9216;
>> unit 0 {
>> family inet {
>> address 172.16.130.1/30;
>> }
>> family mpls;
>> }
>>
>> Interface facing destination QFX
>>
>> liam@MS-QFX5110-1# show interfaces xe-0/0/0
>> description "OTN MS-NA";
>> mtu 9216;
>> unit 0 {
>> family inet {
>> address 172.16.130.5/30;
>> }
>> family mpls;
>> }
>>
>> liam@MS-QFX5110-1# show interfaces lo0
>> unit 0 {
>> family inet {
>> address 127.0.0.1/32;
>> address 192.168.68.6/32;
>> }
>> }
>>
>> liam@MS-QFX5110-1# show protocols ldp
>> interface xe-0/0/0.0;
>> interface xe-0/0/1.0;
>> interface lo0.0;
>>
>> liam@MS-QFX5110-1# show protocols mpls
>> path-mtu {
>> rsvp mtu-signaling;
>> }
>> ipv6-tunneling;
>> icmp-tunneling;
>> optimize-timer 60;
>> path anypath;
>> interface xe-0/0/0.0;
>> interface xe-0/0/1.0;
>>
>> liam@MS-QFX5110-1# show protocols ospf
>> traffic-engineering;
>> area 0.0.0.0 {
>> interface lo0.0 {
>> passive;
>> }
>> interface vme.0 {
>> disable;
>> }
>> interface xe-0/0/0.0 {
>> interface-type p2p;
>> }
>> interface xe-0/0/1.0 {
>> interface-type p2p;
>> }
>> }
>>
>>
>> *Destination QFX / other end of l2circuit*, interfacing test equipment on
>> vlan 123
>>
>> liam@NA-QFX5110-1# show interfaces xe-0/0/9
>> description "Temp Link to Arista";
>> flexible-vlan-tagging;
>> mtu 9216;
>> encapsulation flexible-ethernet-services;
>> unit 123 {
>> encapsulation vlan-ccc;
>> vlan-id 123;
>> family ccc;
>> }
>>
>> Interface facing intermediate / transit QFX
>>
>> liam@NA-QFX5110-1# show interfaces xe-0/0/1
>> description "OTN NA-MS";
>> mtu 9216;
>> unit 0 {
>> family inet {
>> address 172.16.130.6/30;
>> }
>> family mpls;
>> }
>>
>> liam@NA-QFX5110-1# show interfaces lo0
>> unit 0 {
>> family inet {
>> address 127.0.0.1/32;
>> address 192.168.68.5/32;
>> }
>> }
>>
>> liam@NA-QFX5110-1# show protocols l2circuit
>> neighbor 192.168.68.3 {
>> interface xe-0/0/9.123 {
>> virtual-circuit-id 123;
>> control-word;
>> encapsulation-type ethernet-vlan;
>> ignore-mtu-mismatch;
>> pseudowire-status-tlv;
>> }
>> }
>>
>> liam@NA-QFX5110-1# show protocols ldp
>> interface xe-0/0/1.0;
>> interface lo0.0;
>>
>> liam@NA-QFX5110-1# show protocols mpls
>> path-mtu {
>> rsvp mtu-signaling;
>> }
>> ipv6-tunneling;
>> icmp-tunneling;
>> optimize-timer 60;
>> label-switched-path na-qfx-to-wn-mx-test {
>> from 192.168.68.5;
>> to 192.168.68.3;
>> adaptive;
>> fast-reroute;
>> primary anypath;
>> }
>> path anypath;
>> interface xe-0/0/1.0;
>>
>> liam@NA-QFX5110-1# show protocols ospf
>> traffic-engineering;
>> area 0.0.0.0 {
>> interface lo0.0 {
>> passive;
>> }
>> interface vme.0 {
>> disable;
>> }
>> interface xe-0/0/0.554 {
>> interface-type p2p;
>> }
>> interface xe-0/0/1.0 {
>> interface-type p2p;
>> }
>> }
>>
>>
>> L2 Circuit is up on the QFX
>>
>> liam@NA-QFX5110-1> show l2circuit connections
>> Layer-2 Circuit Connections:
>>
>> Legend for connection status (St)
>> EI -- encapsulation invalid NP -- interface h/w not present
>> MM -- mtu mismatch Dn -- down
>> EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
>> CM -- control-word mismatch Up -- operational
>> VM -- vlan id mismatch CF -- Call admission control failure
>> OL -- no outgoing label IB -- TDM incompatible bitrate
>> NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
>> BK -- Backup Connection ST -- Standby Connection
>> CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
>> LD -- local site signaled down RS -- remote site standby
>> RD -- remote site signaled down HS -- Hot-standby Connection
>> XX -- unknown
>>
>> Legend for interface status
>> Up -- operational
>> Dn -- down
>> Neighbor: 192.168.68.3
>> Interface Type St Time last up # Up trans
>> xe-0/0/9.123(vc 123) rmt Up Jul 18 21:05:02 2019 1
>> Remote PE: 192.168.68.3, Negotiated control-word: Yes (Null)
>> Incoming label: 73, Outgoing label: 95
>> Negotiated PW status TLV: Yes
>> local PW status code: 0x00000000, Neighbor PW status code: 0x00000000
>> Local interface: xe-0/0/9.123, Status: Up, Encapsulation: VLAN
>> Flow Label Transmit: No, Flow Label Receive: No
>>
>> L2 Circuit is up on the MX
>>
>> liam@WN-MX204-1> show l2circuit connections
>> Layer-2 Circuit Connections:
>>
>> Legend for connection status (St)
>> EI -- encapsulation invalid NP -- interface h/w not present
>> MM -- mtu mismatch Dn -- down
>> EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
>> CM -- control-word mismatch Up -- operational
>> VM -- vlan id mismatch CF -- Call admission control failure
>> OL -- no outgoing label IB -- TDM incompatible bitrate
>> NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
>> BK -- Backup Connection ST -- Standby Connection
>> CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
>> LD -- local site signaled down RS -- remote site standby
>> RD -- remote site signaled down HS -- Hot-standby Connection
>> XX -- unknown
>>
>> Legend for interface status
>> Up -- operational
>> Dn -- down
>> Neighbor: 192.168.68.5
>> Interface Type St Time last up # Up trans
>> xe-0/1/3.123(vc 123) rmt Up Jul 19 01:03:21 2019 1
>> Remote PE: 192.168.68.5, Negotiated control-word: Yes (Null)
>> Incoming label: 95, Outgoing label: 73
>> Negotiated PW status TLV: Yes
>> local PW status code: 0x00000000, Neighbor PW status code: 0x00000000
>> Local interface: xe-0/1/3.123, Status: Up, Encapsulation: VLAN
>> Flow Label Transmit: No, Flow Label Receive: No
>>
>>
>> On the* MX end test equipment *I can see the MAC address learned from the *QFX
>> end test equipment*, however on the *QFX end test equipment* I cannot see
>> the MAC address of the* MX end test equipment*.
>>
>> The MX's and QFX's are running Junos: 18.4R1-S3.1
>>
>> Not sure if I just have this configured wrong, or a QFX chippie limitation
>> or a Junos bug.
>>
>> Any help / pointers would be appreciated :)
>>
>>
>
> _______________________________________________
> juniper-nsp mailing list juniper-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp

_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
Re: l2circuit between QFX-5110 & MX204 - one way traffic [ In reply to ]
    Here is an production version (thx Phil) but on QFX-5100 and MX960
(and MX104 before).

    This works for about 200ish circuits so far...

    We had a bunch of issue with those which can lead to unresponsive
interface...  So depending on your situation you may have to reboot the
switch :(

xe-<snip> {
    description <snip>
    flexible-vlan-tagging;
    mtu 9216;
    encapsulation flexible-ethernet-services;
    unit 123 {
        description <snip>
        encapsulation vlan-ccc;
        no-traps;
        vlan-id 123;
        input-vlan-map pop;
        output-vlan-map push;
    }
....
    interface xe-<snip>.123 {
        virtual-circuit-id 123456;
        description <snip>
        no-control-word;
        mtu 9000;
    }

-----
Alain Hebertahebert@pubnix.net
PubNIX Inc.
50 boul. St-Charles
P.O. Box 26770 Beaconsfield, Quebec H9W 6G7
Tel: 514-990-5911http://www.pubnix.net Fax: 514-990-9443

On 2019-07-18 10:02, Heng Chai, Tan wrote:
> Try below on QFX5110 terminating l2circuit. Last I remember the
> flexible-vlan-tagging + flexible-ethernet-services behaves oddly on
> the QFX5110.
>
> delete interfaces xe-0/0/9 flexible-vlan-tagging
> set interfaces xe-0/0/9 vlan-tagging
> set interfaces xe-0/0/9 encapsulation vlan-ccc
>
> Heng Chai, Tan
>
> On 18-07-19 9:48 PM, Liam Farr wrote:
>> Hi,
>>
>> Not sure if I'm "doing the dumb" or Junos bug or limitation of the QFX /
>> Trident 2+ chip-set.
>>
>> Trying to do a basic l2circuit as follows
>>
>> VLAN Tagged Interface > MX204 l2circuit / ldp > QFX-5110 / ldp >
>> QFX-5110
>> l2circuit / ldp > VLAN Tagged Interface
>>
>> What I am seeing is traffic going Test Device > QFX-5110 > QFX-5110 >
>> MX204
>>> Test Device arrives fine.
>> Return path from Test Device > MX204 > QFX-5110 > QFX-5110 > Test
>> Device is
>> broken.
>>
>>
>> Config is as follows
>>
>> *MX204 Port facing test device on VLAN tag 123*
>>
>> liam@WN-MX204-1# show interfaces xe-0/1/3
>> description "WN-PVE-1 C0/F3 enp6s0f1";
>> flexible-vlan-tagging;
>> mtu 9216;
>> encapsulation flexible-ethernet-services;
>> unit 123 {
>>      encapsulation vlan-ccc;
>>      vlan-id 123;
>>      family ccc;
>> }
>>
>> MPLS port facing intermediate / transit QFX (MS)
>>
>> liam@WN-MX204-1# show interfaces xe-0/1/1
>> description "OTN MS";
>> mtu 9216;
>> unit 0 {
>>      family inet {
>>          address 172.16.130.2/30;
>>      }
>>      family mpls;
>> }
>>
>> liam@WN-MX204-1# show interfaces lo0
>> unit 0 {
>>      family inet {
>>          address 127.0.0.1/32;
>>          address 192.168.68.3/32;
>>      }
>> }
>>
>> liam@WN-MX204-1# show protocols l2circuit
>> neighbor 192.168.68.5 {
>>      interface xe-0/1/3.123 {
>>          virtual-circuit-id 123;
>>          control-word;
>>          encapsulation-type ethernet-vlan;
>>          ignore-mtu-mismatch;
>>          pseudowire-status-tlv;
>>      }
>> }
>>
>> liam@WN-MX204-1# show protocols ldp
>> interface xe-0/1/1.0;
>> interface lo0.0;
>>
>> liam@WN-MX204-1# show protocols mpls
>> path-mtu {
>>      rsvp mtu-signaling;
>> }
>> ipv6-tunneling;
>> icmp-tunneling;
>> optimize-timer 60;
>> label-switched-path wn-mx-to-na-qfx-test {
>>      from 192.168.68.3;
>>      to 192.168.68.5;
>>      adaptive;
>>      fast-reroute;
>>      primary anypath;
>> }
>> path anypath;
>> interface xe-0/1/1.0;
>>
>> liam@WN-MX204-1# show protocols ospf
>> traffic-engineering;
>> area 0.0.0.0 {
>>      interface lo0.0 {
>>          passive;
>>      }
>>      interface fxp0.0 {
>>          disable;
>>      }
>>      interface xe-0/1/0.549 {
>>          interface-type p2p;
>>      }
>>      interface xe-0/1/1.0 {
>>          interface-type p2p;
>>      }
>> }
>>
>>
>> *Intermediate / transit QFX*, MPLS interface facing MX204
>>
>> liam@MS-QFX5110-1# show interfaces xe-0/0/1
>> description "OTN MS-WN";
>> mtu 9216;
>> unit 0 {
>>      family inet {
>>          address 172.16.130.1/30;
>>      }
>>      family mpls;
>> }
>>
>> Interface facing destination QFX
>>
>> liam@MS-QFX5110-1# show interfaces xe-0/0/0
>> description "OTN MS-NA";
>> mtu 9216;
>> unit 0 {
>>      family inet {
>>          address 172.16.130.5/30;
>>      }
>>      family mpls;
>> }
>>
>> liam@MS-QFX5110-1# show interfaces lo0
>> unit 0 {
>>      family inet {
>>          address 127.0.0.1/32;
>>          address 192.168.68.6/32;
>>      }
>> }
>>
>> liam@MS-QFX5110-1# show protocols ldp
>> interface xe-0/0/0.0;
>> interface xe-0/0/1.0;
>> interface lo0.0;
>>
>> liam@MS-QFX5110-1# show protocols mpls
>> path-mtu {
>>      rsvp mtu-signaling;
>> }
>> ipv6-tunneling;
>> icmp-tunneling;
>> optimize-timer 60;
>> path anypath;
>> interface xe-0/0/0.0;
>> interface xe-0/0/1.0;
>>
>> liam@MS-QFX5110-1# show protocols ospf
>> traffic-engineering;
>> area 0.0.0.0 {
>>      interface lo0.0 {
>>          passive;
>>      }
>>      interface vme.0 {
>>          disable;
>>      }
>>      interface xe-0/0/0.0 {
>>          interface-type p2p;
>>      }
>>      interface xe-0/0/1.0 {
>>          interface-type p2p;
>>      }
>> }
>>
>>
>> *Destination QFX / other end of l2circuit*, interfacing test
>> equipment on
>> vlan 123
>>
>> liam@NA-QFX5110-1# show interfaces xe-0/0/9
>> description "Temp Link to Arista";
>> flexible-vlan-tagging;
>> mtu 9216;
>> encapsulation flexible-ethernet-services;
>> unit 123 {
>>      encapsulation vlan-ccc;
>>      vlan-id 123;
>>      family ccc;
>> }
>>
>> Interface facing intermediate / transit QFX
>>
>> liam@NA-QFX5110-1# show interfaces xe-0/0/1
>> description "OTN NA-MS";
>> mtu 9216;
>> unit 0 {
>>      family inet {
>>          address 172.16.130.6/30;
>>      }
>>      family mpls;
>> }
>>
>> liam@NA-QFX5110-1# show interfaces lo0
>> unit 0 {
>>      family inet {
>>          address 127.0.0.1/32;
>>          address 192.168.68.5/32;
>>      }
>> }
>>
>> liam@NA-QFX5110-1# show protocols l2circuit
>> neighbor 192.168.68.3 {
>>      interface xe-0/0/9.123 {
>>          virtual-circuit-id 123;
>>          control-word;
>>          encapsulation-type ethernet-vlan;
>>          ignore-mtu-mismatch;
>>          pseudowire-status-tlv;
>>      }
>> }
>>
>> liam@NA-QFX5110-1# show protocols ldp
>> interface xe-0/0/1.0;
>> interface lo0.0;
>>
>> liam@NA-QFX5110-1# show protocols mpls
>> path-mtu {
>>      rsvp mtu-signaling;
>> }
>> ipv6-tunneling;
>> icmp-tunneling;
>> optimize-timer 60;
>> label-switched-path na-qfx-to-wn-mx-test {
>>      from 192.168.68.5;
>>      to 192.168.68.3;
>>      adaptive;
>>      fast-reroute;
>>      primary anypath;
>> }
>> path anypath;
>> interface xe-0/0/1.0;
>>
>> liam@NA-QFX5110-1# show protocols ospf
>> traffic-engineering;
>> area 0.0.0.0 {
>>      interface lo0.0 {
>>          passive;
>>      }
>>      interface vme.0 {
>>          disable;
>>      }
>>      interface xe-0/0/0.554 {
>>          interface-type p2p;
>>      }
>>      interface xe-0/0/1.0 {
>>          interface-type p2p;
>>      }
>> }
>>
>>
>> L2 Circuit is up on the QFX
>>
>> liam@NA-QFX5110-1> show l2circuit connections
>> Layer-2 Circuit Connections:
>>
>> Legend for connection status (St)
>> EI -- encapsulation invalid      NP -- interface h/w not present
>> MM -- mtu mismatch               Dn -- down
>> EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down
>> CM -- control-word mismatch      Up -- operational
>> VM -- vlan id mismatch           CF -- Call admission control failure
>> OL -- no outgoing label          IB -- TDM incompatible bitrate
>> NC -- intf encaps not CCC/TCC    TM -- TDM misconfiguration
>> BK -- Backup Connection          ST -- Standby Connection
>> CB -- rcvd cell-bundle size bad  SP -- Static Pseudowire
>> LD -- local site signaled down   RS -- remote site standby
>> RD -- remote site signaled down  HS -- Hot-standby Connection
>> XX -- unknown
>>
>> Legend for interface status
>> Up -- operational
>> Dn -- down
>> Neighbor: 192.168.68.3
>>      Interface                 Type  St     Time last up          #
>> Up trans
>>      xe-0/0/9.123(vc 123)      rmt   Up     Jul 18 21:05:02
>> 2019           1
>>        Remote PE: 192.168.68.3, Negotiated control-word: Yes (Null)
>>        Incoming label: 73, Outgoing label: 95
>>        Negotiated PW status TLV: Yes
>>        local PW status code: 0x00000000, Neighbor PW status code:
>> 0x00000000
>>        Local interface: xe-0/0/9.123, Status: Up, Encapsulation: VLAN
>>        Flow Label Transmit: No, Flow Label Receive: No
>>
>> L2 Circuit is up on the MX
>>
>> liam@WN-MX204-1> show l2circuit connections
>> Layer-2 Circuit Connections:
>>
>> Legend for connection status (St)
>> EI -- encapsulation invalid      NP -- interface h/w not present
>> MM -- mtu mismatch               Dn -- down
>> EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down
>> CM -- control-word mismatch      Up -- operational
>> VM -- vlan id mismatch           CF -- Call admission control failure
>> OL -- no outgoing label          IB -- TDM incompatible bitrate
>> NC -- intf encaps not CCC/TCC    TM -- TDM misconfiguration
>> BK -- Backup Connection          ST -- Standby Connection
>> CB -- rcvd cell-bundle size bad  SP -- Static Pseudowire
>> LD -- local site signaled down   RS -- remote site standby
>> RD -- remote site signaled down  HS -- Hot-standby Connection
>> XX -- unknown
>>
>> Legend for interface status
>> Up -- operational
>> Dn -- down
>> Neighbor: 192.168.68.5
>>      Interface                 Type  St     Time last up          #
>> Up trans
>>      xe-0/1/3.123(vc 123)      rmt   Up     Jul 19 01:03:21
>> 2019           1
>>        Remote PE: 192.168.68.5, Negotiated control-word: Yes (Null)
>>        Incoming label: 95, Outgoing label: 73
>>        Negotiated PW status TLV: Yes
>>        local PW status code: 0x00000000, Neighbor PW status code:
>> 0x00000000
>>        Local interface: xe-0/1/3.123, Status: Up, Encapsulation: VLAN
>>        Flow Label Transmit: No, Flow Label Receive: No
>>
>>
>> On the* MX end test equipment *I can see the MAC address learned from
>> the *QFX
>> end test equipment*, however on the *QFX end test equipment* I cannot
>> see
>> the MAC address of the* MX end  test equipment*.
>>
>> The MX's and QFX's are running Junos: 18.4R1-S3.1
>>
>> Not sure if I just have this configured wrong, or a QFX chippie
>> limitation
>> or a Junos bug.
>>
>> Any help / pointers would be appreciated :)
>>
>>
>
> _______________________________________________
> juniper-nsp mailing list juniper-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
>

_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
Re: l2circuit between QFX-5110 & MX204 - one way traffic [ In reply to ]
Hi,

That removed my ability to run bridge interfaces on xe-0/0/9, which might
cause me some design issues further down the track for production
deployments.

Applied this config, but same result.

liam@NA-QFX5110-1# show interfaces xe-0/0/9
description "Temp Link to Arista";
vlan-tagging;
mtu 9216;
encapsulation vlan-ccc;
unit 123 {
encapsulation vlan-ccc;
vlan-id 123;
family ccc;
}


On the MX end I can learn both MAC's, the NA/QFX test equip and the
WN/MX204 test equip (I have a HV connected to the QFX end for testing
running OVS and a test router VM).

root@WLG-PVE-1:~# ovs-appctl fdb/show vmbr0 | grep 123
4 123 36:06:b7:37:b4:63 0
5 123 6c:3b:6b:f0:9b:0f 0
root@WLG-PVE-1:~#


But on the QFX end I'm not learning any mac back out the interface facing
the l2tunnel (should be learning a mac on Et9 from the MX side, but only
learning a mac on Et4 which is the QFX test device).

NA-ARISTA#show vlan 123
VLAN Name Status Ports
----- -------------------------------- ---------
-------------------------------
123 VLAN0123 active Et4, Et9
NA-ARISTA#show mac address-table vlan 123
Mac Address Table
------------------------------------------------------------------

Vlan Mac Address Type Ports Moves Last Move
---- ----------- ---- ----- ----- ---------
123 6c3b.6bf0.9b0f DYNAMIC Et4 1 8:18:08 ago
Total Mac Addresses for this criterion: 1

Multicast Mac Address Table
------------------------------------------------------------------

Vlan Mac Address Type Ports
---- ----------- ---- -----
Total Mac Addresses for this criterion: 0


On Fri, 19 Jul 2019 at 02:02, Heng Chai, Tan <hc.tan@sg.gs> wrote:

> Try below on QFX5110 terminating l2circuit. Last I remember the
> flexible-vlan-tagging + flexible-ethernet-services behaves oddly on the
> QFX5110.
>
> delete interfaces xe-0/0/9 flexible-vlan-tagging
> set interfaces xe-0/0/9 vlan-tagging
> set interfaces xe-0/0/9 encapsulation vlan-ccc
>
> Heng Chai, Tan
>
> On 18-07-19 9:48 PM, Liam Farr wrote:
> > Hi,
> >
> > Not sure if I'm "doing the dumb" or Junos bug or limitation of the QFX /
> > Trident 2+ chip-set.
> >
> > Trying to do a basic l2circuit as follows
> >
> > VLAN Tagged Interface > MX204 l2circuit / ldp > QFX-5110 / ldp > QFX-5110
> > l2circuit / ldp > VLAN Tagged Interface
> >
> > What I am seeing is traffic going Test Device > QFX-5110 > QFX-5110 >
> MX204
> >> Test Device arrives fine.
> > Return path from Test Device > MX204 > QFX-5110 > QFX-5110 > Test Device
> is
> > broken.
> >
> >
> > Config is as follows
> >
> > *MX204 Port facing test device on VLAN tag 123*
> >
> > liam@WN-MX204-1# show interfaces xe-0/1/3
> > description "WN-PVE-1 C0/F3 enp6s0f1";
> > flexible-vlan-tagging;
> > mtu 9216;
> > encapsulation flexible-ethernet-services;
> > unit 123 {
> > encapsulation vlan-ccc;
> > vlan-id 123;
> > family ccc;
> > }
> >
> > MPLS port facing intermediate / transit QFX (MS)
> >
> > liam@WN-MX204-1# show interfaces xe-0/1/1
> > description "OTN MS";
> > mtu 9216;
> > unit 0 {
> > family inet {
> > address 172.16.130.2/30;
> > }
> > family mpls;
> > }
> >
> > liam@WN-MX204-1# show interfaces lo0
> > unit 0 {
> > family inet {
> > address 127.0.0.1/32;
> > address 192.168.68.3/32;
> > }
> > }
> >
> > liam@WN-MX204-1# show protocols l2circuit
> > neighbor 192.168.68.5 {
> > interface xe-0/1/3.123 {
> > virtual-circuit-id 123;
> > control-word;
> > encapsulation-type ethernet-vlan;
> > ignore-mtu-mismatch;
> > pseudowire-status-tlv;
> > }
> > }
> >
> > liam@WN-MX204-1# show protocols ldp
> > interface xe-0/1/1.0;
> > interface lo0.0;
> >
> > liam@WN-MX204-1# show protocols mpls
> > path-mtu {
> > rsvp mtu-signaling;
> > }
> > ipv6-tunneling;
> > icmp-tunneling;
> > optimize-timer 60;
> > label-switched-path wn-mx-to-na-qfx-test {
> > from 192.168.68.3;
> > to 192.168.68.5;
> > adaptive;
> > fast-reroute;
> > primary anypath;
> > }
> > path anypath;
> > interface xe-0/1/1.0;
> >
> > liam@WN-MX204-1# show protocols ospf
> > traffic-engineering;
> > area 0.0.0.0 {
> > interface lo0.0 {
> > passive;
> > }
> > interface fxp0.0 {
> > disable;
> > }
> > interface xe-0/1/0.549 {
> > interface-type p2p;
> > }
> > interface xe-0/1/1.0 {
> > interface-type p2p;
> > }
> > }
> >
> >
> > *Intermediate / transit QFX*, MPLS interface facing MX204
> >
> > liam@MS-QFX5110-1# show interfaces xe-0/0/1
> > description "OTN MS-WN";
> > mtu 9216;
> > unit 0 {
> > family inet {
> > address 172.16.130.1/30;
> > }
> > family mpls;
> > }
> >
> > Interface facing destination QFX
> >
> > liam@MS-QFX5110-1# show interfaces xe-0/0/0
> > description "OTN MS-NA";
> > mtu 9216;
> > unit 0 {
> > family inet {
> > address 172.16.130.5/30;
> > }
> > family mpls;
> > }
> >
> > liam@MS-QFX5110-1# show interfaces lo0
> > unit 0 {
> > family inet {
> > address 127.0.0.1/32;
> > address 192.168.68.6/32;
> > }
> > }
> >
> > liam@MS-QFX5110-1# show protocols ldp
> > interface xe-0/0/0.0;
> > interface xe-0/0/1.0;
> > interface lo0.0;
> >
> > liam@MS-QFX5110-1# show protocols mpls
> > path-mtu {
> > rsvp mtu-signaling;
> > }
> > ipv6-tunneling;
> > icmp-tunneling;
> > optimize-timer 60;
> > path anypath;
> > interface xe-0/0/0.0;
> > interface xe-0/0/1.0;
> >
> > liam@MS-QFX5110-1# show protocols ospf
> > traffic-engineering;
> > area 0.0.0.0 {
> > interface lo0.0 {
> > passive;
> > }
> > interface vme.0 {
> > disable;
> > }
> > interface xe-0/0/0.0 {
> > interface-type p2p;
> > }
> > interface xe-0/0/1.0 {
> > interface-type p2p;
> > }
> > }
> >
> >
> > *Destination QFX / other end of l2circuit*, interfacing test equipment on
> > vlan 123
> >
> > liam@NA-QFX5110-1# show interfaces xe-0/0/9
> > description "Temp Link to Arista";
> > flexible-vlan-tagging;
> > mtu 9216;
> > encapsulation flexible-ethernet-services;
> > unit 123 {
> > encapsulation vlan-ccc;
> > vlan-id 123;
> > family ccc;
> > }
> >
> > Interface facing intermediate / transit QFX
> >
> > liam@NA-QFX5110-1# show interfaces xe-0/0/1
> > description "OTN NA-MS";
> > mtu 9216;
> > unit 0 {
> > family inet {
> > address 172.16.130.6/30;
> > }
> > family mpls;
> > }
> >
> > liam@NA-QFX5110-1# show interfaces lo0
> > unit 0 {
> > family inet {
> > address 127.0.0.1/32;
> > address 192.168.68.5/32;
> > }
> > }
> >
> > liam@NA-QFX5110-1# show protocols l2circuit
> > neighbor 192.168.68.3 {
> > interface xe-0/0/9.123 {
> > virtual-circuit-id 123;
> > control-word;
> > encapsulation-type ethernet-vlan;
> > ignore-mtu-mismatch;
> > pseudowire-status-tlv;
> > }
> > }
> >
> > liam@NA-QFX5110-1# show protocols ldp
> > interface xe-0/0/1.0;
> > interface lo0.0;
> >
> > liam@NA-QFX5110-1# show protocols mpls
> > path-mtu {
> > rsvp mtu-signaling;
> > }
> > ipv6-tunneling;
> > icmp-tunneling;
> > optimize-timer 60;
> > label-switched-path na-qfx-to-wn-mx-test {
> > from 192.168.68.5;
> > to 192.168.68.3;
> > adaptive;
> > fast-reroute;
> > primary anypath;
> > }
> > path anypath;
> > interface xe-0/0/1.0;
> >
> > liam@NA-QFX5110-1# show protocols ospf
> > traffic-engineering;
> > area 0.0.0.0 {
> > interface lo0.0 {
> > passive;
> > }
> > interface vme.0 {
> > disable;
> > }
> > interface xe-0/0/0.554 {
> > interface-type p2p;
> > }
> > interface xe-0/0/1.0 {
> > interface-type p2p;
> > }
> > }
> >
> >
> > L2 Circuit is up on the QFX
> >
> > liam@NA-QFX5110-1> show l2circuit connections
> > Layer-2 Circuit Connections:
> >
> > Legend for connection status (St)
> > EI -- encapsulation invalid NP -- interface h/w not present
> > MM -- mtu mismatch Dn -- down
> > EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
> > CM -- control-word mismatch Up -- operational
> > VM -- vlan id mismatch CF -- Call admission control failure
> > OL -- no outgoing label IB -- TDM incompatible bitrate
> > NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
> > BK -- Backup Connection ST -- Standby Connection
> > CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
> > LD -- local site signaled down RS -- remote site standby
> > RD -- remote site signaled down HS -- Hot-standby Connection
> > XX -- unknown
> >
> > Legend for interface status
> > Up -- operational
> > Dn -- down
> > Neighbor: 192.168.68.3
> > Interface Type St Time last up # Up
> trans
> > xe-0/0/9.123(vc 123) rmt Up Jul 18 21:05:02 2019
> 1
> > Remote PE: 192.168.68.3, Negotiated control-word: Yes (Null)
> > Incoming label: 73, Outgoing label: 95
> > Negotiated PW status TLV: Yes
> > local PW status code: 0x00000000, Neighbor PW status code:
> 0x00000000
> > Local interface: xe-0/0/9.123, Status: Up, Encapsulation: VLAN
> > Flow Label Transmit: No, Flow Label Receive: No
> >
> > L2 Circuit is up on the MX
> >
> > liam@WN-MX204-1> show l2circuit connections
> > Layer-2 Circuit Connections:
> >
> > Legend for connection status (St)
> > EI -- encapsulation invalid NP -- interface h/w not present
> > MM -- mtu mismatch Dn -- down
> > EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
> > CM -- control-word mismatch Up -- operational
> > VM -- vlan id mismatch CF -- Call admission control failure
> > OL -- no outgoing label IB -- TDM incompatible bitrate
> > NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
> > BK -- Backup Connection ST -- Standby Connection
> > CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
> > LD -- local site signaled down RS -- remote site standby
> > RD -- remote site signaled down HS -- Hot-standby Connection
> > XX -- unknown
> >
> > Legend for interface status
> > Up -- operational
> > Dn -- down
> > Neighbor: 192.168.68.5
> > Interface Type St Time last up # Up
> trans
> > xe-0/1/3.123(vc 123) rmt Up Jul 19 01:03:21 2019
> 1
> > Remote PE: 192.168.68.5, Negotiated control-word: Yes (Null)
> > Incoming label: 95, Outgoing label: 73
> > Negotiated PW status TLV: Yes
> > local PW status code: 0x00000000, Neighbor PW status code:
> 0x00000000
> > Local interface: xe-0/1/3.123, Status: Up, Encapsulation: VLAN
> > Flow Label Transmit: No, Flow Label Receive: No
> >
> >
> > On the* MX end test equipment *I can see the MAC address learned from
> the *QFX
> > end test equipment*, however on the *QFX end test equipment* I cannot see
> > the MAC address of the* MX end test equipment*.
> >
> > The MX's and QFX's are running Junos: 18.4R1-S3.1
> >
> > Not sure if I just have this configured wrong, or a QFX chippie
> limitation
> > or a Junos bug.
> >
> > Any help / pointers would be appreciated :)
> >
> >
>
>

--
Kind Regards


Liam Farr

Maxum Data
+64-9-950-5302
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
Re: l2circuit between QFX-5110 & MX204 - one way traffic [ In reply to ]
Try Alain's recommendation. I completely forgot about the input/output
vlan part. You should have it on the MX as well, so that VLAN 123 would
be transmitted over the l2circuit.

> xe-<snip> {
>     description <snip>
>     flexible-vlan-tagging;
>     mtu 9216;
>     encapsulation flexible-ethernet-services;
>     unit 123 {
>         description <snip>
>         encapsulation vlan-ccc;
>         no-traps;
>         vlan-id 123;
>         input-vlan-map pop;
>         output-vlan-map push;
>     }

Heng Chai, Tan

On 18-07-19 10:17 PM, Liam Farr wrote:
> Hi,
>
> That removed my ability to run bridge interfaces on xe-0/0/9, which
> might cause me some design issues further down the track for
> production deployments.
>
> Applied this config, but same result.
>
> liam@NA-QFX5110-1# show interfaces xe-0/0/9
> description "Temp Link to Arista";
> vlan-tagging;
> mtu 9216;
> encapsulation vlan-ccc;
> unit 123 {
>     encapsulation vlan-ccc;
>     vlan-id 123;
>     family ccc;
> }
>
>
> On the MX end I can learn both MAC's, the NA/QFX test equip and the
> WN/MX204 test equip (I have a HV connected to the QFX end for testing
> running OVS and a test router VM).
>
> root@WLG-PVE-1:~# ovs-appctl fdb/show vmbr0 | grep 123
>     4   123  36:06:b7:37:b4:63    0
>     5   123  6c:3b:6b:f0:9b:0f    0
> root@WLG-PVE-1:~#
>
>
> But on the QFX end I'm not learning any mac back out the interface
> facing the l2tunnel (should be learning a mac on Et9 from the MX side,
> but only learning a mac on Et4 which is the QFX test device).
>
> NA-ARISTA#show vlan 123
> VLAN  Name                             Status    Ports
> ----- -------------------------------- ---------
> -------------------------------
> 123   VLAN0123                         active    Et4, Et9
> NA-ARISTA#show mac address-table vlan 123
>           Mac Address Table
> ------------------------------------------------------------------
>
> Vlan    Mac Address       Type        Ports      Moves   Last Move
> ----    -----------       ----        -----      ----- ---------
>  123    6c3b.6bf0.9b0f    DYNAMIC     Et4        1 8:18:08 ago
> Total Mac Addresses for this criterion: 1
>
>           Multicast Mac Address Table
> ------------------------------------------------------------------
>
> Vlan    Mac Address       Type        Ports
> ----    -----------       ----        -----
> Total Mac Addresses for this criterion: 0
>
>
> On Fri, 19 Jul 2019 at 02:02, Heng Chai, Tan <hc.tan@sg.gs
> <mailto:hc.tan@sg.gs>> wrote:
>
> Try below on QFX5110 terminating l2circuit. Last I remember the
> flexible-vlan-tagging + flexible-ethernet-services behaves oddly
> on the
> QFX5110.
>
> delete interfaces xe-0/0/9 flexible-vlan-tagging
> set interfaces xe-0/0/9 vlan-tagging
> set interfaces xe-0/0/9 encapsulation vlan-ccc
>
> Heng Chai, Tan
>
> On 18-07-19 9:48 PM, Liam Farr wrote:
> > Hi,
> >
> > Not sure if I'm "doing the dumb" or Junos bug or limitation of
> the QFX /
> > Trident 2+ chip-set.
> >
> > Trying to do a basic l2circuit as follows
> >
> > VLAN Tagged Interface > MX204 l2circuit / ldp > QFX-5110 / ldp >
> QFX-5110
> > l2circuit / ldp > VLAN Tagged Interface
> >
> > What I am seeing is traffic going Test Device > QFX-5110 >
> QFX-5110 > MX204
> >> Test Device arrives fine.
> > Return path from Test Device > MX204 > QFX-5110 > QFX-5110 >
> Test Device is
> > broken.
> >
> >
> > Config is as follows
> >
> > *MX204 Port facing test device on VLAN tag 123*
> >
> > liam@WN-MX204-1# show interfaces xe-0/1/3
> > description "WN-PVE-1 C0/F3 enp6s0f1";
> > flexible-vlan-tagging;
> > mtu 9216;
> > encapsulation flexible-ethernet-services;
> > unit 123 {
> >      encapsulation vlan-ccc;
> >      vlan-id 123;
> >      family ccc;
> > }
> >
> > MPLS port facing intermediate / transit QFX (MS)
> >
> > liam@WN-MX204-1# show interfaces xe-0/1/1
> > description "OTN MS";
> > mtu 9216;
> > unit 0 {
> >      family inet {
> >          address 172.16.130.2/30 <http://172.16.130.2/30>;
> >      }
> >      family mpls;
> > }
> >
> > liam@WN-MX204-1# show interfaces lo0
> > unit 0 {
> >      family inet {
> >          address 127.0.0.1/32 <http://127.0.0.1/32>;
> >          address 192.168.68.3/32 <http://192.168.68.3/32>;
> >      }
> > }
> >
> > liam@WN-MX204-1# show protocols l2circuit
> > neighbor 192.168.68.5 {
> >      interface xe-0/1/3.123 {
> >          virtual-circuit-id 123;
> >          control-word;
> >          encapsulation-type ethernet-vlan;
> >          ignore-mtu-mismatch;
> >          pseudowire-status-tlv;
> >      }
> > }
> >
> > liam@WN-MX204-1# show protocols ldp
> > interface xe-0/1/1.0;
> > interface lo0.0;
> >
> > liam@WN-MX204-1# show protocols mpls
> > path-mtu {
> >      rsvp mtu-signaling;
> > }
> > ipv6-tunneling;
> > icmp-tunneling;
> > optimize-timer 60;
> > label-switched-path wn-mx-to-na-qfx-test {
> >      from 192.168.68.3;
> >      to 192.168.68.5;
> >      adaptive;
> >      fast-reroute;
> >      primary anypath;
> > }
> > path anypath;
> > interface xe-0/1/1.0;
> >
> > liam@WN-MX204-1# show protocols ospf
> > traffic-engineering;
> > area 0.0.0.0 {
> >      interface lo0.0 {
> >          passive;
> >      }
> >      interface fxp0.0 {
> >          disable;
> >      }
> >      interface xe-0/1/0.549 {
> >          interface-type p2p;
> >      }
> >      interface xe-0/1/1.0 {
> >          interface-type p2p;
> >      }
> > }
> >
> >
> > *Intermediate / transit QFX*, MPLS interface facing MX204
> >
> > liam@MS-QFX5110-1# show interfaces xe-0/0/1
> > description "OTN MS-WN";
> > mtu 9216;
> > unit 0 {
> >      family inet {
> >          address 172.16.130.1/30 <http://172.16.130.1/30>;
> >      }
> >      family mpls;
> > }
> >
> > Interface facing destination QFX
> >
> > liam@MS-QFX5110-1# show interfaces xe-0/0/0
> > description "OTN MS-NA";
> > mtu 9216;
> > unit 0 {
> >      family inet {
> >          address 172.16.130.5/30 <http://172.16.130.5/30>;
> >      }
> >      family mpls;
> > }
> >
> > liam@MS-QFX5110-1# show interfaces lo0
> > unit 0 {
> >      family inet {
> >          address 127.0.0.1/32 <http://127.0.0.1/32>;
> >          address 192.168.68.6/32 <http://192.168.68.6/32>;
> >      }
> > }
> >
> > liam@MS-QFX5110-1# show protocols ldp
> > interface xe-0/0/0.0;
> > interface xe-0/0/1.0;
> > interface lo0.0;
> >
> > liam@MS-QFX5110-1# show protocols mpls
> > path-mtu {
> >      rsvp mtu-signaling;
> > }
> > ipv6-tunneling;
> > icmp-tunneling;
> > optimize-timer 60;
> > path anypath;
> > interface xe-0/0/0.0;
> > interface xe-0/0/1.0;
> >
> > liam@MS-QFX5110-1# show protocols ospf
> > traffic-engineering;
> > area 0.0.0.0 {
> >      interface lo0.0 {
> >          passive;
> >      }
> >      interface vme.0 {
> >          disable;
> >      }
> >      interface xe-0/0/0.0 {
> >          interface-type p2p;
> >      }
> >      interface xe-0/0/1.0 {
> >          interface-type p2p;
> >      }
> > }
> >
> >
> > *Destination QFX / other end of l2circuit*, interfacing test
> equipment on
> > vlan 123
> >
> > liam@NA-QFX5110-1# show interfaces xe-0/0/9
> > description "Temp Link to Arista";
> > flexible-vlan-tagging;
> > mtu 9216;
> > encapsulation flexible-ethernet-services;
> > unit 123 {
> >      encapsulation vlan-ccc;
> >      vlan-id 123;
> >      family ccc;
> > }
> >
> > Interface facing intermediate / transit QFX
> >
> > liam@NA-QFX5110-1# show interfaces xe-0/0/1
> > description "OTN NA-MS";
> > mtu 9216;
> > unit 0 {
> >      family inet {
> >          address 172.16.130.6/30 <http://172.16.130.6/30>;
> >      }
> >      family mpls;
> > }
> >
> > liam@NA-QFX5110-1# show interfaces lo0
> > unit 0 {
> >      family inet {
> >          address 127.0.0.1/32 <http://127.0.0.1/32>;
> >          address 192.168.68.5/32 <http://192.168.68.5/32>;
> >      }
> > }
> >
> > liam@NA-QFX5110-1# show protocols l2circuit
> > neighbor 192.168.68.3 {
> >      interface xe-0/0/9.123 {
> >          virtual-circuit-id 123;
> >          control-word;
> >          encapsulation-type ethernet-vlan;
> >          ignore-mtu-mismatch;
> >          pseudowire-status-tlv;
> >      }
> > }
> >
> > liam@NA-QFX5110-1# show protocols ldp
> > interface xe-0/0/1.0;
> > interface lo0.0;
> >
> > liam@NA-QFX5110-1# show protocols mpls
> > path-mtu {
> >      rsvp mtu-signaling;
> > }
> > ipv6-tunneling;
> > icmp-tunneling;
> > optimize-timer 60;
> > label-switched-path na-qfx-to-wn-mx-test {
> >      from 192.168.68.5;
> >      to 192.168.68.3;
> >      adaptive;
> >      fast-reroute;
> >      primary anypath;
> > }
> > path anypath;
> > interface xe-0/0/1.0;
> >
> > liam@NA-QFX5110-1# show protocols ospf
> > traffic-engineering;
> > area 0.0.0.0 {
> >      interface lo0.0 {
> >          passive;
> >      }
> >      interface vme.0 {
> >          disable;
> >      }
> >      interface xe-0/0/0.554 {
> >          interface-type p2p;
> >      }
> >      interface xe-0/0/1.0 {
> >          interface-type p2p;
> >      }
> > }
> >
> >
> > L2 Circuit is up on the QFX
> >
> > liam@NA-QFX5110-1> show l2circuit connections
> > Layer-2 Circuit Connections:
> >
> > Legend for connection status (St)
> > EI -- encapsulation invalid      NP -- interface h/w not present
> > MM -- mtu mismatch               Dn -- down
> > EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down
> > CM -- control-word mismatch      Up -- operational
> > VM -- vlan id mismatch           CF -- Call admission control
> failure
> > OL -- no outgoing label          IB -- TDM incompatible bitrate
> > NC -- intf encaps not CCC/TCC    TM -- TDM misconfiguration
> > BK -- Backup Connection          ST -- Standby Connection
> > CB -- rcvd cell-bundle size bad  SP -- Static Pseudowire
> > LD -- local site signaled down   RS -- remote site standby
> > RD -- remote site signaled down  HS -- Hot-standby Connection
> > XX -- unknown
> >
> > Legend for interface status
> > Up -- operational
> > Dn -- down
> > Neighbor: 192.168.68.3
> >      Interface                 Type  St     Time last up        
> # Up trans
> >      xe-0/0/9.123(vc 123)      rmt   Up     Jul 18 21:05:02
> 2019           1
> >        Remote PE: 192.168.68.3, Negotiated control-word: Yes (Null)
> >        Incoming label: 73, Outgoing label: 95
> >        Negotiated PW status TLV: Yes
> >        local PW status code: 0x00000000, Neighbor PW status
> code: 0x00000000
> >        Local interface: xe-0/0/9.123, Status: Up, Encapsulation:
> VLAN
> >        Flow Label Transmit: No, Flow Label Receive: No
> >
> > L2 Circuit is up on the MX
> >
> > liam@WN-MX204-1> show l2circuit connections
> > Layer-2 Circuit Connections:
> >
> > Legend for connection status (St)
> > EI -- encapsulation invalid      NP -- interface h/w not present
> > MM -- mtu mismatch               Dn -- down
> > EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down
> > CM -- control-word mismatch      Up -- operational
> > VM -- vlan id mismatch           CF -- Call admission control
> failure
> > OL -- no outgoing label          IB -- TDM incompatible bitrate
> > NC -- intf encaps not CCC/TCC    TM -- TDM misconfiguration
> > BK -- Backup Connection          ST -- Standby Connection
> > CB -- rcvd cell-bundle size bad  SP -- Static Pseudowire
> > LD -- local site signaled down   RS -- remote site standby
> > RD -- remote site signaled down  HS -- Hot-standby Connection
> > XX -- unknown
> >
> > Legend for interface status
> > Up -- operational
> > Dn -- down
> > Neighbor: 192.168.68.5
> >      Interface                 Type  St     Time last up        
> # Up trans
> >      xe-0/1/3.123(vc 123)      rmt   Up     Jul 19 01:03:21
> 2019           1
> >        Remote PE: 192.168.68.5, Negotiated control-word: Yes (Null)
> >        Incoming label: 95, Outgoing label: 73
> >        Negotiated PW status TLV: Yes
> >        local PW status code: 0x00000000, Neighbor PW status
> code: 0x00000000
> >        Local interface: xe-0/1/3.123, Status: Up, Encapsulation:
> VLAN
> >        Flow Label Transmit: No, Flow Label Receive: No
> >
> >
> > On the* MX end test equipment *I can see the MAC address learned
> from the *QFX
> > end test equipment*, however on the *QFX end test equipment* I
> cannot see
> > the MAC address of the* MX end  test equipment*.
> >
> > The MX's and QFX's are running Junos: 18.4R1-S3.1
> >
> > Not sure if I just have this configured wrong, or a QFX chippie
> limitation
> > or a Junos bug.
> >
> > Any help / pointers would be appreciated :)
> >
> >
>
>
>
> --
> Kind Regards
>
>
> Liam Farr
>
> Maxum Data
> +64-9-950-5302

_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
Re: l2circuit between QFX-5110 & MX204 - one way traffic [ In reply to ]
Hi,

Tried as follows;

liam@NA-QFX5110-1# show interfaces xe-0/0/9
description "Temp Link to Arista";
vlan-tagging;
mtu 9216;
encapsulation flexible-ethernet-services;
unit 123 {
encapsulation vlan-ccc;
vlan-id 123;
input-vlan-map pop;
output-vlan-map push;
family ccc;
}

liam@NA-QFX5110-1# show protocols l2circuit
neighbor 192.168.68.3 {
interface xe-0/0/9.123 {
virtual-circuit-id 123;
no-control-word;
ignore-mtu-mismatch;
pseudowire-status-tlv;
}
}

liam@WN-MX204-1# show interfaces xe-0/1/3
description "ISPCO-WN-PVE-1 C0/F3 enp6s0f1";
flexible-vlan-tagging;
mtu 9216;
encapsulation flexible-ethernet-services;
unit 123 {
encapsulation vlan-ccc;
vlan-id 123;
input-vlan-map push;
output-vlan-map pop;
family ccc;
}

liam@WN-MX204-1# show protocols l2circuit
neighbor 192.168.68.5 {
interface xe-0/1/3.123 {
virtual-circuit-id 123;
no-control-word;
ignore-mtu-mismatch;
pseudowire-status-tlv;
}
}

When I removed the l2circuit encapsulation altogether from both ends I got
an EM -- encapsulation mismatch on the l2circuit

I also tried encapsulation internetworking / ethernet-vlan / ethernet


At some point I did get mac learning both ways in that at the QFX end I
could see mac from the MX end, but haven't successfully managed to pass
icmp / ping.


NA-ARISTA#show mac address-table vlan 123
Mac Address Table
------------------------------------------------------------------

Vlan Mac Address Type Ports Moves Last Move
---- ----------- ---- ----- ----- ---------
123 3606.b737.b463 DYNAMIC Et9 1 0:18:11 ago
123 6c3b.6bf0.9b0f DYNAMIC Et4 1 8:55:37 ago
Total Mac Addresses for this criterion: 2


Multicast Mac Address Table
------------------------------------------------------------------

Vlan Mac Address Type Ports
---- ----------- ---- -----
Total Mac Addresses for this criterion: 0



I've got an option to borrow a QFX-5110 tomorrow and set it up in a bit
better of a LAB config with a MX I have locally, where I can break things a
bit more without affecting prod traffic. That might be the go and rebuild
some l2circuits from scratch.


https://www.juniper.net/documentation/en_US/junos/topics/reference/general/mpls-limitations-qfx-series.html





*(QFX5100, QFX5110, QFX5120, QFX5200, QFX5210, EX4600) When VLAN bridge
encapsulation is enabled on a CE connected interface, the switch drops
packets if both flexible Ethernet services and VLAN CCC encapsulations are
configured on the same logical interface. Only one can be configured, not
both. For example:set interfaces xe-0/0/18 encapsulation
flexible-ethernet-services, or set interfaces xe-0/0/18 encapsulation
vlan-ccc.*


As mentioned the above might be causing me issues, as I did have some sub
interfaces running vlan-bridge alongside the vlan-ccc interface on xe-0/0/9.



On Fri, 19 Jul 2019 at 02:20, Heng Chai, Tan <hc.tan@sg.gs> wrote:

> Try Alain's recommendation. I completely forgot about the input/output
> vlan part. You should have it on the MX as well, so that VLAN 123 would be
> transmitted over the l2circuit.
>
> xe-<snip> {
> description <snip>
> flexible-vlan-tagging;
> mtu 9216;
> encapsulation flexible-ethernet-services;
> unit 123 {
> description <snip>
> encapsulation vlan-ccc;
> no-traps;
> vlan-id 123;
> input-vlan-map pop;
> output-vlan-map push;
> }
>
>
> Heng Chai, Tan
>
>
>
--
Kind Regards


Liam Farr

Maxum Data
+64-9-950-5302
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
Re: l2circuit between QFX-5110 & MX204 - one way traffic [ In reply to ]
Hello

Some important information:

Top level encapsulation flex-eth and flex-vlan-tagging is not supported on QFabric (QFX family) devices. That means you can't use a port that does ccc with any other type of encap, i.e. vlan-bridge, ext-vlan-br, or set family inet on a unit. Only MX with trio chipset can do that. If you did at *any other point* configure some other units on there with different encaps, traffic will remain one way. There is also a PR on the use of flex stuff on QFX that states that at some points labels are not getting programmed properly and circuit will stop working.

You don't need family ccc in the unit, only encap vlan-ccc

You should remove and RSVP-TE and static LSP config that you have to start fresh and make it work only with LDP, then add complexity.

The pop/push operation on the unit is there to get a pure ethernet frame to slap the LDP tag onto and possibly deliver untagged on the other side. It's not necessary if you also deliver on a simple tagged unit on the other side. The difference in the core network will be between ETHERNET-CCC and VLAN-CCC. You don't need to force the encasulation type in config, this is automatic from what you set on both sides.

Also, don't do ignore-mtu, but set the mtu to what you want as a value lower than the physical interface mtu, the same on both sides.

I don't think QFX supports control-word.

Examples of what works:

Xe-X
vlan-tagging;
mtu 9216;
encapsulation vlan-ccc;
unit 538 {
encapsulation vlan-ccc;
no-traps;
vlan-id 538;
input-vlan-map pop;
output-vlan-map push;
}

interface xe-0/0/36.538 {
virtual-circuit-id 13911065;
no-control-word;
mtu 9000;
}

If you do use pop/push on the unit, make sure it's there on both sides. You can also deliver untagged on the other side by doing something like this. It will push the frame out untagged since you removed it accepting the packet initially. Keep in mind this dedicates the port to that service.

mtu 9216;
encapsulation ethernet-ccc;
unit 0 {
no-traps;
family ccc;
}

interface xe-0/0/12.0 {
virtual-circuit-id 1385956;
no-control-word;
mtu 9000;
}

MX can have top flex-ethernet and flex-vlan tagging and mix and match stuff. For the rest, config must stay the same.

Keep your stuff simple, leave as much as you can to the system to figure out unless you absolutely need to force.

Cheers.

-----Original Message-----
From: juniper-nsp <juniper-nsp-bounces@puck.nether.net> On Behalf Of Liam Farr
Sent: July 18, 2019 11:26 AM
To: Heng Chai, Tan <hc.tan@sg.gs>
Cc: juniper-nsp@puck.nether.net
Subject: Re: [j-nsp] l2circuit between QFX-5110 & MX204 - one way traffic

Hi,

Tried as follows;

liam@NA-QFX5110-1# show interfaces xe-0/0/9 description "Temp Link to Arista"; vlan-tagging; mtu 9216; encapsulation flexible-ethernet-services; unit 123 {
encapsulation vlan-ccc;
vlan-id 123;
input-vlan-map pop;
output-vlan-map push;
family ccc;
}

liam@NA-QFX5110-1# show protocols l2circuit neighbor 192.168.68.3 {
interface xe-0/0/9.123 {
virtual-circuit-id 123;
no-control-word;
ignore-mtu-mismatch;
pseudowire-status-tlv;
}
}

liam@WN-MX204-1# show interfaces xe-0/1/3 description "ISPCO-WN-PVE-1 C0/F3 enp6s0f1"; flexible-vlan-tagging; mtu 9216; encapsulation flexible-ethernet-services; unit 123 {
encapsulation vlan-ccc;
vlan-id 123;
input-vlan-map push;
output-vlan-map pop;
family ccc;
}

liam@WN-MX204-1# show protocols l2circuit neighbor 192.168.68.5 {
interface xe-0/1/3.123 {
virtual-circuit-id 123;
no-control-word;
ignore-mtu-mismatch;
pseudowire-status-tlv;
}
}

When I removed the l2circuit encapsulation altogether from both ends I got an EM -- encapsulation mismatch on the l2circuit

I also tried encapsulation internetworking / ethernet-vlan / ethernet


At some point I did get mac learning both ways in that at the QFX end I could see mac from the MX end, but haven't successfully managed to pass icmp / ping.


NA-ARISTA#show mac address-table vlan 123
Mac Address Table
------------------------------------------------------------------

Vlan Mac Address Type Ports Moves Last Move
---- ----------- ---- ----- ----- ---------
123 3606.b737.b463 DYNAMIC Et9 1 0:18:11 ago
123 6c3b.6bf0.9b0f DYNAMIC Et4 1 8:55:37 ago
Total Mac Addresses for this criterion: 2


Multicast Mac Address Table
------------------------------------------------------------------

Vlan Mac Address Type Ports
---- ----------- ---- -----
Total Mac Addresses for this criterion: 0



I've got an option to borrow a QFX-5110 tomorrow and set it up in a bit better of a LAB config with a MX I have locally, where I can break things a bit more without affecting prod traffic. That might be the go and rebuild some l2circuits from scratch.


https://www.juniper.net/documentation/en_US/junos/topics/reference/general/mpls-limitations-qfx-series.html





*(QFX5100, QFX5110, QFX5120, QFX5200, QFX5210, EX4600) When VLAN bridge encapsulation is enabled on a CE connected interface, the switch drops packets if both flexible Ethernet services and VLAN CCC encapsulations are configured on the same logical interface. Only one can be configured, not both. For example:set interfaces xe-0/0/18 encapsulation flexible-ethernet-services, or set interfaces xe-0/0/18 encapsulation
vlan-ccc.*


As mentioned the above might be causing me issues, as I did have some sub interfaces running vlan-bridge alongside the vlan-ccc interface on xe-0/0/9.



On Fri, 19 Jul 2019 at 02:20, Heng Chai, Tan <hc.tan@sg.gs> wrote:

> Try Alain's recommendation. I completely forgot about the input/output
> vlan part. You should have it on the MX as well, so that VLAN 123
> would be transmitted over the l2circuit.
>
> xe-<snip> {
> description <snip>
> flexible-vlan-tagging;
> mtu 9216;
> encapsulation flexible-ethernet-services;
> unit 123 {
> description <snip>
> encapsulation vlan-ccc;
> no-traps;
> vlan-id 123;
> input-vlan-map pop;
> output-vlan-map push;
> }
>
>
> Heng Chai, Tan
>
>
>
--
Kind Regards


Liam Farr

Maxum Data
+64-9-950-5302
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
Re: l2circuit between QFX-5110 & MX204 - one way traffic [ In reply to ]
Liam,

Did you ever get this worked out?

On Thu, Jul 18, 2019 at 12:25 PM Philippe Girard <
philippe.girard@metrooptic.com> wrote:

> Hello
>
> Some important information:
>
> Top level encapsulation flex-eth and flex-vlan-tagging is not supported on
> QFabric (QFX family) devices. That means you can't use a port that does ccc
> with any other type of encap, i.e. vlan-bridge, ext-vlan-br, or set family
> inet on a unit. Only MX with trio chipset can do that. If you did at *any
> other point* configure some other units on there with different encaps,
> traffic will remain one way. There is also a PR on the use of flex stuff on
> QFX that states that at some points labels are not getting programmed
> properly and circuit will stop working.
>
> You don't need family ccc in the unit, only encap vlan-ccc
>
> You should remove and RSVP-TE and static LSP config that you have to start
> fresh and make it work only with LDP, then add complexity.
>
> The pop/push operation on the unit is there to get a pure ethernet frame
> to slap the LDP tag onto and possibly deliver untagged on the other side.
> It's not necessary if you also deliver on a simple tagged unit on the other
> side. The difference in the core network will be between ETHERNET-CCC and
> VLAN-CCC. You don't need to force the encasulation type in config, this is
> automatic from what you set on both sides.
>
> Also, don't do ignore-mtu, but set the mtu to what you want as a value
> lower than the physical interface mtu, the same on both sides.
>
> I don't think QFX supports control-word.
>
> Examples of what works:
>
> Xe-X
> vlan-tagging;
> mtu 9216;
> encapsulation vlan-ccc;
> unit 538 {
> encapsulation vlan-ccc;
> no-traps;
> vlan-id 538;
> input-vlan-map pop;
> output-vlan-map push;
> }
>
> interface xe-0/0/36.538 {
> virtual-circuit-id 13911065;
> no-control-word;
> mtu 9000;
> }
>
> If you do use pop/push on the unit, make sure it's there on both sides.
> You can also deliver untagged on the other side by doing something like
> this. It will push the frame out untagged since you removed it accepting
> the packet initially. Keep in mind this dedicates the port to that service.
>
> mtu 9216;
> encapsulation ethernet-ccc;
> unit 0 {
> no-traps;
> family ccc;
> }
>
> interface xe-0/0/12.0 {
> virtual-circuit-id 1385956;
> no-control-word;
> mtu 9000;
> }
>
> MX can have top flex-ethernet and flex-vlan tagging and mix and match
> stuff. For the rest, config must stay the same.
>
> Keep your stuff simple, leave as much as you can to the system to figure
> out unless you absolutely need to force.
>
> Cheers.
>
> -----Original Message-----
> From: juniper-nsp <juniper-nsp-bounces@puck.nether.net> On Behalf Of Liam
> Farr
> Sent: July 18, 2019 11:26 AM
> To: Heng Chai, Tan <hc.tan@sg.gs>
> Cc: juniper-nsp@puck.nether.net
> Subject: Re: [j-nsp] l2circuit between QFX-5110 & MX204 - one way traffic
>
> Hi,
>
> Tried as follows;
>
> liam@NA-QFX5110-1# show interfaces xe-0/0/9 description "Temp Link to
> Arista"; vlan-tagging; mtu 9216; encapsulation flexible-ethernet-services;
> unit 123 {
> encapsulation vlan-ccc;
> vlan-id 123;
> input-vlan-map pop;
> output-vlan-map push;
> family ccc;
> }
>
> liam@NA-QFX5110-1# show protocols l2circuit neighbor 192.168.68.3 {
> interface xe-0/0/9.123 {
> virtual-circuit-id 123;
> no-control-word;
> ignore-mtu-mismatch;
> pseudowire-status-tlv;
> }
> }
>
> liam@WN-MX204-1# show interfaces xe-0/1/3 description "ISPCO-WN-PVE-1
> C0/F3 enp6s0f1"; flexible-vlan-tagging; mtu 9216; encapsulation
> flexible-ethernet-services; unit 123 {
> encapsulation vlan-ccc;
> vlan-id 123;
> input-vlan-map push;
> output-vlan-map pop;
> family ccc;
> }
>
> liam@WN-MX204-1# show protocols l2circuit neighbor 192.168.68.5 {
> interface xe-0/1/3.123 {
> virtual-circuit-id 123;
> no-control-word;
> ignore-mtu-mismatch;
> pseudowire-status-tlv;
> }
> }
>
> When I removed the l2circuit encapsulation altogether from both ends I got
> an EM -- encapsulation mismatch on the l2circuit
>
> I also tried encapsulation internetworking / ethernet-vlan / ethernet
>
>
> At some point I did get mac learning both ways in that at the QFX end I
> could see mac from the MX end, but haven't successfully managed to pass
> icmp / ping.
>
>
> NA-ARISTA#show mac address-table vlan 123
> Mac Address Table
> ------------------------------------------------------------------
>
> Vlan Mac Address Type Ports Moves Last Move
> ---- ----------- ---- ----- ----- ---------
> 123 3606.b737.b463 DYNAMIC Et9 1 0:18:11 ago
> 123 6c3b.6bf0.9b0f DYNAMIC Et4 1 8:55:37 ago
> Total Mac Addresses for this criterion: 2
>
>
> Multicast Mac Address Table
> ------------------------------------------------------------------
>
> Vlan Mac Address Type Ports
> ---- ----------- ---- -----
> Total Mac Addresses for this criterion: 0
>
>
>
> I've got an option to borrow a QFX-5110 tomorrow and set it up in a bit
> better of a LAB config with a MX I have locally, where I can break things a
> bit more without affecting prod traffic. That might be the go and rebuild
> some l2circuits from scratch.
>
>
>
> https://www.juniper.net/documentation/en_US/junos/topics/reference/general/mpls-limitations-qfx-series.html
>
>
>
>
>
> *(QFX5100, QFX5110, QFX5120, QFX5200, QFX5210, EX4600) When VLAN bridge
> encapsulation is enabled on a CE connected interface, the switch drops
> packets if both flexible Ethernet services and VLAN CCC encapsulations are
> configured on the same logical interface. Only one can be configured, not
> both. For example:set interfaces xe-0/0/18 encapsulation
> flexible-ethernet-services, or set interfaces xe-0/0/18 encapsulation
> vlan-ccc.*
>
>
> As mentioned the above might be causing me issues, as I did have some sub
> interfaces running vlan-bridge alongside the vlan-ccc interface on xe-0/0/9.
>
>
>
> On Fri, 19 Jul 2019 at 02:20, Heng Chai, Tan <hc.tan@sg.gs> wrote:
>
> > Try Alain's recommendation. I completely forgot about the input/output
> > vlan part. You should have it on the MX as well, so that VLAN 123
> > would be transmitted over the l2circuit.
> >
> > xe-<snip> {
> > description <snip>
> > flexible-vlan-tagging;
> > mtu 9216;
> > encapsulation flexible-ethernet-services;
> > unit 123 {
> > description <snip>
> > encapsulation vlan-ccc;
> > no-traps;
> > vlan-id 123;
> > input-vlan-map pop;
> > output-vlan-map push;
> > }
> >
> >
> > Heng Chai, Tan
> >
> >
> >
> --
> Kind Regards
>
>
> Liam Farr
>
> Maxum Data
> +64-9-950-5302
> _______________________________________________
> juniper-nsp mailing list juniper-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
> _______________________________________________
> juniper-nsp mailing list juniper-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
>
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp