Mailing List Archive

BGP-BFD on CER2024 / Netiron
Hi!
We are trying to set up BGP-BFD on a CER2024 running version 6.2.0aT183.
Our configuration looks like this:


bfd sh-session-setup-delay 5

interface ethernet 1/6
enable
no fdp enable
no cdp enable
no spanning-tree
sflow forwarding

vlan 3000 name "Vlan 3000"
tagged ethe 1/6
router-interface ve 3000

vlan 3001 name "Vlan 3001"
tagged ethe 1/6
router-interface ve 3001

interface ve 3000
bfd interval 2000 min-rx 2000 multiplier 4
ip address 1.1.1.1/31
!

SSH@c13-1#show run int ve 3001
interface ve 3001
bfd interval 2000 min-rx 2000 multiplier 4
ip address 2.2.2.1/31

router bgp
local-as 15594
bfd-enable
auto-shutdown-new-neighbors
default-local-preference 110
fast-external-fallover

neighbor 1.1.1.2 remote-as 12345
neighbor 1.1.1.2 password 2 SECRET
neighbor 1.1.1.2 bfd min-tx 200 min-rx 200 multiplier 4
neighbor 1.1.1.2 bfd holdover-interval 5

neighbor 2.2.2.2 remote-as 12345
neighbor 2.2.2.2 password 2 SECRET
neighbor 2.2.2.2 bfd min-tx 200 min-rx 200 multiplier 4
neighbor 2.2.2.2 bfd holdover-interval 5

address-family ipv4 unicast
neighbor 1.1.1.2 prefix-list BGP-3000-IN in
neighbor 1.1.1.2 prefix-list BGP-3000-OUT out
neighbor 2.2.2.2 prefix-list BGP-3001-IN in
neighbor 2.2.2.2 prefix-list BGP-3001-OUT out



According to our peer (Juniper MX system) they are only running BGP-BFD,
not BFD on the interface. We tried our configuration with or without BFD on
the interfaces ve3000/ve3001. In any case, "show ip bgp neighbors $IP"
always says "BFD: Disabled". "show bfd" says:

BFD State: ENABLED Version: 1 Use PBIF Assist: Y SH setup delay 5 MH setup
delay 0
Current Registered Protocols: bgp/0 static/0
All Sessions: Current: 0 Maximum Allowed: 40 Maximum Exceeded Count: 0
Maximum TX/RX Sessions Allowed on LP: 40 Maximum Session Exceeded Count for
LPs: 0
LP Tx/Rx Sessions LP Tx/Rx Sessions
1 0/0 2 0/0
BFD Enabled ports count: 2
Port MinTx MinRx Mult Sessions
ve 3000 2000 2000 4 0
ve 3001 2000 2000 4 0


show bfd neighbors
No BFD Neighbor found.


show bfd applications
Registered Protocols Count: 2
Protocol VRFID Parameter HoldoverInterval
bgp 0 0 0
static 0 1 0


We are not sure how to configure and/or debug BFD. Various "debug bfd *"
settings did not show any output.
Does anybody have any ideas about this?

Regards
Cenk
Re: BGP-BFD on CER2024 / Netiron [ In reply to ]
Hi Cenk,

Could this be what you are looking for:

neighbor 1.1.1.2 fail-over bfd-enable
neighbor 2.2.2.2 fail-over bfd-enable


________________________________


?Met vriendelijke groet,

Bas van Elburg
NOC Engineer





Postadres:
?Postbus 83
?5126 ZH Gilze
?

T:
+31 (0)161 888877 (algemeen)
Bezoekadres:
?Europalaan 5
?5121 DH Rijen
? E:
?I:
b.van.elburg@global-datacenter.nl
https://www.global-datacenter.nl

De informatie in dit e-mail bericht (inclusief bijlagen) is vertrouwelijk en uitsluitend bestemd voor de geadresseerde. Verstrekking aan en gebruik door anderen is niet toegestaan. Door de elektronische verzending van het bericht kunnen er geen rechten worden ontleend aan de informatie. Op alle offertes en opdrachten tussen opdrachtgevers en Global-e Datacenter BV zijn de algemene voorwaarden van toepassing. Global-e Datacenter BV, Kvk Tilburg 17246070, BTW nr: NL 8205.53.128.B.01

?
From: foundry-nsp <foundry-nsp-bounces@puck.nether.net> on behalf of Cenk Kücük <kuecuek@sipgate.de>
Sent: Wednesday, 3 February 2021 11:12
To: foundry-nsp@puck.nether.net <foundry-nsp@puck.nether.net>
Subject: [f-nsp] BGP-BFD on CER2024 / Netiron

Hi!
We are trying to set up BGP-BFD on a CER2024 running version 6.2.0aT183.
Our configuration looks like this:


bfd sh-session-setup-delay 5

interface ethernet 1/6
enable
no fdp enable
no cdp enable
no spanning-tree
sflow forwarding

vlan 3000 name "Vlan 3000"
tagged ethe 1/6
router-interface ve 3000

vlan 3001 name "Vlan 3001"
tagged ethe 1/6
router-interface ve 3001

interface ve 3000
bfd interval 2000 min-rx 2000 multiplier 4
ip address 1.1.1.1/31<http://1.1.1.1/31>
!

SSH@c13-1#show run int ve 3001
interface ve 3001
bfd interval 2000 min-rx 2000 multiplier 4
ip address 2.2.2.1/31<http://2.2.2.1/31>

router bgp
local-as 15594
bfd-enable
auto-shutdown-new-neighbors
default-local-preference 110
fast-external-fallover

neighbor 1.1.1.2 remote-as 12345
neighbor 1.1.1.2 password 2 SECRET
neighbor 1.1.1.2 bfd min-tx 200 min-rx 200 multiplier 4
neighbor 1.1.1.2 bfd holdover-interval 5

neighbor 2.2.2.2 remote-as 12345
neighbor 2.2.2.2 password 2 SECRET
neighbor 2.2.2.2 bfd min-tx 200 min-rx 200 multiplier 4
neighbor 2.2.2.2 bfd holdover-interval 5

address-family ipv4 unicast
neighbor 1.1.1.2 prefix-list BGP-3000-IN in
neighbor 1.1.1.2 prefix-list BGP-3000-OUT out
neighbor 2.2.2.2 prefix-list BGP-3001-IN in
neighbor 2.2.2.2 prefix-list BGP-3001-OUT out



According to our peer (Juniper MX system) they are only running BGP-BFD, not BFD on the interface. We tried our configuration with or without BFD on the interfaces ve3000/ve3001. In any case, "show ip bgp neighbors $IP" always says "BFD: Disabled". "show bfd" says:

BFD State: ENABLED Version: 1 Use PBIF Assist: Y SH setup delay 5 MH setup delay 0
Current Registered Protocols: bgp/0 static/0
All Sessions: Current: 0 Maximum Allowed: 40 Maximum Exceeded Count: 0
Maximum TX/RX Sessions Allowed on LP: 40 Maximum Session Exceeded Count for LPs: 0
LP Tx/Rx Sessions LP Tx/Rx Sessions
1 0/0 2 0/0
BFD Enabled ports count: 2
Port MinTx MinRx Mult Sessions
ve 3000 2000 2000 4 0
ve 3001 2000 2000 4 0


show bfd neighbors
No BFD Neighbor found.


show bfd applications
Registered Protocols Count: 2
Protocol VRFID Parameter HoldoverInterval
bgp 0 0 0
static 0 1 0


We are not sure how to configure and/or debug BFD. Various "debug bfd *" settings did not show any output.
Does anybody have any ideas about this?

Regards
Cenk
Re: BGP-BFD on CER2024 / Netiron [ In reply to ]
Hi Bas,

thanks for your quick reaction! :)
That was indeed the issue.

The setting is documented under the section "enable BFD for a non-default
VRF" but we are using a default VRF, so we did not look into this. It seems
that this setting is always needed.


Regards
Cenk

Am Mi., 3. Feb. 2021 um 12:10 Uhr schrieb Bas van Elburg <
b.van.elburg@global-datacenter.nl>:

> Hi Cenk,
>
> Could this be what you are looking for:
>
> neighbor 1.1.1.2 fail-over bfd-enable
> neighbor 2.2.2.2 fail-over bfd-enable
>
>
>
> ?Met vriendelijke groet,?
>
> Bas van Elburg
> NOC Engineer
>
>
>
>
>
> Postadres:
> ?Postbus 83
> ?5126 ZH Gilze
> ?
>
>
> T:
> +31 (0)161 888877 (algemeen)
> Bezoekadres:
> ?Europalaan 5
> ?5121 DH Rijen
> ? E:
> ?I:
> *b.van.elburg@global-datacenter.nl* <b.van.elburg@global-datacenter.nl>
> *https://www.global-datacenter.nl* <https://www.global-datacenter.nl/>
>
> De informatie in dit e-mail bericht (inclusief bijlagen) is vertrouwelijk
> en uitsluitend bestemd voor de geadresseerde. Verstrekking aan en gebruik
> door anderen is niet toegestaan. Door de elektronische verzending van het
> bericht kunnen er geen rechten worden ontleend aan de informatie. Op alle
> offertes en opdrachten tussen opdrachtgevers en Global-e Datacenter BV zijn
> de algemene voorwaarden van toepassing. Global-e Datacenter BV, Kvk Tilburg
> 17246070, BTW nr: NL 8205.53.128.B.01
>
> ?
> ------------------------------
> *From:* foundry-nsp <foundry-nsp-bounces@puck.nether.net> on behalf of
> Cenk Kücük <kuecuek@sipgate.de>
> *Sent:* Wednesday, 3 February 2021 11:12
> *To:* foundry-nsp@puck.nether.net <foundry-nsp@puck.nether.net>
> *Subject:* [f-nsp] BGP-BFD on CER2024 / Netiron
>
> Hi!
> We are trying to set up BGP-BFD on a CER2024 running version 6.2.0aT183.
> Our configuration looks like this:
>
>
> bfd sh-session-setup-delay 5
>
> interface ethernet 1/6
> enable
> no fdp enable
> no cdp enable
> no spanning-tree
> sflow forwarding
>
> vlan 3000 name "Vlan 3000"
> tagged ethe 1/6
> router-interface ve 3000
>
> vlan 3001 name "Vlan 3001"
> tagged ethe 1/6
> router-interface ve 3001
>
> interface ve 3000
> bfd interval 2000 min-rx 2000 multiplier 4
> ip address 1.1.1.1/31
> !
>
> SSH@c13-1#show run int ve 3001
> interface ve 3001
> bfd interval 2000 min-rx 2000 multiplier 4
> ip address 2.2.2.1/31
>
> router bgp
> local-as 15594
> bfd-enable
> auto-shutdown-new-neighbors
> default-local-preference 110
> fast-external-fallover
>
> neighbor 1.1.1.2 remote-as 12345
> neighbor 1.1.1.2 password 2 SECRET
> neighbor 1.1.1.2 bfd min-tx 200 min-rx 200 multiplier 4
> neighbor 1.1.1.2 bfd holdover-interval 5
>
> neighbor 2.2.2.2 remote-as 12345
> neighbor 2.2.2.2 password 2 SECRET
> neighbor 2.2.2.2 bfd min-tx 200 min-rx 200 multiplier 4
> neighbor 2.2.2.2 bfd holdover-interval 5
>
> address-family ipv4 unicast
> neighbor 1.1.1.2 prefix-list BGP-3000-IN in
> neighbor 1.1.1.2 prefix-list BGP-3000-OUT out
> neighbor 2.2.2.2 prefix-list BGP-3001-IN in
> neighbor 2.2.2.2 prefix-list BGP-3001-OUT out
>
>
>
> According to our peer (Juniper MX system) they are only running BGP-BFD,
> not BFD on the interface. We tried our configuration with or without BFD on
> the interfaces ve3000/ve3001. In any case, "show ip bgp neighbors $IP"
> always says "BFD: Disabled". "show bfd" says:
>
> BFD State: ENABLED Version: 1 Use PBIF Assist: Y SH setup delay 5 MH setup
> delay 0
> Current Registered Protocols: bgp/0 static/0
> All Sessions: Current: 0 Maximum Allowed: 40 Maximum Exceeded Count: 0
> Maximum TX/RX Sessions Allowed on LP: 40 Maximum Session Exceeded Count
> for LPs: 0
> LP Tx/Rx Sessions LP Tx/Rx Sessions
> 1 0/0 2 0/0
> BFD Enabled ports count: 2
> Port MinTx MinRx Mult Sessions
> ve 3000 2000 2000 4 0
> ve 3001 2000 2000 4 0
>
>
> show bfd neighbors
> No BFD Neighbor found.
>
>
> show bfd applications
> Registered Protocols Count: 2
> Protocol VRFID Parameter HoldoverInterval
> bgp 0 0 0
> static 0 1 0
>
>
> We are not sure how to configure and/or debug BFD. Various "debug bfd *"
> settings did not show any output.
> Does anybody have any ideas about this?
>
> Regards
> Cenk
>


--
Cenk Kücük - kuecuek@sipgate.de
Telefon: +49 (0)211-63 55 57-46
Telefax: +49 (0)211-63 55 55-22

sipgate GmbH - Gladbacher Str. 74 - 40219 Düsseldorf
HRB Düsseldorf 39841 - Geschäftsführer: Thilo Salmon, Tim Mois
Steuernummer: 106/5724/7147, Umsatzsteuer-ID: DE219349391

www.sipgate.de - www.sipgate.co.uk