Mailing List Archive

[PATCH rdma-next v3 0/5] Cleanup restrack code
From: Leon Romanovsky <leonro@nvidia.com>

Changelog:
v3:
* Removed the mlx4 SR-IOV patch in favour of more robust fix that not needed in
this series.
* Cut the eroginal series to already reviewed and standalone patches.
v2: https://lore.kernel.org/linux-rdma/20200907122156.478360-1-leon@kernel.org/
* Added new patch to fix mlx4 failure on SR-IOV, it didn't have port set.
* Changed "RDMA/cma: Delete from restrack DB after successful destroy" patch.
v1:
* Fixed rebase error, deleted second assignment of qp_type.
* Rebased code on latests rdma-next, the changes in cma.c caused to change
in patch "RDMA/cma: Delete from restrack DB after successful destroy".
* Dropped patch of port assignment, it is already done as part of this
series.
* I didn't add @calller description, regular users should not use _named() funciton.
* https://lore.kernel.org/lkml/20200830101436.108487-1-leon@kernel.org
v0: https://lore.kernel.org/lkml/20200824104415.1090901-1-leon@kernel.org

----------------------------------------------------------------------------------

Leon Romanovsky (5):
RDMA/cma: Delete from restrack DB after successful destroy
RDMA/mlx5: Don't call to restrack recursively
RDMA/restrack: Count references to the verbs objects
RDMA/restrack: Simplify restrack tracking in kernel flows
RDMA/restrack: Improve readability in task name management

drivers/infiniband/core/cma.c | 140 +++++++++------
drivers/infiniband/core/core_priv.h | 13 +-
drivers/infiniband/core/counters.c | 15 +-
drivers/infiniband/core/cq.c | 9 +-
drivers/infiniband/core/restrack.c | 161 +++++++++---------
drivers/infiniband/core/restrack.h | 10 +-
drivers/infiniband/core/ucma.c | 7 +-
drivers/infiniband/core/uverbs_cmd.c | 27 ++-
drivers/infiniband/core/uverbs_std_types_cq.c | 8 +-
drivers/infiniband/core/verbs.c | 31 ++--
drivers/infiniband/hw/mlx5/gsi.c | 16 +-
include/rdma/rdma_cm.h | 47 ++---
include/rdma/restrack.h | 21 +--
13 files changed, 266 insertions(+), 239 deletions(-)

--
2.26.2
Re: [PATCH rdma-next v3 0/5] Cleanup restrack code [ In reply to ]
On Tue, Sep 22, 2020 at 12:11:01PM +0300, Leon Romanovsky wrote:
> From: Leon Romanovsky <leonro@nvidia.com>
>
> Changelog:
> v3:
> * Removed the mlx4 SR-IOV patch in favour of more robust fix that not needed in
> this series.
> * Cut the eroginal series to already reviewed and standalone patches.
> v2: https://lore.kernel.org/linux-rdma/20200907122156.478360-1-leon@kernel.org/
> * Added new patch to fix mlx4 failure on SR-IOV, it didn't have port set.
> * Changed "RDMA/cma: Delete from restrack DB after successful destroy" patch.
> v1:
> * Fixed rebase error, deleted second assignment of qp_type.
> * Rebased code on latests rdma-next, the changes in cma.c caused to change
> in patch "RDMA/cma: Delete from restrack DB after successful destroy".
> * Dropped patch of port assignment, it is already done as part of this
> series.
> * I didn't add @calller description, regular users should not use _named() funciton.
> * https://lore.kernel.org/lkml/20200830101436.108487-1-leon@kernel.org
> v0: https://lore.kernel.org/lkml/20200824104415.1090901-1-leon@kernel.org
>
>
> Leon Romanovsky (5):
> RDMA/cma: Delete from restrack DB after successful destroy
> RDMA/mlx5: Don't call to restrack recursively
> RDMA/restrack: Count references to the verbs objects
> RDMA/restrack: Simplify restrack tracking in kernel flows
> RDMA/restrack: Improve readability in task name management

Applied to for-next, thanks

Jason