Mailing List Archive

MILO and Adaptec AHA2940AU
Hello everyone,

I have a hardware-related question for you guys and gals today. I want
to install a new HDD in my Alpha XL-366 (XLT system type,
AlphaBIOS-only, so I'm stuck with MILO...). Now, the first problem is
that I can't run it off the onboard sym53c810 SCSI controller, because
(as I understand it) it is a Wide SCSI-2 device, and the sym53c810 only
supports Fast SCSI-2, and the problem is that the kernel driver tries to
set the controller to Wide which causes errors to be continuously
printed to the console.

for a description of the exact same problem. That person solved it by
patching the kernel driver to turn off Wide mode, which is a bit drastic
and I don't want to do it each time I build my kernel...)

So what I'm trying now is to run the drive off an Adaptec AHA2940AU
controller I had in another unused machine. The controller and drive are
detected on bootup, I see them in the BIOS, so all seems peachy. But
when MILO starts up and tries to detect the machine's devices (after
typing in a "boot" command, or when doing an "ls" for example), it hangs
right after detecting the Adaptec controller.

(first 1/3 of the message), where the same problem is described.

First question is why does MILO 2.2-18 hang when loading the Adaptec
driver? Is it a known bug with this hardware/software combination?

That person says that downgrading to MILO 2.2-17 allowed him to boot.
When I try that version, it hangs at "Swapping to PALcode at
0x80080000". I even tried linload.exe version 1.3a and 1.5, both give
the same problem. How do I get MILO 2.2-17 to boot?

Of course, if someone could tell me how to disable Wide mode in my kernel's sym53c8xx driver without having to hack the code at
each kernel upgrade, that would (probably) solve the root problem and
eliminate the need for the Adaptec controller. I saw that passing
'sym53c8xx="wide:0"' to the kernel in the boot command would do the
trick, if the sym53c8xx driver were built as a module. But the
controller is needed to boot at all, so I have to compile it into the
kernel or else the kernel starts but doesn't see the root device, and
with the driver compiled into the kernel it doesn't check those
arguments (argh). One solution could be to install an IDE controller
with a small IDE drive to boot from, and then compile the sym53c8xx
driver as a module, but I'd like to keep that as a last resort and try
to make it work with what I have first.

I anxiously await any suggestions. Thanks in advance,


Jean-S├ębastien Guay

-- mailing list