Mailing List Archive

VOIP QoS questions
I'm testing out QoS following the example at
http://www.cisco.com/warp/public/788/voice-qos/voip-qos-fr-atm.html.

My setup is a 7206vxr (12.2(14)S), PA-MC-T3, M13 MUX, 1602 (12.2(16),
wic-1T, and an Adtran TSU LT. I've setup both ends following the "Frame
Relay Connected Router" example config, with the only real difference
being that circuit I'm simulating is a 384k CIR frame.

The first odd thing I've noticed is that the LLQ service policy doesn't
work as expected. i.e. I expected it to reserve at least the bandwidth
specified in the priority statement for that class of packets. Instead,
packets in that class seem to get only the reserved bandwith...and not
even all of it. i.e.

policy-map VOIP
class voice
priority 64
class class-default
fair-queue

An FTP transfer who's packets all fall in the voice class runs at about
4KB/s. With the priority set to 256, I get 27KB/s in the voice class.
An FTP transfer who's packets are not in the voice class will run along at
35KB/s if they're the only traffic...30KB/s if there's a voice class
transfer going on at the same time. The LLQ policy does seem to do a
reasonable job of reserving bandwidth...several other FTP transfers not in
the voice class will take a back seat to the voice class packets, except
in the case where priority is small enough (64) that packets outside the
voice class actually get better throughput than those in the class.

Another oddity I noticed is that if I configure the test circuit as a 6
channel HDLC circuit, I can FTP at 44KB/s. With the MLPPP over frame
setup with

[adapted from the example in the URL above]
map-class frame-relay mlp
no frame-relay adaptive-shaping
frame-relay cir 384000
frame-relay bc 3840
frame-relay be 0

the best I can get is 35KB/s for packets not in the voice class or with
the service policy disabled.

If I change this to the sort of map-class we'd normally use to shape a
frame customer, i.e.

map-class frame-relay mlp
frame-relay traffic-rate 384000 384000
no frame-relay adaptive-shaping

then non voice class throughput goes up to about 40KB/s, but the voice
class throughput falls to about 3KB/s.

Most of the testing I've done (all the numbers above) are downloading data
linux->7200->1600->linux. Am I missing something in the config, or is the
IOS version just not working properly? It seems I have to bump the
priority up to about 110 to actually get 64kbit/s reserved, and overall,
I'm losing about 80kbit/s of the 384k circuit's capacity.

Here's most of the config from the 7206...irrelevant parts clipped.

boot system flash slot0:c7200-p-mz.122-14.S.bin
class-map match-all voice
match access-group 105
!
policy-map VOIP
class voice
priority 64
class class-default
fair-queue
!
frame-relay switching
!
controller T3 2/0
cablelength 10
t1 1 channel-group 0 timeslots 1-24
!
interface Serial2/0/1:0
no ip address
encapsulation frame-relay IETF
frame-relay traffic-shaping
frame-relay lmi-type ansi
frame-relay intf-type dce
!
interface Serial2/0/1:0.1 point-to-point
frame-relay interface-dlci 16 ppp Virtual-Template1
class mlp
!
interface Virtual-Template1
bandwidth 384
ip unnumbered Loopback0
no ip route-cache
ip tcp header-compression iphc-format
load-interval 30
max-reserved-bandwidth 99
service-policy output VOIP
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
ip rtp header-compression iphc-format
!
map-class frame-relay mlp
no frame-relay adaptive-shaping
frame-relay cir 384000
frame-relay bc 3840
frame-relay be 0
!
access-list 105 permit ip host 209.208.3.58 any



----------------------------------------------------------------------
Jon Lewis *jlewis@lewis.org*| I route
System Administrator | therefore you are
Atlantic Net |
_________ http://www.lewis.org/~jlewis/pgp for PGP public key_________