Mailing List Archive

[nsp] Help with QoS
Hi,

I wanted to prioritize traffic coming from two workstations connected to a
2924 catalyst switch. The workstations are Windows Media encoders and serve
traffic to Windows Media server/reflectors over a WAN link. On some
occasions, the WAN link gets congested and the session between the encoders
and servers is cutoff.

Here's the network layout:

[MS encoder machines]
|
[Catalyst 2924]
| +--E1-->[to Cisco 1750 @ local IX]
| /
[Cisco 3640]--+
\
+--E1-->[to Cisco 7206 @ core]

I labeled the packets on the ports where the encoders are connected with a
value of 5:

interface FastEthernet0/18
description MS Media Encoder 1
duplex full
speed 100
switchport priority default 5
!
interface FastEthernet0/19
description MS Media Encoder 2
duplex full
speed 100
switchport priority default 5

and on the Cisco 3640, I created a class-map to match the COS from the
switch and then do some stuff to it in a policy-map:

class-map match-all COS5
match cos 5

policy-map HIGH-PRIORITY
class COS5
set ip dscp 10
priority 128

and then applying that to the outgoing interface:

c3640-noc-cal(config-if)#service-policy output HIGH-PRIORITY
'match cos' supported only with IEEE 802.1Q/ISL interfaces

I'm assuming that COS is not carried all the way to the router from the
switch. Is there any other way around this? Will DSCP be carried over the
WAN interface? I'd like to also look at the DSCP tag once it reaches other
routers within our administrative control.

Thanks.

---
francis a. vidal [bitstop network services] | http://www.bitstop.ph
streaming media + web hosting | http://www.keystone.ph
v(02)330-2871,(02)330-2872; f(02)330-2873 | http://www.kuro.ph
Re: [nsp] Help with QoS [ In reply to ]
Thus spake <francisv@dagupan.com>
> I wanted to prioritize traffic coming from two workstations connected to a
> 2924 catalyst switch. The workstations are Windows Media encoders and serve
> traffic to Windows Media server/reflectors over a WAN link. On some
> occasions, the WAN link gets congested and the session between the encoders
> and servers is cutoff.
>
> Here's the network layout:
>
> [MS encoder machines]
> |
> [Catalyst 2924]
> | +--E1-->[to Cisco 1750 @ local IX]
> | /
> [Cisco 3640]--+
> \
> +--E1-->[to Cisco 7206 @ core]
>
> I labeled the packets on the ports where the encoders are connected with a
> value of 5:
>
> interface FastEthernet0/18
> description MS Media Encoder 1
> duplex full
> speed 100
> switchport priority default 5
> !
> interface FastEthernet0/19
> description MS Media Encoder 2
> duplex full
> speed 100
> switchport priority default 5
>
> and on the Cisco 3640, I created a class-map to match the COS from the
> switch and then do some stuff to it in a policy-map:
>
> class-map match-all COS5
> match cos 5
>
> policy-map HIGH-PRIORITY
> class COS5
> set ip dscp 10
> priority 128
>
> and then applying that to the outgoing interface:
>
> c3640-noc-cal(config-if)#service-policy output HIGH-PRIORITY
> 'match cos' supported only with IEEE 802.1Q/ISL interfaces
>
> I'm assuming that COS is not carried all the way to the router from the
> switch. Is there any other way around this? Will DSCP be carried over the
> WAN interface? I'd like to also look at the DSCP tag once it reaches other
> routers within our administrative control.

COS != DSCP

Use this on your router:

!
class-map COS4
match cos 4
!
policy-map cos-to-dscp
class COS4
set dscp 33
!
class-map AF41
match dscp 33
!
policy-map cos4-128k
class AF41
bandwidth 128
!
interface [from 2950]
sevice-policy input cos-to-dscp
!
interface [to E1]
service-policy output cos4-128k
!

S