Mailing List Archive

Help Cisco IOS XR 9001
Hello,

I am asking you for a little help, I just got an ASR9001 router and I am a
little confused with the IOS XR completely different from my ASR1001.

1- First problem, ISIS seems not to work

on my ASR1001X I have:
interface TenGigabitEthernet7/1
mtu 1600
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip

router isis
net 49.0001.0000.0000.0450.00
is-type level-2-only
metric-style wide
redistribute connected
!
address-family ipv6
multi-topology
redistribute connected
redistribute static
exit-address-family

connected on this port, I have the ASR9001 with in conf:

interface TenGigE0/0/2/0
mtu 1600
ipv4 address 192.168.1.2 255.255.255.252

router isis WanCmp
is-type level-2-only
net 49.0001.0000.0000.0452.00
address-family ipv6 unicast
!
interface TenGigE0/0/2/0
address-family ipv4 unicast
!
!
!


but when i put sh isis topo
Wed Sep 23 07:45:50.378 UTC

IS-IS phibee paths to IPv4 Unicast (Level-2) routers
System Id Metric Next-Hop Interface SNPA
ASR9001 --

Anyone have a idea of the problems ?


2- SSH/Telnet access to the router

currently I have to connect the ASR9001 router via the MgmtEth0 / RSP0 /
CPU0 / 0 port to access it.

Unable to go through the wan classic TenGigE0 / 0/2/0 interface

in my configuration, i have:

telnet vrf default ipv4 server max-servers 10

line console
exec-timeout 1440 0
escape-character 0x5a
session-limit 10
disconnect-character 0x59
session-timeout 100
transport input telnet ssh
transport output telnet ssh
transport preferred none
!
line default
exec-timeout 1440 0
access-class ingress admin-nets
transport input all
transport output telnet ssh
transport preferred none

vty-pool default 0 5 line-template default
control-plane
management-plane
out-of-band
interface TenGigE0/0/2/0
allow SSH peer
address ipv4 192.168.0.0/21
!
allow Telnet peer
address ipv4 192.168.0.0/21
!


ssh server v2
ssh server vrf default
ssh server vrf Mgmt-intf
end


if i want connect on wan interface, i have all time a connexion refused





thanks for your help
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: Help Cisco IOS XR 9001 [ In reply to ]
Regarding isis, it looks like you have MTU mismatch since you configured 1600 byte on both platforms.

IOS/XE doesn't count the Ethernet header (1600) while XR/JunOS does (1614).

You also need to add the interface under `mpls ldp`.

Sent from my Phone

> On 23 Sep 2020, at 17:25, Olivier CALVANO <o.calvano@gmail.com> wrote:
>
> ?Hello,
>
> I am asking you for a little help, I just got an ASR9001 router and I am a
> little confused with the IOS XR completely different from my ASR1001.
>
> 1- First problem, ISIS seems not to work
>
> on my ASR1001X I have:
> interface TenGigabitEthernet7/1
> mtu 1600
> ip address 192.168.1.1 255.255.255.252
> ip router isis
> mpls label protocol ldp
> mpls ip
>
> router isis
> net 49.0001.0000.0000.0450.00
> is-type level-2-only
> metric-style wide
> redistribute connected
> !
> address-family ipv6
> multi-topology
> redistribute connected
> redistribute static
> exit-address-family
>
> connected on this port, I have the ASR9001 with in conf:
>
> interface TenGigE0/0/2/0
> mtu 1600
> ipv4 address 192.168.1.2 255.255.255.252
>
> router isis WanCmp
> is-type level-2-only
> net 49.0001.0000.0000.0452.00
> address-family ipv6 unicast
> !
> interface TenGigE0/0/2/0
> address-family ipv4 unicast
> !
> !
> !
>
>
> but when i put sh isis topo
> Wed Sep 23 07:45:50.378 UTC
>
> IS-IS phibee paths to IPv4 Unicast (Level-2) routers
> System Id Metric Next-Hop Interface SNPA
> ASR9001 --
>
> Anyone have a idea of the problems ?
>
>
> 2- SSH/Telnet access to the router
>
> currently I have to connect the ASR9001 router via the MgmtEth0 / RSP0 /
> CPU0 / 0 port to access it.
>
> Unable to go through the wan classic TenGigE0 / 0/2/0 interface
>
> in my configuration, i have:
>
> telnet vrf default ipv4 server max-servers 10
>
> line console
> exec-timeout 1440 0
> escape-character 0x5a
> session-limit 10
> disconnect-character 0x59
> session-timeout 100
> transport input telnet ssh
> transport output telnet ssh
> transport preferred none
> !
> line default
> exec-timeout 1440 0
> access-class ingress admin-nets
> transport input all
> transport output telnet ssh
> transport preferred none
>
> vty-pool default 0 5 line-template default
> control-plane
> management-plane
> out-of-band
> interface TenGigE0/0/2/0
> allow SSH peer
> address ipv4 192.168.0.0/21
> !
> allow Telnet peer
> address ipv4 192.168.0.0/21
> !
>
>
> ssh server v2
> ssh server vrf default
> ssh server vrf Mgmt-intf
> end
>
>
> if i want connect on wan interface, i have all time a connexion refused
>
>
>
>
>
> thanks for your help
> _______________________________________________
> cisco-nsp mailing list cisco-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: Help Cisco IOS XR 9001 [ In reply to ]
CPP is the other issue.
ex
control-plane
management-plane
inband
interface hundred-gige0/1/1
allow SSH
allow blah


On Wed, Sep 23, 2020 at 12:51 PM Ted Pelas Johansson <tedpelas@gmail.com>
wrote:

> Regarding isis, it looks like you have MTU mismatch since you configured
> 1600 byte on both platforms.
>
> IOS/XE doesn't count the Ethernet header (1600) while XR/JunOS does (1614).
>
> You also need to add the interface under `mpls ldp`.
>
> Sent from my Phone
>
> > On 23 Sep 2020, at 17:25, Olivier CALVANO <o.calvano@gmail.com> wrote:
> >
> > ?Hello,
> >
> > I am asking you for a little help, I just got an ASR9001 router and I am
> a
> > little confused with the IOS XR completely different from my ASR1001.
> >
> > 1- First problem, ISIS seems not to work
> >
> > on my ASR1001X I have:
> > interface TenGigabitEthernet7/1
> > mtu 1600
> > ip address 192.168.1.1 255.255.255.252
> > ip router isis
> > mpls label protocol ldp
> > mpls ip
> >
> > router isis
> > net 49.0001.0000.0000.0450.00
> > is-type level-2-only
> > metric-style wide
> > redistribute connected
> > !
> > address-family ipv6
> > multi-topology
> > redistribute connected
> > redistribute static
> > exit-address-family
> >
> > connected on this port, I have the ASR9001 with in conf:
> >
> > interface TenGigE0/0/2/0
> > mtu 1600
> > ipv4 address 192.168.1.2 255.255.255.252
> >
> > router isis WanCmp
> > is-type level-2-only
> > net 49.0001.0000.0000.0452.00
> > address-family ipv6 unicast
> > !
> > interface TenGigE0/0/2/0
> > address-family ipv4 unicast
> > !
> > !
> > !
> >
> >
> > but when i put sh isis topo
> > Wed Sep 23 07:45:50.378 UTC
> >
> > IS-IS phibee paths to IPv4 Unicast (Level-2) routers
> > System Id Metric Next-Hop Interface SNPA
> > ASR9001 --
> >
> > Anyone have a idea of the problems ?
> >
> >
> > 2- SSH/Telnet access to the router
> >
> > currently I have to connect the ASR9001 router via the MgmtEth0 / RSP0 /
> > CPU0 / 0 port to access it.
> >
> > Unable to go through the wan classic TenGigE0 / 0/2/0 interface
> >
> > in my configuration, i have:
> >
> > telnet vrf default ipv4 server max-servers 10
> >
> > line console
> > exec-timeout 1440 0
> > escape-character 0x5a
> > session-limit 10
> > disconnect-character 0x59
> > session-timeout 100
> > transport input telnet ssh
> > transport output telnet ssh
> > transport preferred none
> > !
> > line default
> > exec-timeout 1440 0
> > access-class ingress admin-nets
> > transport input all
> > transport output telnet ssh
> > transport preferred none
> >
> > vty-pool default 0 5 line-template default
> > control-plane
> > management-plane
> > out-of-band
> > interface TenGigE0/0/2/0
> > allow SSH peer
> > address ipv4 192.168.0.0/21
> > !
> > allow Telnet peer
> > address ipv4 192.168.0.0/21
> > !
> >
> >
> > ssh server v2
> > ssh server vrf default
> > ssh server vrf Mgmt-intf
> > end
> >
> >
> > if i want connect on wan interface, i have all time a connexion refused
> >
> >
> >
> >
> >
> > thanks for your help
> > _______________________________________________
> > cisco-nsp mailing list cisco-nsp@puck.nether.net
> > https://puck.nether.net/mailman/listinfo/cisco-nsp
> > archive at http://puck.nether.net/pipermail/cisco-nsp/
> _______________________________________________
> cisco-nsp mailing list cisco-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: Help Cisco IOS XR 9001 [ In reply to ]
On 9/23/20 12:48 PM, Ted Pelas Johansson wrote:
> router isis WanCmp
> is-type level-2-only
> net 49.0001.0000.0000.0452.00
> address-family ipv6 unicast
> !
> interface TenGigE0/0/2/0
> address-family ipv4 unicast
> !



You'll also need this for each AF...


address-family ipv4 unicast
metric-style wide



and as others have mentioned, probably:

interface TenGigE0/0/2/0
mtu 1614

--
inoc.net!rblayzor
XMPP: rblayzor.AT.inoc.net
PGP: https://pgp.inoc.net/rblayzor/
_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
Re: Help Cisco IOS XR 9001 [ In reply to ]
> From: cisco-nsp <cisco-nsp-bounces@puck.nether.net> On Behalf Of Olivier
> CALVANO
> Sent: Wednesday, September 23, 2020 4:20 PM
>
> Hello,
>
> I am asking you for a little help, I just got an ASR9001 router and I am a
little
> confused with the IOS XR completely different from my ASR1001.
>
What other said will keep you going (for now), but there will be other
surprises (bgp default deny-all on im/ex springs to mind).
I suggest you read the book "ios xr fundamentals" so you can get the most
out of your ASR9001/XR.


adam

_______________________________________________
cisco-nsp mailing list cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/