Mailing List Archive

[nsp] Not using "redist sta sub" in OSPF
Hi

I've been reading Cisco's "IOS Essentials" paper
(http://www.cisco.com/public/cons/isp/essentials/IOS_Essentials_2-9.pdf)
which mentions you rarely need to redistribute anything into an IGP. It
recommends using "network x.x.x.x" over redist (static|connected).

I have a few static routes pointing at frame relay subifs that I'd like
to get into OSPF, without using "redist sta sub" as that redistributes
all the static routes I have.

interface Loopback0
ip address 192.168.1.240 255.255.255.255
!
interface Serial2/0
no ip address
encapsulation frame-relay
framing g751
dsu bandwidth 34010
frame-relay lmi-type ansi
!
interface Serial2/0.101 point-to-point
ip unnumbered Loopback0
frame-relay interface-dlci 101 IETF
!
router ospf 100
router-id 192.168.1.240
log-adjacency-changes
redistribute static subnets
passive-interface Serial2/0
passive-interface Serial2/0.101
passive-interface Loopback0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0 ! doesn't work
!
ip route 192.168.20.16 255.255.255.240 Serial2/0.101

I tried using "network 192.168.20.0 0.0.0.255 area 0" but that doesn't
work (not a surprise after consulting documentation). Is there a better
way to do this?

Cheers,

--

Mark Drayton
izR Solutions Ltd
Tel: +44 08707 447799
Re: [nsp] Not using "redist sta sub" in OSPF [ In reply to ]
On Fri, 9 Aug 2002 10:30:47 +0100 Mark Drayton <mark.drayton@izrsolutions.com> wrote:
> I have a few static routes pointing at frame relay subifs that I'd like
> to get into OSPF, without using "redist sta sub" as that redistributes
> all the static routes I have.
[snip]
> I tried using "network 192.168.20.0 0.0.0.255 area 0" but that doesn't
> work (not a surprise after consulting documentation). Is there a better
> way to do this?

Use a route-map on the redistribute command, like this:

router ospf 100
redistribute static 1 subnets route-map static-to-ospf

route-map static-to-ospf permit 10
match ip address 1

access-list 1 permit host 192.168.20.0

--
Ryan O'Connell - CCIE #8174
<ryan@complicity.co.uk> - http://www.complicity.co.uk

I'm not losing my mind, no I'm not changing my lines,
I'm just learning new things with the passage of time
RE: [nsp] Not using "redist sta sub" in OSPF [ In reply to ]
usually the confusion comes from the difference of the 'network x.x.x.x'
command meaning in routing protocols. i mean:

- in bgp, it means 'originate this PREFIX if present in the routing
table' (of course if other conditions are met - like synchronization
etc.). that means, _directly_ triggering announcements. it applies to
ANY routes (connected, static, dynamic from igp's etc.)

- in ospf, it means 'activate ospf on all interfaces whose ip addressess
comply to this WILDCARD'. this turns on hello's etc but also makes the
router advertising this as the ospf router link - thus _indirectly_
triggering the announcements. it applies to CONNECTED routes only (so
even if a static route complies to the wildcard it is not originated by
the 'network' command)

- etc for other routing protocols

- so as ryan said, use controlled 'redistribute static'


hope this helps


deejay

--

Tomas Daniska
systems engineer
Tronet Computer Networks
Plynarenska 5, 829 75 Bratislava, Slovakia
tel: +421 2 58224111, fax: +421 2 58224199

A transistor protected by a fast-acting fuse will protect the fuse by
blowing first.



> -----Original Message-----
> From: Ryan O'Connell [mailto:ryan@complicity.co.uk]
> Sent: 9. augusta 2002 11:49
> To: Mark Drayton; cisco-nsp@puck.nether.net
> Subject: Re: [nsp] Not using "redist sta sub" in OSPF
>
>
> On Fri, 9 Aug 2002 10:30:47 +0100 Mark Drayton
> <mark.drayton@izrsolutions.com> wrote:
> > I have a few static routes pointing at frame relay subifs
> that I'd like
> > to get into OSPF, without using "redist sta sub" as that
> redistributes
> > all the static routes I have.
> [snip]
> > I tried using "network 192.168.20.0 0.0.0.255 area 0" but
> that doesn't
> > work (not a surprise after consulting documentation). Is
> there a better
> > way to do this?
>
> Use a route-map on the redistribute command, like this:
>
> router ospf 100
> redistribute static 1 subnets route-map static-to-ospf
>
> route-map static-to-ospf permit 10
> match ip address 1
>
> access-list 1 permit host 192.168.20.0
>
> --
> Ryan O'Connell - CCIE #8174
> <ryan@complicity.co.uk> - http://www.complicity.co.uk
>
> I'm not losing my mind, no I'm not changing my lines,
> I'm just learning new things with the passage of time
>
> _______________________________________________
> cisco-nsp mailing list real_name)s@puck.nether.net
> http://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
RE: [nsp] Not using "redist sta sub" in OSPF [ In reply to ]
I don't see the logic of using "network" statements over redistributing
statics. If I have a customer connected on a leased line (numbered with a
/30 or /31 subnet) and they have a /24 on the back of their CPE router how
am I supposed to announce the route back into my IGP? Speak a routing
protocol with the CPE device (which I'd say is much more dangerous than
using statics)? Using a route-map as Ryan suggests would seem the pragmatic
solution to avoid any screw-ups by adding an incorrect static.


Matt.

-----Original Message-----
From: Ryan O'Connell [mailto:ryan@complicity.co.uk]
Sent: 09 August 2002 10:49
To: Mark Drayton; cisco-nsp@puck.nether.net
Subject: Re: [nsp] Not using "redist sta sub" in OSPF


On Fri, 9 Aug 2002 10:30:47 +0100 Mark Drayton
<mark.drayton@izrsolutions.com> wrote:
> I have a few static routes pointing at frame relay subifs that I'd like
> to get into OSPF, without using "redist sta sub" as that redistributes
> all the static routes I have.
[snip]
> I tried using "network 192.168.20.0 0.0.0.255 area 0" but that doesn't
> work (not a surprise after consulting documentation). Is there a better
> way to do this?

Use a route-map on the redistribute command, like this:

router ospf 100
redistribute static 1 subnets route-map static-to-ospf

route-map static-to-ospf permit 10
match ip address 1

access-list 1 permit host 192.168.20.0

--
Ryan O'Connell - CCIE #8174
<ryan@complicity.co.uk> - http://www.complicity.co.uk

I'm not losing my mind, no I'm not changing my lines,
I'm just learning new things with the passage of time

_______________________________________________
cisco-nsp mailing list real_name)s@puck.nether.net
http://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

------------------------------------------------------------------------------
Live Life in Broadband
www.telewest.co.uk


The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential and/or privileged material.
Statements and opinions expressed in this e-mail may not represent those of the company. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender immediately and delete the material from any computer.


==============================================================================
Re: [nsp] Not using "redist sta sub" in OSPF [ In reply to ]
Matt Ryan wrote:

>I don't see the logic of using "network" statements over redistributing
>statics.
>
Assuming its a customer CPE, not administered by you, and there are no
alternate paths to it (conditions that were not specified in the
original post, but may well be true), then using statics and
redistributing via route map is appropriate.

In general, redistribution is bad. In OSPF, by default, a redistributed
route will be injected into OSPF as a type II external route. This
means it will flow to all areas, regardless of route summarization on
the ABR's, and could destroy the scalability of the network design. (Not
really an issue in a small simple net, unless you end up growing beyond
your plans.)

If the equipment is administered by you, I'd probably run OSPF on it.
If not, and there are alternate paths, you need BGP.

> If I have a customer connected on a leased line (numbered with a
>/30 or /31 subnet) and they have a /24 on the back of their CPE router how
>am I supposed to announce the route back into my IGP? Speak a routing
>protocol with the CPE device (which I'd say is much more dangerous than
>using statics)? Using a route-map as Ryan suggests would seem the pragmatic
>solution to avoid any screw-ups by adding an incorrect static.
>
>
>Matt.
>
>-----Original Message-----
>From: Ryan O'Connell [mailto:ryan@complicity.co.uk]
>Sent: 09 August 2002 10:49
>To: Mark Drayton; cisco-nsp@puck.nether.net
>Subject: Re: [nsp] Not using "redist sta sub" in OSPF
>
>
>On Fri, 9 Aug 2002 10:30:47 +0100 Mark Drayton
><mark.drayton@izrsolutions.com> wrote:
>
>>I have a few static routes pointing at frame relay subifs that I'd like
>>to get into OSPF, without using "redist sta sub" as that redistributes
>>all the static routes I have.
>>
>[snip]
>
>>I tried using "network 192.168.20.0 0.0.0.255 area 0" but that doesn't
>>work (not a surprise after consulting documentation). Is there a better
>>way to do this?
>>
>
>Use a route-map on the redistribute command, like this:
>
>router ospf 100
> redistribute static 1 subnets route-map static-to-ospf
>
>route-map static-to-ospf permit 10
> match ip address 1
>
>access-list 1 permit host 192.168.20.0
>
>--
> Ryan O'Connell - CCIE #8174
><ryan@complicity.co.uk> - http://www.complicity.co.uk
>
>I'm not losing my mind, no I'm not changing my lines,
>I'm just learning new things with the passage of time
>
>_______________________________________________
>cisco-nsp mailing list real_name)s@puck.nether.net
>http://puck.nether.net/mailman/listinfo/cisco-nsp
>archive at http://puck.nether.net/pipermail/cisco-nsp/
>
>------------------------------------------------------------------------------
>Live Life in Broadband
>www.telewest.co.uk
>
>
>The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential and/or privileged material.
>Statements and opinions expressed in this e-mail may not represent those of the company. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender immediately and delete the material from any computer.
>
>
>==============================================================================
>
>_______________________________________________
>cisco-nsp mailing list real_name)s@puck.nether.net
>http://puck.nether.net/mailman/listinfo/cisco-nsp
>archive at http://puck.nether.net/pipermail/cisco-nsp/
>
RE: [nsp] Not using "redist sta sub" in OSPF [ In reply to ]
>In general, redistribution is bad. In OSPF, by default, a redistributed
route will be
>injected into OSPF as a type II external route. This means it will flow to
all areas,
>regardless of route summarization on the ABR's, and could destroy the
scalability of the
>network design. (Not really an issue in a small simple net, unless you end
up growing
>beyond your plans.)

I don't believe this is the case - the stability of an link state protocol
link OSPF is governed by the number of branches in the SPF tree that the
routers have to recalculate when a topology change occurs - externals are
leaves and therefore do not have a impact on CPU (but do, of course, take up
additional memory). If a significant number of customer specific routes are
redistributed into the IGP it's easy to make them contiguous and then just
redistribute the supernet.


Matt.

------------------------------------------------------------------------------
Live Life in Broadband
www.telewest.co.uk


The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential and/or privileged material.
Statements and opinions expressed in this e-mail may not represent those of the company. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender immediately and delete the material from any computer.


==============================================================================