Mailing List Archive

[nsp] Type-7 LSA not getting put into table
I am having a problem.

I have a ASBR that is originating a Type 7 LSA. This ASBR is in a NSSA
(area 11) and is connected to its ABR via a serial link.

The Type 7 LSA is making it to the ABR, but there is no route installed.
I am not getting the "Routing Bit Set on this LSA", on the ABR, and I am
not sure why.......

If anyone can show me what I am doing wrong, I would appreciate it.

Brian


The ASBR
========
interface Loopback0
ip address 207.254.193.57 255.255.255.255
!
interface Ethernet0
ip address 207.254.193.145 255.255.255.240
!
interface Serial0
ip address 207.254.193.186 255.255.255.252
!
router ospf 10
area 11 nssa
redistribute connected subnets
redistribute static subnets
redistribute rip subnets
passive-interface Ethernet0
network 207.254.193.144 0.0.0.15 area 11
network 207.254.193.184 0.0.0.3 area 11
!
router rip
version 2
passive-interface Ethernet0
passive-interface Serial0
passive-interface Serial1
network 207.254.193.0
no auto-summary

longview-gw#show ip route rip
207.254.201.0/25 is subnetted, 1 subnets
R 207.254.201.0 [120/1] via 207.254.193.148, 00:00:04, Ethernet0


longview-gw#show ip ospf data nssa-external 207.254.201.0

OSPF Router with ID (207.254.193.57) (Process ID 10)


Type-7 AS External Link States (Area 11)

LS age: 1006
Options: (No TOS-capability, Type 7/5 translation, DC)
LS Type: AS External Link
Link State ID: 207.254.201.0 (External Network Number )
Advertising Router: 207.254.193.57
LS Seq Number: 80000001
Checksum: 0xEDA3
Length: 36
Network Mask: /25
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward Address: 207.254.193.145
External Route Tag: 0


The ABR
=======
router ospf 10
log-adjacency-changes
area 11 nssa default-information-originate
redistribute connected subnets
redistribute static subnets
network 207.254.193.32 0.0.0.15 area 0
network 207.254.193.184 0.0.0.3 area 11

cygnus#show ip ospf database nssa-external 207.254.201.0

OSPF Router with ID (207.254.193.53) (Process ID 10)

Type-7 AS External Link States (Area 11)

LS age: 1054
Options: (No TOS-capability, Type 7/5 translation, DC)
LS Type: AS External Link
Link State ID: 207.254.201.0 (External Network Number )
Advertising Router: longview-gw.shreve.net
LS Seq Number: 80000001
Checksum: 0xEDA3
Length: 36
Network Mask: /25
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward Address: 207.254.193.145
External Route Tag: 0



-----------------------------------------------
Brian Feeny, CCIE #8036 e: signal@shreve.net
Network Engineer p: 318.222.2638x109
ShreveNet Inc. f: 318.221.6612
RE: [nsp] Type-7 LSA not getting put into table [ In reply to ]
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

http://www.cisco.com/warp/public/104/nssa.html

Redistributed RIP routes won't be allowed in area 1 because NSSA is
an extension to the stub area. The stub area characteristics still
exist, including no type 5 LSAs allowed.

==DMT>

- ----SIGNAURE-------
Douglas M. Todd, Jr.
CCNA, CCNP, CIT
Network Engineering
Partners Health Care
Building 149
149 13 Street
Charlestown, MA 02129-200
Tel: 617.726.1403
Email: dtodd@partners.org
- --------------------------------------------------------------------
PGP Finger Print: 9429 CAE3 B2D1 C2E1 DFBC E7A6 E90A 9BE5 C7B6 47BC
Key available via email.
Verisign S/N: 3ff65cdf58b9dceda004baeed49e16cf
https://digitalid.verisign.com/services/client/index.html

> -----Original Message-----
> From: Brian [mailto:signal@shreve.net]
> Sent: Tuesday, July 30, 2002 8:52 PM
> To: cisco-nsp@puck.nether.net
> Subject: [nsp] Type-7 LSA not getting put into table
>
>
>
>
> I am having a problem.
>
> I have a ASBR that is originating a Type 7 LSA. This ASBR is
> in a NSSA
> (area 11) and is connected to its ABR via a serial link.
>
> The Type 7 LSA is making it to the ABR, but there is no route
> installed.
> I am not getting the "Routing Bit Set on this LSA", on the
> ABR, and I am
> not sure why.......
>
> If anyone can show me what I am doing wrong, I would appreciate it.
>
> Brian
>
>
> The ASBR
> ========
> interface Loopback0
> ip address 207.254.193.57 255.255.255.255
> !
> interface Ethernet0
> ip address 207.254.193.145 255.255.255.240
> !
> interface Serial0
> ip address 207.254.193.186 255.255.255.252
> !
> router ospf 10
> area 11 nssa
> redistribute connected subnets
> redistribute static subnets
> redistribute rip subnets
> passive-interface Ethernet0
> network 207.254.193.144 0.0.0.15 area 11
> network 207.254.193.184 0.0.0.3 area 11
> !
> router rip
> version 2
> passive-interface Ethernet0
> passive-interface Serial0
> passive-interface Serial1
> network 207.254.193.0
> no auto-summary
>
> longview-gw#show ip route rip
> 207.254.201.0/25 is subnetted, 1 subnets
> R 207.254.201.0 [120/1] via 207.254.193.148, 00:00:04,
> Ethernet0
>
>
> longview-gw#show ip ospf data nssa-external 207.254.201.0
>
> OSPF Router with ID (207.254.193.57) (Process ID 10)
>
>
> Type-7 AS External Link States (Area 11)
>
> LS age: 1006
> Options: (No TOS-capability, Type 7/5 translation, DC)
> LS Type: AS External Link
> Link State ID: 207.254.201.0 (External Network Number )
> Advertising Router: 207.254.193.57
> LS Seq Number: 80000001
> Checksum: 0xEDA3
> Length: 36
> Network Mask: /25
> Metric Type: 2 (Larger than any link state path)
> TOS: 0
> Metric: 20
> Forward Address: 207.254.193.145
> External Route Tag: 0
>
>
> The ABR
> =======
> router ospf 10
> log-adjacency-changes
> area 11 nssa default-information-originate
> redistribute connected subnets
> redistribute static subnets
> network 207.254.193.32 0.0.0.15 area 0
> network 207.254.193.184 0.0.0.3 area 11
>
> cygnus#show ip ospf database nssa-external 207.254.201.0
>
> OSPF Router with ID (207.254.193.53) (Process ID 10)
>
> Type-7 AS External Link States (Area 11)
>
> LS age: 1054
> Options: (No TOS-capability, Type 7/5 translation, DC)
> LS Type: AS External Link
> Link State ID: 207.254.201.0 (External Network Number )
> Advertising Router: longview-gw.shreve.net
> LS Seq Number: 80000001
> Checksum: 0xEDA3
> Length: 36
> Network Mask: /25
> Metric Type: 2 (Larger than any link state path)
> TOS: 0
> Metric: 20
> Forward Address: 207.254.193.145
> External Route Tag: 0
>
>
>
> -----------------------------------------------
> Brian Feeny, CCIE #8036 e: signal@shreve.net
> Network Engineer p: 318.222.2638x109
> ShreveNet Inc. f: 318.221.6612
>
>
> _______________________________________________
> cisco-nsp mailing list real_name)s@puck.nether.net
> http://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/

-----BEGIN PGP SIGNATURE-----
Version: PGP 7.0

iQA/AwUBPUqk2wgiZycqTvq3EQJJEQCgktRmsBOY7OBkO0j4s/uQbC+TGrEAn2wl
m9Wyn06xO6dnCDiA2oZTFl49
=w/cR
-----END PGP SIGNATURE-----
RE: [nsp] Type-7 LSA not getting put into table [ In reply to ]
Todd,

yes, I understand, but that "rule" applies *only* to area 1, and not to
area 0 and 11 which are the only two I am dealing with.

What it turned out to be was this. The Type-7 LSA was listed in the OSPF
Database with a Forwarding Address of 207.254.193.145.

A static route was in the router of:

ip address 207.254.193.144 255.255.255.240 207.254.193.186

That killed it right there. Because to OSPF the forwarding address is
being learned externally to OSPF, and it doesnt like that. Removing
the static route fixed everything. The static route was "correct", in
that the subnet was being routed to the correct place, but OSPF doesnt
like it, and its common. I was used to seeing it with external routing
processes like BGP or RIP, and never thought of statics as messing it up.

We bring up remotes alot of times on static, and then do the intial config
and migrate over to an IGP like OSPF. The static was never removed and
gave us some hell.

Brian


On Fri, 2 Aug 2002, Todd, Douglas M. wrote:

>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> http://www.cisco.com/warp/public/104/nssa.html
>
> Redistributed RIP routes won't be allowed in area 1 because NSSA is
> an extension to the stub area. The stub area characteristics still
> exist, including no type 5 LSAs allowed.
>
> ==DMT>
>
> - ----SIGNAURE-------
> Douglas M. Todd, Jr.
> CCNA, CCNP, CIT
> Network Engineering
> Partners Health Care
> Building 149
> 149 13 Street
> Charlestown, MA 02129-200
> Tel: 617.726.1403
> Email: dtodd@partners.org
> - --------------------------------------------------------------------
> PGP Finger Print: 9429 CAE3 B2D1 C2E1 DFBC E7A6 E90A 9BE5 C7B6 47BC
> Key available via email.
> Verisign S/N: 3ff65cdf58b9dceda004baeed49e16cf
> https://digitalid.verisign.com/services/client/index.html
>
> > -----Original Message-----
> > From: Brian [mailto:signal@shreve.net]
> > Sent: Tuesday, July 30, 2002 8:52 PM
> > To: cisco-nsp@puck.nether.net
> > Subject: [nsp] Type-7 LSA not getting put into table
> >
> >
> >
> >
> > I am having a problem.
> >
> > I have a ASBR that is originating a Type 7 LSA. This ASBR is
> > in a NSSA
> > (area 11) and is connected to its ABR via a serial link.
> >
> > The Type 7 LSA is making it to the ABR, but there is no route
> > installed.
> > I am not getting the "Routing Bit Set on this LSA", on the
> > ABR, and I am
> > not sure why.......
> >
> > If anyone can show me what I am doing wrong, I would appreciate it.
> >
> > Brian
> >
> >
> > The ASBR
> > ========
> > interface Loopback0
> > ip address 207.254.193.57 255.255.255.255
> > !
> > interface Ethernet0
> > ip address 207.254.193.145 255.255.255.240
> > !
> > interface Serial0
> > ip address 207.254.193.186 255.255.255.252
> > !
> > router ospf 10
> > area 11 nssa
> > redistribute connected subnets
> > redistribute static subnets
> > redistribute rip subnets
> > passive-interface Ethernet0
> > network 207.254.193.144 0.0.0.15 area 11
> > network 207.254.193.184 0.0.0.3 area 11
> > !
> > router rip
> > version 2
> > passive-interface Ethernet0
> > passive-interface Serial0
> > passive-interface Serial1
> > network 207.254.193.0
> > no auto-summary
> >
> > longview-gw#show ip route rip
> > 207.254.201.0/25 is subnetted, 1 subnets
> > R 207.254.201.0 [120/1] via 207.254.193.148, 00:00:04,
> > Ethernet0
> >
> >
> > longview-gw#show ip ospf data nssa-external 207.254.201.0
> >
> > OSPF Router with ID (207.254.193.57) (Process ID 10)
> >
> >
> > Type-7 AS External Link States (Area 11)
> >
> > LS age: 1006
> > Options: (No TOS-capability, Type 7/5 translation, DC)
> > LS Type: AS External Link
> > Link State ID: 207.254.201.0 (External Network Number )
> > Advertising Router: 207.254.193.57
> > LS Seq Number: 80000001
> > Checksum: 0xEDA3
> > Length: 36
> > Network Mask: /25
> > Metric Type: 2 (Larger than any link state path)
> > TOS: 0
> > Metric: 20
> > Forward Address: 207.254.193.145
> > External Route Tag: 0
> >
> >
> > The ABR
> > =======
> > router ospf 10
> > log-adjacency-changes
> > area 11 nssa default-information-originate
> > redistribute connected subnets
> > redistribute static subnets
> > network 207.254.193.32 0.0.0.15 area 0
> > network 207.254.193.184 0.0.0.3 area 11
> >
> > cygnus#show ip ospf database nssa-external 207.254.201.0
> >
> > OSPF Router with ID (207.254.193.53) (Process ID 10)
> >
> > Type-7 AS External Link States (Area 11)
> >
> > LS age: 1054
> > Options: (No TOS-capability, Type 7/5 translation, DC)
> > LS Type: AS External Link
> > Link State ID: 207.254.201.0 (External Network Number )
> > Advertising Router: longview-gw.shreve.net
> > LS Seq Number: 80000001
> > Checksum: 0xEDA3
> > Length: 36
> > Network Mask: /25
> > Metric Type: 2 (Larger than any link state path)
> > TOS: 0
> > Metric: 20
> > Forward Address: 207.254.193.145
> > External Route Tag: 0
> >
> >
> >
> > -----------------------------------------------
> > Brian Feeny, CCIE #8036 e: signal@shreve.net
> > Network Engineer p: 318.222.2638x109
> > ShreveNet Inc. f: 318.221.6612
> >
> >
> > _______________________________________________
> > cisco-nsp mailing list real_name)s@puck.nether.net
> > http://puck.nether.net/mailman/listinfo/cisco-nsp
> > archive at http://puck.nether.net/pipermail/cisco-nsp/
>
> -----BEGIN PGP SIGNATURE-----
> Version: PGP 7.0
>
> iQA/AwUBPUqk2wgiZycqTvq3EQJJEQCgktRmsBOY7OBkO0j4s/uQbC+TGrEAn2wl
> m9Wyn06xO6dnCDiA2oZTFl49
> =w/cR
> -----END PGP SIGNATURE-----
>

-----------------------------------------------
Brian Feeny, CCIE #8036 e: signal@shreve.net
Network Engineer p: 318.222.2638x109
ShreveNet Inc. f: 318.221.6612