Mailing List Archive

ping fails over dialer interface
Hi,

I have cisco850 - pppoe client, i am unable to ping to the default gw on
the bras.
pc-----cisco850(CPE)-------netgearSwitch(pvid 4001)------BRAS

cisco-850 gets a ip address from BRAS as 172.16.1.3. multibind interface
at BRAS is 172.16.1.254.
so when i try to ping 172.16.1.254 from cisco, encapsulation fails, may be
arp res

cpe1#sh run
Building configuration...

Current configuration : 1540 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cpe1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$pb71$nc1Bi.IaAJLdMPXtXeggO0
enable password test123
!
no aaa new-model
!
resource policy
!
ip subnet-zero
no ip routing
no ip dhcp use vrf connected
!
ip dhcp pool myownpool
import all
network 192.168.100.0 255.255.255.0
dns-server 68.2.16.25
lease 7
!
!
no ip cef
vpdn enable
!
!
!
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
description "UPLINK connected to BRAS"
no ip address
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
description "dhcp interface for home-users"
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname team@teambackbone
ppp chap password 0 team
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password test
login
!
scheduler max-task-time 5000
end


cpe1#ping 172.16.1.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.254, timeout is 2 seconds:

*Mar 1 06:55:26.082: IP: tableid=0, s=172.16.1.4 (local),
d=172.16.1.254(Dialer0), routed via RIB
*Mar 1 06:55:26.082: IP: s=172.16.1.4 (local), d=172.16.1.254 (Dialer0),
len 100, sending
03C2C9D0: 45000064 004E0000 E..d.N..
03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M


1 06:55:26.082: IP: s=172.16.1.4 (local), d=172.16.1.254 (Dialer0), len
100, sending
03C2C9D0: 45000064 004E0000 E..d.N..
03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
03C2CA30: ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M
*Mar 1 06:55:26.086: IP ARP: creating incomplete entry for IP address:
172.16.1.254 interface Vlan1
*Mar 1 06:55:26.086: IP ARP: sent req src 192.168.100.1 0018.1849.c9ee,
dst 172.16.1.254 0000.0000.0000 Vlan1
*Mar 1 06:55:26.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
dst 172.16.1.254 0000.0000.0000 Dialer0
*Mar 1 06:55:27.086: IP ARP: sent req src 192.168.100.1 0018.1849.c9ee,
dst 172.16.1.254 0000.0000.0000 Vlan1
*Mar 1 06:55:27.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
dst 172.16.1.254 0000.0000.0000 Dialer0.
*Mar 1 06:55:28.086: IP ARP: sent req src 192.168.100.1 0018.1849.c9ee,
dst 172.16.1.254 0000.0000.0000 Vlan1
*Mar 1 06:55:28.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
dst 172.16.1.254 0000.0000.0000 Dialer0
*Mar 1 06:55:29.086: IP ARP: sent req src 192.168.100.1 0018.1849.c9ee,
dst 172.16.1.254 0000.0000.0000 Vlan1
*Mar 1 06:55:29.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
dst 172.16.1.254 0000.0000.0000 Dialer0
*Mar 1 06:55:29.086: IP: s=172.16.1.4 (local), d=172.16.1.254 (Dialer0),
len 100, encapsulation failed
03C2C9D0: 45000064 004E0000 E..d.N..
03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
Re: ping fails over dialer interface [ In reply to ]
Hi Dinesh,

Have a look through your NAT translations.

Depending on what you're trying to achieve the "ip nat outside"
should be on FastEthernet4 possibly.

Have a read of this to see if if your setup is similar.

http://www.cisco.com/en/US/docs/routers/access/800/850/software/
configuration/guide/pppoenat.html#wp1235296


--

Shaineel Singh
IP/MPLS Engineering
AAPT Pty Ltd

phone: +613 8308 3567
email: shain.singh@aapt.com.au



On 26/09/2008, at 10:18 AM, Dinesh Bhonsle wrote:

> Hi,
>
> I have cisco850 - pppoe client, i am unable to ping to the default
> gw on the bras.
> pc-----cisco850(CPE)-------netgearSwitch(pvid 4001)------BRAS
>
> cisco-850 gets a ip address from BRAS as 172.16.1.3. multibind
> interface at BRAS is 172.16.1.254.
> so when i try to ping 172.16.1.254 from cisco, encapsulation fails,
> may be arp res
>
> cpe1#sh run
> Building configuration...
>
> Current configuration : 1540 bytes
> !
> version 12.4
> no service pad
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname cpe1
> !
> boot-start-marker
> boot-end-marker
> !
> enable secret 5 $1$pb71$nc1Bi.IaAJLdMPXtXeggO0
> enable password test123
> !
> no aaa new-model
> !
> resource policy
> !
> ip subnet-zero
> no ip routing
> no ip dhcp use vrf connected
> !
> ip dhcp pool myownpool
> import all
> network 192.168.100.0 255.255.255.0
> dns-server 68.2.16.25
> lease 7
> !
> !
> no ip cef
> vpdn enable
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface FastEthernet0
> !
> interface FastEthernet1
> shutdown
> !
> interface FastEthernet2
> shutdown
> !
> interface FastEthernet3
> shutdown
> !
> interface FastEthernet4
> description "UPLINK connected to BRAS"
> no ip address
> ip virtual-reassembly
> no ip route-cache
> duplex auto
> speed auto
> pppoe enable group global
> pppoe-client dial-pool-number 1
> !
> interface Vlan1
> description "dhcp interface for home-users"
> ip address 192.168.100.1 255.255.255.0
> ip nat inside
> ip virtual-reassembly
> no ip route-cache
> !
> interface Dialer0
> ip address negotiated
> ip mtu 1492
> ip nat outside
> ip virtual-reassembly
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> ppp chap hostname team@teambackbone
> ppp chap password 0 team
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer0
> !
> no ip http server
> no ip http secure-server
> ip nat inside source list 1 interface Dialer0 overload
> !
> dialer-list 1 protocol ip permit
> !
> control-plane
> !
> !
> line con 0
> no modem enable
> line aux 0
> line vty 0 4
> password test
> login
> !
> scheduler max-task-time 5000
> end
>
>
> cpe1#ping 172.16.1.254
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 172.16.1.254, timeout is 2 seconds:
>
> *Mar 1 06:55:26.082: IP: tableid=0, s=172.16.1.4 (local),
> d=172.16.1.254 (Dialer0), routed via RIB
> *Mar 1 06:55:26.082: IP: s=172.16.1.4 (local), d=172.16.1.254
> (Dialer0), len 100, sending
> 03C2C9D0: 45000064 004E0000 E..d.N..
> 03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
> 03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
> 03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
>
>
> 1 06:55:26.082: IP: s=172.16.1.4 (local), d=172.16.1.254
> (Dialer0), len 100, sending
> 03C2C9D0: 45000064 004E0000 E..d.N..
> 03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
> 03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
> 03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA30: ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M
> *Mar 1 06:55:26.086: IP ARP: creating incomplete entry for IP
> address: 172.16.1.254 interface Vlan1
> *Mar 1 06:55:26.086: IP ARP: sent req src 192.168.100.1
> 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:26.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:27.086: IP ARP: sent req src 192.168.100.1
> 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:27.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0.
> *Mar 1 06:55:28.086: IP ARP: sent req src 192.168.100.1
> 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:28.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:29.086: IP ARP: sent req src 192.168.100.1
> 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:29.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:29.086: IP: s=172.16.1.4 (local), d=172.16.1.254
> (Dialer0), len 100, encapsulation failed
> 03C2C9D0: 45000064 004E0000 E..d.N..
> 03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
> 03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
> 03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
>
>
> _______________________________________________
> cisco-nas mailing list
> cisco-nas@puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nas


This communication, including any attachments, is confidential. If you are not the intended recipient, you should not read it - please contact me immediately, destroy it, and do not copy or use any part of this communication or disclose anything about it.
Re: ping fails over dialer interface [ In reply to ]
Dinesh,

the cisco shouldn't arp for any address over the Dialer, it's a p2p
interface.

Looking at the config: you have routing disabled! please enable this
("ip routing"), and please also enable CEF ("ip cef" globally and "ip
route-cache"/"ip route-cache cef" on all the interfaces..

oli

Dinesh Bhonsle <> wrote on Friday, September 26, 2008 2:19 AM:

> Hi,
>
> I have cisco850 - pppoe client, i am unable to ping to the default
> gw on the bras. pc-----cisco850(CPE)-------netgearSwitch(pvid
> 4001)------BRAS
>
> cisco-850 gets a ip address from BRAS as 172.16.1.3. multibind
> interface at BRAS is 172.16.1.254. so when i try to ping 172.16.1.254
> from cisco, encapsulation fails, may be arp res
>
> cpe1#sh run
> Building configuration...
>
> Current configuration : 1540 bytes
> !
> version 12.4
> no service pad
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname cpe1
> !
> boot-start-marker
> boot-end-marker
> !
> enable secret 5 $1$pb71$nc1Bi.IaAJLdMPXtXeggO0
> enable password test123
> !
> no aaa new-model
> !
> resource policy
> !
> ip subnet-zero
> no ip routing
> no ip dhcp use vrf connected
> !
> ip dhcp pool myownpool
> import all
> network 192.168.100.0 255.255.255.0
> dns-server 68.2.16.25
> lease 7
> !
> !
> no ip cef
> vpdn enable
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface FastEthernet0
> !
> interface FastEthernet1
> shutdown
> !
> interface FastEthernet2
> shutdown
> !
> interface FastEthernet3
> shutdown
> !
> interface FastEthernet4
> description "UPLINK connected to BRAS"
> no ip address
> ip virtual-reassembly
> no ip route-cache
> duplex auto
> speed auto
> pppoe enable group global
> pppoe-client dial-pool-number 1
> !
> interface Vlan1
> description "dhcp interface for home-users"
> ip address 192.168.100.1 255.255.255.0
> ip nat inside
> ip virtual-reassembly
> no ip route-cache
> !
> interface Dialer0
> ip address negotiated
> ip mtu 1492
> ip nat outside
> ip virtual-reassembly
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> ppp chap hostname team@teambackbone
> ppp chap password 0 team
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer0
> !
> no ip http server
> no ip http secure-server
> ip nat inside source list 1 interface Dialer0 overload
> !
> dialer-list 1 protocol ip permit
> !
> control-plane
> !
> !
> line con 0
> no modem enable
> line aux 0
> line vty 0 4
> password test
> login
> !
> scheduler max-task-time 5000
> end
>
>
> cpe1#ping 172.16.1.254
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 172.16.1.254, timeout is 2 seconds:
>
> *Mar 1 06:55:26.082: IP: tableid=0, s=172.16.1.4 (local),
> d=172.16.1.254 (Dialer0), routed via RIB
> *Mar 1 06:55:26.082: IP: s=172.16.1.4 (local), d=172.16.1.254
> (Dialer0), len 100, sending 03C2C9D0: 45000064
> 004E0000 E..d.N.. 03C2C9E0: FF016028 AC100104 AC1001FE
> 080031FD ..`(,...,..~..1} 03C2C9F0: 00130000 00000000 015E4ADC
> ABCDABCD .........^J\+M+M 03C2CA00: ABCDABCD ABCDABCD ABCDABCD
> ABCDABCD +M+M+M+M+M+M+M+M 03C2CA10: ABCDABCD ABCDABCD ABCDABCD
> ABCDABCD +M+M+M+M+M+M+M+M 03C2CA20: ABCDABCD ABCDABCD ABCDABCD
> ABCDABCD +M+M+M+M+M+M+M+M
>
>
> 1 06:55:26.082: IP: s=172.16.1.4 (local), d=172.16.1.254 (Dialer0),
> len 100, sending 03C2C9D0: 45000064 004E0000
> E..d.N.. 03C2C9E0: FF016028 AC100104 AC1001FE 080031FD
> ..`(,...,..~..1} 03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD
> .........^J\+M+M 03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD
> +M+M+M+M+M+M+M+M 03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD
> +M+M+M+M+M+M+M+M 03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD
> +M+M+M+M+M+M+M+M 03C2CA30: ABCDABCD ABCDABCD ABCDABCD
> +M+M+M+M+M+M
> *Mar 1 06:55:26.086: IP ARP: creating incomplete entry for IP
> address: 172.16.1.254 interface Vlan1
> *Mar 1 06:55:26.086: IP ARP: sent req src 192.168.100.1
> 0018.1849.c9ee, dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:26.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:27.086: IP ARP: sent req src 192.168.100.1
> 0018.1849.c9ee, dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:27.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0.
> *Mar 1 06:55:28.086: IP ARP: sent req src 192.168.100.1
> 0018.1849.c9ee, dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:28.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:29.086: IP ARP: sent req src 192.168.100.1
> 0018.1849.c9ee, dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:29.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:29.086: IP: s=172.16.1.4 (local), d=172.16.1.254
> (Dialer0), len 100, encapsulation failed 03C2C9D0:
> 45000064 004E0000 E..d.N.. 03C2C9E0: FF016028 AC100104
> AC1001FE 080031FD ..`(,...,..~..1} 03C2C9F0: 00130000 00000000
> 015E4ADC ABCDABCD .........^J\+M+M 03C2CA00: ABCDABCD ABCDABCD
> ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M 03C2CA10: ABCDABCD ABCDABCD
> ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M 03C2CA20: ABCDABCD ABCDABCD
> ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
_______________________________________________
cisco-nas mailing list
cisco-nas@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nas
Re: ping fails over dialer interface [ In reply to ]
Hi,
thanks for the help, enabling iprouting fixed the ping issue.
But have doubt on nat config.

on cisco850, i want to translate ip addresses on my internal lan to a global
ip-address got via pppoe dialer0 .

interface FastEthernet0 --> connects to lan were linux box are dhcp client
interface FastEthernet4-> is uplink

so i tried this nat config which does not work.

ip nat pool letmeout 172.16.1.1 172.16.1.254 netmask 255.255.255.0
ip nat inside source list 1 pool letmeout
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit


interface FastEthernet0
!
!
interface FastEthernet4
description "UPLINK connected to BRAS"
no ip address
ip nat outside
no ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet4.4001
ip virtual-reassembly
pppoe enable
!
interface Vlan1
description "dhcp interface for home-users"
ip address 192.168.100.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname team@teambackbone
ppp chap password 0 team
!

On Thu, Sep 25, 2008 at 5:18 PM, Dinesh Bhonsle <dineshbs123@gmail.com>wrote:

> Hi,
>
> I have cisco850 - pppoe client, i am unable to ping to the default gw on
> the bras.
> pc-----cisco850(CPE)-------netgearSwitch(pvid 4001)------BRAS
>
> cisco-850 gets a ip address from BRAS as 172.16.1.3. multibind
> interface at BRAS is 172.16.1.254.
> so when i try to ping 172.16.1.254 from cisco, encapsulation fails, may be
> arp res
>
> cpe1#sh run
> Building configuration...
>
> Current configuration : 1540 bytes
> !
> version 12.4
> no service pad
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname cpe1
> !
> boot-start-marker
> boot-end-marker
> !
> enable secret 5 $1$pb71$nc1Bi.IaAJLdMPXtXeggO0
> enable password test123
> !
> no aaa new-model
> !
> resource policy
> !
> ip subnet-zero
> no ip routing
> no ip dhcp use vrf connected
> !
> ip dhcp pool myownpool
> import all
> network 192.168.100.0 255.255.255.0
> dns-server 68.2.16.25
> lease 7
> !
> !
> no ip cef
> vpdn enable
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface FastEthernet0
> !
> interface FastEthernet1
> shutdown
> !
> interface FastEthernet2
> shutdown
> !
> interface FastEthernet3
> shutdown
> !
> interface FastEthernet4
> description "UPLINK connected to BRAS"
> no ip address
> ip virtual-reassembly
> no ip route-cache
> duplex auto
> speed auto
> pppoe enable group global
> pppoe-client dial-pool-number 1
> !
> interface Vlan1
> description "dhcp interface for home-users"
> ip address 192.168.100.1 255.255.255.0
> ip nat inside
> ip virtual-reassembly
> no ip route-cache
> !
> interface Dialer0
> ip address negotiated
> ip mtu 1492
> ip nat outside
> ip virtual-reassembly
> encapsulation ppp
> dialer pool 1
> dialer-group 1
> ppp chap hostname team@teambackbone
> ppp chap password 0 team
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer0
> !
> no ip http server
> no ip http secure-server
> ip nat inside source list 1 interface Dialer0 overload
> !
> dialer-list 1 protocol ip permit
> !
> control-plane
> !
> !
> line con 0
> no modem enable
> line aux 0
> line vty 0 4
> password test
> login
> !
> scheduler max-task-time 5000
> end
>
>
> cpe1#ping 172.16.1.254
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 172.16.1.254, timeout is 2 seconds:
>
> *Mar 1 06:55:26.082: IP: tableid=0, s=172.16.1.4 (local), d=172.16.1.254(Dialer0), routed via RIB
> *Mar 1 06:55:26.082: IP: s=172.16.1.4 (local), d=172.16.1.254 (Dialer0),
> len 100, sending
> 03C2C9D0: 45000064 004E0000 E..d.N..
> 03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
> 03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
> 03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
>
>
> 1 06:55:26.082: IP: s=172.16.1.4 (local), d=172.16.1.254 (Dialer0), len
> 100, sending
> 03C2C9D0: 45000064 004E0000 E..d.N..
> 03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
> 03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
> 03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA30: ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M
> *Mar 1 06:55:26.086: IP ARP: creating incomplete entry for IP address:
> 172.16.1.254 interface Vlan1
> *Mar 1 06:55:26.086: IP ARP: sent req src 192.168.100.1 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:26.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:27.086: IP ARP: sent req src 192.168.100.1 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:27.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0.
> *Mar 1 06:55:28.086: IP ARP: sent req src 192.168.100.1 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:28.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:29.086: IP ARP: sent req src 192.168.100.1 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Vlan1
> *Mar 1 06:55:29.086: IP ARP: sent req src 172.16.1.4 0018.1849.c9ee,
> dst 172.16.1.254 0000.0000.0000 Dialer0
> *Mar 1 06:55:29.086: IP: s=172.16.1.4 (local), d=172.16.1.254 (Dialer0),
> len 100, encapsulation failed
> 03C2C9D0: 45000064 004E0000 E..d.N..
> 03C2C9E0: FF016028 AC100104 AC1001FE 080031FD ..`(,...,..~..1}
> 03C2C9F0: 00130000 00000000 015E4ADC ABCDABCD .........^J\+M+M
> 03C2CA00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
> 03C2CA20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD +M+M+M+M+M+M+M+M
>
>
>
Re: ping fails over dialer interface [ In reply to ]
Dinesh Bhonsle <> wrote on Friday, September 26, 2008 10:02 PM:

> Hi,
> thanks for the help, enabling iprouting fixed the ping issue.
> But have doubt on nat config.
>
> on cisco850, i want to translate ip addresses on my internal lan to a
> global ip-address got via pppoe dialer0 .
>
> interface FastEthernet0 --> connects to lan were linux box are dhcp
> client
> interface FastEthernet4-> is uplink

Actually, Dialer 0 is the Layer 3 uplink interface.

> so i tried this nat config which does not work.
>
> ip nat pool letmeout 172.16.1.1 172.16.1.254 netmask 255.255.255.0
> ip nat inside source list 1 pool letmeout

why are you translating to a pool? You don't own these addresses (or
only one of it which is assigned to you) Your initial NAT config was
correct:

ip nat inside source list 1 interface Dialer0 overload

with an

access-list 1 permit 192.168.100.0 0.0.0.255

can you try this?

oli

_______________________________________________
cisco-nas mailing list
cisco-nas@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nas