Mailing List Archive

question regarding TRACK PPPoE/cellular failover
hi there!


i am right now testing an failover enviroment between PPPoE and an
Cellular
interface.

i can realice it with 2 different dialers (dialer 1 PPPoE speaking PPPoE
on FastEthernet)
and the dialer2 which is bound to the cell interface. i solved the
failover right
now via route tracking, which works fine.. means when the primary
interface fails
the state is down and the cell interface (dialer2) is dialing in. - the
problem is the fallback
to the primary interface. in fact of dialer pesistant definition there
seem not a really
easy way to "force the cell interface to disconnect".
i have tried the backup interface statement, but my fastethernet will
never go down except my dsl modem
have a problem.

so any idea how to force the switching from cellular back to PPPoE?

c880data-universalk9-mz.124-24.T.bin

track 133 interface Dialer1 ip routing
delay down 10 up 10

interface FastEthernet4
description GSHDSL
no ip address
duplex auto
speed auto
pppoe-client dial-pool-number 1

interface Dialer1
description PPPoE xDSL Interface
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
load-interval 30
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username xxx password 0 xxx
ppp ipcp dns request

interface Cellular0
description XXX Backup Interface
mtu 1460
no ip address
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer in-band
dialer pool-member 233
dialer-group 1
async mode interactive

interface Dialer2
description H3G Backup Interface
mtu 1460
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 233
dialer idle-timeout 0
dialer string gsm
dialer persistent
no cdp enable
no ppp lcp fast-start
ppp authentication pap callin
ppp chap refuse
ppp pap sent-username xxx password 0 xxx
ppp ipcp dns request

ip route 0.0.0.0 0.0.0.0 Dialer1 150 name DSL-PPPoE track 133
ip route 0.0.0.0 0.0.0.0 Dialer2 200 name XXX

thanks!

chris


This e-mail is confidential and may well also be legally privileged. If you have received it in error, you are on notice of its status. Please notify us immediately by reply e-mail and then delete this message from your system. Please do not copy it or use it for any purposes, or disclose its contents to any other person: to do so could be a breach of confidence. Thank you for your cooperation.
Information pursuant to paragraph 14 Austrian Companies Code: UPC Austria GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company Register Number: FN 189858d at the Commercial Court of Vienna
_______________________________________________
cisco-nas mailing list
cisco-nas@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nas
Re: question regarding TRACK PPPoE/cellular failover [ In reply to ]
hi!

thanks for your response, unfortunately "ip sla" is not a solution.
actually i wanna do
something like that:

if a route or if a device on dialer1 is reachable "clear the cellular
interface" or something else..
just remember i would like to have a persistant connection on both
dialer interfaces (PPPoE as well as Cell)

chris


*
* What if you track something over your PPPoE with IP SLA?
*
* Marton
*
* -----Original Message-----
* From: cisco-nas-bounces@puck.nether.net
* [mailto:cisco-nas-bounces@puck.nether.net] On Behalf Of Steger,
* Christian
* Sent: Saturday, March 28, 2009 1:06 PM
* To: cisco-nas@puck.nether.net
* Subject: [cisco-nas] question regarding TRACK PPPoE/cellular failover
*
* hi there!
*
*
* i am right now testing an failover enviroment between PPPoE and an
* Cellular
* interface.
*
* i can realice it with 2 different dialers (dialer 1 PPPoE speaking
* PPPoE on
* FastEthernet) and the dialer2 which is bound to the cell interface. i
* solved
* the failover right now via route tracking, which works fine.. means
* when the
* primary interface fails the state is down and the cell interface
* (dialer2)
* is dialing in. - the problem is the fallback to the primary interface.
* in
* fact of dialer pesistant definition there seem not a really easy way
to
* "force the cell interface to disconnect".
* i have tried the backup interface statement, but my fastethernet will
* never
* go down except my dsl modem have a problem.
*
* so any idea how to force the switching from cellular back to PPPoE?
*
* c880data-universalk9-mz.124-24.T.bin
*
* track 133 interface Dialer1 ip routing
* delay down 10 up 10
*
* interface FastEthernet4
* description GSHDSL
* no ip address
* duplex auto
* speed auto
* pppoe-client dial-pool-number 1
*
* interface Dialer1
* description PPPoE xDSL Interface
* mtu 1492
* ip address negotiated
* ip nat outside
* ip virtual-reassembly
* encapsulation ppp
* no ip mroute-cache
* load-interval 30
* dialer pool 1
* dialer idle-timeout 0
* dialer persistent
* dialer-group 1
* no cdp enable
* ppp authentication pap callin
* ppp pap sent-username xxx password 0 xxx ppp ipcp dns request
*
* interface Cellular0
* description XXX Backup Interface
* mtu 1460
* no ip address
* ip nat outside
* ip virtual-reassembly
* encapsulation ppp
* load-interval 30
* dialer in-band
* dialer pool-member 233
* dialer-group 1
* async mode interactive
*
* interface Dialer2
* description H3G Backup Interface
* mtu 1460
* ip address negotiated
* ip nat outside
* ip virtual-reassembly
* encapsulation ppp
* load-interval 30
* dialer pool 233
* dialer idle-timeout 0
* dialer string gsm
* dialer persistent
* no cdp enable
* no ppp lcp fast-start
* ppp authentication pap callin
* ppp chap refuse
* ppp pap sent-username xxx password 0 xxx ppp ipcp dns request
*
* ip route 0.0.0.0 0.0.0.0 Dialer1 150 name DSL-PPPoE track 133 ip route
* 0.0.0.0 0.0.0.0 Dialer2 200 name XXX
*
* thanks!
*
* chris
*
*
* This e-mail is confidential and may well also be legally privileged.
If
* you
* have received it in error, you are on notice of its status. Please
* notify us
* immediately by reply e-mail and then delete this message from your
* system.
* Please do not copy it or use it for any purposes, or disclose its
* contents
* to any other person: to do so could be a breach of confidence. Thank
* you for
* your cooperation.
* Information pursuant to paragraph 14 Austrian Companies Code: UPC
* Austria
* GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company
* Register
* Number: FN 189858d at the Commercial Court of Vienna
* _______________________________________________
* cisco-nas mailing list
* cisco-nas@puck.nether.net
* https://puck.nether.net/mailman/listinfo/cisco-nas
This e-mail is confidential and may well also be legally privileged. If you have received it in error, you are on notice of its status. Please notify us immediately by reply e-mail and then delete this message from your system. Please do not copy it or use it for any purposes, or disclose its contents to any other person: to do so could be a breach of confidence. Thank you for your cooperation.
Information pursuant to paragraph 14 Austrian Companies Code: UPC Austria GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company Register Number: FN 189858d at the Commercial Court of Vienna
_______________________________________________
cisco-nas mailing list
cisco-nas@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nas
Re: question regarding TRACK PPPoE/cellular failover [ In reply to ]
Hi,

On Sat, Mar 28, 2009 at 04:45:31PM +0100, Steger, Christian wrote:
> thanks for your response, unfortunately "ip sla" is not a solution.
> actually i wanna do
> something like that:
>
> if a route or if a device on dialer1 is reachable "clear the cellular
> interface" or something else..
> just remember i would like to have a persistant connection on both
> dialer interfaces (PPPoE as well as Cell)

This is exactly what you can do with "ip sla" and "track".

"ip sla" will figure out whether or not "a device on dialer1 is reachable"

"track" will move your default (or more specific) routes around according
to whatever you want to achieve.

gert
--
USENET is *not* the non-clickable part of WWW!
//www.muc.de/~gert/
Gert Doering - Munich, Germany gert@greenie.muc.de
fax: +49-89-35655025 gert@net.informatik.tu-muenchen.de
Re: question regarding TRACK PPPoE/cellular failover [ In reply to ]
hi gert,

thanks for your reply.

* >
* > if a route or if a device on dialer1 is reachable "clear the
cellular
* > interface" or something else..
* > just remember i would like to have a persistant connection on both
* > dialer interfaces (PPPoE as well as Cell)
*
* This is exactly what you can do with "ip sla" and "track".
*
* "ip sla" will figure out whether or not "a device on dialer1 is
* reachable"
*
* "track" will move your default (or more specific) routes around
* according to whatever you want to achieve.

yes, you are right, but remember i use on both interfaces the statement
"dialer persistent" (nailed-up) - means, of course he swap in fact of
the "ip sla"
the "reachable" interfaces and use according that the tracking
"route"...
my problem is, actually a "worest case":
if you have an "routing issue" on the access-layer level (to the core)
and your cellular route
wins always, means the routing way is assymetric -> from point of view
the CPE the primary
interface the defaultroute pointing to the primary interface.. (in case
of an normal operation of course!)
on the point of view in the backbone the traffic routes back on the
cellular interface. (because it has
an smaller distance - different routing protocols as example)

and again this is just an worest case scenario i try to avoid such
issues and play a bit with it in the lab.
what i am looking for is something like "backup interface dialer2" but
its of course not an solution
in fact that i cannot use it on the dialer1 (and my PPPoE interface is
an FastEthernet so it would be
much stupid to use this statement here :))

hope you understand what my actual "solutionrequest" is.

chris

This e-mail is confidential and may well also be legally privileged. If you have received it in error, you are on notice of its status. Please notify us immediately by reply e-mail and then delete this message from your system. Please do not copy it or use it for any purposes, or disclose its contents to any other person: to do so could be a breach of confidence. Thank you for your cooperation.
Information pursuant to paragraph 14 Austrian Companies Code: UPC Austria GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company Register Number: FN 189858d at the Commercial Court of Vienna
_______________________________________________
cisco-nas mailing list
cisco-nas@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nas
Re: question regarding TRACK PPPoE/cellular failover [ In reply to ]
If "clear cellular" does what you want you can use EEM, something like:

event manager applet DEMO
event track 123 state up
action 1.0 cli command "clear cellular ..."

Marton

-----Original Message-----
From: cisco-nas-bounces@puck.nether.net
[mailto:cisco-nas-bounces@puck.nether.net] On Behalf Of Steger, Christian
Sent: Saturday, March 28, 2009 4:46 PM
To: cisco-nas@puck.nether.net
Subject: Re: [cisco-nas] question regarding TRACK PPPoE/cellular failover

hi!

thanks for your response, unfortunately "ip sla" is not a solution.
actually i wanna do
something like that:

if a route or if a device on dialer1 is reachable "clear the cellular
interface" or something else..
just remember i would like to have a persistant connection on both dialer
interfaces (PPPoE as well as Cell)

chris


*
* What if you track something over your PPPoE with IP SLA?
*
* Marton
*
* -----Original Message-----
* From: cisco-nas-bounces@puck.nether.net
* [mailto:cisco-nas-bounces@puck.nether.net] On Behalf Of Steger,
* Christian
* Sent: Saturday, March 28, 2009 1:06 PM
* To: cisco-nas@puck.nether.net
* Subject: [cisco-nas] question regarding TRACK PPPoE/cellular failover
*
* hi there!
*
*
* i am right now testing an failover enviroment between PPPoE and an
* Cellular
* interface.
*
* i can realice it with 2 different dialers (dialer 1 PPPoE speaking
* PPPoE on
* FastEthernet) and the dialer2 which is bound to the cell interface. i
* solved
* the failover right now via route tracking, which works fine.. means
* when the
* primary interface fails the state is down and the cell interface
* (dialer2)
* is dialing in. - the problem is the fallback to the primary interface.
* in
* fact of dialer pesistant definition there seem not a really easy way to
* "force the cell interface to disconnect".
* i have tried the backup interface statement, but my fastethernet will
* never
* go down except my dsl modem have a problem.
*
* so any idea how to force the switching from cellular back to PPPoE?
*
* c880data-universalk9-mz.124-24.T.bin
*
* track 133 interface Dialer1 ip routing
* delay down 10 up 10
*
* interface FastEthernet4
* description GSHDSL
* no ip address
* duplex auto
* speed auto
* pppoe-client dial-pool-number 1
*
* interface Dialer1
* description PPPoE xDSL Interface
* mtu 1492
* ip address negotiated
* ip nat outside
* ip virtual-reassembly
* encapsulation ppp
* no ip mroute-cache
* load-interval 30
* dialer pool 1
* dialer idle-timeout 0
* dialer persistent
* dialer-group 1
* no cdp enable
* ppp authentication pap callin
* ppp pap sent-username xxx password 0 xxx ppp ipcp dns request
*
* interface Cellular0
* description XXX Backup Interface
* mtu 1460
* no ip address
* ip nat outside
* ip virtual-reassembly
* encapsulation ppp
* load-interval 30
* dialer in-band
* dialer pool-member 233
* dialer-group 1
* async mode interactive
*
* interface Dialer2
* description H3G Backup Interface
* mtu 1460
* ip address negotiated
* ip nat outside
* ip virtual-reassembly
* encapsulation ppp
* load-interval 30
* dialer pool 233
* dialer idle-timeout 0
* dialer string gsm
* dialer persistent
* no cdp enable
* no ppp lcp fast-start
* ppp authentication pap callin
* ppp chap refuse
* ppp pap sent-username xxx password 0 xxx ppp ipcp dns request
*
* ip route 0.0.0.0 0.0.0.0 Dialer1 150 name DSL-PPPoE track 133 ip route
* 0.0.0.0 0.0.0.0 Dialer2 200 name XXX
*
* thanks!
*
* chris
*
*
* This e-mail is confidential and may well also be legally privileged.
If
* you
* have received it in error, you are on notice of its status. Please
* notify us
* immediately by reply e-mail and then delete this message from your
* system.
* Please do not copy it or use it for any purposes, or disclose its
* contents
* to any other person: to do so could be a breach of confidence. Thank
* you for
* your cooperation.
* Information pursuant to paragraph 14 Austrian Companies Code: UPC
* Austria
* GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company
* Register
* Number: FN 189858d at the Commercial Court of Vienna
* _______________________________________________
* cisco-nas mailing list
* cisco-nas@puck.nether.net
* https://puck.nether.net/mailman/listinfo/cisco-nas
This e-mail is confidential and may well also be legally privileged. If you
have received it in error, you are on notice of its status. Please notify us
immediately by reply e-mail and then delete this message from your system.
Please do not copy it or use it for any purposes, or disclose its contents
to any other person: to do so could be a breach of confidence. Thank you for
your cooperation.
Information pursuant to paragraph 14 Austrian Companies Code: UPC Austria
GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company Register
Number: FN 189858d at the Commercial Court of Vienna
_______________________________________________
cisco-nas mailing list
cisco-nas@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nas

_______________________________________________
cisco-nas mailing list
cisco-nas@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nas
Re: question regarding TRACK PPPoE/cellular failover [ In reply to ]
hi!

this is the solution! - i was surprised that cisco have such imoplemented.

thank you for your great help!

chris


* -----Ursprüngliche Nachricht-----
* Von: MIHI [mailto:mihi@ludens.elte.hu]
* Gesendet: Sonntag, 29. März 2009 20:42
* An: Steger, Christian; cisco-nas@puck.nether.net
* Betreff: RE: [cisco-nas] question regarding TRACK PPPoE/cellular
* failover
*
* If "clear cellular" does what you want you can use EEM, something like:
*
* event manager applet DEMO
* event track 123 state up
* action 1.0 cli command "clear cellular ..."
*
* Marton
*
* -----Original Message-----
* From: cisco-nas-bounces@puck.nether.net
* [mailto:cisco-nas-bounces@puck.nether.net] On Behalf Of Steger,
* Christian
* Sent: Saturday, March 28, 2009 4:46 PM
* To: cisco-nas@puck.nether.net
* Subject: Re: [cisco-nas] question regarding TRACK PPPoE/cellular
* failover
*
* hi!
*
* thanks for your response, unfortunately "ip sla" is not a solution.
* actually i wanna do
* something like that:
*
* if a route or if a device on dialer1 is reachable "clear the cellular
* interface" or something else..
* just remember i would like to have a persistant connection on both
* dialer
* interfaces (PPPoE as well as Cell)
*
* chris
*
*
* *
* * What if you track something over your PPPoE with IP SLA?
* *
* * Marton
* *
* * -----Original Message-----
* * From: cisco-nas-bounces@puck.nether.net
* * [mailto:cisco-nas-bounces@puck.nether.net] On Behalf Of Steger,
* * Christian
* * Sent: Saturday, March 28, 2009 1:06 PM
* * To: cisco-nas@puck.nether.net
* * Subject: [cisco-nas] question regarding TRACK PPPoE/cellular failover
* *
* * hi there!
* *
* *
* * i am right now testing an failover enviroment between PPPoE and an
* * Cellular
* * interface.
* *
* * i can realice it with 2 different dialers (dialer 1 PPPoE speaking
* * PPPoE on
* * FastEthernet) and the dialer2 which is bound to the cell interface. i
* * solved
* * the failover right now via route tracking, which works fine.. means
* * when the
* * primary interface fails the state is down and the cell interface
* * (dialer2)
* * is dialing in. - the problem is the fallback to the primary
* interface.
* * in
* * fact of dialer pesistant definition there seem not a really easy way
* to
* * "force the cell interface to disconnect".
* * i have tried the backup interface statement, but my fastethernet will
* * never
* * go down except my dsl modem have a problem.
* *
* * so any idea how to force the switching from cellular back to PPPoE?
* *
* * c880data-universalk9-mz.124-24.T.bin
* *
* * track 133 interface Dialer1 ip routing
* * delay down 10 up 10
* *
* * interface FastEthernet4
* * description GSHDSL
* * no ip address
* * duplex auto
* * speed auto
* * pppoe-client dial-pool-number 1
* *
* * interface Dialer1
* * description PPPoE xDSL Interface
* * mtu 1492
* * ip address negotiated
* * ip nat outside
* * ip virtual-reassembly
* * encapsulation ppp
* * no ip mroute-cache
* * load-interval 30
* * dialer pool 1
* * dialer idle-timeout 0
* * dialer persistent
* * dialer-group 1
* * no cdp enable
* * ppp authentication pap callin
* * ppp pap sent-username xxx password 0 xxx ppp ipcp dns request
* *
* * interface Cellular0
* * description XXX Backup Interface
* * mtu 1460
* * no ip address
* * ip nat outside
* * ip virtual-reassembly
* * encapsulation ppp
* * load-interval 30
* * dialer in-band
* * dialer pool-member 233
* * dialer-group 1
* * async mode interactive
* *
* * interface Dialer2
* * description H3G Backup Interface
* * mtu 1460
* * ip address negotiated
* * ip nat outside
* * ip virtual-reassembly
* * encapsulation ppp
* * load-interval 30
* * dialer pool 233
* * dialer idle-timeout 0
* * dialer string gsm
* * dialer persistent
* * no cdp enable
* * no ppp lcp fast-start
* * ppp authentication pap callin
* * ppp chap refuse
* * ppp pap sent-username xxx password 0 xxx ppp ipcp dns request
* *
* * ip route 0.0.0.0 0.0.0.0 Dialer1 150 name DSL-PPPoE track 133 ip
* route
* * 0.0.0.0 0.0.0.0 Dialer2 200 name XXX
* *
* * thanks!
* *
* * chris
* *
* *
* * This e-mail is confidential and may well also be legally privileged.
* If
* * you
* * have received it in error, you are on notice of its status. Please
* * notify us
* * immediately by reply e-mail and then delete this message from your
* * system.
* * Please do not copy it or use it for any purposes, or disclose its
* * contents
* * to any other person: to do so could be a breach of confidence. Thank
* * you for
* * your cooperation.
* * Information pursuant to paragraph 14 Austrian Companies Code: UPC
* * Austria
* * GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company
* * Register
* * Number: FN 189858d at the Commercial Court of Vienna
* * _______________________________________________
* * cisco-nas mailing list
* * cisco-nas@puck.nether.net
* * https://puck.nether.net/mailman/listinfo/cisco-nas
* This e-mail is confidential and may well also be legally privileged. If
* you
* have received it in error, you are on notice of its status. Please
* notify us
* immediately by reply e-mail and then delete this message from your
* system.
* Please do not copy it or use it for any purposes, or disclose its
* contents
* to any other person: to do so could be a breach of confidence. Thank
* you for
* your cooperation.
* Information pursuant to paragraph 14 Austrian Companies Code: UPC
* Austria
* GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company
* Register
* Number: FN 189858d at the Commercial Court of Vienna
* _______________________________________________
* cisco-nas mailing list
* cisco-nas@puck.nether.net
* https://puck.nether.net/mailman/listinfo/cisco-nas
This e-mail is confidential and may well also be legally privileged. If you have received it in error, you are on notice of its status. Please notify us immediately by reply e-mail and then delete this message from your system. Please do not copy it or use it for any purposes, or disclose its contents to any other person: to do so could be a breach of confidence. Thank you for your cooperation.
Information pursuant to paragraph 14 Austrian Companies Code: UPC Austria GmbH; Registered Office: Wolfganggasse 58-60, 1120 Vienna Company Register Number: FN 189858d at the Commercial Court of Vienna
_______________________________________________
cisco-nas mailing list
cisco-nas@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nas